Subject: [Cbor] Barry Leiba's Yes on charter-ietf-cbor-01-01: (with COMMENT)

From: Barry Leiba via Datatracker <[email-masked]>
Date: Mon, 24 Jun 2019 00:33:45 -0700

Barry Leiba has entered the following ballot position for
charter-ietf-cbor-01-01: Yes

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/charter-ietf-cbor/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Nit: "a mechanism other that" should be "a mechanism other than".

"and add to a second edition of the specification if warranted" ... presumably
this is in the re-charter because it *is* warranted.  I suggest removing "if
warranted".

"The body of existing specifications that make use of CDDL is considered
precious":  Awwwwwwwww...  :-)

"It is currently expected that this would be done using a Wiki of some type.
This work would not be expected to be published by the IETF."  Yayyyyy!  Thanks.

Nit: that are either currently adopted by the working group, by other working
groups, or as individual submissions" is not a parallel list.  Maybe, "that are
currently adopted by the working group, are work items in other working groups,
or exist as individual submissions."  Also, I suggest removing the paragraph
break between this paragraph and the next.

Nit: "Internet wide specifications" needs a hyphen: "Internet-wide
specifications".

---

From: Jim Schaad <[email-masked]>
Date: Sun, 30 Jun 2019 11:42:53 -0700

-----Original Message-----
From: Barry Leiba via Datatracker <[email-masked]> 
Sent: Monday, June 24, 2019 12:34 AM
To: The IESG <[email-masked]>
Cc: [email-masked]; [email-masked]
Subject: Barry Leiba's Yes on charter-ietf-cbor-01-01: (with COMMENT)

When responding, please keep the subject line intact and reply to all email addresses included in the To and CC lines. (Feel free to cut this introductory paragraph, however.)

"and add to a second edition of the specification if warranted" ... presumably this is in the re-charter because it *is* warranted.  I suggest removing "if warranted".
[JLS] I would be happy for a re-wording, but the "if warranted" related to individual features and not to the entire process of producing a second version.   A better string might be "where warrented"

[JLS] Not actionable?

Nit: that are either currently adopted by the working group, by other working groups, or as individual submissions" is not a parallel list.  Maybe, "that are currently adopted by the working group, are work items in other working groups, or exist as individual submissions."  Also, I suggest removing the paragraph break between this paragraph and the next.

Nit: "Internet wide specifications" needs a hyphen: "Internet-wide specifications".

---

From: Barry Leiba <[email-masked]>
Date: Sun, 30 Jun 2019 17:36:11 -0400

Hi, Jim,

>> "and add to a second edition of the specification if warranted" ... presumably this is in the
>> re-charter because it *is* warranted.  I suggest removing "if warranted".
>
> [JLS] I would be happy for a re-wording, but the "if warranted" related to individual features
> and not to the entire process of producing a second version.   A better string might be
> "where warranted"

Yeh, that works.

>> precious":  Awwwwwwwww...  :-)

And not expected to be; it was a silly.

Barry