Subject: [Cbor] Allocating a CBOR tag for RFC 3339 date strings

From: Mike Jones <[email-masked]>
Date: Mon, 9 Mar 2020 23:18:02 +0000

I have published the specification Concise Binary Object Representation (CBOR) Tag for Date to allocate a CBOR tag for RFC 3339 full-date<https://tools.ietf.org/html/rfc3339#section-5.6> values.  While there's already a tag for date-time<https://tools.ietf.org/html/rfc7049#section-2.4.1> values, there's currently no tag allocated for full-date values - a date string without a time.  The need for this arose for the ISO Mobile Driver's License specification in the working group ISO/IEC JTC 1/SC 17<https://www.iso.org/committee/45144.html> "Cards and security devices for personal identification".

Thanks to Carsten Bormann for pointers on the best way to accomplish this.

The specification is available at:

  *   https://tools.ietf.org/html/draft-jones-cbor-date-tag-00

An HTML-formatted version is also available at:

  *   https://self-issued.info/docs/draft-jones-cbor-date-tag-00.html

                                                       -- Mike

P.S.  This notice was also posted at https://self-issued.info/?p=2059 and as @selfissued<https://twitter.com/selfissued>.

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 10 Mar 2020 06:52:25 +0100

It would be helpful if people who read this specification can send a line or two to the mailing list.  I’m going to recommend registering this tag next week on Tuesday unless people see a serious problem.  In parallel, we can improve this specification.

We haven’t really talked about the best way to handle these small tag definition documents.  I believe it would be best to do a little bit of aggregation on them; maybe we can spend some time in the interim tomorrow to discuss what is the best way to organize this aggregation.
This might include pulling in some of the most useful tag definitions that are not available as I-D/RFC yet (e.g., tag 257 which is even mentioned in 7049bis, but also others like 30, 31, 37, 260/261, 264/265, 266/267 — the choice here is totally personal, but not without reason; we could develop these criteria a little bit to write them down).

Grüße, Carsten

> On 2020-03-10, at 00:18, Mike Jones <Michael.Jones=[email-masked]> wrote:
> 
> I have published the specification Concise Binary Object Representation (CBOR) Tag for Date to allocate a CBOR tag for RFC 3339 full-date values.  While there’s already a tag for date-time values, there’s currently no tag allocated for full-date values – a date string without a time.  The need for this arose for the ISO Mobile Driver’s License specification in the working group ISO/IEC JTC 1/SC 17 “Cards and security devices for personal identification”.
>  
> 	• https://tools.ietf.org/html/draft-jones-cbor-date-tag-00
>  
> 	• https://self-issued.info/docs/draft-jones-cbor-date-tag-00.html
>  
>                                                        -- Mike
>  
> P.S.  This notice was also posted at https://self-issued.info/?p=2059 and as @selfissued.
>  
> _______________________________________________
> CBOR mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cbor

---

From: Richter, Jörg <[email-masked]>
Date: Tue, 10 Mar 2020 19:12:09 +0000

> It would be helpful if people who read this specification can send a line or two to
> the mailing list.  I’m going to recommend registering this tag next week on
> Tuesday unless people see a serious problem.  In parallel, we can improve this
> specification.

It's in line with the request I made a year ago [1] that in encodes the date as 
YYYY-MM-DD. I requested another encoding in days-since-an-epoch 
(e.g. 1970-01-01). Encoded as major type 0 or 1. This would be faster for 
the case where the date is stored as a day count since some fixed date. 
Conversion between the two representations is a common operation that 
should be offered with any date/time library.
I requested tag 100 instead of 1004. I'm not very attached to tag 100, 
but I would like tag 100 to be used instead.

> We haven’t really talked about the best way to handle these small tag definition
> documents. 

Since I have already requested several tags, but have not received any feedback, 
I would appreciate it if someone would point out the correct way to request them. 
Otherwise this is a rather disappointing experience to extend CBOR. 

- Jörg

[1] https://j-richter.github.io/CBOR/date.html