Subject: [Cbor] Fwd: [dispatch] Heads up - JSON Data Definition Format (JDDF)

From: Ira McDonald <[email-masked]>
Date: Mon, 13 Apr 2020 13:14:12 -0400

Hi,

FYI

This JDDF in the ISE appears to overlap w/ CDDL - is anyone in CBOR WG
watching this one?

Cheers,
- Ira

---------- Forwarded message ---------
From: RFC ISE (Adrian Farrel) <[email-masked]>
Date: Fri, Apr 10, 2020 at 6:18 PM
Subject: [dispatch] Heads up - JSON Data Definition Format (JDDF)
To: <[email-masked]>
Cc: <[email-masked]>

Hi Dispatch,

draft-ucarion-json-type-definition has been presented to the Independent
Submissions Editor for publication as an RFC.

During review it was suggested to me that the topic might be of sufficient
interest that a WG could be formed, but there doesn't seem to be quite
that level of enthusiasm.

In discussing this with the ADs, they suggested I should flag this to you.
I'd certainly be interested in hearing any comments, and if Dispatch
wanted to take this on that would be worth knowing.

Thanks,
Adrian
-- 
Adrian Farrel (ISE),
[email-masked]

_______________________________________________
dispatch mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dispatch

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 13 Apr 2020 22:30:42 +0200

> This JDDF in the ISE appears to overlap w/ CDDL - is anyone in CBOR WG 

Hi Ira,

I certainly am; we had some discussions over in the JSON WG mailing list.

JDDF is a rather minimal form of a data definition format for JSON data that is itself represented in JSON (I’ll call that homoiconic here).  I find it interesting as it seems to be quite useful even in its minimal design.

CDDL (RFC 8610) is different from JDDF (and other homoiconic data definition format proposals) in that it is a language, i.e. it is meant for human use, e.g., in specifications.
It is based on grammar concepts, as is ABNF (RFC 5234), so it has a wide, orthogonal gamut of expressiveness compared to the sometimes somewhat cobbled-together homoiconic proposals.
It also covers the wider generic data model of CBOR, not just that of JSON.  

https://tools.ietf.org/html/draft-bormann-cbor-cddl-freezer-03#section-8 defines a JSON representation of CDDL specifications, which might be used in a similar way that JDDF and other homoiconic approaches are being used.  I’m proposing to document this form in a specification so it becomes easier to interchange parsed CDDL between tools.  
(An implementation of a parser frontend is at https://github.com/cabo/cddlc — this also provides a reencoding of the JSON format in the popular YAML format, which is a bit more useful to humans.)

Grüße, Carsten

> CBOR mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cbor