Subject: [Cbor] Combination tags and CBOR Packed

From: Jim Schaad <[email-masked]>
Date: Fri, 28 Aug 2020 15:33:34 -0700

As a derivative thought from the question on loop detection and the ability
to have things reference other things.

Is it legal to stack up packing tags into a single item?   Is
6.229(6.232(simple(1)) legal and does it do what I would expect it to do.
Specifically it would concatenate three different value that are extracted
from the packing tables.

Jim

---

From: Carsten Bormann <[email-masked]>
Date: Sat, 29 Aug 2020 00:39:42 +0200

> Specifically it would concatenate three different value that are extracted

Yes.

(This has approximately the same complexity as an indefinite length string with three components.)

(In diagnostic notation, you don’t write the “6.” — that is for CDDL “#6.”....
Apologies for this discontinuity.)

Grüße, Carsten

---

From: Jim Schaad <[email-masked]>
Date: Fri, 28 Aug 2020 16:04:35 -0700

-----Original Message-----
From: Carsten Bormann <[email-masked]> 
Sent: Friday, August 28, 2020 3:40 PM
To: Jim Schaad <[email-masked]>
Cc: [email-masked]; [email-masked]
Subject: Re: [Cbor] Combination tags and CBOR Packed

On 2020-08-29, at 00:33, Jim Schaad <[email-masked]> wrote:
> Specifically it would concatenate three different value that are 
> extracted from the packing tables.

Yes.

(This has approximately the same complexity as an indefinite length string with three components.)
[JLS] No this has much more complexity that the CBOR indefinite string.  It has the complexity of the ASN.1 indefinite string since each of the first two elements could them selves be composite items of multiple components.

(In diagnostic notation, you don’t write the “6.” — that is for CDDL “#6.”....
Apologies for this discontinuity.)
[JLS] And should really know this.  I guess I need to start writing CDDL more often.

Jim

Grüße, Carsten