Subject: [Cbor] Allow reducing .feature diagnostic verbosity

From: Carsten Bormann <[email-masked]>
Date: Sat, 14 Nov 2020 01:25:32 +0100

Over in ASDF, with SDF 1.1 development picking up speed, we are noticing some undue verbosity of .feature controls in type choices (as opposed to keys of optional entries in maps, where they are usually fine).

I made a pull request:

https://github.com/cbor-wg/cddl-control/pull/1/files

This is also implemented in cddl tool 0.8.13 (just pushed; update with “gem update”).

Discussion welcome.
Example for use in:

https://github.com/ietf-wg-asdf/SDF/blob/1-1/sdf-1-1.cddl#L63

(I needed to put in extra parentheses because the cddl tool doesn’t exactly implement the CDDL ABNF…  On the list for the next version of the tool; cddlc already has the correct ABNF.)

Grüße, Carsten

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 17 Nov 2020 21:10:47 +0100

> https://github.com/ietf-wg-asdf/SDF/blob/1-1/sdf-1-1.cddl#L63

This is now in active use in draft-ietf-asdf-sdf-01 [1].

In preparation for Thursday’s WG meeting, I have submitted draft-ietf-cbor-cddl-control-01 with this change.  Comments, as always, welcome!

As a little bonus, the cddl tool (version 0.8.14) now does .cat, .plus as well.
(ABNF is next week, then :-)

Grüße, Carsten

[1]: https://tools.ietf.org/id/draft-ietf-asdf-sdf-01.html#name-formal-syntax-of-sdf