Subject: [Cbor] cbor-diag 0.5.14: Support for sequences in diag2x

From: Carsten Bormann <[email-masked]>
Date: Wed, 24 Feb 2021 15:44:28 +0100

We already could do:

$ echo 01CBOR | cborseq2diag.rb -t
-17, -18, 'BOR', 10

(Note how the newline turns into 10 :-)

With 0.5.14, we now also can do:

$ echo "-17, -18, 'BOR', 10" | diag2pretty.rb
# CBOR sequence with 4 elements
30 # negative(16)
31 # negative(17)
43        # bytes(3)
   424f52 # "BOR"
0a # unsigned(10)

(The lines with the hash marks are the output.)

As always, upgrade with 

	gem update
or
	gem update cbor-diag

cbor.me is next…

Grüße, Carsten

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 24 Feb 2021 17:34:49 +0100

> cbor.me is next…

Done.

Please play and send feedback.

Grüße, Carsten