Subject: [Cbor] New CDDL control operator proposal: .iana

From: Carsten Bormann <[email-masked]>
Date: Fri, 25 Jun 2021 13:13:52 +0200

I have submitted a new version of the CDDL freezer document, which suggests a new control operator: .iana, to enable referencing IANA registries in models [1].

I think we’ll need some discussions with IANA to make this really useful in practice, but the overall direction should be visible from the proposal.

(BTW, there also is a fleeting mention of a possible .iregexp [2].)

Grüße, Carsten

[1]: https://www.ietf.org/archive/id/draft-bormann-cbor-cddl-freezer-08.html#name-iana-references

[2]: https://www.ietf.org/archive/id/draft-bormann-cbor-cddl-freezer-08.html#section-4.1-4

> Name:		draft-bormann-cbor-cddl-freezer
> Revision:	08
> Title:		A feature freezer for the Concise Data Definition Language (CDDL)
> Document date:	2021-06-25
> Group:		Individual Submission
> Pages:		11
> Status:         https://datatracker.ietf.org/doc/draft-bormann-cbor-cddl-freezer/
> Html:           https://www.ietf.org/archive/id/draft-bormann-cbor-cddl-freezer-08.html
> Diff:           https://www.ietf.org/rfcdiff?url2=draft-bormann-cbor-cddl-freezer-08
> 
> Abstract:
>   In defining the Concise Data Definition Language (CDDL), some
>   features have turned up that would be nice to have.  In the interest
>   of completing this specification in a timely manner, the present
>   document was started to collect nice-to-have features that did not
>   make it into the first RFC for CDDL, RFC 8610.
> 
>   It is now time to discuss thawing some of the concepts discussed
>   here.  A number of additional proposals have been added.

---

From: Michael Richardson <[email-masked]>
Date: Fri, 25 Jun 2021 12:00:04 -0400

Carsten Bormann <[email-masked]> wrote:
    > I have submitted a new version of the CDDL freezer document, which
    > suggests a new control operator: .iana, to enable referencing IANA
    > registries in models [1].

My first thought was that IANA registries are hard to reference, and you get
this, and suggest XPath.

How to reference things which are not yet created... I actually think that
maybe we need .iana-future, which gets changed at or before AUTH48 to ".iana"

    > I think we’ll need some discussions with IANA to make this really
    > useful in practice, but the overall direction should be visible from
    > the proposal.

Agreed.
I also think we need some interoperation with YANG, and I think that YANG
also needs ".iana"

    > [1]:
    > https://www.ietf.org/archive/id/draft-bormann-cbor-cddl-freezer-08.html#name-iana-references

--
]               Never tell me the odds!                 | ipv6 mesh networks [
]   Michael Richardson, Sandelman Software Works        |    IoT architect   [
]     [email-masked]  http://www.sandelman.ca/        |   ruby on rails    [

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 25 Jun 2021 18:23:07 +0200

> My first thought was that IANA registries are hard to reference, and you get

XPath doesn’t really help with extracting the data, only with finding it.
I’m sure Julian Reschke would be able to write some xslt for this :-)

> maybe we need .iana-future, which gets changed at or before AUTH48 to ".iana"

Right.  The important thing is that it can reference another document, which can then independently move forward.  But that would need to *export* its registry content (probably via XML…) in a common format.
Lots of tooling needed.

> I also think we need some interoperation with YANG, and I think that YANG

Absolutely.  But maybe we can design it in a simple enough way so we can use it, too.

Grüße, Carsten