Subject: Re: [Cbor] Concise Binary Object Representation Maintenance and Extensions (cbor) WG Virtual Meeting: 2022-01-12

From: Carsten Bormann <[email-masked]>
Date: Tue, 11 Jan 2022 18:28:49 +0100

I don’t have specific agenda items I want to bring to this meeting.

The 800-pound gorilla right now is the description of data than can go both into JSON and into CBOR.  Of course that whole set of issues can be avoided by using CBOR only, but sometimes people are stubborn and want both.  RFC 9165 has one proposal:

https://www.rfc-editor.org/rfc/rfc9165#figure-9

Is that what we want to use?
(My still-not-published “second system” implementation of the CDDL tool has support for that, but that doesn’t mean it is the right way to do things.)

I’m not sure we’ll have enough input to discuss this tomorrow, but maybe we should put this general issue on the agenda of the 2022-01-26 interim.

Grüße, Carsten

On 2021-11-16, at 16:37, IESG Secretary <[email-masked]> wrote:
> 
> The Concise Binary Object Representation Maintenance and Extensions (cbor) WG will hold
> a virtual interim meeting on 2022-01-12 from 16:00 to 17:00 Europe/Vienna (15:00 to 16:00 UTC).
> 
> Agenda:
> - WG documents status and issues
> - CBOR use in IETF and other SDOs
> - AOB
> 
> Please add items you would like to bring up to live version in the meeting's notes in advance.
> 
> Information about remote participation:
> https://meetings.conf.meetecho.com/interim/?short=75b43816-9452-4eac-bb4c-def88eeaf458
>

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 12 Jan 2022 15:41:11 +0100

> The 800-pound gorilla right now is the description of data than can go both into JSON and into CBOR.  Of course that whole set of issues can be avoided by using CBOR only, but sometimes people are…

Zoologists have alerted me that I was talking about an elephant in the room, and those are > 800 lb.

Anyway:  For a worked example of how this could look like in action, please see:

https://www.ietf.org/archive/id/draft-ietf-rats-uccs-02.html#name-cddl

Grüße, Carsten