Subject: GTTP and LSP PING

From: Ronald Bonica <[email-masked]>
Date: Sat, 06 Mar 2004 12:43:27 -0500

Folks,

At IETF 59, an issue regarding the relationship of GTTP to LSP PING was
raised and redirected toward the list. I am posting this message in order to
initiate discussion.

One might argue that GTTP should invoke LSP PING when tracing though an MPLS
LSP. (In fact, previous versions of the GTTP draft stated that GTTP would
invoke LSP PING.) I'm not sure that this is a good idea.

GTTP has a requirement to trace through multiple levels of heterogenous
tunnels. For example, GTTP might be required to discover IP over MPLS over
IP. If GTTP were to invoke LSP PING to discover LSP details, I fear that it
would miss the IP tunnel at the bottom of the stack.

This assumption could be wrong. Comments?

----------------
Ronald P. Bonica
----------------
Sometimes the easiest way to 
start a dialog is to start talking.

---

From: Kireeti Kompella <[email-masked]>
Date: Sat, 6 Mar 2004 15:51:18 -0800 (PST)

> invoke LSP PING.) I'm not sure that this is a good idea.

LSP ping traces through the data plane, which is not always possible
with GTTP.  One thing to consider is to reuse some of the formats and
objects from LSP ping.

> This assumption could be wrong. Comments?

LSP ping uses TTL for tracing.  TTL-hiding tunnels present a problem.
Also, at present, LSP ping doesn't address IP tunnels, although it
could (and this has been suggested).

Kireeti.
-------

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Mon, 8 Mar 2004 12:50:59 -0500

] -----Original Message-----
] From: [email-masked] 
] [mailto:[email-masked]] On Behalf Of Ronald Bonica
] Sent: Saturday, March 06, 2004 12:43 PM
] To: [email-masked]
] Subject: GTTP and LSP PING
] 
] 
] Folks,
] 
] At IETF 59, an issue regarding the relationship of GTTP to 
] LSP PING was raised and redirected toward the list. I am 
] posting this message in order to initiate discussion.
] 
] One might argue that GTTP should invoke LSP PING when tracing 
] though an MPLS LSP. (In fact, previous versions of the GTTP 
] draft stated that GTTP would invoke LSP PING.) I'm not sure 
] that this is a good idea.

	Can you ellaborate why? 

] GTTP has a requirement to trace through multiple levels of 
] heterogenous tunnels. For example, GTTP might be required to 
] discover IP over MPLS over IP. If GTTP were to invoke LSP 
] PING to discover LSP details, I fear that it would miss the 
] IP tunnel at the bottom of the stack.

	That is an issue, as LSP ping/trace doesn't
work for IP as far as I understand. One idea is that it 
may be possible that LSP ping/trace could invoke IP trace/ping 
recursively.

	--Tom

] This assumption could be wrong. Comments?
] 
] ----------------
] Ronald P. Bonica
] ----------------
] Sometimes the easiest way to 
] start a dialog is to start talking.