Subject: RE: ason-routing-reqts: issue 2 architecture

From: "Ong, Lyndon" <[email-masked]>
Date: Wed, 17 Mar 2004 09:39:09 -0800

Hi Adrian,
 
If you follow this through, is there a visible difference between the following cases:
 
        A)                       B)
           ------------------       ------   ------   ------
          |R1                |     |R1    | |R2    | |R3    |
          |  --    --    --  |     |  --  | |  --  | |  --  |
          | |L1|  |L2|  |L3| |     | |L1| | | |L2| | | |L3| |
          |  --    --    --  |     |  --  | |  --  | |  --  |
          |   :     :     :  |     |   :  | |   :  | |   :  |
Control    ---+-----+-----+--       ---+--   ---+--   ---+--
Plane         :     :     :            :        :        :
--------------+-----+-----+----    ----+--------+--------+----
Data          :     :     :            :        :        :
Plane        --     :    --           --        :       --
        ----|P1|--------|P3|---   ---|P1|--------------|P3|---
             -- \   :  / --           --    \   :  /    --
                 \ -- /                      \ -- /
                  |P2|                        |P2|
                   --                          --

Thanks,
 
Lyndon

-----Original Message-----
From: Adrian Farrel [mailto:[email-masked]]
Sent: Tuesday, March 16, 2004 2:27 PM
To: Stephen Shew; Ong, Lyndon; [email-masked]
Cc: Don Fedyk; Brungard, Deborah A, ALABS; [email-masked]
Subject: Re: ason-routing-reqts: issue 2 architecture

Seems you are all a bit hung up on the definition of a "router".
 
Because GMPLS comes from a perspective where an LSR was a router was a single bearer plane device you are assuming that the identity advertised it the router id. But really the "TE router id" is the physical node id (or the logical router id - Ln in my figure).
 
Stephen has it when he says...
 
> One instantiation that is possible would be for R1 in Adrian's diagram to
> advertise on behalf of each of the P1/P2/P3 nodes, not as one abstract node.
> In that case, it would be confusing to scope the P1-P2 link using the router
> id of R1.
 
This is exactly right. And why would you scope the P1-P2 link using the router id of R1?
Why not use the node id P1 or the logical router id L1?
 
Adrian

> >              ------------------     ------    
> >             |R1                |   |R2    |   
> >             |  --    --    --  |   |  --  |    ------
> >             | |L1|  |L2|  |L3| |   | |L4| |   |R3    |
> >             |  --    --    --  |   |  --  |   |  --  |
> >             |   :     :     :  |   |   :  |   | |L5| |
> > Control      ---+-----+-----+--     ---+--    |  --  |
> > Plane           :     :     :          :      |   :  |
> > ----------------+-----+-----+----------+------+---+--+-
> > Data            :     :     :          :      |   :  |
> > Plane          --     :    --         --      |  --  |
> >           ----|P1|--------|P3|-------|P4|-----+-|P5|-+-
> >                -- \   :  / --         --      |  --  |
> >                    \ -- /                     |      |
> >                     |P2|                       ------
> >                      --
> > 
> > Pn is a physical (bearer/data/transport plane) node.
> > Rn is a control plane "router"
> > Ln is a logical control plane entity that manages a single
> >    physical node.
> > 
> > Thus:
> > R3 represents an LSR with all components collocated.
> > R2 shows how the "router" component may be disjoint from
> >    the switch
> > R1 shows how a single "router" may manage multiple switches

---

From: "Adrian Farrel" <[email-masked]>
Date: Thu, 18 Mar 2004 11:32:00 -0000

Lyndon,

> If you follow this through, is there a visible difference between

Well, yes. I can see a difference.
But I suppose you are asking a deeper question.

Your B) shows only a decoupling of control plane and data plane such as one might achieve using GSMP (or TL1 or ...) in a standard configuration.

Your A) includes with this decoupling a centralization of control into a single controling entity. As Jonathan points out, this might be done in order to present the data plane resources (nodes and links) as a single entity, or might be done simply because there is a single centralized control plane node.

It was my intention to distinguish these cases using R1 and R2 on my figure.

NOTE WELL. None of these figures dwells on control plane connectivity. This is entirely a separate matter from TE connectivity.

Thanks,
Adrian