Subject: Final updates to draft-ietf-ccamp-sdhsonet-control-03.txt

From: "Adrian Farrel" <[email-masked]>
Date: Mon, 20 Sep 2004 18:01:25 +0100

Folks,

This draft is now blocking the progress of other drafts, and actually only needs a few
additional updates.

If the authors would like to commit to making the final updates before the end of
September (this year!) then that would be great. Otherwise, I am looking for a volunteer
to make the changes - please email me off-list.

Thanks,
Adrian

---

From: "Vishal Sharma" <[email-masked]>
Date: Wed, 22 Sep 2004 08:34:11 +0530

Adrian et al,

The authors have been working on this for a rather very long time, and
do have other committments. At this time, we can commit to making 
the updates by the DC IETF.

BTW, I have looked at the feedback you sent, and some of the 
comments (such as VC termination on different line cards) are
I believe not feasible, and, therefore, not applicable. We will look at
them in more detail, and make modifications as needed.

-Vishal

> -----Original Message-----
> From: Adrian Farrel [mailto:[email-masked]]
> Sent: Monday, September 20, 2004 10:31 PM
> To: [email-masked]
> Cc: [email-masked]; Vishal Sharma (E-mail 2); Greg Bernstein; Eric
> Mannie
> Subject: Final updates to draft-ietf-ccamp-sdhsonet-control-03.txt
> 
> 
> Folks,
>

---

From: "Adrian Farrel" <[email-masked]>
Date: Wed, 22 Sep 2004 16:20:05 +0100

Vishal,

> the updates by the DC IETF.

I'm sure we all appreciate the considerable effort that all three authors have put into
this working group draft over the years. No one is making any criticism of, or "taking the
draft away" from, the current authors.

At the same time, it is my responsibility to get the draft through to completion, and it
would be reasonable to get it through the IESG before the Washington IETF. As we all know
the draft has suffered from being dropped by the chairs a couple of times in the past, but
the last set of comments were made on July 25th. The remaining work is relatively small,
and I have a volunteer to do the work in short order.

I believe this is a beneift to you because:
- the work gets done
- you get consulted and continue to have a say in the text
- you don't have to commit to as much effort as making the changes yourself.

It is clearly of benefit to the working group because we will get the draft out of the way
and off our charter before the next IETF.

So, unless the WG has strong objections, I will hand this over to another editor this week
and we can all move on.

> them in more detail, and make modifications as needed.

The topology and bandwidth work fine. If there are other issues, they are actually the
same issues as with PSC and you are not comparing like with like. Inverse muxing into two
channels on the same end-to-end path is not the same as inverse muxing onto two channels
on separate paths. The latter may be hard/impossible to do, because of the need to
synchronize between hardware components and between paths of different lengths, but that
is precisely my point.

Thanks,
Adrian

---

From: "Vishal Sharma" <[email-masked]>
Date: Wed, 22 Sep 2004 20:20:47 -0700

Adrian,

Thanks for the note.

While we certainly appreciate the efforts to move the draft and
are keen to do so ourselves to move the WG work forward,
we do not think there is a need to burden someone else with
making the very last set of changes to the document at this
late stage.

We have promised to get the work done within the next 4 odd 
weeks, which is pretty short order. 

It is great that there is someone willing to make the changes 
(who is it?), but it is
a *greater workload* for us to coordinate the changes with someone
else, rather than making them ourselves!
(We have, after all,
been editing the draft for over 2 years (the document is much older), and 
are certainly better equipped to make these changes.)

As such, we would like for us to make the changes, and do not
agree with the idea of hading the draft over to someone else, at 
this stage.

BTW, which CCAMP drafts are in the RFC etc. queue, whose progress
depends _solely_ upon the progress of this draft? Even if there
are, are they likely to clear the queue, before DC?

If the need of the WG is so extremely dire for the progress of
this draft, let us know. We will do our best to make time for it.

Otherwise, the WG will have the revised document from us shortly
anyway.

-Vishal

> From: [email-masked] [mailto:[email-masked]]On
> Behalf Of Adrian Farrel
> Sent: Wednesday, September 22, 2004 8:50 PM
> To: [email-masked]; [email-masked]
> Cc: Kireeti Kompella; Greg Bernstein; Eric Mannie
> Subject: Re: Final updates to draft-ietf-ccamp-sdhsonet-control-03.txt
> 
> 
> Vishal,
>

---

From: "Adrian Farrel" <[email-masked]>
Date: Fri, 24 Sep 2004 18:50:24 +0100

Hi Vishal,

Apologies for the delay in replying.

I certainly don't want to drag this out into a long debate one way or the other. We run
the risk of spending more cycles on this than we would have done simply to make the
changes.

> (who is it?), but it is a *greater workload* for us to coordinate
> the changes with someone else, rather than making them ourselves!
>
> (We have, after all, been editing the draft for over 2 years
> (the document is much older), and are certainly better equipped
> to make these changes.)
>

There are several drafts that are blocking progress of very many items on the RFC Ed's
queue. This is a mess that has gone on too long, and the chairs bear a fair amount of
responsibility for being lax in chasing up various people and actions.

Various people (including editors, and chairs) are now getting put under pressure to
complete their jobs very quickly or to stand aside.

The status of the blocking drafts is as follows:

- P&R functional spec:
   marked up after AD review
   with Kireeti to confirm changes are OK
   response planned this week
   then submit and pass to IESG
- P&R terminology
   ditto
- G.709
   updates after AD review done
   reviewed for changes (just done by me)
   re-publication imminent
   the pass to IESG
- SDH/SONET control
   AD comments made on 4th March
   re-published 15th July
   I reviewed 25th July
- Overlay draft
   WG last call completed 23rd March
   No response from authors so I made changes 26th April
   AD comments 13th July
   No response from authors despite several pings
- LMP MIB
  Just gone into IETF last call

> this draft, let us know. We will do our best to make time for it.

"Dire" would be an exageration, but there are now drafts from several WGs blocked by the
list above.

> Otherwise, the WG will have the revised document from us shortly

Frankly, I cannot see why you object to someone else making these editorial updates. Since
I have heard no objection from anyone else in the WG (nor from the other two authors), we
will take Eric Gray up on his kind offer to make the last changes and submit a revised
version of the draft.

Eric will make the necessary edits and work with the all of the authors to submit a new
draft really soon.

Thanks,
Adrian

---

From: "Vishal Sharma" <[email-masked]>
Date: Sun, 26 Sep 2004 12:56:03 +0530

Adrian,

> Sent: Friday, September 24, 2004 11:20 PM
> To: [email-masked]
> Cc: Kireeti Kompella; Greg Bernstein; Eric Mannie; [email-masked];
> [email-masked]

Agreed. Let's proceed to get the job done!
Since it is Eric Gray who has volunteered to make the edits,
I'm happy to let him do that.

-Vishal