Subject: About LSP Stiching

From: Amit 70405 <[email-masked]>
Date: Thu, 07 Apr 2005 18:08:25 +0800

Hi All,
	In the draft draft-ietf-ccamp-lsp-stitching-00 for LSP stitching, I think one more extension may be needed for E2e LSP.
	The draft suggest 2 main extensions,LSP Stitch desired bit and LSP Stitch Ready Bit.
	Both these extensions are for LSP Segement LSP.
	An LSP Segment will be treated like any other TE-Link.
	So TE-Link type will be hidden from E2e LSP.
	There is no way for LSP segment head node, to identify that a Outif selected is a LSP Segment for setting up E2e LSP.

	That is Some extension will be needed to RSVP that will allow RSVP message(for E2e LSP) processing at LSP segment head node to be processed according to the Sticthing needs.

	For Eg: LSP1-2 is an E2e LSP setup over an LSP segment LSPA-B.

	1-----A--D---E--B-----2

	Now if A gets the Path message for LSP1-2, and A selects LSP segment LSPA-B as outif.
	Then how does RSVP(at Node A) identify that the outif selected is a LSP segment?
	
	Also when A receives Resv for LSP1-2(from B), how can it ignore Label in it.
	There should be a way to determine at node A, that a LSP segment is in use.

	One possible way could be that Resv message for LSP1-2 should be sent(by B) with some special Label value.
	This Label value should indicate the node A that the Resv is received for a TE-Link(of type LSP Segment).
	This will help node A to ignore Label value in Resv msg for E2e Lsp LSP1-2.

	Plz let me know your view.
	Thanks in advance.
Regards,
Amit.

---

From: Arthi Ayyangar <[email-masked]>
Date: Fri, 8 Apr 2005 13:22:18 -0700 (PDT)

Amit,

> 	There is no way for LSP segment head node, to identify that a
> Outif selected is a LSP Segment for setting up E2e LSP.
---> What do you mean ? Why would the head-end of an LSP segment not know
that selected nexthop is the LSP segment ? It is the head-end of the LSP
segment selecting what you call Outif.

> 	That is Some extension will be needed to RSVP that will allow RSVP
> message(for E2e LSP) processing at LSP segment head node to be processed
> according to the Sticthing needs.
------> I don't think there is any need for any more extensions..see my
explanation above and below.

> 	Then how does RSVP(at Node A) identify that the outif selected is
        a LSP segment?
-------> A is doing nexthop (what you call outif) selection, A is the
head-end of LSP segment. A knows that nexthop is an LSP segment.

> 	There should be a way to determine at node A, that a LSP segment
-----> A chose to stitch the e2e LSP to the LSP segment in the first place.

thanks,
-arthi

> 	One possible way could be that Resv message for LSP1-2 should be
> sent(by B) with some special Label value.
> 	This Label value should indicate the node A that the Resv is
> received for a TE-Link(of type LSP Segment).