Subject: A Design Team for Layer Two Switching

From: "Adrian Farrel" <[email-masked]>
Date: Tue, 7 Jun 2005 12:40:08 +0100

Hi,

In Minneapolis there was some discussion about solutions for layer two
switching and in particular for GMPLS control of Ethernet devices.

After much discussion backwards and forwards I am setting up a team to
develop a framework and the basic requirements. Their charter (which
limits their scope quite tightly) is found below. Please help them and
look forward to reviewing their output in Paris.

Thanks,
Adrian

========
Charter for the CCAMP Layer 2 Ethernet Design Team

    GMPLS signaling and routing is applicable to Layer 2.
    However, up to now, very little attention has been given to the
    control of Ethernet switches using GMPLS protocols.

    This Design Team is chartered to start the work of applying
    GMPLS to Ethernet devices by developing a framework draft that
    covers possible deployment scenarios, identifies the consequent
    requirements, and highlights possible interactions with other
    SDOs.

    The sole objective of the Design Team is to produce this
    framework draft which should be around 10 pages in length.
    Solutions work is out of scope at this time.

    The draft will be ready for discussion at the Paris IETF.

    The Design Team members are as follows...

    - Dimitri Papadimitriou (Team Lead and Editor)
      [email-masked]
    - Jaihyung Cho (Co-Editor)
      [email-masked]
    - Loa Andersson
      [email-masked]
    - Arthi Ayyangar
      [email-masked]
    - Anders Gavler
      [email-masked]
    - Martin Vigoureux
      [email-masked]
    - Deborah Brungard
      [email-masked]
    - Simon Delord
      [email-masked]
    - Avri Doria
      [email-masked]
    - Tomohiro Otani
      [email-masked]
    - Jean-Louis Le Roux
      [email-masked]

Standard design team disclaimer: this design team has no special
status in the CCAMP WG. Any document produced is subject to the usual WG
procedures. Individuals are encouraged to interact with the design team,
to offer suggestions and, if they feel so inclined, to submit their own
drafts.

===

Suggested contents of framework I-D (fully open for revision)
- half page introduction
   - what does GMPLS currently do
   - L2 switching is in scope
   - Ethernet not previously examined
   - state that MPLS over Ethernet is not the same thing
- half page overview of the objectives
- four pages of figures and deployment scenarios
- two pages of requirements (just brief statements)
   - which nodes participate in signaling and routing?
   - what needs to be labeled?
       - don't get sucked into *how* to label anything
   - any scoping requirements for labels
   - is link discovery needed?
   - what needs to be advertised in routing?
   - etc.
   Each requirement should note which scenarios do/don't
   depend on the requirement
- half page to reference other SDOs (I think IEEE and ITU-T SG15)
- half page on security implications of control of Ethernet

===

---

From: "Diego Caviglia" <[email-masked]>
Date: Tue, 7 Jun 2005 19:11:55 +0200

Adrian,
        I'd like to see stressed expecially the following point of your
list

May be could be useful to explain why a Network Operator should prefer
GMPLS control for L2 instead MPLS.

Hope this helps

Diego

"Adrian Farrel" <[email-masked]>@ops.ietf.org on 07/06/2005 13.40.08

Please respond to "Adrian Farrel" <[email-masked]>

Sent by:    [email-masked]

To:    <[email-masked]>
cc:

Subject:    A Design Team for Layer Two Switching

Hi,

Thanks,
Adrian

========

===

===