Subject: RE: A new ID is available on the repository draft-caviglia-ccamp- pc-and-sc-reqs-00

From: "Diego Caviglia" <[email-masked]>
Date: Thu, 1 Jun 2006 09:20:00 +0200

Hi Vijay,
          some answers in line.

Regards

Diego

"Pandian, Vijay" <[email-masked]>@ops.ietf.org on 01/06/2006
04.34.12

Sent by:    [email-masked]

To:    "'Adrian Farrel'" <[email-masked]>,
       [email-masked]
cc:    [email-masked], Diego Caviglia <[email-masked]>,
       Dino Bramanti <[email-masked]>

Subject:    RE: A new ID is available on the repository
       draft-caviglia-ccamp-  pc-and-sc-reqs-00

Adrian and Dimitri,

Not sure why we need extra requirements to handle this case. Also not sure
why CP needs to guarantee identical states at [a] and [b]. May be I am not
understanding the case that is being pictured here.

The way I read the requirements, once the control is transferred to MP
(i.e., CP[a] -> MP), CP should forget everything about this LSP, Isn't it?
[dc] That is the idea.

If this is true, then MP -> CP[b] should be treated as the ONLY general
case
of MP -> CP conversion, right?
[dc] Yes, unless Dimitri calirifies better what he intend with state[a] and
state[b]

Regards,
Vijay

-----Original Message-----
From: Adrian Farrel [mailto:[email-masked]]
Sent: Wednesday, May 31, 2006 7:18 PM
To: [email-masked]
Cc: [email-masked]; Diego Caviglia; Dino Bramanti
Subject: Re: A new ID is available on the repository
draft-caviglia-ccamp-pc-and-sc-reqs-00

Interesting question.

It would certainly be the case that the picture you draw could arise. I
guess we would describe this in terms of SPCs. Is it necessary that
identical state is held at [a] and [b]. In particular, the question of
Session ID and LSP ID spring to mind.

Yes, we need clear requirements for this type of situation.  Want to
suggest

some?

Adrian

----- Original Message -----
From: <[email-masked]>
To: "Adrian Farrel" <[email-masked]>
Cc: <[email-masked]>; "Diego Caviglia" <[email-masked]>;
"Dino Bramanti" <[email-masked]>
Sent: Wednesday, May 31, 2006 7:44 PM
Subject: Re: A nerw ID is available on the repository
draft-caviglia-ccamp-pc-and-sc-reqs-00

> agreed -
>
> question: in case of move CP->MP who guarantees that the CP at state [b]
> retrieves its states it had at [a] e.g.
>
> MP->CP[a]->MP->CP[b]?
>
> do we need a specific requirement for this case ?
>
>
>
>
>
>
> "Adrian Farrel" <[email-masked]>
> Sent by: [email-masked]
> 25/05/2006 19:53
> Please respond to "Adrian Farrel"
>
>        To:     <[email-masked]>, "Diego Caviglia"
> <[email-masked]>
>        cc:     "Dan Li <danli", "Dino Bramanti"
> <[email-masked]>
>        Subject:        Re: A nerw ID is available on the repository
> draft-caviglia-ccamp-pc-and-sc-reqs-00
>
>
> Hi Diego,
>
> Thanks for putting this I-D together. I think it gives a much clearer
> picture of what you are trying to achieve with your discussion of moving
> control of an LSP between the management plane and the control plane.
>
> This seems like a reasonable set of requirements to me, and I would like
> to
> see some discussion from folk on whether they think this is valuable
work,
>
> and whether we should start to look for protocol solutions.
>
> Thanks,
> Adrian
>
> ----- Original Message -----
> From: "Diego Caviglia" <[email-masked]>
> To: <[email-masked]>
> Cc: "Dan Li <danli" <[email-masked]>; "Dino Bramanti"
> <[email-masked]>
> Sent: Wednesday, May 24, 2006 8:48 AM
> Subject: A nerw ID is available on the repository
> draft-caviglia-ccamp-pc-and-sc-reqs-00
>
>
>>A new ID is available on the ID repository
>>
>
http://www.ietf.org/internet-drafts/draft-caviglia-ccamp-pc-and-sc-reqs-00.t

xt
> .
>>
>> The ID states some basic requrements for the possibility of turning a
>> Permanent Connection (PC) into a Soft Permanent Connection (SPC) and
> vice
>> versa, without actually affecting Data Plane traffic, no solutions are
>> proposed in the ID.
>>
>> Abstract
>>
>>   From a Carrier perspective, the possibility of turning a Permanent
>>   Connection (PC) into a Soft Permanent Connection (SPC) and vice
>>   versa, without actually affecting Data Plane traffic being carried
>>   over it, is a valuable option. In other terms, such operation can be
>>   seen as a way of transferring the ownership and control of an
>>   existing and in-use Data Plane connection between the Management
>>   Plane and the Control Plane, leaving its Data Plane state untouched.
>>   This memo sets out the requirements for such procedures within a
>>   Generalized Multiprotocol Label Switching (GMPLS) network.
>>
>>
>> Comments and suggestions are very welcome sxpecially from the carrier
>> community.
>>
>> Regards
>>
>> Diego
>>
>>
>>
>>
>>
>>
>
>
>
>
>
>
>
>

---

From: "Adrian Farrel" <[email-masked]>
Date: Thu, 1 Jun 2006 12:25:26 +0100

Hi,

I read Dimitri's comments as being spatial not temporal.
I.e. he drew a figure showing four LSRs.

Dimitri?

Cheers,
Adrian

----- Original Message ----- 
From: "Diego Caviglia" <[email-masked]>
To: <[email-masked]>
Cc: """'Adrian Farrel'" <adrian"" <[email-masked]>; 
"Dimitri.Papadimitriou" <[email-masked]>; "ccamp" 
<[email-masked]>; "Dino Bramanti <Dino.Bramanti" 
<[email-masked]>; "Dan Li <danli" <[email-masked]>
Sent: Thursday, June 01, 2006 8:20 AM
Subject: RE: A new ID is available on the repository draft-caviglia-ccamp- 
pc-and-sc-reqs-00

---

From: [email-masked]
Date: Fri, 2 Jun 2006 15:56:35 +0200

hi adrian

CP[I] is to be complemented with I including values from the set 
{t,s[i],lsp[i]}

t      = time
s[i]   = rsvp_instance
lsp[i] = values associated to the P/RSB indexed by 5_tuple[i]

thanks,
- dimitri.

01/06/2006 13:25
 
        To:     <[email-masked]>, "Diego Caviglia" 
<[email-masked]>
        cc:     Dimitri PAPADIMITRIOU/BE/ALCATEL@ALCATEL, "ccamp" 
<[email-masked]>, "Dino Bramanti <Dino.Bramanti", "Dan Li <danli"
        Subject:        Re: A new ID is available on the repository 
draft-caviglia-ccamp-   pc-and-sc-reqs-00

Hi,

Dimitri?

Cheers,
Adrian

----- Original Message ----- 
From: "Diego Caviglia" <[email-masked]>
To: <[email-masked]>
Cc: """'Adrian Farrel'" <adrian"" <[email-masked]>; 

pc-and-sc-reqs-00

---

From: [email-masked]
Date: Sat, 3 Jun 2006 10:42:57 +0200

hi diego - see inline

"Diego Caviglia" <[email-masked]>
Sent by: [email-masked]
01/06/2006 09:20
 
        To:     [email-masked]
        cc:     "\"\"'Adrian Farrel'\" <adrian\"", Dimitri 
PAPADIMITRIOU/BE/ALCATEL@ALCATEL, "ccamp" <[email-masked]>, "Dino 
Bramanti <Dino.Bramanti", "Dan Li <danli"
        Subject:        RE: A new ID is available on the repository 
draft-caviglia-ccamp-   pc-and-sc-reqs-00

Hi Vijay,
          some answers in line.

Regards

Diego

"Pandian, Vijay" <[email-masked]>@ops.ietf.org on 
01/06/2006
04.34.12

Adrian and Dimitri,

[dp] meaning that you must be ensure that b/f transfer the state is 
completely in-sync among all nodes used to be traversed by the LSP

If this is true, then MP -> CP[b] should be treated as the ONLY general
case
of MP -> CP conversion, right?
[dc] Yes, unless Dimitri calirifies better what he intend with state[a] 
and
state[b]

[dp] see my previous post - note the above has an impact on the present
point

Regards,
Vijay

-----Original Message-----
From: Adrian Farrel [mailto:[email-masked]]
Sent: Wednesday, May 31, 2006 7:18 PM
To: [email-masked]
Cc: [email-masked]; Diego Caviglia; Dino Bramanti
Subject: Re: A new ID is available on the repository

Interesting question.

some?

Adrian

----- Original Message -----
From: <[email-masked]>
To: "Adrian Farrel" <[email-masked]>
Cc: <[email-masked]>; "Diego Caviglia" <[email-masked]>;

work,

xt