Subject: RE: A nerw ID is available on the repository draft-caviglia-ccamp-pc-and-sc-reqs-00

From: "Dean Cheng \(dcheng\)" <[email-masked]>
Date: Thu, 1 Jun 2006 17:17:55 -0700

Dear Author,

The conversion between PC and SPC as documented is useful
sometimes, and there was example in carriers networks
in the past as such from PC to SPC although with other
data plane technologies. And so I support this I-D.

Some suggestions:

1) Regarding the division of resources (Section 1.2 etc.).

   This is not only an "implementation" issue. If we allow
   the conversion, it should be defined clearly architecturally.

2) In addition to the "ownership" and "resource division",
   it might also be useful to mention interaction and
   resource transition between CP and MP during the conversion
   as required.

3) In Section 4.1, it may be clearer to say normal make-before-break
   is not an option for the requirement here (data plane consistency).

Thanks
Dean 

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Adrian Farrel
> Sent: Thursday, May 25, 2006 10:53 AM
> To: [email-masked]; Diego Caviglia
> Cc: Dan Li <danli; Dino Bramanti
> Subject: Re: A nerw ID is available on the repository 
> draft-caviglia-ccamp-pc-and-sc-reqs-00
> 
> Hi Diego,
> 
> Thanks for putting this I-D together. I think it gives a much 
> clearer picture of what you are trying to achieve with your 
> discussion of moving control of an LSP between the management 
> plane and the control plane.
> 
> This seems like a reasonable set of requirements to me, and I 
> would like to see some discussion from folk on whether they 
> think this is valuable work, and whether we should start to 
> look for protocol solutions.
> 
> Thanks,
> Adrian
> 
> ----- Original Message -----
> From: "Diego Caviglia" <[email-masked]>
> To: <[email-masked]>
> Cc: "Dan Li <danli" <[email-masked]>; "Dino Bramanti" 
> <[email-masked]>
> Sent: Wednesday, May 24, 2006 8:48 AM
> Subject: A nerw ID is available on the repository 
> draft-caviglia-ccamp-pc-and-sc-reqs-00
> 
> 
> >A new ID is available on the ID repository  
> >http://www.ietf.org/internet-drafts/draft-caviglia-ccamp-pc-a
> nd-sc-reqs-00.txt.
> >
> > The ID states some basic requrements for the possibility of 
> turning a 
> > Permanent Connection (PC) into a Soft Permanent Connection 
> (SPC) and 
> > vice versa, without actually affecting Data Plane traffic, no 
> > solutions are proposed in the ID.
> >
> > Abstract
> >
> >   From a Carrier perspective, the possibility of turning a Permanent
> >   Connection (PC) into a Soft Permanent Connection (SPC) and vice
> >   versa, without actually affecting Data Plane traffic being carried
> >   over it, is a valuable option. In other terms, such 
> operation can be
> >   seen as a way of transferring the ownership and control of an
> >   existing and in-use Data Plane connection between the Management
> >   Plane and the Control Plane, leaving its Data Plane state 
> untouched.
> >   This memo sets out the requirements for such procedures within a
> >   Generalized Multiprotocol Label Switching (GMPLS) network.
> >
> >
> > Comments and suggestions are very welcome sxpecially from 
> the carrier 
> > community.
> >
> > Regards
> >
> > Diego
> >
> >
> >
> >
> >
> > 
> 
>

---

From: Dan Li <[email-masked]>
Date: Fri, 02 Jun 2006 10:44:03 +0800

Hi Dean,

Many thanks for your support.

Please see my answer below.

Dan

----- Original Message ----- 
From: "Dean Cheng (dcheng)" <[email-masked]>
To: "Adrian Farrel" <[email-masked]>; <[email-masked]>; "Diego Caviglia" <[email-masked]>
Cc: "Dan Li <danli" <[email-masked]>; "Dino Bramanti" <[email-masked]>
Sent: Friday, June 02, 2006 8:17 AM
Subject: RE: A nerw ID is available on the repository draft-caviglia-ccamp-pc-and-sc-reqs-00

Dear Author,

Some suggestions:

[DL] Ok.

[DL] Yes, for PC and SC, there is no interaction between CP and MP, but for SPC, there are some interactions between CP and MP. Could you give us a suggestion requirement on this issue?

[DL] Ok.

Thanks
Dean