Subject: RE: I-D ACTION:draft-chen-ccamp-ospf-interas-te-extension-01.txt

From: "Vijayanand C - TLS, Chennai." <[email-masked]>
Date: Fri, 2 Feb 2007 13:00:29 +0530

The draft does not seem to address multi-access links between ASes.
Should the inter-AS link only be a point to point link or you are trying
to model multi-access links as multiple P2P links ( in which case B.W
calculations etc would not be straightforward)

Regards
Vijay

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
Behalf
> Of Mach Chen
> Sent: Friday, February 02, 2007 6:49 AM
> To: [email-masked]
> Subject: Fw: I-D
ACTION:draft-chen-ccamp-ospf-interas-te-extension-01.txt
> 
> Hi,
> 
> We have just submitted the second revision of our
I-D,draft-chen-ccamp-
> ospf-interas-te-extensions.
> 
> The problem we are trying to solve is how a PCE or entry-point ASBR
can
> select the exit-point ASBR for a TE LSP when it knows (from the ERO)
the
> downstream AS or the downstream ASBR. We believe that IGP needs to
flood
> the inter-AS TE links together with additional information about the
> neighboring AS and ASBR. The problem arises for both the pd-path and
brpc
> computation methods.
> 
> We would welcome your input on our problem statement and our proposed
> solution.
> 
> Best regards,
> 
> Mach & Renhai
> 
> ----- Original Message -----
> From: <[email-masked]>
> To: <[email-masked]>
> Sent: Friday, February 02, 2007 4:50 AM
> Subject: I-D ACTION:draft-chen-ccamp-ospf-interas-te-extension-01.txt
> 
> 
> >A New Internet-Draft is available from the on-line Internet-Drafts
> > directories.
> >
> >
> > Title : OSPF Extensions in Support of Inter-AS (G)MPLS TE
> > Author(s) : M. Chen, R. Zhang
> > Filename : draft-chen-ccamp-ospf-interas-te-extension-01.txt
> > Pages : 11
> > Date : 2007-2-1
> >
> > This document describes extensions to the OSPF protocol to support
> >   Multiprotocol Label Switching (MPLS) and Generalized MPLS (GMPLS)
> >   Traffic Engineering (TE) for multiple Autonomous Systems (ASes).
It
> >   defines OSPF extensions for the flooding of inter-AS links which
can
> >   be used to perform inter-AS path computation.
> >
> > A URL for this Internet-Draft is:
> >
http://www.ietf.org/internet-drafts/draft-chen-ccamp-ospf-interas-te-
> extension-01.txt
> >
> > To remove yourself from the I-D Announcement list, send a message to
> > [email-masked] with the word unsubscribe in the body
of
> > the message.
> > You can also visit
https://www1.ietf.org/mailman/listinfo/I-D-announce
> > to change your subscription settings.
> >
> > Internet-Drafts are also available by anonymous FTP. Login with the
> > username "anonymous" and a password of your e-mail address. After
> > logging in, type "cd internet-drafts" and then
> > "get draft-chen-ccamp-ospf-interas-te-extension-01.txt".
> >
> > A list of Internet-Drafts directories can be found in
> > http://www.ietf.org/shadow.html
> > or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
> >
> > Internet-Drafts can also be obtained by e-mail.
> >
> > Send a message to:
> > [email-masked].
> > In the body type:
> > "FILE /internet-drafts/draft-chen-ccamp-ospf-interas-te-extension-
> 01.txt".
> >
> > NOTE: The mail server at ietf.org can return the document in
> > MIME-encoded form by using the "mpack" utility.  To use this
> > feature, insert the command "ENCODING mime" before the "FILE"
> > command.  To decode the response(s), you will need "munpack" or
> > a MIME-compliant mail reader.  Different MIME-compliant mail readers
> > exhibit different behavior, especially when dealing with
> > "multipart" MIME messages (i.e. documents which have been split
> > up into multiple messages), so check your local documentation on
> > how to manipulate these messages.
> >
> > Below is the data which will enable a MIME compliant mail reader
> > implementation to automatically retrieve the ASCII version of the
> > Internet-Draft.
> >
> 
> 
>
------------------------------------------------------------------------
--
> ------
> 
> 
> > _______________________________________________
> > I-D-Announce mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/i-d-announce
> >

DISCLAIMER:
-----------------------------------------------------------------------------------------------------------------------

The contents of this e-mail and any attachment(s) are confidential and intended for the named recipient(s) only.
It shall not attach any liability on the originator or HCL or its affiliates. Any views or opinions presented in 
this email are solely those of the author and may not necessarily reflect the opinions of HCL or its affiliates.
Any form of reproduction, dissemination, copying, disclosure, modification, distribution and / or publication of 
this message without the prior written consent of the author of this e-mail is strictly prohibited. If you have 
received this email in error please delete it and notify the sender immediately. Before opening any mail and 
attachments please check them for viruses and defect.

-----------------------------------------------------------------------------------------------------------------------

---

From: Mach Chen <[email-masked]>
Date: Fri, 02 Feb 2007 18:19:27 +0800

Hi vijay,

First, thanks for your questions.

So far this version doesn't mention inter-as multi-access links, an alternative method, as you said, 
of describing this kind of links is to treat them as multiple P2P links. I will supplement this description
in the future revised version.

Best regards,

Mach

----- Original Message ----- 
From: "Vijayanand C - TLS, Chennai." <[email-masked]>
To: "Mach Chen" <[email-masked]>; <[email-masked]>
Sent: Friday, February 02, 2007 3:30 PM
Subject: RE: I-D ACTION:draft-chen-ccamp-ospf-interas-te-extension-01.txt

Regards
Vijay

Behalf
I-D,draft-chen-ccamp-
can
the
flood
brpc
It
can
of

---

From: "Adrian Farrel" <[email-masked]>
Date: Fri, 2 Feb 2007 20:05:17 -0000

Hmmm.

Question: Does anyone use multi-access TE links between ASes?

If so, we should address them (probably the same way that we address them 
within an AS/area - that is by defining a separate link type). But if no-one 
uses them, then we should leave that definition until there is a need.

I see that section 3.2 of Mach's I-D is very explicit that the new link type 
is p2p, so that is good.

Cheers,
Adrian