Subject: Proposed CCAMP recharter

From: "Adrian Farrel" <[email-masked]>
Date: Thu, 26 Jul 2007 22:25:20 +0100

Hi,

As discussed at the meeting(s) we should consider a small recharter to put 
the GELS work clearly in scope and to indicate that we will work with IEEE 
802.1 as necessary.

We should take the opportunity to rejig the milestones, but noting that a 
bunch of (overdue) milestones are about to be completed it is moot whether 
we should rearrange them all. Basically, I am too lazy to do that and 
propose just to change the ones that are further out.

I would like to ask you all to look at this and comment. In particular: are 
the document editors happy with these targets?

ADs - your opinions too, please.

The changes proposed are...
===
First paragraph
OLD
The CCAMP working group coordinates the work within the IETF defining a 
common control plane and a separate common measurement plane for physical 
path and core tunneling technologies of Internet and telecom service 
providers (ISPs and SPs), e.g. O-O and O-E-O optical switches, ATM and Frame 
Relay switches, MPLS, GRE, in cooperation with the MPLS WG.

NEW
The CCAMP working group coordinates the work within the IETF defining a 
common control plane and a separate common measurement plane for physical 
path and core tunneling technologies of Internet and telecom service 
providers (ISPs and SPs), e.g. O-O and O-E-O optical switches, TDM switches, 
Ethernet switches, ATM and Frame Relay switches, and MPLS GRE, in 
cooperation with the MPLS WG.
===
Final paragraph
OLD
In doing this work, the WG will work closely with at least the following 
other WGs: MPLS, ISIS, OSPF, IDR, L1VPN and PCE. The WG will also cooperate 
with the ITU-T.

NEW
In doing this work, the WG will work closely with at least the following 
other WGs: MPLS, ISIS, OSPF, IDR, L1VPN and PCE. The WG will also cooperate 
with the ITU-T, and the IEEE 802.1.
===
Milestones (only those changed or new)

Aug 2007    First version WG I-D for Protocol solutions for MLN/MRN
Aug 2007    First version WG I-D GMPLS OAM Requirements
Sep 2007    Submit Informational I-D for Analysis of inter-domain issues for 
disjoint and protected paths for IESG review
Sep 2007    Submit MPLS to GMPLS migration strategies I-D for IESG review
Sep 2007    Submit MPLS-GMPLS interworking requirements and solutions I-D 
for IESG review
Sep 2007    First version WG I-Ds for control of Ethernet networks
Oct 2007    Submit Requirements for Multi-Layer and Multi-Region Networks 
I-D for IESG review
Oct 2007    Submit Evaluation of existing protocols for MLN/MRN for IESG 
review
Oct 2007    First version of WG I-D for additional MIB module to cover 
RSVP-TE signaling extensions
Dec 2007    Submit OSPF-TE/GMPLS MIB module for MIB doctor and IESG review
Jan 2008    Submit ASON Routing solutions I-D for IESG review
Feb 2008    Submit GMPLS OAM Requirements I-D for IESG review
Mar 2008    Submit Protocol solutions for MLN/MRN I-D for IESG review
Apr 2008    Submit MIB module for RSVP-TE signaling extensions for MIB 
doctor and IESG review
May 2008    Submit protocol extensions for control of Ethernet networks for 
IESG review
Dec 2008    Recharter or close Working Group
====

Thanks,
Adrian

---

From: dimitri papadimitriou <[email-masked]>
Date: Fri, 27 Jul 2007 00:53:45 +0200

adrian

couple of points on editorship:

- MRN req + eval. should imho be ready by end Aug.

- concerning the i/w document i'd like to suggest referring to MPLS-TE 
(rather than MPLS) since applying only to RSVP-TE

- also you refer to a solution for the latter but we just have req. and 
a framework since so far -> are u sure solution would be ready by Sep'07
or alternatively the former doc shall be split and further discussed

we need also a milestone for input to the MPLS security doc. but not 
sure this has to be recorded

concerning the charter, two specific comments

- like also mentioned during the second meeting, clarifying the term 
Ethernet types would be suggested otherwise entering in an open-ended
discussion about what is allowed/not allowed, desired/not-desired, 
possible/not possible, etc. and probably focus on the analytical work 
here (something we should have probably done in the GELS context but 
did not happen) - side note here it was always felt useful to have 
operational use case described as well but that work did also never happen

- is this milestone also including Ethernet service signaling e.g. MEF ? 
in that case i would suggest to make a clear distinction here ?

thanks,
-d.

Adrian Farrel wrote:
> Hi,
> 
> As discussed at the meeting(s) we should consider a small recharter to 
> put the GELS work clearly in scope and to indicate that we will work 
> with IEEE 802.1 as necessary.
> 
> We should take the opportunity to rejig the milestones, but noting that 
> a bunch of (overdue) milestones are about to be completed it is moot 
> whether we should rearrange them all. Basically, I am too lazy to do 
> that and propose just to change the ones that are further out.
> 
> I would like to ask you all to look at this and comment. In particular: 
> are the document editors happy with these targets?
> 
> common control plane and a separate common measurement plane for 
> physical path and core tunneling technologies of Internet and telecom 
> service providers (ISPs and SPs), e.g. O-O and O-E-O optical switches, 
> ATM and Frame Relay switches, MPLS, GRE, in cooperation with the MPLS WG.
> 
> NEW
> common control plane and a separate common measurement plane for 
> physical path and core tunneling technologies of Internet and telecom 
> service providers (ISPs and SPs), e.g. O-O and O-E-O optical switches, 
> TDM switches, Ethernet switches, ATM and Frame Relay switches, and MPLS 
> GRE, in cooperation with the MPLS WG.
> ===
> Final paragraph
> OLD
> other WGs: MPLS, ISIS, OSPF, IDR, L1VPN and PCE. The WG will also 
> cooperate with the ITU-T.
> 
> NEW
> other WGs: MPLS, ISIS, OSPF, IDR, L1VPN and PCE. The WG will also 
> cooperate with the ITU-T, and the IEEE 802.1.
> ===
> Sep 2007    Submit Informational I-D for Analysis of inter-domain issues 
> for disjoint and protected paths for IESG review
> Sep 2007    Submit MPLS-GMPLS interworking requirements and solutions 
> I-D for IESG review
> Oct 2007    Submit Requirements for Multi-Layer and Multi-Region 
> Networks I-D for IESG review
> May 2008    Submit protocol extensions for control of Ethernet networks 
> for IESG review
> .

---

From: "tom.petch" <[email-masked]>
Date: Tue, 31 Jul 2007 10:04:40 +0200

In the 'first paragraph', I am puzzled by the change from 
 MPLS, GRE,
to
 and MPLS GRE,
which seems a material, semantic change; is this intended?

Tom Petch

---

From: "Adrian Farrel" <[email-masked]>
Date: Tue, 31 Jul 2007 12:40:39 +0100

Good catch.
Should be...
and MPLS and GRE,

A
----- Original Message ----- 
From: "tom.petch" <[email-masked]>
To: "Adrian Farrel" <[email-masked]>; <[email-masked]>
Cc: "Ross Callon" <[email-masked]>; <[email-masked]>
Sent: Tuesday, July 31, 2007 9:04 AM
Subject: Re: Proposed CCAMP recharter

>> put
>> are
>> cooperate
>> for
>> for