Subject: Re: [Softwires] BGP TE attr last call by softwires WG (2nd question)

From: Igor Bryskin <[email-masked]>
Date: Fri, 29 Aug 2008 11:28:38 -0700 (PDT)

Hi John,

No, not really. When you add a PE you configure local interfaces, local VPN port mappings, stuff like that. While doing this you will also configure an IPinIP tunnel to one of your spoke Ps and enable L1VPN OSPF instance on the tunnel. Once you did that the local VPN information will be flooded accross the overlay, likewise, the new PE will get all the necessary information from other PEs.

Cheers,
Igor

----- Original Message ----
From: "Drake, John E" <[email-masked]>
To: Igor Bryskin <[email-masked]>; Yakov Rekhter <[email-masked]>; Lou Berger <[email-masked]>
Cc: Yakov Rekhter <[email-masked]>; Adrian Farrel <[email-masked]>; [email-masked]; [email-masked]
Sent: Friday, August 29, 2008 11:20:16 AM
Subject: RE: [Softwires] BGP TE attr last call by softwires WG (2nd question)

Igor,

Doesn't this defeat auto-discovery?  I.e., how is a new PE added to a
given L1VPN?

Thanks,

John 

>-----Original Message-----
>From: Igor Bryskin [mailto:[email-masked]] 
>Sent: Friday, August 29, 2008 5:51 AM
>To: Yakov Rekhter; Lou Berger
>Cc: Yakov Rekhter; Adrian Farrel; [email-masked]; 
>[email-masked]
>Subject: Re: [Softwires] BGP TE attr last call by softwires WG 
>(2nd question)
>
>Yakov,
>
>You said:
>
>
>... And while on the subject of scaling, please keep in mind 
>that BGP only stores L1VPN routes on PEs that have sites of 
>that VPN connected to them, and on an RR if used, but *not* on 
>any of the P routers. In contrast, rfc5252 (OSPF for L1VPN 
>autodiscovery) results in storing *all VPN TE information for 
>all the VPNs* on *all* the IGP nodes, both P and PE. So, 
>clearly BGP-based approach scales better than OSPF-based approach.
>
>Yakov.
>
>This is not true in case of multi-instance OSPF: one can build 
>an overlay interconnecting PEs via one or small number of Ps 
>using IPinIP tunnels and run in this overlay an instance of 
>OSPF specifically designated for distribution of L1VPN 
>information. In this case the OSPF solution won't scale any 
>worse than the BGP approach. Note. that rfc252 never said that 
>the instance of OSPF used for flooding of the L1VPN 
>information must be the same instance that is used for the 
>distribution of IP-related LSAs.
>
>Regards,
>Igor
>
>
>
>

---

From: "Drake, John E" <[email-masked]>
Date: Fri, 29 Aug 2008 11:31:36 -0700

So you are proposing an OSPF route reflector?  At what point does the
silliness stop? 

>Sent: Friday, August 29, 2008 11:29 AM
>To: Drake, John E; Yakov Rekhter; Lou Berger
>No, not really. When you add a PE you configure local 
>interfaces, local VPN port mappings, stuff like that. While 
>doing this you will also configure an IPinIP tunnel to one of 
>your spoke Ps and enable L1VPN OSPF instance on the tunnel. 
>Once you did that the local VPN information will be flooded 
>accross the overlay, likewise, the new PE will get all the 
>necessary information from other PEs.
>
>Cheers,
>Igor
>
>
>To: Igor Bryskin <[email-masked]>; Yakov Rekhter 
><[email-masked]>; Lou Berger <[email-masked]>
>Cc: Yakov Rekhter <[email-masked]>; Adrian Farrel 
><[email-masked]>; [email-masked]; [email-masked]
>Doesn't this defeat auto-discovery?  I.e., how is a new PE 
>added to a given L1VPN?
>
>Thanks,
>
>John 
>
>>Subject: Re: [Softwires] BGP TE attr last call by softwires WG (2nd 
>>question)
>>
>>Yakov,
>>
>>You said:
>>
>>
>>... And while on the subject of scaling, please keep in mind that BGP 
>>only stores L1VPN routes on PEs that have sites of that VPN connected 
>>to them, and on an RR if used, but *not* on any of the P routers. In 
>>contrast, rfc5252 (OSPF for L1VPN
>>autodiscovery) results in storing *all VPN TE information for all the 
>>VPNs* on *all* the IGP nodes, both P and PE. So, clearly BGP-based 
>>approach scales better than OSPF-based approach.
>>
>>Yakov.
>>
>>This is not true in case of multi-instance OSPF: one can build an 
>>overlay interconnecting PEs via one or small number of Ps 
>using IPinIP 
>>tunnels and run in this overlay an instance of OSPF specifically 
>>designated for distribution of L1VPN information. In this 
>case the OSPF 
>>solution won't scale any worse than the BGP approach. Note. 
>that rfc252 
>>never said that the instance of OSPF used for flooding of the L1VPN