Subject: RE: [mpls-tp] MPLS over OTN

From: "Diego Caviglia" <[email-masked]>
Date: Mon, 4 Aug 2008 17:23:25 +0200

Hi,
   I think that the Maarten interpretation is correct.

BR

Diego

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Maarten Vissers
> Sent: lunedì 4 agosto 2008 16.28
> To: 'Francesco Fondelli'
> Cc: [email-masked]; [email-masked]
> Subject: Re: [mpls-tp] MPLS over OTN
> 
> Francesco,
> 
> This requirement defines that the MPLS-TP data (transport) plane operates
> in
> the absence of an IP data (transport) plane. This requirement does not say
> anything about the DCN, and the technologies deployed in this DCN.
> 
> Regards,
> Maarten
> 
> -----Original Message-----
> From: Francesco Fondelli [mailto:[email-masked]]
> Sent: 04 August 2008 15:00
> To: Maarten Vissers
> Cc: Adrian Farrel; Howard Green; [email-masked]; [email-masked]
> Subject: Re: [mpls-tp] MPLS over OTN
> 
> On Mon, Aug 4, 2008 at 2:50 PM, Maarten Vissers
> <[email-masked]>
> wrote:
> > Adrian, Howard,
> >
> > The transport network has a DCN, and this DCN inlcudes today a mix of
> > OSI and IP technologies.
> 
> Hi,
> 
> --- draft-jenkins-mpls-mpls-tp-requirements-00
> 
>    o  It MUST be possible to operate and configure the MPLS-TP data
>       (transport) plane without any IP functionality.
> 
> ---
> 
> So what do you think about this requirement?
> 
> Ciao
> FF
> 
> 
> _______________________________________________
> mpls-tp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls-tp

---

From: "Diego Caviglia" <[email-masked]>
Date: Mon, 4 Aug 2008 17:35:37 +0200

Opsss you are right!

I've missed the term configure! I was focused on the fact that an MPLS-TP equipment doesn't need to be able to perform IP forwarding at the data plane.

BR

Diego

> Of Francesco Fondelli
> Sent: lunedì 4 agosto 2008 17.32
> To: Maarten Vissers
> On Mon, Aug 4, 2008 at 4:28 PM, Maarten Vissers
> <[email-masked]> wrote:
> > Francesco,
> 
> Hi Maarten,
> 
> > This requirement defines that the MPLS-TP data (transport) plane
> operates in
> I agree with you, but I think that "and configure" should be removed.
> 
> How can you *configure* MPLS-TP data plane without IP (or OSI)?
> Am I the only one that feel uncomfortable with this piece of text?
> 
> > Regards,
> > Maarten
> 
> Ciao
> FF

---

From: <[email-masked]>
Date: Mon, 4 Aug 2008 17:48:57 +0200

Hi Francesco.

I guess I understand your concern. I believe the original intention was
to say implicitely "It MUST be possible to operate and configure the
MPLS-TP data (transport) plane without any IP functionality *in the data
plane*." My interpretation of these requirements is indeed that they
apply to the MPLS-TP data plane only, not the MPLS-TP-capable equipment,
nor the MPLS-TP control plane...

Anyway you're right, this could be confusing and it deserves a small
rewording.

Regards,

Julien

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Francesco Fondelli

Hi Maarten,

operates in

Ciao
FF

---

From: Huub van Helvoort <[email-masked]>
Date: Mon, 04 Aug 2008 18:33:52 +0200

Hi Francesco,

You replied:

>> This requirement defines that the MPLS-TP data (transport) plane operates in

By using the same NMS that is used to configure the OTN node.

Ciao, Huub.

-- 
================================================================
                   http://www.van-helvoort.eu/
================================================================
Always remember that you are unique...just like everyone else...

---

From: "Lam, Hing-Kam \(Kam\)" <[email-masked]>
Date: Mon, 4 Aug 2008 13:31:24 -0500

Dear all,

Julien's proposed rephrase is good.

By the way, DCN requirements (more specifically Management Communication
Network (MCN) requirements) are already described in
draft-gray-mpls-tp-nm-req-00.txt. Of course comments for improvement are
always welcome.

Regards,
Kam

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Italo Busi
Sent: Monday, August 04, 2008 2:14 PM
To: 'Francesco Fondelli'; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: Re: [mpls-tp] MPLS over OTN

I think that Julien's proposed rephrase better describes the requirement
so I
support it.

It is worth noticing that in case of static configuration and OSI based
DCN, the
MPLS-TP data (transport) plane is actually configured without any IP
functionality.

However I think that DCN requirements should be described in
draft-gray-mpls-tp-nm-req-00.txt.

For the scope of draft-jenkins-mpls-mpls-tp-requirements-00.txt, I think
that it
is more appropriate to rephrase the requirement as proposed by Julien.

Italo

> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Francesco Fondelli
> Sent: Monday, August 04, 2008 6:00 PM
> To: [email-masked]
> On Mon, Aug 4, 2008 at 5:48 PM,  
> <[email-masked]> wrote:
> > Hi Francesco.
> 
> Hi Julien,
> 
> Nice, thanks a lot.

---

From: "Diego Caviglia" <[email-masked]>
Date: Tue, 5 Aug 2008 09:38:04 +0200

Hi all,
       So we are at the point where we agreed that Ip forwarding is not needed in the data plane nevertheless Ip is needed for sure for GMPLS protocols (if used).

Now in this thread we mentioned several times the DCN, are there any requirement about the protocol to be used for the DCN? Do we think that the DCN should support both OSI and Ip?

Given that we are in IETF I think the answer is that the DCN and configuration protocol must be Ip based, but may be could be useful state that somewhere; I agree that draft-gray-mpls-tp-nm-req-00.txt is the right place.

BR

Diego

> Of Italo Busi
> Sent: lunedì 4 agosto 2008 20.14

---

From: Ben Niven-Jenkins <[email-masked]>
Date: Tue, 12 Aug 2008 17:59:47 +0100

Catching up on mails...

> nor the MPLS-TP control plane...

Correct.

> Anyway you're right, this could be confusing and it deserves a small

I have reworded to:
"It MUST be possible to operate and configure the MPLS-TP data (transport)
plane without any IP functionality in the MPLS-TP data plane."

Ben