Subject: Re: [mpls-tp] mpls-tp Dual stack DCN? (was MPLS over OTN)

From: "Adrian Farrel" <[email-masked]>
Date: Tue, 5 Aug 2008 09:54:46 +0100

Maarten,

I think you need to get off this OSI thing.

Nothing the IETF does will require the use of IP in the DCN for an MPLS-TP 
stack. However, the IETF will only work on DCN protocols that are based on 
IP.

It will remain possible to manage MPLS-TP functionality using a DCN based on 
OSI, SNA, PNNI, or bluetak.

Since IP stacks are freely available and pretty small, and since it has 
already been established that IP forwarding is not necessarily required in 
the NEs, I don't know why this thread continues.

A

----- Original Message ----- 
From: "Maarten Vissers" <[email-masked]>
To: "'Diego Caviglia'" <[email-masked]>; "'Italo Busi'" 
<[email-masked]>; "'Francesco Fondelli'" 
<[email-masked]>; <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>
Sent: Tuesday, August 05, 2008 9:23 AM
Subject: Re: [mpls-tp] mpls-tp Dual stack DCN? (was MPLS over OTN)

Diego,

The MPLS-TP functionality may be in equipment with e.g. SDH and OTN
functions. If such equipment uses MS-DCC to connect to the DCN, then it is
very likely that OSI is used. The MPLS-TP functions in this equipment should
**not** require that this equipment has to be equipped with two more DCN
connections supporting IP. I.e. it should be posible to manage MPLS-TP
functionality in equipment also via an OSI type DCN connection.

Regards,
Maarten

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Diego Caviglia
Sent: 05 August 2008 09:38
To: Italo Busi; Francesco Fondelli; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: [mpls-tp] mpls-tp Dual stack DCN? (was MPLS over OTN)

Hi all,
       So we are at the point where we agreed that Ip forwarding is not
needed in the data plane nevertheless Ip is needed for sure for GMPLS
protocols (if used).

Now in this thread we mentioned several times the DCN, are there any
requirement about the protocol to be used for the DCN? Do we think that the
DCN should support both OSI and Ip?

Given that we are in IETF I think the answer is that the DCN and
configuration protocol must be Ip based, but may be could be useful state
that somewhere; I agree that draft-gray-mpls-tp-nm-req-00.txt is the right
place.

BR

Diego

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Italo Busi
> Sent: lunedì 4 agosto 2008 20.14
> To: 'Francesco Fondelli'; [email-masked]
> Cc: [email-masked]; [email-masked]
> Subject: Re: [mpls-tp] MPLS over OTN
>
> I think that Julien's proposed rephrase better describes the
> requirement so I support it.
>
> It is worth noticing that in case of static configuration and OSI
> based DCN, the MPLS-TP data (transport) plane is actually configured
> without any IP functionality.
>
> However I think that DCN requirements should be described in
> draft-gray-mpls-tp-nm-req-00.txt.
>
> For the scope of draft-jenkins-mpls-mpls-tp-requirements-00.txt, I
> think that it is more appropriate to rephrase the requirement as
> proposed by Julien.
>
> Italo
>
> > -----Original Message-----
> > From: [email-masked]
> > [mailto:[email-masked]] On Behalf Of Francesco Fondelli
> > Sent: Monday, August 04, 2008 6:00 PM
> > To: [email-masked]
> > Cc: [email-masked]; [email-masked]
> > Subject: Re: [mpls-tp] MPLS over OTN
> >
> > On Mon, Aug 4, 2008 at 5:48 PM,
> > <[email-masked]> wrote:
> > > Hi Francesco.
> >
> > Hi Julien,
> >
> > > I guess I understand your concern. I believe the original
> > intention was
> > > to say implicitely "It MUST be possible to operate and configure
> > > the MPLS-TP data (transport) plane without any IP functionality
> > *in the data
> > > plane*." My interpretation of these requirements is indeed that
> > > they apply to the MPLS-TP data plane only, not the
> > MPLS-TP-capable equipment,
> > > nor the MPLS-TP control plane...
> > >
> > > Anyway you're right, this could be confusing and it deserves a
> > > small rewording.
> >
> > Nice, thanks a lot.
> >
> > > Regards,
> > >
> > > Julien
> >
> > Ciao
> > FF
> > _______________________________________________
> > mpls-tp mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/mpls-tp
> >
>
> _______________________________________________
> mpls-tp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls-tp
_______________________________________________
mpls-tp mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mpls-tp

_______________________________________________
mpls-tp mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mpls-tp

---

From: Ben Niven-Jenkins <[email-masked]>
Date: Fri, 15 Aug 2008 14:43:22 +0100

Maarten,

I agree that OSI is still present in many transport network elements and
therefore DCN support for OSI will be required for some DCNs.

However, does this lead to a requirement that MPLS-TP equipment *must*
support OSI?

Modern transport gear also supports IP for DCN and this is the direction
many operators are choosing to move.

So it would appear to me that the requirements placed on DCN design in
general are different to the requirements placed on the transport equipment
itself (which will be controlled via the DCN).

Let me use BT's transmission DCN as an example - we have a significant sized
DCN consisting of several thousand routers/switches (just for the
transmission DCN itself).  It supports both OSI and IP.  Therefore we are
able to accommodate new transport equipment control via IP while maintaining
control of old transport equipment via OSI.

Ben

On 15/08/2008 00:27, "Maarten Vissers" <[email-masked]> wrote:

> Do routers today only support IPv6, or are there still many of the older
> protocols supported? I assume it is the latter case, as it is difficult to
> switch off support for older protocols as long as its original equipment is
> still present at some places in the network. I.e. wouldn't it be in the long
> term economic interest of the customer to migrate to IPv6 only? When do you
> think you can switch of support for IPv4 and older protocols in the routers?
> 
> With OSI in the DCN we have a similar situation. It is still present in many
> network elements and must as such be supported within the existing and
> future DCN.
> 
> Regards,
> Maarten
> 
> From: Stewart Bryant [mailto:[email-masked]]
> Sent: 11 August 2008 13:52
> To: Adrian Farrel
> Cc: Maarten Vissers; 'Diego Caviglia'; 'Italo Busi'; 'Francesco Fondelli';
> [email-masked]; [email-masked]; [email-masked]
> These control channels are the last vestige of OSI in modern networks (apart
> from ISIS which is alive and well). Surely it is in the long term economic
> interests of the customer (infrastructure equipment costs, training,
> commonality etc)  to migrate to IP?
> 
> Stewart
>> 
> 
> 
>