Subject: Re: Comments on "draft-li-ccamp-wson-igp-eval-01.txt"

From: Dan Li <[email-masked]>
Date: Fri, 01 Aug 2008 17:09:57 +0800

Comments on "draft-li-ccamp-wson-igp-eval-01.txt"Hi Snigdho,

Very good question! See my comments below.

Thanks,

Dan
  ----- Original Message ----- 
  From: Bardalai, Snigdho 
  To: Ccamp (E-mail) 
  Sent: Friday, August 01, 2008 4:26 AM
  Subject: Comments on "draft-li-ccamp-wson-igp-eval-01.txt"

  Hi Adrian and Dan, 

  I have the following comments on this draft. I was wondering what were the objectives for the IGP evaluation. IMHO the evaluation from WSON perspective should address the following:

  1. IGP usage in the context of traditional distributed solutions for WSON 

  [Dan] With the situation that TE information is already be carried by IGP, it's nature to think that the wavelength information can also be carried by IGP. I am not saying it should be, but it's worth to look at.

  2. IGP usage in the context of PCE solutions for WSON

  [Dan] It's a potential way for PCE to get the wavelength information.

  3. Flooding and refresh of static and dynamic link state updates

  [Dan] Try to figure out the impact to the performance of IGP.

  4. Data base sync-up during node restarts

  [Dan] Yes, this should be considered. Especially the very large amount of data will be sent to the restarting node. We may consider the point to point data exchange instead of flooding the LSA updates. Or slice the big data packet into small pieces.

  Could you please let me know if the above is within the current scope? I believe that these are important. 

  Thanks, 
  Snigdho

---

From: "Bardalai, Snigdho" <[email-masked]>
Date: Wed, 6 Aug 2008 23:09:16 -0500

Hi Dan,
 
Please see my response below.
 
Thanks,
Snigdho

-----Original Message-----
From: Dan Li [mailto:[email-masked]]
Sent: Friday, August 01, 2008 4:10 AM
To: Bardalai, Snigdho; Ccamp (E-mail)
Subject: Re: Comments on "draft-li-ccamp-wson-igp-eval-01.txt"

Hi Snigdho,

Thanks,
 
Dan

----- Original Message ----- 
From: Bardalai, Snigdho <mailto:[email-masked]>  
To: Ccamp (E-mail) <mailto:[email-masked]>  
Sent: Friday, August 01, 2008 4:26 AM
Subject: Comments on "draft-li-ccamp-wson-igp-eval-01.txt"

Hi Adrian and Dan, 

[Dan] With the situation that TE information is already be carried by IGP, it's nature to think that the wavelength information can also be carried by IGP. I am not saying it should be, but it's worth to look at.
[Bardalai, Snigdho] Do you see any particular issues with using the IGP for this purpose ? 

[Dan] It's a potential way for PCE to get the wavelength information.
[Bardalai, Snigdho] Since the PCE is the location where path-computation takes place is it possible to limit LSA advertisements from PCC to PCE neighbors, instead of to every PCC neighbor?

[Dan] Try to figure out the impact to the performance of IGP.
[Bardalai, Snigdho] Is it possible to limit refreshing of static LSA? Ex. using the OSPF "do not age" concept?

[Dan] Yes, this should be considered. Especially the very large amount of data will be sent to the restarting node. We may consider the point to point data exchange instead of flooding the LSA updates. Or slice the big data packet into small pieces.
[Bardalai, Snigdho] This is little tricky, I would be interested to see if there is a clean solution.

Thanks, 
Snigdho

---

From: Dan Li <[email-masked]>
Date: Mon, 11 Aug 2008 09:48:59 +0800

I copied the original text here for easy read. See my comments below.

=====
Hi Adrian and Dan, 

[Dan] From the result of the simulation, the OSPF convergency time takes a liitle bit longer when the entire network restarts. Because the WSON information is added in the OSPF LSA. During the network running normally, the update of wavelength availability information doesn't impact the IGP performance obviously.
 
2. IGP usage in the context of PCE solutions for WSON
[Dan] It's a potential way for PCE to get the wavelength information.
[Bardalai, Snigdho] Since the PCE is the location where path-computation takes place is it possible to limit LSA advertisements from PCC to PCE neighbors, instead of to every PCC neighbor?
[Dan] You are right, PCC which doesn't do the path-computation doesn't need this kind of information.

3. Flooding and refresh of static and dynamic link state updates
[Dan] Try to figure out the impact to the performance of IGP.
[Bardalai, Snigdho] Is it possible to limit refreshing of static LSA? Ex. using the OSPF "do not age" concept?
[Dan] Yes, it's possible to take this way to reduce the protocol traffic. But we should consider the scenario when a node gets restart or goes down, so the HELLO message may still need to be kept.

---

From: Dan Li <[email-masked]>
Date: Mon, 11 Aug 2008 15:33:01 +0800

=====
Hi Adrian and Dan, 

Thanks,

Dan