Subject: [CCAMP] Term "PSC" in draft-ietf-mpls-tp-linear-protection-01

From: Vivien Sterling <[email-masked]>
Date: Wed, 24 Mar 2010 16:20:35 +0800

Dear Experts,

I'm surprised to find the term "PSC" used in this draft. I suppose the
authors are talking about data plane not control plane, right? Isn't PSC in
GMPLS elaborated as "Packet Switch Capable" ? It's confusing :-(

-- 
Cheers,
Vivien

---

From: Alexander Vainshtein <[email-masked]>
Date: Wed, 24 Mar 2010 10:30:22 +0200

Vivien and all,
AFAIK, PSC stands for "Protection State Coordination" in the MPLS-TP parlance (see MPLS-TP Survivability Framework<http://datatracker.ietf.org/doc/draft-ietf-mpls-tp-survive-fwk/>) - a new fancy name for what has been known as "APS Protocol" in SONET/SDH.

As you've noted, it has a completely different meaning in GMPLS.

Since GMPLS is going to be used with MPLS-TP, double usage of this acronym looks highly problematic.

Regards,
     Sasha

From: [email-masked] [mailto:[email-masked]] On Behalf Of Vivien Sterling
Sent: Wednesday, March 24, 2010 10:21 AM
To: [email-masked]; [email-masked]; [email-masked]
Subject: [mpls] Term "PSC" in draft-ietf-mpls-tp-linear-protection-01

Dear Experts,

I'm surprised to find the term "PSC" used in this draft. I suppose the authors are talking about data plane not control plane, right? Isn't PSC in GMPLS elaborated as "Packet Switch Capable" ? It's confusing :-(

--
Cheers,
Vivien

---

From: Vivien Sterling <[email-masked]>
Date: Wed, 24 Mar 2010 17:27:06 +0800

Sasha,

Right. It causes more confusion when GMPLS is used with MPLS-TP.
Could you share more information about the relationship between "PSC" and
"APS protocol" ? Are they exactly the same with only the different naming?
If so, I don't see any good of giving "a new fancy name". Anyway, I might be
out of fashion ;-)

Cheers,
Vivien

2010/3/24 Alexander Vainshtein <[email-masked]>

>  Vivien and all,
>
> AFAIK, PSC stands for “Protection State Coordination” in the MPLS-TP
> parlance (see MPLS-TP Survivability Framework<http://datatracker.ietf.org/doc/draft-ietf-mpls-tp-survive-fwk/>)
> – a new fancy name for what has been known as “APS Protocol” in SONET/SDH.
>
>
>
> As you’ve noted, it has a completely different meaning in GMPLS.
>
>
>
> *From:* [email-masked] [mailto:[email-masked]] *On Behalf Of
> *Vivien Sterling
> *Sent:* Wednesday, March 24, 2010 10:21 AM
> *To:* [email-masked]; [email-masked]; [email-masked]
> *Subject:* [mpls] Term "PSC" in draft-ietf-mpls-tp-linear-protection-01
>
>
>
> Dear Experts,
>
>
>

-- 
Cheers,
Vivien

---

From: "Cecil Byles" <[email-masked]>
Date: Wed, 24 Mar 2010 10:49:21 +0100

Hi,
Can I therefore also asked how PSC "Protection State Coordination" in
the MPLS-TP parlance align with ITU-T 808.1 recommendation that "defines
the generic functional models, characteristics and processes associated
with various linear protection schemes for connection-oriented layer
networks; e.g., Optical Transport Networks (OTN), Synchronous Digital
Hierarchy (SDH) networks and Asynchronous Transfer Mode (ATM) networks"
and the sections covering  Terms and Definitions as well as
Abbreviations.  IMO all transport engineers and the general telecom
community understand that 1+1 or 1:1 are either SNCP or APS. Hence why
introduce a new TLA (three letter abbreviation) cover the same function
and feature for MPLS-TP.  I can only agree that this will only cause
confusion.
 
Cecil Byles   

Senior Architect 

Transmission Services 

Interoute Communications Limited
Walbrook Building, 195 Marsh Wall, London E14 9SG, UK

  <http://www.interoute.com/networks/index.html> 
 
direct line: +44 (0)2070259599
fax: +44 (0)2070259864
mobile +44(0)7866447466
email: [email-masked] <mailto:[email-masked]> 
web: www.interoute.com <http://www.interoute.com/> 

________________________________

From: [email-masked] [mailto:[email-masked]] On
Behalf Of Vivien Sterling
Sent: 24 March 2010 09:27
To: Alexander Vainshtein
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re: [mpls-tp] [mpls] Term "PSC"
indraft-ietf-mpls-tp-linear-protection-01

Sasha,
 
Right. It causes more confusion when GMPLS is used with MPLS-TP. 
Could you share more information about the relationship between "PSC"
and "APS protocol" ? Are they exactly the same with only the different
naming? If so, I don't see any good of giving "a new fancy name".
Anyway, I might be out of fashion ;-)
 
Cheers,
Vivien

	Vivien and all,

	AFAIK, PSC stands for "Protection State Coordination" in the
MPLS-TP parlance (see MPLS-TP Survivability Framework
<http://datatracker.ietf.org/doc/draft-ietf-mpls-tp-survive-fwk/> ) - a
new fancy name for what has been known as "APS Protocol" in SONET/SDH.

	Since GMPLS is going to be used with MPLS-TP, double usage of
this acronym looks highly problematic.

	Regards,

	     Sasha

	From: [email-masked] [mailto:[email-masked]] On
Behalf Of Vivien Sterling
	Sent: Wednesday, March 24, 2010 10:21 AM
	To: [email-masked]; [email-masked]; [email-masked]
	Subject: [mpls] Term "PSC" in
draft-ietf-mpls-tp-linear-protection-01

	Dear Experts,

	I'm surprised to find the term "PSC" used in this draft. I
suppose the authors are talking about data plane not control plane,
right? Isn't PSC in GMPLS elaborated as "Packet Switch Capable" ? It's
confusing :-(

	-- 
	Cheers,
	Vivien

-- 
Cheers,
Vivien

---

From: Huub van Helvoort <[email-masked]>
Date: Wed, 24 Mar 2010 18:14:27 +0100

Hello Cecil,

You wrote:

> Can I therefore also asked how PSC “Protection State Coordination” in 

I agree with you.

In addition to that:
The ITU-T experts that reviewed the survivability draft had the same 
concerns, and expressed that in their reply liaison for the review of
this draft: https://datatracker.ietf.org/liaison/618/ that was
sent in november last year.
This concern has not been addressed yet.

Regards, Huub.

-- 
================================================================
Always remember that you are unique...just like everyone else...

---

From: Curtis Villamizar <[email-masked]>
Date: Thu, 25 Mar 2010 01:59:29 -0400

In message <[email-masked]>
> GMPLS elaborated as "Packet Switch Capable" ? It's confusing :-(

I fully agree.  This is an IETF document within MPLS and the PSC
acronym conflicts with a prior MPLS acronym.  The prior usage should
take precedence.  This acronym really should be changed.

A change as simple as recovery service coordination (RSC) would avoid
the clash.  Or a substitute for the word coordination could be used.

Curtis

---

From: Curtis Villamizar <[email-masked]>
Date: Thu, 25 Mar 2010 02:09:29 -0400

In message <[email-masked]>
> and feature for MPLS-TP.  I can only agree that this will only cause

Though this is joint work, this is the IETF not the ITU.  We should
use ITU terms where appropriate but where there is a conflict such as
this we need to pick another term and another TLA.  If the ITU wants
to update 808.1 at some later date that is up to the ITU.  In the mean
time we can use another term and point out the mapping.

Curtis

---

From: Huub van Helvoort <[email-masked]>
Date: Thu, 25 Mar 2010 07:18:08 +0100

Hi Curtis,

> the clash.  Or a substitute for the word coordination could be used.

What is wrong with the acronym APS?
MPLS-TP will be used by transport network operators that are
familiar with the term APS and where it is used for.
Why confuse them with another TLW (three letter word)?

Regards, Huub.

-- 
================================================================
                   http://www.van-helvoort.eu/
================================================================
Always remember that you are unique...just like everyone else...

---

From: Huub van Helvoort <[email-masked]>
Date: Thu, 25 Mar 2010 07:18:29 +0100

Hi Curtis,

Regards, Huub.

---

From: Curtis Villamizar <[email-masked]>
Date: Thu, 25 Mar 2010 03:18:17 -0400

In message <[email-masked]>
> Why confuse them with another TLW (three letter word)?

APS is specific to SONET and serves a similar function but is
different.

Curtis

---

From: <[email-masked]>
Date: Thu, 25 Mar 2010 07:21:23 -0000

APS is not specific to SONET. Try again 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Curtis Villamizar
Sent: 25 March 2010 07:18
To: [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re: [CCAMP] [mpls-tp] Term "PSC"
indraft-ietf-mpls-tp-linear-protection-01

In message <[email-masked]>
Huub van Helvoort writes:
>  
> Hi Curtis,
>  
> You wrote:
>  
> > In message 
> > <[email-masked]>
> > Vivien Sterling writes:
> >>  
> >> Dear Experts,
> >>  
> >> I'm surprised to find the term "PSC" used in this draft. I suppose 
> >> the authors are talking about data plane not control plane, right? 
> >> Isn't PSC in GMPLS elaborated as "Packet Switch Capable" ? It's 
> >> confusing :-(
> >>  
> >> --
> >> Cheers,
> >> Vivien
> > 

> > A change as simple as recovery service coordination (RSC) would 
> > avoid the clash.  Or a substitute for the word coordination could be
used.
> MPLS-TP will be used by transport network operators that are familiar 
> with the term APS and where it is used for.

APS is specific to SONET and serves a similar function but is different.

Curtis
_______________________________________________
CCAMP mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ccamp

---

From: "Adrian Farrel" <[email-masked]>
Date: Thu, 25 Mar 2010 07:55:42 -0000

For issues related to clashes of acronyms please see RFC 5513.

----- Original Message ----- 
From: "Alexander Vainshtein" <[email-masked]>
To: "Vivien Sterling" <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>; <[email-masked]>
Sent: Wednesday, March 24, 2010 8:30 AM
Subject: Re: [CCAMP] [mpls] Term "PSC" 

Vivien and all,
AFAIK, PSC stands for "Protection State Coordination" in the MPLS-TP 
parlance (see MPLS-TP Survivability 
Framework<http://datatracker.ietf.org/doc/draft-ietf-mpls-tp-survive-fwk/>)  
- a new fancy name for what has been known as "APS Protocol" in SONET/SDH.

Since GMPLS is going to be used with MPLS-TP, double usage of this acronym 
looks highly problematic.

Regards,
     Sasha

From: [email-masked] [mailto:[email-masked]] On Behalf Of 
Vivien Sterling
Sent: Wednesday, March 24, 2010 10:21 AM
To: [email-masked]; [email-masked]; [email-masked]
Subject: [mpls] Term "PSC" in draft-ietf-mpls-tp-linear-protection-01

Dear Experts,

--
Cheers,
Vivien

--------------------------------------------------------------------------------

---

From: Adrian Farrel <[email-masked]>
Date: Thu, 25 Mar 2010 08:32:48 +0000

Huub,

You will note that the comment in the liaison you reference said:

"The acronyms PSC and APS are used, in ITU-T APS is a generic term used in 
different methodologies and does not provide a solution."

This was neither a question nor a request for any change. And it is not 
really clear that it is a "concern".

APS is an abstract protocol (G.808.1) with specific characteristics and 
behaviors.

The Survivability Framework deliberately does not prejudge the abstract 
protocol or solution protocol that is required. Instead, it picked another 
acronym to avoid any assumptions. This frees the people working in the 
solution space to choose the necessary abstract model for the problems they 
need to solve, and to develop a protocol realisation that meets the model. 
This neither precludes nor forces the use of APS.

If you like, PSC is simply a generalisation that allows freedom of 
interpretation. Viz.

   In some protection switching schemes (such as bidirectional
   protection switching), it is necessary to coordinate the protection
   state between the edges of the recovery domain.  An MPLS-TP
   Protection State Coordination (PSC) protocol may be used as an in-
   band (i.e., data plane-based) control protocol to align both ends of
   the protected domain.  Control plane-based mechanism can also be used
   to coordinate the protection states between the edges of the
   protection domain.

In the view of the authors, the term "APS" has become synonymous with 
specific protocol realisations. For example, in the working copy of G.8131 I 
have infront of me, section 10 describes the "APS Protocol" setting out byte 
formats and defining messages to go on the wire. While we can interpret "APS 
Protocol" as the technology-specific realisation of "APS", there are 
sufficient overtones that if the Survivability Framework used the term "APS" 
it might be construed as support for a specific protocol realisation. Y.1731 
defines APS PDUs for Ethernet which gives us another competing 
interpretation of the term. (It is notable that the term "APS Protocol" is 
used in G.870 to mean the abstract protocol, which is subtly different from 
its use in G.8131 and Y.1731.)

Surely the working group would prefer to derive the correct protocol 
solution without being constrained except at a functional level?

Adrian

----- Original Message ----- 
From: "Huub van Helvoort" <[email-masked]>
To: "Cecil Byles" <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>; <[email-masked]>
Sent: Wednesday, March 24, 2010 5:14 PM
Subject: Re: [CCAMP] [mpls-tp] [mpls] Term"PSC" 

Hello Cecil,

You wrote:

> Can I therefore also asked how PSC “Protection State Coordination” in the 
> MPLS-TP parlance align with ITU-T 808.1 recommendation that "defines the 
> generic functional models, characteristics and processes associated with 
> various linear protection schemes for connection-oriented layer networks; 
> e.g., Optical Transport Networks (OTN), Synchronous Digital Hierarchy 
> (SDH) networks and Asynchronous Transfer Mode (ATM) networks" and the 
> sections covering  Terms and Definitions as well as Abbreviations.  IMO 
> all transport engineers and the general telecom community understand that 
> 1+1 or 1:1 are either SNCP or APS. Hence why introduce a new TLA (three 
> letter abbreviation) cover the same function and feature for MPLS-TP.  I 
> can only agree that this will only cause confusion.

I agree with you.

In addition to that:

Regards, Huub.

---

From: Yuji Tochio <[email-masked]>
Date: Thu, 25 Mar 2010 01:42:29 -0700

Hi Adrian,

Very minnor comment, but need to address for clear understanding:

Adrian Farrel wrote:
> Y.1731 defines APS PDUs for Ethernet which gives us another competing
> interpretation of the term. (It is notable that the term "APS
> Protocol" is used in G.870 to mean the abstract protocol, which is
> subtly different from its use in G.8131 and Y.1731.)
>

Y.1731 does not fully define APS PDU, only defines the opcode and common
OAM PDU. APS PDU is defined in G.8031 and G.8032 (ERP)
Please read 9.10.1 in Y.1731

Regards,
Yuji

---

From: Alexander Vainshtein <[email-masked]>
Date: Thu, 25 Mar 2010 10:52:25 +0200

Adrian,
Lots of thanks for pointing to 5513, I've missed its publication.
IMHO and FWIW (which are not covered by 5513) it is extremely relevant for the MPLS-TP project.
Do you consider 5513bis to cover MPLS-TP?

Regards,
     Sasha

----- Original Message ----- 
From: "Alexander Vainshtein" <[email-masked]>
To: "Vivien Sterling" <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>; <[email-masked]>
Sent: Wednesday, March 24, 2010 8:30 AM
Subject: Re: [CCAMP] [mpls] Term "PSC" 

Vivien and all,

Regards,
     Sasha

Dear Experts,

--
Cheers,
Vivien

---

From: Zhi-Wei Lin <[email-masked]>
Date: Thu, 25 Mar 2010 10:38:06 -0400

Hi,

I like to give my perspective. As a small network company (but one of the
largest transit agencies), we have a small operating staff split into two
groups: one that handles traditional data network (Ethernet, IP), and one
that handles transport network (SONET, WDM).

We are targeting the transport network operating staff to maintain and
operate the MPLS-TP network. As such, anything that will help to reduce the
learning curve (less training), simplify operating, and make the MOP as
consistent as possible between SONET and MPLS-TP would be hugely beneficial.

Obviously there will be some differences since MPLS-TP is a packet-based
transport network, but the standards groups (I don't really care for
politics of IETF and ITU) should strive to make these differences easy to
learn.

Thanks
Zhi

On Thu, Mar 25, 2010 at 2:09 AM, Curtis Villamizar <[email-masked]> wrote:

> mpls mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls
>

---

From: Lou Berger <[email-masked]>
Date: Thu, 25 Mar 2010 08:31:05 -0700

Adrian,
	I fully support the high-level point you are making, i.e., the
continued use of a term other than APS in the context of TP.  That said,
I'm open to renaming PSC to something that doesn't conflict with
existing MPLS/GMPLS terms.  Curtis' proposal of RSC is an example.

Lou

---

From: "Shahram Davari" <[email-masked]>
Date: Thu, 25 Mar 2010 08:35:34 -0700

Hi,

By the way PSC is also used in RFC3270 as acronym for "Per-hop Scheduling Class"

Thanks,
Shahram 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Lou Berger
Sent: Thursday, March 25, 2010 8:31 AM
To: Adrian Farrel
Cc: Cecil Byles; [email-masked]; [email-masked]; [email-masked]
Subject: Re: [mpls] [CCAMP] [mpls-tp] Term"PSC" indraft-ietf-mpls-tp-linear-protection-01

Adrian,

Lou

On 3/25/2010 1:32 AM, Adrian Farrel wrote:
>> Can I therefore also asked how PSC "Protection State Coordination" in the

---

From: Zhi-Wei Lin <[email-masked]>
Date: Thu, 25 Mar 2010 11:42:08 -0400

Hi,

We have PSC, RSC, APS...how about MPS for MPLS-TP Protection Switching...? I
think the acronym (whatever it is) should have "protection switching" in it
just so that transport folks know it is similar to what they have used (but
different because it's not TDM based).

Thanks
Zhi

On Thu, Mar 25, 2010 at 11:31 AM, Lou Berger <[email-masked]> wrote:

> the

---

From: <[email-masked]>
Date: Thu, 25 Mar 2010 15:56:27 -0000

There are only so many ways to provide DP/MP/CP components of each of
the 3 networking modes (addressing, signalling, routing, OAM,
etc)....and there will be a best-of-breed solution for a given component
at any given time, whatever name we give it.  I sometimes sense that
judgement of technical merit might get compromised by a stronger NIH
(Not Invented Here) behaviour....esp if the component in question comes
from another SDO. 
 
Speaking as an operator we have a (well publicised internally) desire to
have as much sensible re-use of components as possible.
 
regards, Neil

	From: [email-masked] [mailto:[email-masked]] On
Behalf Of Zhi-Wei Lin
	Sent: 25 March 2010 15:42
	To: Lou Berger
	Cc: Cecil Byles; [email-masked]; [email-masked]; Adrian Farrel;
[email-masked]
	Subject: Re: [CCAMP] [mpls-tp] [mpls]
Term"PSC"indraft-ietf-mpls-tp-linear-protection-01

	Hi,
	
	We have PSC, RSC, APS...how about MPS for MPLS-TP Protection
Switching...? I think the acronym (whatever it is) should have
"protection switching" in it just so that transport folks know it is
similar to what they have used (but different because it's not TDM
based).
	
	Thanks
	Zhi

	On Thu, Mar 25, 2010 at 11:31 AM, Lou Berger <[email-masked]>
wrote:

		Adrian,
		       I fully support the high-level point you are
making, i.e., the
		continued use of a term other than APS in the context of
TP.  That said,
		I'm open to renaming PSC to something that doesn't
conflict with
		existing MPLS/GMPLS terms.  Curtis' proposal of RSC is
an example.
		
		Lou

---

From: John E Drake <[email-masked]>
Date: Thu, 25 Mar 2010 09:29:38 -0700

Doesn't it also stand for 'packet switch capable'?

Sent from my iPhone

On Mar 25, 2010, at 8:36 AM, "Shahram Davari" <[email-masked]>  
wrote:

>> Protocol" is

---

From: Adrian Farrel <[email-masked]>
Date: Thu, 25 Mar 2010 16:55:24 +0000

Oh, but I thought someone said APS was an abstract protocol.

Is it the case that there are multiple documents that define PDUs and data 
fields for APS?

Thanks,
Adrian
----- Original Message ----- 
From: "Yuji Tochio" <[email-masked]>
To: "Adrian Farrel" <[email-masked]>
Cc: <[email-masked]>; "Cecil Byles" <[email-masked]>; 
<[email-masked]>; <[email-masked]>; <[email-masked]>
Sent: Thursday, March 25, 2010 8:42 AM
Subject: Re: [mpls] [CCAMP] [mpls-tp] 
Term"PSC"indraft-ietf-mpls-tp-linear-protection-01

---

From: "Adrian Farrel" <[email-masked]>
Date: Thu, 25 Mar 2010 16:56:54 -0000

Hi,

Welcome your input on this as an operator.

Need to understand whether "MOP" covers the PDU formats or refers to the 
actions that an operator must take, and the states that are reported by the 
network?

Thanks,
Adrian
----- Original Message ----- 
From: "Zhi-Wei Lin" <[email-masked]>
To: <[email-masked]>
Cc: "Cecil Byles" <[email-masked]>; <[email-masked]>; 
<[email-masked]>; "Alexander Vainshtein" <[email-masked]>; 
<[email-masked]>
Sent: Thursday, March 25, 2010 2:38 PM
Subject: Re: [mpls] [CCAMP] [mpls-tp] Term 
"PSC"indraft-ietf-mpls-tp-linear-protection-01

>> <[email-masked]>
>> "Cecil Byles" writes:
>> >
>> >
>> > Hi,

---

From: Zhi-Wei Lin <[email-masked]>
Date: Thu, 25 Mar 2010 13:12:30 -0400

Hi,

I found the following documents to contain APS:

ITU: G.841, G.870, G.8031
Also used obviously in U.S. SONET standards and Telcordia GRs.

As mentioned before, from operating staff point of view, using the term APS
would have a warm and fuzzy feeling of familiarity (at least in our company,
MPLS-TP will be maintained by the transport group, not the data group). APS
protocol definition and operation obviously will be little bit different for
MPLS-TP, but that's the case in general for the TDM world as well. You also
have modifiers for APS, such as 1:1 linear APS, ring APS, Ethernet APS.

So here we have MPLS-TP APS...

Thanks
Zhi

On Thu, Mar 25, 2010 at 12:55 PM, Adrian Farrel <[email-masked]>wrote:

> ----- Original Message ----- From: "Yuji Tochio" <[email-masked]>
> Cc: <[email-masked]>; "Cecil Byles" <[email-masked]>; <
> [email-masked]>; <[email-masked]>; <[email-masked]>

---

From: Zhi-Wei Lin <[email-masked]>
Date: Thu, 25 Mar 2010 13:15:44 -0400

Hi Adrian,

Sorry. MOP in our company refers to method of procedure, basically the
operating model and process for operation and maintenance of the network.

We do realize our MOP would need to be modified to handle MPLS-TP, but
anything that can be done to reduce the effort would be greatly appreciated.

Thanks
Zhi

On Thu, Mar 25, 2010 at 12:56 PM, Adrian Farrel <[email-masked]> wrote:

> ----- Original Message ----- From: "Zhi-Wei Lin" <[email-masked]>
> To: <[email-masked]>
> Cc: "Cecil Byles" <[email-masked]>; <[email-masked]>; <
> [email-masked]>; "Alexander Vainshtein" <[email-masked]>;
> <[email-masked]>
>>> In message <
>>> [email-masked]>
>>> "Cecil Byles" writes:
>>> >
>>> >
>>> > Hi,
>>> > the MPLS-TP parlance align with ITU-T 808.1 recommendation that >
>>> "defines

---

From: "Cecil Byles" <[email-masked]>
Date: Thu, 25 Mar 2010 19:01:40 +0100

Hi Adrian,
 
As stated in all the various e-mails associated with this issue, the
acronym APS (also in our company) relates to all manner of automated
protections switching (no manual interaction) schemes applied to either
SDH, OTN or Ethernet and in the future MPLS-TP ( which is also aim at a
transport team doing the O&M). However the semantics of how APS is
applied and implemented in SDH, OTN, Ethernet and MPLS-TP can all be
different or similar, but the basic principle is that there is a work
and protect path that can function as either Uni-directional or
bi-directional protection switch . Thus I believe that the PSC protocol
is just one of the methodology for implementing MPLS-TP APS (automatic
protection switching) be that linear or ring protection. 
 
MOP also means "Method of Procedure in our company as well with the same
understand as stated by Zhi below. 
 
regards
Cecil

From: Zhi-Wei Lin [mailto:[email-masked]] 
Sent: 25 March 2010 17:16
To: Adrian Farrel
Cc: [email-masked]; Cecil Byles; [email-masked]; [email-masked];
Alexander Vainshtein; [email-masked]
Subject: Re: [mpls] [CCAMP] [mpls-tp] Term
"PSC"indraft-ietf-mpls-tp-linear-protection-01

Hi Adrian,

Sorry. MOP in our company refers to method of procedure, basically the
operating model and process for operation and maintenance of the
network.

We do realize our MOP would need to be modified to handle MPLS-TP, but
anything that can be done to reduce the effort would be greatly
appreciated.

Thanks
Zhi

On Thu, Mar 25, 2010 at 12:56 PM, Adrian Farrel <[email-masked]>
wrote:

	Hi,

	Need to understand whether "MOP" covers the PDU formats or
refers to the actions that an operator must take, and the states that
are reported by the network?
	
	Thanks,
	Adrian
	----- Original Message ----- From: "Zhi-Wei Lin"
<[email-masked]>
	To: <[email-masked]>
	Cc: "Cecil Byles" <[email-masked]>; <[email-masked]>;
<[email-masked]>; "Alexander Vainshtein"
<[email-masked]>; <[email-masked]>
	Sent: Thursday, March 25, 2010 2:38 PM
	Subject: Re: [mpls] [CCAMP] [mpls-tp] Term
"PSC"indraft-ietf-mpls-tp-linear-protection-01 

		Hi,
		
		I like to give my perspective. As a small network
company (but one of the
		largest transit agencies), we have a small operating
staff split into two
		groups: one that handles traditional data network
(Ethernet, IP), and one
		that handles transport network (SONET, WDM).
		
		We are targeting the transport network operating staff
to maintain and
		operate the MPLS-TP network. As such, anything that will
help to reduce the
		learning curve (less training), simplify operating, and
make the MOP as
		consistent as possible between SONET and MPLS-TP would
be hugely beneficial.
		
		Obviously there will be some differences since MPLS-TP
is a packet-based
		transport network, but the standards groups (I don't
really care for
		politics of IETF and ITU) should strive to make these
differences easy to
		learn.
		
		Thanks
		Zhi

		On Thu, Mar 25, 2010 at 2:09 AM, Curtis Villamizar
<[email-masked]> wrote:

			In message
			"Cecil Byles" writes:
			> the MPLS-TP parlance align with ITU-T 808.1
recommendation that > "defines
			> and feature for MPLS-TP.  I can only agree
that this will only cause

			Though this is joint work, this is the IETF not
the ITU.  We should
			use ITU terms where appropriate but where there
is a conflict such as
			this we need to pick another term and another
TLA.  If the ITU wants
			to update 808.1 at some later date that is up to
the ITU.  In the mean
			time we can use another term and point out the
mapping.
			
			Curtis

------------------------------------------------------------------------
--------

---

From: "Cecil Byles" <[email-masked]>
Date: Thu, 25 Mar 2010 19:51:21 +0100

Hi Adrian,
 
Please can you or colleagues explain to me, what do you mean by the
following statement "
" If you like, PSC is simply a generalisation that allows freedom of
interpretation. "
 
>From a transport view point, us and all other operators' can
inter-operate various protection schemes (SDH/OTN) base on
characteristics and behaviours of G. 808.1 and G.841/G.873.1 without
having the same manufactures equipment. Thus are you advocating
operators must now all purchase the same equipment type if they want to
inter-operate MPLS-TP protection schemes based various equipment vendors
freedom of interpretation of the PSC protocol that do not comply with
Y.1731 sections 7.8 and 9.10 to 9.10.2. Also are you by inference
stating as an SDO can not run nested protection schemes for example
G.8131 over a G.8031/G.8032 or G.8132. or a combination of any of these
protection schemes as a hierarchal network similar to other ITU
standards based transports networks.?
 
Regards
 
Cecil

From: [email-masked] [mailto:[email-masked]] 
Sent: 25 March 2010 15:56
To: [email-masked]; [email-masked]
Cc: Cecil Byles; [email-masked]; [email-masked];
[email-masked]; [email-masked]
Subject: RE: [CCAMP] [mpls-tp] [mpls]
Term"PSC"indraft-ietf-mpls-tp-linear-protection-01

 
regards, Neil

	Hi,

	Thanks
	Zhi

		Adrian,
		
		Lou

---

From: Curtis Villamizar <[email-masked]>
Date: Sat, 27 Mar 2010 22:54:04 -0400

> > existing MPLS/GMPLS terms.  Curtis' proposal of RSC is an example.

I'm in favor of R for recovery rather than P for protection. in the
future we won't get into a semantic argument over whether that is a
protection or a restoration scheme if it is fast but has some
signaling (or OAM) on failure.  For example we define a capability
that sets aside some shared bandwidth but commits it to a particular
use depending on the SRLG that failed we could get into such an
argument if we use P rather than R.

Curtis