Subject: Re: [CCAMP] [mpls] Term "PSC"indraft-ietf-mpls-tp-linear-protection-01

From: <[email-masked]>
Date: Fri, 2 Apr 2010 12:39:28 +0100

LOL, if only I had got around to reading this e-mail yesterday :-) Ben

On 25/03/2010 08:52, "Alexander Vainshtein"
<[email-masked]> wrote:

> Adrian,
> Lots of thanks for pointing to 5513, I've missed its publication.
> IMHO and FWIW (which are not covered by 5513) it is extremely relevant for the
> MPLS-TP project.
> Do you consider 5513bis to cover MPLS-TP?
> 
> Regards,
>      Sasha
> 
> -----Original Message-----
> From: Adrian Farrel [mailto:[email-masked]]
> Sent: Thursday, March 25, 2010 9:56 AM
> To: Alexander Vainshtein; Vivien Sterling
> Cc: [email-masked]; [email-masked]; [email-masked]
> Subject: Re: [CCAMP] [mpls] Term "PSC"
> indraft-ietf-mpls-tp-linear-protection-01
> 
> For issues related to clashes of acronyms please see RFC 5513.
> 
> 
> ----- Original Message -----
> From: "Alexander Vainshtein" <[email-masked]>
> To: "Vivien Sterling" <[email-masked]>
> Cc: <[email-masked]>; <[email-masked]>; <[email-masked]>
> Sent: Wednesday, March 24, 2010 8:30 AM
> Subject: Re: [CCAMP] [mpls] Term "PSC"
> indraft-ietf-mpls-tp-linear-protection-01
> 
> 
> Vivien and all,
> AFAIK, PSC stands for "Protection State Coordination" in the MPLS-TP
> parlance (see MPLS-TP Survivability
> Framework<http://datatracker.ietf.org/doc/draft-ietf-mpls-tp-survive-fwk/>)
> - a new fancy name for what has been known as "APS Protocol" in SONET/SDH.
> 
> As you've noted, it has a completely different meaning in GMPLS.
> 
> Since GMPLS is going to be used with MPLS-TP, double usage of this acronym
> looks highly problematic.
> 
> Regards,
>      Sasha
> 
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Vivien Sterling
> Sent: Wednesday, March 24, 2010 10:21 AM
> To: [email-masked]; [email-masked]; [email-masked]
> Subject: [mpls] Term "PSC" in draft-ietf-mpls-tp-linear-protection-01
> 
> Dear Experts,
> 
> I'm surprised to find the term "PSC" used in this draft. I suppose the
> authors are talking about data plane not control plane, right? Isn't PSC in
> GMPLS elaborated as "Packet Switch Capable" ? It's confusing :-(
> 
> --
> Cheers,
> Vivien
> 
> 
> 
> ------------------------------------------------------------------------------
> --
> 
> 
>> _______________________________________________
>> CCAMP mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/ccamp
>> 
> 
> _______________________________________________
> CCAMP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ccamp

---

From: <[email-masked]>
Date: Fri, 2 Apr 2010 12:46:29 +0100

Zhi,

Thanks, I understand you perspective.

However I suspect other operators may target their existing data network
operations staff to maintain and operate an MPLS-TP network!

The functionality needs to be as aligned to existing practices (MPLS and
Transport) as possible. Re-learning/Re-definition of existing operations
processes should be minimised but given that MPLS-TP is bridging a gap
between data and transport networks some relearning on both sides is
inevitable.

HTH
Ben

On 25/03/2010 14:38, "Zhi-Wei Lin" <[email-masked]> wrote:

> Hi,
> 
> I like to give my perspective. As a small network company (but one of the
> largest transit agencies), we have a small operating staff split into two
> groups: one that handles traditional data network (Ethernet, IP), and one that
> handles transport network (SONET, WDM).
> 
> We are targeting the transport network operating staff to maintain and operate
> the MPLS-TP network. As such, anything that will help to reduce the learning
> curve (less training), simplify operating, and make the MOP as consistent as
> possible between SONET and MPLS-TP would be hugely beneficial.
> 
> Obviously there will be some differences since MPLS-TP is a packet-based
> transport network, but the standards groups (I don't really care for politics
> of IETF and ITU) should strive to make these differences easy to learn.
> 
> Thanks
> Zhi
> 
> 
> On Thu, Mar 25, 2010 at 2:09 AM, Curtis Villamizar
> <[email-masked]<mailto:[email-masked]>> wrote:
> 
> In message 
> <[email-masked]<mailto:4B2E9510
> [email-masked]>>
> "Cecil Byles" writes:
>> 
>> 
>> Hi,
>> Can I therefore also asked how PSC "Protection State Coordination" in
>> the MPLS-TP parlance align with ITU-T 808.1 recommendation that "defines
>> the generic functional models, characteristics and processes associated
>> with various linear protection schemes for connection-oriented layer
>> networks; e.g., Optical Transport Networks (OTN), Synchronous Digital
>> Hierarchy (SDH) networks and Asynchronous Transfer Mode (ATM) networks"
>> and the sections covering  Terms and Definitions as well as
>> Abbreviations.  IMO all transport engineers and the general telecom
>> community understand that 1+1 or 1:1 are either SNCP or APS. Hence why
>> introduce a new TLA (three letter abbreviation) cover the same function
>> and feature for MPLS-TP.  I can only agree that this will only cause
>> confusion.
>> 
>> Cecil Byles
> 
> 
> Though this is joint work, this is the IETF not the ITU.  We should
> use ITU terms where appropriate but where there is a conflict such as
> this we need to pick another term and another TLA.  If the ITU wants
> to update 808.1 at some later date that is up to the ITU.  In the mean
> time we can use another term and point out the mapping.
> 
> Curtis
> mpls mailing list
> [email-masked]<mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/mpls
>