Subject: [CCAMP] Ask for comments

From: Yabin Ye <[email-masked]>
Date: Mon, 26 Jul 2010 12:26:16 +0200

Dear All,

We have submitted a draft entitled “OSPF Extensions in Support of
Impairment Aware Routing and Wavelength Assignment in Wavelength Switched
Optical Networks (WSONs)”. 

http://tools.ietf.org/html/draft-agraz-ccamp-wson-impairment-ospf-00

This document suggests to extend the OSPF-TE protocols by including the
physical impairments in order to support Generalized Multi-Protocol Label
Switching (GMPLS) and Path Computation Element (PCE)    control of
Impairment Aware Routing and Wavelength Assignment in Wavelength Switched
Optical Networks (WSONs).

Due to urgent issues, we are not able to attend the meeting. Attached please
find the presentation, and kindly let us know if you have any comments.

Background: This draft is the output of EU FP7 funded DICONET project. More
details of this project can be found at http://www.diconet.eu/homepage.asp

Thanks and regards,

Yabin Ye  

*********************************************************

Yabin Ye 叶亚斌

European Research Center

Huawei Technologies

Riesstr. 25

80992 Munich

Germany
Tel: +49 89 158 834 4078

Cell: +49 162 2047570
Fax: +49 89 158 834 4447
E-mail: [email-masked]
www.huawei.com

*********************************************************

---

From: Acee Lindem <[email-masked]>
Date: Tue, 27 Jul 2010 10:26:49 -0400

Hi Yabin,

I have a couple comments:

       - First, this document extends OSPF TE rather than the OSPF protocol itself.
       - Second, the document refers to PLI TE LSAs as if they were separate LSAs. However, I believe these are just additional TE LSAs as described in RFC 3630.
       - Similarly, the document refers to the top-level Link and Node TLVs as if they are new PLI TLVs. However, these are referenced with the same code points as the existing Link and Node TLVs. They will need new types if you want to redefine them with different semantics.
       - Same for the Remote Interface IP Address Sub-TLV and Local Interface IP Address Sub-TLV. These are not new Sub-TLVs and probably don't need to be even if new top-level PLI TLVs are required.

From a high-level, it seems the only new TLVs required are the ones for PLI and this information can be just advertised with the existing TE information. However, due to the volume and frequency of change, you may want separate LSAs.

Thanks,
Acee

On Jul 26, 2010, at 6:26 AM, Yabin Ye wrote:

Dear All,

We have submitted a draft entitled “OSPF Extensions in Support of Impairment Aware Routing and Wavelength Assignment in Wavelength Switched Optical Networks (WSONs)”.

This document suggests to extend the OSPF-TE protocols by including the physical impairments in order to support Generalized Multi-Protocol Label Switching (GMPLS) and Path Computation Element (PCE)    control of Impairment Aware Routing and Wavelength Assignment in Wavelength Switched Optical Networks (WSONs).

Due to urgent issues, we are not able to attend the meeting. Attached please find the presentation, and kindly let us know if you have any comments.

Background: This draft is the output of EU FP7 funded DICONET project. More details of this project can be found at http://www.diconet.eu/homepage.asp

Thanks and regards,

Yabin Ye

*********************************************************
Yabin Ye 叶亚斌
European Research Center
Huawei Technologies
Riesstr. 25
80992 Munich
Germany
Tel: +49 89 158 834 4078
Cell: +49 162 2047570
Fax: +49 89 158 834 4447
E-mail: [email-masked]<mailto:[email-masked]>
www.huawei.com<http://www.huawei.com/>
*********************************************************

<WSON impairment ospf V1.ppt><ATT00001..txt>