Subject: [CCAMP] Erratrum on RSVP-TE Hello Timer

From: Adrian Farrel <[email-masked]>
Date: Thu, 19 Aug 2010 14:00:14 +0100

Hi,

http://www.rfc-editor.org/verify_errata_select.php?eid=1883 points out a 
discrepancy between RFC 4803 (GMPLS LSR MIB) and RFC 3209.

In discussing the Hello timer, RFC 3209 says:

   This value MAY be
   configured on a per neighbor basis.  The default value is 5 ms.

However, RFC 4803 defines gmplsInterfaceRsvpHelloPeriod in ms, and says:

  DEFVAL { 3000 }

Clearly, 3000 != 5.

My view is that the operational default for the Hello period in a GMPLS 
system is much more likely to be 30 seconds than 5 ms. (But I was the 
principal author of RFC 4803, so I would say this!)

On the other hand, from a process point of view, RFC 3209 should not have 
talked about a "default" value. It should have described a "recommended" 
value, since there is no concept of a default value in the protocol.

Anyway...

How to resolve this?
I am inclined to reject the Erratum saying that the documented DEFVAL is 
what was intended by the working group.

Comments please.

Thanks,
Adrian

---

From: "Sadler, Jonathan B." <[email-masked]>
Date: Thu, 19 Aug 2010 10:51:17 -0500

Hi Adrian,

I concur with your conclusion/suggested resolution.

RFC3209 was written by the MPLS working group for the MPLS-TE environment where signaling was done in-band.  The Hello timer is therefore useful to determine link alive-ness separate from port aliveness (e.g. if it is an Ethernet going through multiple switches).

In the GMPLS environment, adjacencies run out-of-band and link aliveness is determined using dataplane OAM -- the two are now decoupled.  As such, it's a different use case which makes a different period reasonable.

Jonathan Sadler

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Adrian Farrel
Sent: Thursday, August 19, 2010 8:00 AM
To: [email-masked]
Subject: [CCAMP] Erratrum on RSVP-TE Hello Timer

Hi,

   This value MAY be

  DEFVAL { 3000 }

Clearly, 3000 != 5.

Anyway...

How to resolve this?

Comments please.

Thanks,
Adrian

_______________________________________________
CCAMP mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ccamp

---

From: Eric Gray <[email-masked]>
Date: Thu, 19 Aug 2010 12:20:35 -0400

Adrian,

	I think most people will not be able to access the URL you
include below.  I got the following when I tried: 

"Invalid Login: This page is for use by specified members of the 
 IAB, IESG, IRSG, RFC Editorial Board, and the RFC Editor. 
 Please contact [email-masked] with questions."

For those of us Peons that would like to look at this erratum, I
believe the correct URL is:

  http://www.rfc-editor.org/errata_search.php?eid=1883

Without actually looking at the erratum, it was not possible to
determine which RFC this inconsistency was reported against.  As
it turns out, it was reported against the MIB RFC (RFC 4803) - 
as opposed to the protocol RFC 3209, hence I agree with your 
proposed resolution.

As a side note, 3000 ms is 3 seconds, not 30 seconds...

--
Eric

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Adrian Farrel
Sent: Thursday, August 19, 2010 9:00 AM
To: [email-masked]
Subject: [CCAMP] Erratrum on RSVP-TE Hello Timer

Hi,

   This value MAY be

  DEFVAL { 3000 }

Clearly, 3000 != 5.

Anyway...

How to resolve this?

Comments please.

Thanks,
Adrian

---

From: Lou Berger <[email-masked]>
Date: Thu, 19 Aug 2010 15:21:11 -0400

I have no objection to this resolution.  Perhaps an errata to 3209 
removing the sentence on default value would be useful too?

Lou

PS The default value was added to address a comment raised in early 2000 
by I forget who -- perhaps the IESG, George may remember...

---

From: Thomas Nadeau <[email-masked]>
Date: Thu, 19 Aug 2010 16:13:41 -0400

I agree with you; the wg reviewed the document and agreed with it's contents. It is hard to see this as a defect.

Tom

Sent from my iPhone

On Aug 19, 2010, at 9:00 AM, Adrian Farrel <[email-masked]> wrote:

> Hi,
> 
> http://www.rfc-editor.org/verify_errata_select.php?eid=1883 points out a discrepancy between RFC 4803 (GMPLS LSR MIB) and RFC 3209.
> 
> My view is that the operational default for the Hello period in a GMPLS system is much more likely to be 30 seconds than 5 ms. (But I was the principal author of RFC 4803, so I would say this!)
> 
> On the other hand, from a process point of view, RFC 3209 should not have talked about a "default" value. It should have described a "recommended" value, since there is no concept of a default value in the protocol.
> 
> Anyway...
> 
> How to resolve this?
> I am inclined to reject the Erratum saying that the documented DEFVAL is what was intended by the working group.
> 
> Comments please.
> 
> Thanks,
> Adrian
> 
> 
>

---

From: Vishwas Manral <[email-masked]>
Date: Thu, 19 Aug 2010 19:19:49 -0700

Hi,

I agree with Eric on this!!!

BTW if you want 30 seconds you may need to change things in the MIB too.

Thanks,
Vishwas

---

From: "Adrian Farrel" <[email-masked]>
Date: Fri, 20 Aug 2010 12:08:12 +0100

Sorry, two errors in one email :-)

1. There is one interface to the Erratum system for ADs and one for mortals.
You need to go to...
http://www.rfc-editor.org/errata_search.php?eid=1883

2. ADs (not being mortal) cannot divide by 10.
3000ms is (of course) just 3 seconds.
I believe that RFC 4803 intended to say 3000ms.

Cheers,
Adrian