Subject: Re: [CCAMP] Gen-ART review of draft-ietf-ccamp-gmpls-ethernet-pbb-te-05.txt

From: Adrian Farrel <[email-masked]>
Date: Thu, 26 Aug 2010 18:14:58 +0100

David,

Thanks for this.

Authors: please consider these comments as part of the IETF last call, and 
come to resolution (possibly needing RFC Editor comments or a new revision).

Thanks,
Adrian
----- Original Message ----- 
From: <[email-masked]>
To: <[email-masked]>; <[email-masked]>; 
<[email-masked]>; <[email-masked]>; 
<[email-masked]>
Cc: <[email-masked]>; <[email-masked]>; <[email-masked]>; 
<[email-masked]>; <[email-masked]>; <[email-masked]>
Sent: Thursday, August 26, 2010 6:01 PM
Subject: Gen-ART review of draft-ietf-ccamp-gmpls-ethernet-pbb-te-05.txt

I am the assigned Gen-ART reviewer for this draft. For background on 
Gen-ART, please see the FAQ at 
http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq .

Please resolve these comments along with any other comments you may receive.

Summary:
This draft is on the right track, but has open issues, described in the 
review.

This draft describes the use of a GMPLS control plane to configure explicit 
forwarding in Ethernet bridges for PBB-TE (Provider Backbone Bridge Traffic 
Engineering).

In general, the draft is in good shape; the two open issues are in Section 
5.1.2 and are minor:
- Is the "has to allocate a VID" statement in Section 5.1.2 correct when 
shared forwarding
is in use as described in Section 3.1 ?
- The error value: MPLS Label allocation failure (9) appears to be 
inconsistent with the
second bullet in Section 7 that requests IANA to allocate a new error value: 
"PBB-TE
Ethernet Label VID allocation failure" (suggested value: 35?)  for this 
case.

Nits:

In Section 2, what are the I and B components of an IB-BEB?  Interface and 
Bridge?

In Figure 1, the VIP acronym is not in Section 2's list of acronyms.

In Section 4.1, remove the note to IANA after 2) and instead insert this 
instruction into Section 7.

In Figure 4, the type is TBA.  Add an instruction to Section 7 for IANA to 
fill this in after it is allocated.

In the fourth bullet in Section 7, please state that the registry is created 
by the MLN-EXT draft if that is the case.

idnits 2.12.04 ran clean.

Thanks,
--David
----------------------------------------------------
David L. Black, Distinguished Engineer
EMC Corporation, 176 South St., Hopkinton, MA 01748
+1 (508) 293-7953 FAX: +1 (508) 293-7786
[email-masked] Mobile: +1 (978) 394-7754
----------------------------------------------------

---

From: <[email-masked]>
Date: Thu, 26 Aug 2010 13:01:16 -0400

I am the assigned Gen-ART reviewer for this draft. For background on Gen-ART, please see the FAQ at http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq . 

Summary:
This draft is on the right track, but has open issues, described in the review.

This draft describes the use of a GMPLS control plane to configure explicit forwarding in Ethernet bridges for PBB-TE (Provider Backbone Bridge Traffic Engineering).

In general, the draft is in good shape; the two open issues are in Section 5.1.2 and are minor:
- Is the "has to allocate a VID" statement in Section 5.1.2 correct when shared forwarding
	is in use as described in Section 3.1 ?
- The error value: MPLS Label allocation failure (9) appears to be inconsistent with the
	second bullet in Section 7 that requests IANA to allocate a new error value: "PBB-TE
	Ethernet Label VID allocation failure" (suggested value: 35?)  for this case.

Nits:

In Section 2, what are the I and B components of an IB-BEB?  Interface and Bridge?

In Section 4.1, remove the note to IANA after 2) and instead insert this instruction into Section 7.

In Figure 4, the type is TBA.  Add an instruction to Section 7 for IANA to fill this in after it is allocated.

In the fourth bullet in Section 7, please state that the registry is created by the MLN-EXT draft if that is the case.

Thanks,
--David