Subject: [CCAMP] Questions/comments on OTN signaling

From: "Gruman, Fred" <[email-masked]>
Date: Thu, 22 Sep 2011 12:26:00 -0500

Hello Fatai,

I have some comments/questions on
draft-zhang-ccamp-gmpls-evolving-g709-09.

1) I think the draft should discuss the Generalized Label Request
object.  Will this object use the new OTN switching capability
(Switching Type = 101)?

2)  How is ODUflex(GFP) signaled? In general, the draft seems to lack
detail on ODUflex(GFP).

More specifically, the draft states "In case of ODUflex(CBR), the
Bit_Rate and Tolerance fields MUST be used together to represent the
actual bandwidth of ODUflex" and later "In case of other ODUk signal
types, the Bit_Rate and Tolerance fields are not necessary and MUST be
set to 0."  It is not clear if this implies that ODUflex(GFP) should set
Bit_rate and Tolerance to zero.  I would assume ODUflex(GFP) would need
Bit_Rate, but unsure if tolerance is needed.

3) G.709 Amendment 2 (2011-04) Table 7-9 has a row to cover the generic
ODUflex(CBR) with notes to the formulas to calculate the number of
tributary slots.  Additionally, this table has specific rows to cover
ODUflex(CBR) IB SDR, IB DDR, IB QDR, FC-400, and FC-800 and specifies
the explicit number of tributary slot assignments when mapped into
ODUflex into HO-OPUk).   

It seems that the generic formula for ODUflex(CBR) does not result in
the same number of tributary slots for some of these client signals.
For example, IB SDR over HO-OPU3 has nominal bit rate of 2,500,000
kbits/s and bit rate tolerance of +/-100ppm (from G.709 Amend2 Table
17-14).  Using the generic ODUflex(CBR) formula, you get:

N = ceiling [(2500000 * (1+100/1e6)) / ( 1254703.729 * (1-20/1e6)) ]

    = ceiling [2500250 / 1254678.635]

    = ceiling [1.99274135]

    = 2

Table 7-9 shows that IB SDR mapped into ODUflex over HO-OPU3 would use 3
tributary slots, not 2.

Please verify my math but if the generic ODUflex formula does not apply
to the IB or FC clients, then we may need to have explicit signal types
for these clients.

I found that the IB clients do not match the generic formula for some
HO-OPUk but the FC clients do match.  This may mean we only would need
explicit signal types for:

- ODUflex(CBR)-IB-SDR

- ODUflex(CBR)-IB-DDR

- ODUflex(CBR)-IB-QDR

Please let me know what you think.

Thanks,

Fred

---

From: Zhangfatai <[email-masked]>
Date: Sat, 24 Sep 2011 08:26:10 +0000

Hi Fred,

Thanks for your useful comments and we will reflect the latest progress of G.709 in the next version.

Please see more in-line below.

Thanks

Fatai

From: [email-masked] [mailto:[email-masked]] On Behalf Of Gruman, Fred
Sent: 2011年9月23日 1:26
To: [email-masked]
Subject: [CCAMP] Questions/comments on OTN signaling

Hello Fatai,

I have some comments/questions on draft-zhang-ccamp-gmpls-evolving-g709-09.

1) I think the draft should discuss the Generalized Label Request object.  Will this object use the new OTN switching capability (Switching Type = 101)?

[Fatai] Yes, agree with you. We have captured this in the FWK document and will update the signaling draft in the next version.

2)  How is ODUflex(GFP) signaled? In general, the draft seems to lack detail on ODUflex(GFP).

More specifically, the draft states "In case of ODUflex(CBR), the Bit_Rate and Tolerance fields MUST be used together to represent the actual bandwidth of ODUflex" and later "In case of other ODUk signal types, the Bit_Rate and Tolerance fields are not necessary and MUST be set to 0."  It is not clear if this implies that ODUflex(GFP) should set Bit_rate and Tolerance to zero.  I would assume ODUflex(GFP) would need Bit_Rate, but unsure if tolerance is needed.

[Fatai] The bit rates and tolerance of ODUflex(GFP) was not standardized until the G.709 Amd2 was issued, so we didn’t touch it in this draft so far.
In the G.709 Amd2, it says: “Any bit rate is possible for an ODUflex(GFP) signal, however it is suggested for maximum efficiency that the ODUflex(GFP) will fill an integral number of tributary slots of the smallest HO ODUk path over which the ODUflex(GFP) may be carried. The recommended bit-rates to meet this criteria are specified in Table 7-8.”

We can understand that ONLY 80 values are allowed  and the intermediate values are not allowed (see Table 7-8 in G.709 Amd2). Each of the 80 values is rigidly associated to a number of tributary slots and that the tolerance is fixed to +/- 100ppm. Note that the tolerance is already comprised in the 80 values.

So, we agree with you that ODUflex(GFP) would need Bir_Rate, but it does not need tolerance.

We will add some text to address ODUflex(GFP).

3) G.709 Amendment 2 (2011-04) Table 7-9 has a row to cover the generic ODUflex(CBR) with notes to the formulas to calculate the number of tributary slots.  Additionally, this table has specific rows to cover ODUflex(CBR) IB SDR, IB DDR, IB QDR, FC-400, and FC-800 and specifies the explicit number of tributary slot assignments when mapped into ODUflex into HO-OPUk).

It seems that the generic formula for ODUflex(CBR) does not result in the same number of tributary slots for some of these client signals.  For example, IB SDR over HO-OPU3 has nominal bit rate of 2,500,000 kbits/s and bit rate tolerance of +/-100ppm (from G.709 Amend2 Table 17-14).  Using the generic ODUflex(CBR) formula, you get:

Table 7-9 shows that IB SDR mapped into ODUflex over HO-OPU3 would use 3 tributary slots, not 2.

Please verify my math but if the generic ODUflex formula does not apply to the IB or FC clients, then we may need to have explicit signal types for these clients.

I found that the IB clients do not match the generic formula for some HO-OPUk but the FC clients do match.  This may mean we only would need explicit signal types for:
- ODUflex(CBR)-IB-SDR
- ODUflex(CBR)-IB-DDR
- ODUflex(CBR)-IB-QDR

[Fatai]  If you also take into account the Transcoding Factor described in G.709 and associated to 8B/10B and 64B/65B, you will find the number of tributary slot is correct for your example.

The formulas described in Table 7-9 of G.709V3(12/2009) are as follows:
Number of tributary slots = Ceiling(ODUflex(CBR) nominal bit rate/(T×ODTU2.ts nominal bit rate) × (1+ODUflex(CBR) bit rate tolerance)/(1-HO OPU2 bit rate tolerance)).
Number of tributary slots = Ceiling(ODUflex(CBR) nominal bit rate/(T×ODTU3.ts nominal bit rate) × (1+ODUflex(CBR) bit rate tolerance)/(1-HO OPU3 bit rate tolerance)).
Number of tributary slots = Ceiling(ODUflex(CBR) nominal bit rate/(T×ODTU4.ts nominal bit rate) × (1+ODUflex(CBR) bit rate tolerance)/(1-HO OPU4 bit rate tolerance)).

WITH T specified as follows:

T=16/15 for 8B/10B encoded CBR clients, T=1027/1024 for 64B/66B encoded CBR clients and T=1 for other clients

We will update this draft with this formula:

Number of tributary slots = Ceiling(ODUflex(CBR) nominal bit rate/(T×ODTUj.ts nominal bit rate) × (1+ODUflex(CBR) bit rate tolerance)/(1-HO OPUj bit rate tolerance)).

Inserting also the meaning of T.

So, we don’t need to introduce the new signal types, we just need to use the updated formula.

Thanks,
Fred

---

From: "Gruman, Fred" <[email-masked]>
Date: Sat, 24 Sep 2011 07:17:59 -0500

Hello Fatai,

Thank you for your response on these items

On item #3, I found the error in my calculation.  The problem was not with the transcoding factor (as T>=1 and in the denominator, it would actually only tend to reduce the number of TS required).

I was using the client bit rate for IB in the formula instead of the ODUflex bit rate.  The ODUflex bit rate should be 239/238 x client bit rate.  Taking account this factor results in the correct number of TS per G.709 Table 7-9.

I apologize for the confusion.

Regards,

Fred

 

From: Zhangfatai [mailto:[email-masked]] 
Sent: Saturday, September 24, 2011 3:26 AM
To: Gruman, Fred; [email-masked]
Subject: RE: Questions/comments on OTN signaling

Hi Fred,

 

Thanks
 
Fatai

Hello Fatai,

    = ceiling [1.99274135]

    = 2

- ODUflex(CBR)-IB-SDR

- ODUflex(CBR)-IB-DDR

- ODUflex(CBR)-IB-QDR

Thanks,

Fred