Subject: Re: [CCAMP] Update: draft-ietf-ccamp-general-constraint-encode-05

From: Greg Bernstein <[email-masked]>
Date: Thu, 03 Nov 2011 10:29:18 -0700

Hi Jonathan, sorry for the delay I've been swamped with other projects. 
See response below. We could add some clarifying text and possibly and 
example if desired.

Greg
On 10/20/2011 12:22 AM, Jonathan Harrison wrote:
> Hi Greg,
>
> I've got a question on draft-ietf-ccamp-general-constraint-encode-05 that I hope you can answer.  The description of LABEL_RANGE1 is as follows.
>
>    "In this case the accompanying MaxLabelRange indicates the maximum
>     range of the labels. The corresponding label set is used to indicate
>     the overall label range. Specific center label information can be
>     obtained from dynamic label in use information. It is assumed that
>     both center label and range tuning can be done without causing faults
>     to existing signals."
>
> > From this, it isn't entirely clear to me what labels may or may not be used on a port advertising this type of Port Label Restriction - is it just the set of labels in the label set field?
This constraint was motivated a type of  tunable wave band add/drop 
multi-plexer. The device can add/drop wavelengths within fixed range 
from its tuning center. So we need three pieces of information: (a) the 
total set of wavelengths that could possibly be reached (the labels in 
the label set field), (b) the range of wavelengths that the device can 
process at once (MaxLabelRange), (c) the current wavelengths (available 
labels sub-TLV) in use  (tells us constraints on tuning the devices up 
or down to incorporate more wavelengths).  A pre-print of the journal 
paper with nice color figures illustrating this device can be found at 
http://www.grotto-networking.com/sites/default/files/ModelingWSONswitchesV6_0.pdf.

> Would it be possible for you to add an example in Appendix A to give an example of how LABEL_RANGE1 might be used (and how the specific center label information would be obtained from the dynamic label in use information)?
>
> Thanks,
> Jon
>
>
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of Greg Bernstein
> Sent: 25 May 2011 19:03
> To: [email-masked]
> Subject: [CCAMP] Update: draft-ietf-ccamp-general-constraint-encode-05
>
> Hi CCAMPers interested in WSON, the previous draft (version 04) of
> "General Network Element Constraint Encoding for GMPLS Controlled
> Networks" was expiring so we needed to refresh with a new version. There
> are no changes technical or otherwise in the document.
>
> This document and four other WSON documents are ready for last call but
> were deferred pending a write up from Pierre Peloso concerning some type
> of alternative information model and encoding. In the CCAMP Prague
> meeting minutes (http://www.ietf.org/proceedings/80/minutes/ccamp.htm)
> there was a commitment to resolve this issue quickly. It has now been
> two months.  On April 2 we furnished an analysis of what we though the
> scheme proposed by Peloso was and demonstrated that the proposed
> increase in complexity might save 10-20 bytes, an insignificant amount.
>
> Was an alternate information/encoding still being pursued by Peloso or
> others? If so when can we see it? Or can we finally move these documents
> into last call.
>
> Best Regards
>
> Greg
>

-- 
===================================================
Dr Greg Bernstein, Grotto Networking (510) 573-2237

---

From: Jonathan Harrison <[email-masked]>
Date: Fri, 4 Nov 2011 11:02:56 +0000

Hi Greg,

Thanks for the response - that makes it much clearer.

If you add some clarifying text similar to that below, that'd be great.  If the additional clarifying text includes a reference to your journal paper, an example in the draft probably isn't necessary.

Thanks,
Jon

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Greg Bernstein
Sent: 03 November 2011 17:29
To: Jonathan Harrison
Cc: [email-masked]
Subject: Re: [CCAMP] Update: draft-ietf-ccamp-general-constraint-encode-05

Greg

_______________________________________________
CCAMP mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ccamp