Subject: [CCAMP] Comments on draft-ietf-ccamp-lsp-attribute-ro-01

From: Oscar González de Dios <[email-masked]>
Date: Wed, 13 Mar 2013 14:35:01 +0000

Dear CCAMPers, authors of draft-ietf-ccamp-lsp-attribute-ro-01,

     The object of  draft-ietf-ccamp-lsp-attribute-ro-01 now seems to be focused on adding specific attributes to nodes (that apply locally to that node). However, it may be interesting to differentiate between attributes that apply for a specific node, and attributes that apply to an LSP starting in a specific node.  The main use case is to describe with more detail both multi-domain and multi-layer paths. Currently, the LSP-ATTRIBUTES applies to the end-to-end LSP, but there is no way to express the LSP-ATTRIBUTES of the H-LSPs/FA-LSPS/S-LSPs in between.  In this case, the use of LSP-ATTRIBUTES will comply with the original purpose of the LSP-ATTRIBUTES.

  Another comment, orthogonal to the previous one is to consider both LSP-ATTRIBUTES and LSP-REQUIRED-ATTRIBUTES.

Best Regards,

Oscar

-----------------------------------------
Dr Oscar Gonzalez de Dios
Telefonica I+D, Global CTO Unit

Web: http://people.tid.es/Oscar.GonzalezDeDios

e-mail: [email-masked]<mailto:[email-masked]>
Tel:    +34 913 128 832
Mobile: +34 609 169 028
-----------------------------------------

________________________________

Este mensaje se dirige exclusivamente a su destinatario. Puede consultar nuestra política de envío y recepción de correo electrónico en el enlace situado más abajo.
This message is intended exclusively for its addressee. We only send and receive email on the basis of the terms set out at:
http://www.tid.es/ES/PAGINAS/disclaimer.aspx

---

From: "Giovanni Martinelli (giomarti)" <[email-masked]>
Date: Wed, 13 Mar 2013 17:22:18 +0000

Hi Oscar,

On Mar 13, 2013, at 10:35 , Oscar González de Dios <[email-masked]<mailto:[email-masked]>> wrote:

     The object of  draft-ietf-ccamp-lsp-attribute-ro-01 now seems to be focused on adding specific attributes to nodes (that apply locally to that node).

yes, this was the use case

However, it may be interesting to differentiate between attributes that apply for a specific node, and attributes that apply to an LSP starting in a specific node.  The main use case is to describe with more detail both multi-domain and multi-layer paths. Currently, the LSP-ATTRIBUTES applies to the end-to-end LSP, but there is no way to express the LSP-ATTRIBUTES of the H-LSPs/FA-LSPS/S-LSPs in between.  In this case, the use of LSP-ATTRIBUTES will comply with the original purpose of the LSP-ATTRIBUTES.

Do you mean "partial"  (from and intermediate node to another intermediate node / eventually the end one) path attributes?

Adrian comment sounds like we are extending the semantic of LSP_ATTRIBUTE (hope my free written translation is correct). Does the above extend one step further?

Not expressing an opinion yet, just a clarification request.

I remember was already there but need to double check.

Cheers
G

Best Regards,

Oscar

Este mensaje se dirige exclusivamente a su destinatario. Puede consultar nuestra política de envío y recepción de correo electrónico en el enlace situado más abajo.
This message is intended exclusively for its addressee. We only send and receive email on the basis of the terms set out at:
http://www.tid.es/ES/PAGINAS/disclaimer.aspx
_______________________________________________
CCAMP mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ccamp

---

From: Oscar González de Dios <[email-masked]>
Date: Wed, 13 Mar 2013 23:18:27 +0000

Hi Giovanni, answers inline

Yes, I meant specifying the attributes of a "segment" which starts and ends in intermediate nodes. This "segment" could potentially be for example an FA-LSP (this is just one example use case).

I think this is a further use, so it may be a step further.

I remember was already there but need to double check.
True.. just it was a bit hidden :-) Now I saw it.

Cheers
G