Subject: [CCAMP] R: New version of "Framework and Requirements for GMPLS based control of Flexi-grid DWDM networks"

From: "BELOTTI, SERGIO (SERGIO)" <[email-masked]>
Date: Fri, 1 Mar 2013 09:27:03 +0000

Hi Lei

Some questions for clarifications:

:Available Frequency Range-List is [-300,468] (without any reservation)   ---> how did you get these values ? I saw the lowest value of the range  from slice 1 (n = -(193.1  - 191.23125/0,00625) in the table but what about the highest ?
•         Available Central Frequency Granularity = 6.25GHz,
•         Available Slot Width Granularity = 12.5GHz
•         Minimal Slot Width = 4 (50GHz)
•         Maximal Slot Width = 8 (200GHz) --> Is it not 16 ?
•         High/low frequency edge restriction  = 1 (It is a binary flag. Takes value of 1 when the  High/low frequency edge assigned to one frequeny slot MUST align with the available edge frequencies set; otherwise, 0).

Assuming that the lowest/highest frequecy of available frequency range-list is L/H (193.1 + L/H * 0.00625 THz), and available slot width granularity is G (G * 0.0125 THz), the available low or high edge frequencies set is  {L+k*2G: 0<=k<(H-L)/2G} or {H-k*2G: 0<=k<(H-L)/2G}.

Are you assuming L/H stand for the n of the usual nominal central frequency formula ? Could you detail more ?

In the framework there all definitions of the terms used above but never defined “slice”. It is intuitive but I think a clear definition has to be done.

Thanks
Sergio

-------------------------------------------------------------------------------

Belotti Sergio-  System Architect
ALCATE-LUCENT  Optics Division
via Trento 30 Vimercate (MB) - Italy
phone +39 (039) 6863033
________________________________
Da: [email-masked] [mailto:[email-masked]] Per conto di [email-masked]
Inviato: venerdì 1 marzo 2013 5.21
A: [email-masked]
Oggetto: Re: [CCAMP] New version of "Framework and Requirements for GMPLS based control of Flexi-grid DWDM networks"

Hi, Ramon and CCAMPers,

[At the suggestion of Adrian, I send this mail about Flexi-grid discussion to CCAMP list]

I have one idea to map the restriction we have discussed to <Available Spectrum in Fiber for frequency slot>

the port restriction of Finisar FLEXGRID WSS could be described as follows:

•         Available Frequency Range-List is [-300,468] (without any reservation)
•         Available Central Frequency Granularity = 6.25GHz,
•         Available Slot Width Granularity = 12.5GHz
•         Minimal Slot Width = 4 (50GHz)
•         Maximal Slot Width = 8 (200GHz)
•         High/low frequency edge restriction  = 1 (It is a binary flag. Takes value of 1 when the  High/low frequency edge assigned to one frequeny slot MUST align with the available edge frequencies set; otherwise, 0).

Assuming that the lowest/highest frequecy of available frequency range-list is L/H (193.1 + L/H * 0.00625 THz), and available slot width granularity is G (G * 0.0125 THz), the available low or high edge frequencies set is  {L+k*2G: 0<=k<(H-L)/2G} or {H-k*2G: 0<=k<(H-L)/2G}.

opinions here?

Best Regards

--------------------------------------------
LeiWang

ZTE

Cell phone:+86 13811440067
Email: [email-masked]
      [email-masked]
      [email-masked]
----------------------------------------------

------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Hi, Lei,

  [I am aware that now we should send to CCAMP list, instead of a small group. Just try to finish this thread, without bringing up any new issues. ]

 " In such condition, [-2,2] is supported as one frequency slot, but [-1,3] is not, because it splits the basic slot unit--slice (Xian, Could you understand my meaning? In Finisar WSS, each slice MUST be switched as a whole)."

 Ha, I see your point now. Then, I agree that there is an additional constraint implied in this case (i.e. a frequency slot boundary can be at odd points ONLY). That's why [-2, 2] is considered as an invalid frequency slot.

In this case, the case brought up in Figure 4 of the framework draft definitely won't happen. However, if this constraint is not there, the issue holds.  We definitely should ask Q6 experts whether this constraint holds in general in the joint meeting. If so, save us time on figuring out a solution for this issue, :-).

Regards,

Xian

El 28/02/2013 2:06, [email-masked]<mailto:[email-masked]> escribió:
[Lei] I do not agree with you. The finisar WSS support all the flexigrid central frequencies, not only the odd ones. For example, The central frequecny of  slot [-2,2] is 0, while The central frequecny of  slot [-2,4] is 1.

[Lei] The framework defines the information model, so it MUST be guaranteed that this model could describe all the situations exactly. it is the issue about integrity, clear?

Lei, all

I think I see your point. I believe that the problem resides in the fact that we have made the mental exercise of thinking that the tunability capabilities and granularity of a filter component can be stated or expressed as two independent capabilities that can be considered separately (namely the center and the width). Your example shows that the relationship between both is not as straightforward. I tend to agree that the information model should cover all (at least common) cases, as this is one.

I have yet to think how this can be mapped, other than "provide me a frequency slot description and we can check whether it is feasible or not". [Note: this can be a good question for Friday, for those of you who attend]

Maybe it is possible to generalize this case and says something in the lines of:

tunability granularity capabilities = (central granularity and width granularity) OR (concatenation of a basic slot) or a combination of both?

ideas, comments?

Thanks
R.

--
Ramon Casellas, Ph.D.
Research Associate - Optical Networking Area -- http://wikiona.cttc.es<http://wikiona.cttc.es/>
CTTC - Centre Tecnològic de Telecomunicacions de Catalunya, PMT Ed B4
Av. Carl Friedrich Gauss, 7 - 08860 Castelldefels (Barcelona) - Spain
Tel.: +34 93 645 29 00 -- Fax. +34 93 645 29 01
________________________________

发件人: [email-masked] [[email-masked]]
发送时间: 2013年2月28日 9:06
到: Zhangxian (Xian)
Cc: Abinder Dhillon; 'Adrian Farrel' ([email-masked]); [email-masked]; Biao Lu; Margaria, Cyril (NSN - DE/Munich); Daniel King ([email-masked]); Daniele Ceccarelli; Varma, Eve L (Eve); FELIPE JIMENEZ ARRIBAS; [email-masked]; [email-masked]; [email-masked]; Hanjianrui; [email-masked]; Iftekhar Hussain; [email-masked]'; Leeyoung; [email-masked]; Moustafa Kattan (mkattan); Marco Sosa; Oscar González de Dios; Ramon Casellas; Raul Muñoz; Ricardo Martínez; Rajan Rao; BELOTTI, SERGIO (SERGIO); Sharfuddin Syed; 'Takehiro Tsuritani' ([email-masked]); [email-masked]; [email-masked]; [email-masked]; Fatai Zhang; [email-masked]'; zhangguoying
主题: Re: New version of "Framework and Requirements for GMPLS based control of Flexi-grid DWDM networks"

Hi, everyone,

I think there are some misunderstands on my point, so I will try to re-explain it clearly.

Also  assuming the Finisar FLEXGRID WSS is used as media layer switch, and the slices are are [2(k-1), 2k] for k in [[-149..234]] (I have a mistake on calculation. Thanks to Cyril for the correction). In such condition, [-2,2] is supported as one frequency slot, but [-1,3] is not, because it splits the basic slot unit--slice (Xian, Could you understand my meaning? In Finisar WSS, each slice MUST be switched as a whole). If the Finisar FLEXGRID WSSs are used in the whole network, the problem presented in Fig. 4 will not arise.

[Cyril] "This is an HW specific restriction, it does not support all the flexigrid central frequencies, only the odd ones."

[Lei] I do not agree with you. The finisar WSS support all the flexigrid central frequencies, not only the odd ones. For example, The central frequecny of  slot [-2,2] is 0, while The central frequecny of  slot [-2,4] is 1.

so, If we describe the port restriction of such WSS by <Available Spectrum in Fiber for frequency slot> defined in the draft, it will be:

•         Available Frequency Range-List is [-300,468] (without any reservation)
•         Available Central Frequency Granularity = 6.25GHz,
•         Available Slot Width Granularity = 12.5GHz
•         Minimal Slot Width = 4 (50GHz)
•         Maximal Slot Width = 8 (200GHz)

Such definition cannot describe the ability of finisar WSS exactly, due to the lack of restrictions to differentiate invalid ones such as [-1,3]... from available frequency slot set.

[Xian]  "I do not know whether we did specify it in the framework document"

[Lei] The framework defines the information model, so it MUST be guaranteed that this model could describe all the situations exactly. it is the issue about integrity, clear?

--------------------------------------------
LeiWang

ZTE
Bearer Network Product Pre_research Department,
Wireline R&D Insititute
Cell phone:+86 13811440067
Email: [email-masked]
     [email-masked]
     [email-masked]
----------------------------------------------
"Zhangxian (Xian)" <[email-masked]>
2013-02-27 22:22

收件人

"Margaria, Cyril (NSN - DE/Munich)" <[email-masked]>, "ext [email-masked]" <[email-masked]>, Oscar González de Dios <[email-masked]>

抄送

Abinder Dhillon <[email-masked]>, "'Adrian Farrel' ([email-masked])" <[email-masked]>, "[email-masked]" <[email-masked]>, Biao Lu <[email-masked]>, "Daniel King ([email-masked])" <[email-masked]>, Daniele Ceccarelli <[email-masked]>, "Varma, Eve L (Eve)" <[email-masked]>, FELIPE JIMENEZ ARRIBAS <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, Hanjianrui <[email-masked]>, "[email-masked]" <[email-masked]>, Iftekhar Hussain <[email-masked]>, "[email-masked]'" <[email-masked]>, Leeyoung <[email-masked]>, "[email-masked]" <[email-masked]>, "Moustafa Kattan (mkattan)" <[email-masked]>, Marco Sosa <[email-masked]>, Ramon Casellas <[email-masked]>, Raul Muñoz <[email-masked]>, Ricardo Martínez <[email-masked]>, Rajan Rao <[email-masked]>, "BELOTTI, SERGIO (SERGIO)" <[email-masked]>, Sharfuddin Syed <[email-masked]>, "'Takehiro Tsuritani' ([email-masked])" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, Fatai Zhang <[email-masked]>, "[email-masked]'" <[email-masked]>, zhangguoying <[email-masked]>

主题

答复: New version of "Framework and Requirements for GMPLS based control of Flexi-grid DWDM networks"

Hi,
    I agree with Cyril's analysis on the specific case brought up by Lei. It is a hardware restriction and can be represented by giving the actual central frequency granularity(CFG) supported. I do not know whether we did specify it in the framework document, but the use case presented in Figure 4 holds true, assuming that specification in G.694.1(i.e., CFG=6.25G, and slot width granularity=2*CFG).
    Given this specific case (i.e., nominal central frequency granularity = 12.5G), I wonder whether we should use the following formula for calculating supported central frequency:
    f = 193.1 THz + n x 0.0125 THz ,
   instead of the one specified by G.694.1?
   Also, i wonder why [-2, 2] would be a invalid frequency slot in this specific case? Its central frequency is 0 and the slot width is 2*the supported CFG(12.5G). Is there anything I am missing here?
Regards,
Xian

________________________________

发件人: Margaria, Cyril (NSN - DE/Munich) [[email-masked]]
发送时间: 2013年2月27日 21:32
到: ext [email-masked]; Oscar González de Dios
Cc: Abinder Dhillon; 'Adrian Farrel' ([email-masked]); [email-masked]; Biao Lu; Daniel King ([email-masked]); Daniele Ceccarelli; Varma, Eve L (Eve); FELIPE JIMENEZ ARRIBAS; [email-masked]; [email-masked]; [email-masked]; Hanjianrui; [email-masked]; Iftekhar Hussain; [email-masked]'; Leeyoung; [email-masked]; Moustafa Kattan (mkattan); Marco Sosa; Ramon Casellas; Raul Muñoz; Ricardo Martínez; Rajan Rao; BELOTTI, SERGIO (SERGIO); Sharfuddin Syed; 'Takehiro Tsuritani' ([email-masked]); [email-masked]; [email-masked]; [email-masked]; Zhangxian (Xian); Fatai Zhang; [email-masked]'; zhangguoying
主题: RE: New version of "Framework and Requirements for GMPLS based control of Flexi-grid DWDM networks"

Hi,

Please see inline

Best regards / Mit freundlichen Grüßen
Cyril Margaria

From: ext [email-masked] [mailto:[email-masked]]
Sent: Wednesday, February 27, 2013 9:29 AM
To: Oscar González de Dios
Cc: Abinder Dhillon; 'Adrian Farrel' ([email-masked]); [email-masked]; Biao Lu; Margaria, Cyril (NSN - DE/Munich); Daniel King ([email-masked]); Daniele Ceccarelli; Varma, Eve L (Eve); FELIPE JIMENEZ ARRIBAS; [email-masked]; [email-masked]; [email-masked]; Hanjianrui; [email-masked]; Iftekhar Hussain; [email-masked]'; Leeyoung; [email-masked]; Moustafa Kattan (mkattan); Marco Sosa; Ramon Casellas; Raul Muñoz; Ricardo Martínez; Rajan Rao; BELOTTI, SERGIO (SERGIO); Sharfuddin Syed; 'Takehiro Tsuritani' ([email-masked]); [email-masked]; [email-masked]; [email-masked]; Zhangxian (Xian); Fatai Zhang; [email-masked]'; zhangguoying
Subject: Re: New version of "Framework and Requirements for GMPLS based control of Flexi-grid DWDM networks"

Hi, Oscar and Huub,

I also have one question on the frequecy slot presented in Fig. 4.

Let us firstly review the commercially available optical components that support flexible grid, such as Finisar FLEXGRID WSS Dwpf series. It supports 384 slices on each port, and the slot width of each slice is 12.5GHz. One k*12.5GHz frequecy slot composes of k contiguous slices. In addition, each slice has clear definition, including center frequency and low/high frequency edge. Detailed information could be seen in the attached document.

Get back to the draft we discussed. Assuming the Finisar FLEXGRID WSS is used as media layer switch, and the slices are [-2n-1,-2n+1]...[-3,-1],[-1,1],[1,3]...[2n-1,2n+1]. In such condition, [-1,3] is supported as one frequency slot, but [-2,2] is not, because it splits the basic slot unit--slice. If the Finisar FLEXGRID WSSs are used in the whole network, the problem presented in Fig. 4 will not arise.
This is an HW specific restriction, it does not support all the flexigrid central frequencies, only the odd ones. From the document I calculated the slice 1 corresponding to n=-299, (n as is f= 193.1 + n × 0.00625).
So I believe the slices are [2(k-1), 2k] for k in [[-149..234]] , the central frequencies are 2k-1.
This works in this specific case,
My viewpoint is that: the information model of <Available Spectrum in Fiber for frequency slot>

 <Available Spectrum in Fiber for frequency slot> ::=
     <Available Frequency Range-List>
     <Available Central Frequency Granularity >
     <Available Slot Width Granularity>
     <Minimal Slot Width>
     <Maximal Slot Width>

may be not enough to describe the whole atrributions, and additional constraint on frequecy slot division shown above should be considered, which is caused by physical features of optical components.
From the description the hw restriction is that
•         Available Frequency Range-List is [-300,468] (without any reservation)
•         Available Central Frequency Granularity = 12.5Ghz,
•         Available Slot Width Granularity = 384
•         Minimal Slot Width = 1
•         Maximal Slot Width = 384
With this the first available central frequency is at -299 (minium + Minimal Slot Width) , then the next one is -297, (as Available Central Frequency Granularity = 2x”Flexigrid central frequency granularity”

Opinion here?

Best Regards

--------------------------------------------
LeiWang

ZTE

Cell phone:+86 13811440067
Email: [email-masked]<mailto:[email-masked]>
    [email-masked]<mailto:[email-masked]>
    [email-masked]<mailto:[email-masked]>
----------------------------------------------
Oscar González de Dios <[email-masked]<mailto:[email-masked]>>
2013-02-26 01:23

收件人

"[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>

抄送

"BELOTTI, SERGIO (SERGIO)" <[email-masked]<mailto:[email-masked]>>, Ramon Casellas <[email-masked]<mailto:[email-masked]>>, Daniele Ceccarelli <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "Zhangxian (Xian)" <[email-masked]<mailto:[email-masked]>>, Abinder Dhillon <[email-masked]<mailto:[email-masked]>>, "'Adrian Farrel' ([email-masked]<mailto:[email-masked]>)" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Biao Lu <[email-masked]<mailto:[email-masked]>>, "Margaria, Cyril (NSN - DE/Munich) ([email-masked]<mailto:[email-masked]>)" <[email-masked]<mailto:[email-masked]>>, "Daniel King ([email-masked]<mailto:[email-masked]>)" <[email-masked]<mailto:[email-masked]>>, "Varma, Eve L (Eve)" <[email-masked]<mailto:[email-masked]>>, FELIPE JIMENEZ ARRIBAS <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Hanjianrui <[email-masked]<mailto:[email-masked]>>, "[email-masked]'" <[email-masked]<mailto:[email-masked]>>, Leeyoung <[email-masked]<mailto:[email-masked]>>, "Moustafa Kattan (mkattan)" <[email-masked]<mailto:[email-masked]>>, Marco Sosa <[email-masked]<mailto:[email-masked]>>, Raul Muñoz <[email-masked]<mailto:[email-masked]>>, Ricardo Martínez <[email-masked]<mailto:[email-masked]>>, Rajan Rao <[email-masked]<mailto:[email-masked]>>, Iftekhar Hussain <[email-masked]<mailto:[email-masked]>>, Sharfuddin Syed <[email-masked]<mailto:[email-masked]>>, "'Takehiro Tsuritani' ([email-masked]<mailto:[email-masked]>)" <[email-masked]<mailto:[email-masked]>>, "[email-masked]'" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Fatai Zhang <[email-masked]<mailto:[email-masked]>>, "[email-masked]'" <[email-masked]<mailto:[email-masked]>>, zhangguoying <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>

主题

Re: New version of "Framework and Requirements for GMPLS based control of Flexi-grid DWDM networks"

Hi Huub,

There was an open question (editors note before figure 4) raised wether
or not it was allowed to have several frequency slots in a path that did
not have the same n. The issue is, if different n is allowed, in some
cases the resulting effective frequency slot would be invalid (as in
figure 4), or valid,  as the example you mention (the resulting frequency
slot did not have anything wrong). However, if n is not allowed to vary,
there would be no case of invalid effective frequency slot. That's the
reason why some people suggest that, in sake of simplicity, n should not
be allowed to change.

This can be one of the questions to be raised in the joint meeting with
ITU-T, whether it is possible to have frequency slots of different m in a
media channelŠ

Opinion here?

Oscar

El 25/02/13 18:08, "Huub van Helvoort" <[email-masked]<mailto:[email-masked]>> escribió:

>Hello Oscar,
>
>I have a question fro clarification:
>I understand figure 4 and why this results in an invalid effective
>frequency slot.
>
>Now suppose that in this figure Frequency slot 1 is not [-2],[2] but
>[-1],[3] with center [1]; then frequence slots 1 and 2 overlap as in
>figure 3.
>And the resulting frequency slot is [-1],[3] with center [1]
>? would this still be considered invalid effective frequency slot?
>If yes, maybe worth adding this too?
>
>Hasta pronto, Huub.
>
>==================
>> Lot's of thanks for the provided comments. Please find the attached new
>> version addressing part of the comments. Some of the comments suggested
>> some re-writing in specific parts, which can be addressed for the next
>> version.
>>
>> Up to section 7 the content is quite stable. Only some tuning is needed
>> to remove duplicate content, coherency in terminology and introducing
>> all terms. The section that needs more discussion is the control plane
>> requirements. During next IETF meeting, we should meet together and work
>> on such requirements.
>>
>> Please let me know if you have any quick comment in the attached
>> document. Otherwise, I plan to submit it in a couple of hours.
>>
>> Best Regards,
>>
>> Oscar

________________________________

Este mensaje se dirige exclusivamente a su destinatario. Puede consultar nuestra política de envío y recepción de correo electrónico en el enlace situado más abajo.
This message is intended exclusively for its addressee. We only send and receive email on the basis of the terms set out at:
http://www.tid.es/ES/PAGINAS/disclaimer.aspx

---

From: [email-masked]
Date: Mon, 4 Mar 2013 08:56:51 +0800

"BELOTTI, SERGIO (SERGIO)" <[email-masked]> 
2013-03-01 17:27

收件人
"[email-masked]" <[email-masked]>
抄送
"[email-masked]" <[email-masked]>
主题
R: [CCAMP] New version of "Framework and Requirements for GMPLS based 
control of Flexi-grid DWDM networks"

Hi Lei

:Available Frequency Range-List is [-300,468] (without any reservation) 
---> how did you get these values ? I saw the lowest value of the range 
from slice 1 (n = -(193.1  - 191.23125/0,00625) in the table but what 
about the highest ? 

[Lei] these values are specified in the datasheet of Finisar Dwpf WSS. 

the highest: slice number~384; center frequency~196.01875; low frequency 
edge~196.0125; high frequecny edge~196.0250

·         Available Central Frequency Granularity = 6.25GHz, 
·         Available Slot Width Granularity = 12.5GHz 
·         Minimal Slot Width = 4 (50GHz) 
·         Maximal Slot Width = 8 (200GHz) --> Is it not 16 ?

[Lei]ha, I have a mistake on calculation, thanks for your correction 
·         High/low frequency edge restriction  = 1 (It is a binary flag. 
Takes value of 1 when the  High/low frequency edge assigned to one 
frequeny slot MUST align with the available edge frequencies set; 
otherwise, 0). 
  
Assuming that the lowest/highest frequecy of available frequency 
range-list is L/H (193.1 + L/H * 0.00625 THz), and available slot width 
granularity is G (G * 0.0125 THz), the available low or high edge 
frequencies set is  {L+k*2G: 0<=k<(H-L)/2G} or {H-k*2G: 0<=k<(H-L)/2G}. 
 
Are you assuming L/H stand for the n of the usual nominal central 
frequency formula ? Could you detail more ?

[Lei] L/H stands for the Lowest/Highest edge frequency of the frequecy 
range. Taking Finisar WSS as an example, L=-300 and H=468.

In the framework there all definitions of the terms used above but never 
defined “slice”. It is intuitive but I think a clear definition has to 
be done. 
 
Thanks
Sergio

Da: [email-masked] [mailto:[email-masked]] Per conto di 
[email-masked]
Inviato: venerdì 1 marzo 2013 5.21
A: [email-masked]
Oggetto: Re: [CCAMP] New version of "Framework and Requirements for GMPLS 
based control of Flexi-grid DWDM networks"

Hi, Ramon and CCAMPers, 

[At the suggestion of Adrian, I send this mail about Flexi-grid discussion 
to CCAMP list] 

I have one idea to map the restriction we have discussed to <Available 
Spectrum in Fiber for frequency slot> 

the port restriction of Finisar FLEXGRID WSS could be described as 
follows: 

·         Available Frequency Range-List is [-300,468] (without any 
reservation) 
·         Available Central Frequency Granularity = 6.25GHz, 
·         Available Slot Width Granularity = 12.5GHz 
·         Minimal Slot Width = 4 (50GHz) 
·         Maximal Slot Width = 8 (200GHz) 
·         High/low frequency edge restriction  = 1 (It is a binary flag. 
Takes value of 1 when the  High/low frequency edge assigned to one 
frequeny slot MUST align with the available edge frequencies set; 
otherwise, 0). 
  
Assuming that the lowest/highest frequecy of available frequency 
range-list is L/H (193.1 + L/H * 0.00625 THz), and available slot width 
granularity is G (G * 0.0125 THz), the available low or high edge 
frequencies set is  {L+k*2G: 0<=k<(H-L)/2G} or {H-k*2G: 0<=k<(H-L)/2G}. 

opinions here? 

Best Regards 

ZTE

Hi, Lei, 
  
  [I am aware that now we should send to CCAMP list, instead of a small 
group. Just try to finish this thread, without bringing up any new issues. 
] 
  
 " In such condition, [-2,2] is supported as one frequency slot, but 
[-1,3] is not, because it splits the basic slot unit--slice (Xian, Could 
you understand my meaning? In Finisar WSS, each slice MUST be switched as 
a whole)." 
  
 Ha, I see your point now. Then, I agree that there is an additional 
constraint implied in this case (i.e. a frequency slot boundary can be at 
odd points ONLY). That's why [-2, 2] is considered as an invalid frequency 
slot. 
  
In this case, the case brought up in Figure 4 of the framework draft 
definitely won't happen. However, if this constraint is not there, the 
issue holds.  We definitely should ask Q6 experts whether this constraint 
holds in general in the joint meeting. If so, save us time on figuring out 
a solution for this issue, :-). 
  
Regards, 
  
Xian 

El 28/02/2013 2:06, [email-masked] escribió: 
[Lei] I do not agree with you. The finisar WSS support all the flexigrid 
central frequencies, not only the odd ones. For example, The central 
frequecny of  slot [-2,2] is 0, while The central frequecny of  slot 
[-2,4] is 1. 

[Lei] The framework defines the information model, so it MUST be 
guaranteed that this model could describe all the situations exactly. it 
is the issue about integrity, clear? 

Lei, all

I think I see your point. I believe that the problem resides in the fact 
that we have made the mental exercise of thinking that the tunability 
capabilities and granularity of a filter component can be stated or 
expressed as two independent capabilities that can be considered 
separately (namely the center and the width). Your example shows that the 
relationship between both is not as straightforward. I tend to agree that 
the information model should cover all (at least common) cases, as this is 
one. 

I have yet to think how this can be mapped, other than "provide me a 
frequency slot description and we can check whether it is feasible or 
not". [Note: this can be a good question for Friday, for those of you who 
attend]

Maybe it is possible to generalize this case and says something in the 
lines of:

tunability granularity capabilities = (central granularity and width 
granularity) OR (concatenation of a basic slot) or a combination of both?

ideas, comments? 

Thanks
R.

-- 
Ramon Casellas, Ph.D. 
Research Associate - Optical Networking Area -- http://wikiona.cttc.es
CTTC - Centre Tecnològic de Telecomunicacions de Catalunya, PMT Ed B4
Av. Carl Friedrich Gauss, 7 - 08860 Castelldefels (Barcelona) - Spain
Tel.: +34 93 645 29 00 -- Fax. +34 93 645 29 01 

发件人: [email-masked] [[email-masked]]
发送时间: 2013年2月28日 9:06
到: Zhangxian (Xian)
Cc: Abinder Dhillon; 'Adrian Farrel' ([email-masked]); 
[email-masked]; Biao Lu; Margaria, Cyril (NSN - DE/Munich); 
Daniel King ([email-masked]); Daniele Ceccarelli; Varma, Eve L (Eve); 
FELIPE JIMENEZ ARRIBAS; [email-masked]; [email-masked]; 
[email-masked]; Hanjianrui; [email-masked]; Iftekhar Hussain; 
[email-masked]'; Leeyoung; [email-masked]; Moustafa Kattan 
(mkattan); Marco Sosa; Oscar González de Dios; Ramon Casellas; Raul Muñoz; 
Ricardo Martínez; Rajan Rao; BELOTTI, SERGIO (SERGIO); Sharfuddin Syed; 
'Takehiro Tsuritani' ([email-masked]); [email-masked]; 
[email-masked]; [email-masked]; Fatai Zhang; 
[email-masked]'; zhangguoying
主题: Re: New version of "Framework and Requirements for GMPLS based 
control of Flexi-grid DWDM networks"

Hi, everyone, 

I think there are some misunderstands on my point, so I will try to 
re-explain it clearly. 

Also  assuming the Finisar FLEXGRID WSS is used as media layer switch, and 
the slices are are [2(k-1), 2k] for k in [[-149..234]] (I have a mistake 
on calculation. Thanks to Cyril for the correction). In such condition, 
[-2,2] is supported as one frequency slot, but [-1,3] is not, because it 
splits the basic slot unit--slice (Xian, Could you understand my meaning? 
In Finisar WSS, each slice MUST be switched as a whole). If the Finisar 
FLEXGRID WSSs are used in the whole network, the problem presented in Fig. 
4 will not arise. 

[Cyril] "This is an HW specific restriction, it does not support all the 
flexigrid central frequencies, only the odd ones." 

[Lei] I do not agree with you. The finisar WSS support all the flexigrid 
central frequencies, not only the odd ones. For example, The central 
frequecny of  slot [-2,2] is 0, while The central frequecny of  slot 
[-2,4] is 1. 

so, If we describe the port restriction of such WSS by <Available Spectrum 
in Fiber for frequency slot> defined in the draft, it will be: 

·         Available Frequency Range-List is [-300,468] (without any 
reservation) 
·         Available Central Frequency Granularity = 6.25GHz, 
·         Available Slot Width Granularity = 12.5GHz 
·         Minimal Slot Width = 4 (50GHz) 
·         Maximal Slot Width = 8 (200GHz) 

Such definition cannot describe the ability of finisar WSS exactly, due to 
the lack of restrictions to differentiate invalid ones such as [-1,3]... 
from available frequency slot set. 

[Xian]  "I do not know whether we did specify it in the framework 
document" 

[Lei] The framework defines the information model, so it MUST be 
guaranteed that this model could describe all the situations exactly. it 
is the issue about integrity, clear? 

ZTE

收件人
"Margaria, Cyril (NSN - DE/Munich)" <[email-masked]>, "ext 
[email-masked]" <[email-masked]>, Oscar González de Dios 
<[email-masked]> 
抄送
Abinder Dhillon <[email-masked]>, "'Adrian Farrel' 
([email-masked])" <[email-masked]>, "[email-masked]" 
<[email-masked]>, Biao Lu <[email-masked]>, "Daniel King 
([email-masked])" <[email-masked]>, Daniele Ceccarelli 
<[email-masked]>, "Varma, Eve L (Eve)" 
<[email-masked]>, FELIPE JIMENEZ ARRIBAS <[email-masked]>, 
"[email-masked]" <[email-masked]>, "[email-masked]" 
<[email-masked]>, "[email-masked]" <[email-masked]>, 
Hanjianrui <[email-masked]>, "[email-masked]" 
<[email-masked]>, Iftekhar Hussain <[email-masked]>, 
"[email-masked]'" <[email-masked]>, Leeyoung 
<[email-masked]>, "[email-masked]" 
<[email-masked]>, "Moustafa Kattan (mkattan)" 
<[email-masked]>, Marco Sosa <[email-masked]>, Ramon Casellas 
<[email-masked]>, Raul Muñoz <[email-masked]>, Ricardo 
Martínez <[email-masked]>, Rajan Rao <[email-masked]>, 
"BELOTTI, SERGIO (SERGIO)" <[email-masked]>, Sharfuddin 
Syed <[email-masked]>, "'Takehiro Tsuritani' ([email-masked])" 
<[email-masked]>, "[email-masked]" <[email-masked]>, 
"[email-masked]" <[email-masked]>, "[email-masked]" 
<[email-masked]>, Fatai Zhang <[email-masked]>, 
"[email-masked]'" <[email-masked]>, zhangguoying 
<[email-masked]> 
主题
答复: New version of "Framework and Requirements for GMPLS based control 
of Flexi-grid DWDM networks"

Hi, 
    I agree with Cyril's analysis on the specific case brought up by Lei. 
It is a hardware restriction and can be represented by giving the actual 
central frequency granularity(CFG) supported. I do not know whether we did 
specify it in the framework document, but the use case presented in Figure 
4 holds true, assuming that specification in G.694.1(i.e., CFG=6.25G, and 
slot width granularity=2*CFG). 
    Given this specific case (i.e., nominal central frequency granularity 
= 12.5G), I wonder whether we should use the following formula for 
calculating supported central frequency: 
    f = 193.1 THz + n x 0.0125 THz , 
   instead of the one specified by G.694.1? 
   Also, i wonder why [-2, 2] would be a invalid frequency slot in this 
specific case? Its central frequency is 0 and the slot width is 2*the 
supported CFG(12.5G). Is there anything I am missing here? 
Regards, 
Xian 

发件人: Margaria, Cyril (NSN - DE/Munich) [[email-masked]]
发送时间: 2013年2月27日 21:32
到: ext [email-masked]; Oscar González de Dios
Cc: Abinder Dhillon; 'Adrian Farrel' ([email-masked]); 
[email-masked]; Biao Lu; Daniel King ([email-masked]); 
Daniele Ceccarelli; Varma, Eve L (Eve); FELIPE JIMENEZ ARRIBAS; 
[email-masked]; [email-masked]; [email-masked]; Hanjianrui; 
[email-masked]; Iftekhar Hussain; [email-masked]'; Leeyoung; 
[email-masked]; Moustafa Kattan (mkattan); Marco Sosa; Ramon 
Casellas; Raul Muñoz; Ricardo Martínez; Rajan Rao; BELOTTI, SERGIO 
(SERGIO); Sharfuddin Syed; 'Takehiro Tsuritani' ([email-masked]); 
[email-masked]; [email-masked]; [email-masked]; 
Zhangxian (Xian); Fatai Zhang; [email-masked]'; zhangguoying
主题: RE: New version of "Framework and Requirements for GMPLS based 
control of Flexi-grid DWDM networks"

Hi, 
 
Please see inline 

From: ext [email-masked] [mailto:[email-masked]] 
Sent: Wednesday, February 27, 2013 9:29 AM
To: Oscar González de Dios
Cc: Abinder Dhillon; 'Adrian Farrel' ([email-masked]); 
[email-masked]; Biao Lu; Margaria, Cyril (NSN - DE/Munich); 
Daniel King ([email-masked]); Daniele Ceccarelli; Varma, Eve L (Eve); 
FELIPE JIMENEZ ARRIBAS; [email-masked]; [email-masked]; 
[email-masked]; Hanjianrui; [email-masked]; Iftekhar Hussain; 
[email-masked]'; Leeyoung; [email-masked]; Moustafa Kattan 
(mkattan); Marco Sosa; Ramon Casellas; Raul Muñoz; Ricardo Martínez; Rajan 
Rao; BELOTTI, SERGIO (SERGIO); Sharfuddin Syed; 'Takehiro Tsuritani' 
([email-masked]); [email-masked]; [email-masked]; 
[email-masked]; Zhangxian (Xian); Fatai Zhang; 
[email-masked]'; zhangguoying
Subject: Re: New version of "Framework and Requirements for GMPLS based 
control of Flexi-grid DWDM networks" 

Hi, Oscar and Huub, 

Let us firstly review the commercially available optical components that 
support flexible grid, such as Finisar FLEXGRID WSS Dwpf series. It 
supports 384 slices on each port, and the slot width of each slice is 
12.5GHz. One k*12.5GHz frequecy slot composes of k contiguous slices. In 
addition, each slice has clear definition, including center frequency and 
low/high frequency edge. Detailed information could be seen in the 
attached document. 

Get back to the draft we discussed. Assuming the Finisar FLEXGRID WSS is 
used as media layer switch, and the slices are 
[-2n-1,-2n+1]...[-3,-1],[-1,1],[1,3]...[2n-1,2n+1]. In such condition, 
[-1,3] is supported as one frequency slot, but [-2,2] is not, because it 
splits the basic slot unit--slice. If the Finisar FLEXGRID WSSs are used 
in the whole network, the problem presented in Fig. 4 will not arise. 
This is an HW specific restriction, it does not support all the flexigrid 
central frequencies, only the odd ones. From the document I calculated the 
slice 1 corresponding to n=-299, (n as is f= 193.1 + n × 0.00625). 
So I believe the slices are [2(k-1), 2k] for k in [[-149..234]] , the 
central frequencies are 2k-1. 
This works in this specific case, 
My viewpoint is that: the information model of <Available Spectrum in 
Fiber for frequency slot> 

may be not enough to describe the whole atrributions, and additional 
constraint on frequecy slot division shown above should be considered, 
which is caused by physical features of optical components. 
From the description the hw restriction is that 
·         Available Frequency Range-List is [-300,468] (without any 
reservation) 
·         Available Central Frequency Granularity = 12.5Ghz, 
·         Available Slot Width Granularity = 384 
·         Minimal Slot Width = 1 
·         Maximal Slot Width = 384 
With this the first available central frequency is at -299 (minium + 
Minimal Slot Width) , then the next one is -297, (as Available Central 
Frequency Granularity = 2x”Flexigrid central frequency granularity” 

Opinion here? 

Best Regards 

ZTE

Oscar González de Dios <[email-masked]> 
2013-02-26 01:23 

收件人
"[email-masked]" <[email-masked]> 
抄送
"BELOTTI, SERGIO (SERGIO)" <[email-masked]>, Ramon 
Casellas <[email-masked]>, Daniele Ceccarelli <
[email-masked]>, "[email-masked]" <
[email-masked]>, "Zhangxian (Xian)" <[email-masked]>, 
Abinder Dhillon <[email-masked]>, "'Adrian Farrel' (
[email-masked])" <[email-masked]>, "[email-masked]" 
<[email-masked]>, Biao Lu <[email-masked]>, "Margaria, Cyril 
(NSN - DE/Munich) ([email-masked])" <[email-masked]>, 
"Daniel King ([email-masked])" <[email-masked]>, "Varma, Eve L 
(Eve)" <[email-masked]>, FELIPE JIMENEZ ARRIBAS <
[email-masked]>, "[email-masked]" <[email-masked]>, "
[email-masked]" <[email-masked]>, "[email-masked]" <
[email-masked]>, Hanjianrui <[email-masked]>, 
"[email-masked]'" <[email-masked]>, Leeyoung <[email-masked]
>, "Moustafa Kattan (mkattan)" <[email-masked]>, Marco Sosa <
[email-masked]>, Raul Muñoz <[email-masked]>, Ricardo Martínez <
[email-masked]>, Rajan Rao <[email-masked]>, Iftekhar Hussain 
<[email-masked]>, Sharfuddin Syed <[email-masked]>, "'Takehiro 
Tsuritani' ([email-masked])" <[email-masked]>, 
"[email-masked]'" <[email-masked]>, "
[email-masked]" <[email-masked]>, "[email-masked]" <
[email-masked]>, Fatai Zhang <[email-masked]>, 
"[email-masked]'" <[email-masked]>, zhangguoying <
[email-masked]>, "[email-masked]" <
[email-masked]> 
主题
Re: New version of "Framework and Requirements for GMPLS based control of 
Flexi-grid DWDM networks"

 

Hi Huub,

Opinion here?

Oscar

Este mensaje se dirige exclusivamente a su destinatario. Puede consultar 
nuestra política de envío y recepción de correo electrónico en el enlace 
situado más abajo.
This message is intended exclusively for its addressee. We only send and 
receive email on the basis of the terms set out at:
http://www.tid.es/ES/PAGINAS/disclaimer.aspx