Subject: [CCAMP] Comment on draft-li-ccamp-role-based-automesh-00

From: Gregory Mirsky <[email-masked]>
Date: Fri, 1 Mar 2013 18:36:36 +0000

Dear Authors, et al.,
Very good document. Please find couple comments, notes below:
*       Along with LSR role in a TE mesh-group notion of mesh-group type been introduced. But TLVs don't explicitly characterize each group by its type. I think it might be useful to check whether local settings for mesh-group, type and LSR role, match advertised LSR role.
   One approach might be to partition four octet flag field into two fields: Group Type and LSR Role. LSR Role field is, as already defined, a bit map, while Group Type is a value that assigned by IANA for each type of TE mesh-group. Then, in Elements of Procedure, additional check can be performed to verify whether advertised Group Type corresponds to local Group Type for that TE-MESH-GROUP. In case of mismatch the TLV SHOULD be silently ignored.
   Another way to do it might be without explicitly advertised Group Type in TE-MESH-GROUP TLV by comparing advertised LSR Role with local LSR Role for the same TE mesh-group. Then, in case of mismatch, e.g. Hub being advertised and local setting is Root, the TLV SHOULD be silently ignored.
*       In section 3.1 last paragraph s/it MUST be set/they MUST be set/

        Regards,
                Greg

---

From: Mach Chen <[email-masked]>
Date: Mon, 4 Mar 2013 09:19:47 +0000

Hi Greg,

Many thanks for your valuable  comments!

I think that both the two suggested solutions from you work, I have no preference at present. We'd like to hear more opinions of the WG.  So, please read the draft and give your comments, any comments are welcome!

Best regards,
Mach

From: Gregory Mirsky [mailto:[email-masked]]
Sent: Saturday, March 02, 2013 2:37 AM
To: Mach Chen; Lizhenbin
Cc: [email-masked]
Subject: Comment on draft-li-ccamp-role-based-automesh-00

Dear Authors, et al.,

        Regards,
                Greg