Subject: Re: [CCAMP] [CCAMP WG] #50: Identification of hexadecimal representation in G.709 vs decimal in GMPLS

From: Daniele Ceccarelli <[email-masked]>
Date: Mon, 13 May 2013 08:03:07 +0000

Lou, CCAMP,

This is the proposed text for the info-model wrt the decimal vs hexadecimal encoding issue.

13.  Identification of hexadecimal representation in G.709 vs decimal in
     GMPLS considerations

   Encoding in GMPLS foresses the utilization of hexadecimal values
   format "0x" while in the data plane documents, like G.709
   reccomendation, the format usually used is the decimal one (e.g.
   G-PID in RSVP-TE vs Payload Type in G.709). 

BR
Daniele & Sergio

>-----Original Message-----
>From: ccamp issue tracker [mailto:[email-masked]] 
>Sent: mercoledì 8 maggio 2013 19.22
>To: [email-masked]; 
>[email-masked]
>Cc: [email-masked]
>Subject: [CCAMP WG] #50: Identification of hexadecimal 
>representation in G.709 vs decimal in GMPLS
>
>#50: Identification of hexadecimal representation in G.709 vs 
>decimal in GMPLS
>
> From: http://www.ietf.org/mail-archive/web/ccamp/current/msg14812.html
>
>   The authors had previously stated the intent to just make this clear
>   in the signaling document.  I'd like to make an alternate proposal:
>   let's do the the obvious and have the documents simply use 
>the normal
>   (IETF) convention of using a '0x' prefix anytime a hexadecimal value
>   is represented. I believe this means that only the info-model draft
>   needs to be updated.
>
>-- 
>-------------------------------------+-------------------------
>---------
>-------------------------------------+---
> Reporter:  [email-masked]         |      Owner:  draft-ietf-ccamp-
>     Type:  task                     |  
>[email-masked]
> Priority:  major                    |     Status:  new
>Component:  otn-g709-info-model      |  Milestone:  Post WG Last Call
> Severity:  Waiting for Document     |    Version:
>  Update                             |   Keywords:
>-------------------------------------+-------------------------
>---------
>-------------------------------------+---
>
>Ticket URL: <http://trac.tools.ietf.org/wg/ccamp/trac/ticket/50>
>CCAMP WG <http://tools.ietf.org/wg/ccamp/> Common Control and 
>Measurement Plane Working Group
>

---

From: Fatai Zhang <[email-masked]>
Date: Mon, 13 May 2013 09:43:15 +0000

Hi Daniele,

I think it is better to use the reference format when mentioning some data plane documents, e.g., [G709-2012].

Best Regards

Fatai

-----Original Message-----
From: Daniele Ceccarelli [mailto:[email-masked]] 
Sent: Monday, May 13, 2013 4:03 PM
To: [email-masked]; [email-masked]
Cc: [email-masked]; CCAMP
Subject: RE: [CCAMP WG] #50: Identification of hexadecimal representation in G.709 vs decimal in GMPLS

Lou, CCAMP,

BR
Daniele & Sergio

---

From: Daniele Ceccarelli <[email-masked]>
Date: Mon, 13 May 2013 09:45:45 +0000

Hi Fatai,

Yes, good comment, thanks.

Daniele 

>From: Fatai Zhang [mailto:[email-masked]] 
>Sent: lunedì 13 maggio 2013 11.43
>To: Daniele Ceccarelli; 
>[email-masked]; [email-masked]
>Subject: RE: [CCAMP WG] #50: Identification of hexadecimal 
>I think it is better to use the reference format when 
>mentioning some data plane documents, e.g., [G709-2012].
>
>
>
>
>
>Best Regards
>
>Fatai
>
>
>Subject: RE: [CCAMP WG] #50: Identification of hexadecimal 
>>Subject: [CCAMP WG] #50: Identification of hexadecimal representation 
>>in G.709 vs decimal in GMPLS
>>
>>#50: Identification of hexadecimal representation in G.709 vs decimal 
>>in GMPLS
>>
>> From: 
>http://www.ietf.org/mail-archive/web/ccamp/current/msg14812.html
>>
>>   let's do the the obvious and have the documents simply use the 
>>normal

---

From: Lou Berger <[email-masked]>
Date: Mon, 13 May 2013 06:59:03 -0400

Daniele,

> hexadecimal encoding issue.

I think the author's preference of not using the 0x prefix to
hexadecimal representation is viable if it is clear in the document (as
you mention below) and you can point to precedent of similar usage in
existing RFCs.  Have you checked / can you check to see if there's such?

>    G-PID in RSVP-TE vs Payload Type in G.709). 

Assuming we go this way: I understand your intent, but I think you're
actually stating exactly the opposite.  How about, simply:

  Note that the Payload Types (PT) defined in [G709-2012], and repeated
  in this document, are provided in hexadecimal representation without
  the commonly used '0x' prefix.

Lou

---

From: Acee Lindem <[email-masked]>
Date: Mon, 13 May 2013 11:36:11 +0000

> existing RFCs.  Have you checked / can you check to see if there's such?

As a data point, OSPF RFCs and drafts always precede hexadecimal values with 0x. Of course, the OSPF WG has a heritage of the authors also being software developers.
Unfortunately, I don't see any guidance here:  http://www.rfc-editor.org/styleguide.html

Thanks,
Acee 

> _______________________________________________
> CCAMP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ccamp

---

From: Julien Meuric <[email-masked]>
Date: Mon, 13 May 2013 18:33:05 +0200

Hi.

On my right, a simple prefix that makes values clear and unambiguous at 
reading time, without the burden of references' context; on my left, 2 
confusing statements that will no more be in mind when reading figures...
I have often heard comments about RFC readability and the needed IETF 
background to understand what is not explicit: 2 more characters per 
figure would be both helpful and harmless.

By the way, the IANA registry about GMPLS makes use of the '0x' prefix: 
http://www.iana.org/assignments/gmpls-sig-parameters/gmpls-sig-parameters.xml#gmpls-sig-parameters-8

Regards,

Julien

---

From: Lou Berger <[email-masked]>
Date: Mon, 13 May 2013 13:29:54 -0400

Julien,
	I think you win on this one.

Authors,
	Please add a '0x' prefix to any hexadecimal value in the draft.  In
other words:
  s/=2/=0x2
  s/ 20/ 0x20
  s/ 21/ 0x21

Lou