Subject: Re: [CCAMP] Generalized Labels for the Flexi-Grid in LSC Label Switching Routers

From: Jonas Mårtensson <[email-masked]>
Date: Wed, 5 Feb 2014 09:18:25 +0000

Hi all,

I don't know if this has been proposed and discussed already but why not also add a field indicating slot width granularity (similar to the C.S. field) where today the only defined value would correspond to 12.5 GHz. This would accommodate a potentially finer granularity in the future (when technologies improve as Gabriele points out).

/Jonas

> -----Original Message-----
> From: CCAMP [mailto:[email-masked]] On Behalf Of Gabriele Maria
> Galimberti (ggalimbe)
> Sent: den 31 januari 2014 16:47
> To: [email-masked]; 'Daniel King'; 'CCAMP'
> Subject: Re: [CCAMP] Generalized Labels for the Flexi-Grid in LSC Label
> Switching Routers
> 
> Hi Adrian,
> 
> Thanks for the clarification.
> If We talk about the the slot with granularity specified by G.694.1
> To be 12.5GHz, I agree that we have to wait any ITU feedback.
> On the other hand I don't see any constraint of Spectrum Width
> Size in G.694.1.  So there is no specification/limitation to m value.
> 
> In this sense I'd agree with Ramon: why not extend it.
> 
> Best Regards,
> 
> Gabriele
> 
> 
> 
> Gabriele Galimberti
> Technical Leader
> Cisco Photonics Srl
> 
> 
> Via Philips, 12
> 20900 - Monza (MI)
> Italy
> www.cisco.com/global/IT/ <http://www.cisco.com/global/IT/>
> 
> [email-masked]
> Phone :+39 039 2091462
> Mobile :+39 335 7481947
> Fax :+39 039 2092049
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> On 1/31/14 12:44 PM, "Adrian Farrel" <[email-masked]> wrote:
> 
> >Hi Gabriele,
> >
> >IIRC this topic has come up in various discussions.
> >I think the discussion ran aground when we tried to understand what ITU-T
> >SG15
> >Q6 data plane capabilities this increased value of "m" modelled.
> >
> >I believe that we could easily increase the size of the m field, but as I
> >understand the status of the Q6 work, we would still need to constrain
> >its use
> >as defined in G.694.1. Maybe that is the best compromise: it gives us
> >scope for
> >future expansion, but it makes (for now) the value strictly limited
> >according to
> >the current definition of the data plane we are controlling.
> >
> >Thoughts?
> >Adrian
> >
> >> -----Original Message-----
> >> From: CCAMP [mailto:[email-masked]] On Behalf Of Gabriele Maria
> >> Galimberti (ggalimbe)
> >> Sent: 31 January 2014 10:35
> >> To: Daniel King; 'CCAMP'
> >> Subject: Re: [CCAMP] Generalized Labels for the Flexi-Grid in LSC Label
> >Switching
> >> Routers
> >>
> >> Hi Daniel
> >>
> >> I have a change request on the label:
> >>
> >> 0                   1                   2                   3
> >>     0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0  1 2 3 4 5 6 7 8 9 0 1
> >>    +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
> >>    |Grid | C.S.  |    Identifier      |               n                |
> >>    +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
> >>    |       m     |                     Reserved                    |
> >>    +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
> >>
> >>
> >> I'd like to extend the m value range to 16 bits to have the possibility
> >>to
> >> Allocate the whole C-band spectrum if needed.
> >> With 8 bits we can allocate only 60% of it.
> >> Another reason is that when new technologies will be available the
> >> Slot Width Granularity may increase (to 6.25GHz or better).
> >>
> >> So the proposed change is:
> >>
> >> 0                   1                   2                   3
> >> 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0  1 2 3 4 5 6 7 8 9 0 1
> >> +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
> >> |Grid | C.S. |    Identifier    |                n              |
> >> +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
> >> |                m              |            Reserved           |
> >> +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
> >>
> >>
> >>  m field = 16 bits.
> >>
> >>
> >> Best Regards,
> >>
> >> Gabriele
> >>
> >>
> >>
> >> Gabriele Galimberti
> >> Technical Leader
> >> Cisco Photonics Srl
> >>
> >>
> >> Via Philips, 12
> >> 20900 - Monza (MI)
> >> Italy
> >> www.cisco.com/global/IT/ <http://www.cisco.com/global/IT/>
> >>
> >> [email-masked]
> >> Phone :+39 039 2091462
> >> Mobile :+39 335 7481947
> >> Fax :+39 039 2092049
> >>
> >>
> >>
> >>
> >>
> >>
> >>
> >>
> >>
> >>
> >>
> >>
> >>
> >>
> >>
> >>
> >> On 1/29/14 6:06 PM, "Daniel King" <[email-masked]> wrote:
> >>
> >> >Hi CCAMP'rs,
> >> >
> >> >The authors are planning a revision of this I-D before London, but the
> >> >only
> >> >changes will be the addition of an Implementation Status section as per
> >> >RFC6982.
> >> >
> >> >It seems to us that this I-D is stable and that there are no further
> >> >technical issues. The label format documented in the I-D has been
> >>picked
> >> >up
> >> >by the RSVP-TE extensions draft and the ongoing OSPF work.
> >> >
> >> >We would like to take this opportunity to solicit feedback from the
> >> >working
> >> >group:
> >> >
> >> >- Are there any changes you would like to see in the draft?
> >> >- Are you happy with the label format described?
> >> >- What do you think the next steps should be for this draft?
> >> >
> >> >Thanks,
> >> >Dan (for the authors)
> >> >
> >> >
> >> >_______________________________________________
> >> >CCAMP mailing list
> >> >[email-masked]
> >> >https://www.ietf.org/mailman/listinfo/ccamp
> >>
> >> _______________________________________________
> >> CCAMP mailing list
> >> [email-masked]
> >> https://www.ietf.org/mailman/listinfo/ccamp
> >
> 
> _______________________________________________
> CCAMP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ccamp

---

From: "Adrian Farrel" <[email-masked]>
Date: Wed, 5 Feb 2014 22:40:08 -0000

Hi,

This seems like future-proofing for the sake of future proofing.

I think that the proposed CS value gives us 6.25 (recall, we already had 12.5).

If 3.125 or some "odd" value like 17.937 becomes a requirement in the future we
could define a new CS value to mean "CS is encoded in bytes 6 and 7 of the
label" and then utilise the two currently reserved bytes. That is how we might
do it, but I would be less than enthusiastic about making this provision now on
the theory that we might need it one day.

Cheers,
Adrian

> From: Jonas Mårtensson [mailto:[email-masked]]
> Sent: 05 February 2014 09:18
> To: Gabriele Maria Galimberti (ggalimbe); [email-masked]; 'Daniel King';
> 'CCAMP'
> Subject: RE: [CCAMP] Generalized Labels for the Flexi-Grid in LSC Label
Switching
> Routers
> 
> Hi all,
> 
> I don't know if this has been proposed and discussed already but why not also
> add a field indicating slot width granularity (similar to the C.S. field)
where today
> the only defined value would correspond to 12.5 GHz. This would accommodate a
> potentially finer granularity in the future (when technologies improve as
Gabriele
> points out).

---

From: Jonas Mårtensson <[email-masked]>
Date: Thu, 6 Feb 2014 08:37:22 +0000

Hi Adrian,

I'm not talking about defining new CS values. I'm proposing adding a separate SWG (slot width granularity) field to allow for granularities finer than 12.5 GHz in the future. Maybe this is unnecessarily future-proof and we can deal with it if/when it becomes necessary. Just wanted to bring it up for discussion.

Cheers,
Jonas

> From: Adrian Farrel [mailto:[email-masked]]
> Sent: den 5 februari 2014 23:40
> To: Jonas Mårtensson; 'Gabriele Maria Galimberti (ggalimbe)'; 'Daniel King';
> 'CCAMP'

---

From: "Adrian Farrel" <[email-masked]>
Date: Thu, 6 Feb 2014 10:57:40 -0000

Ah yes, apologies. Ramon has just explained this to me. sorry for being thick.

You are talking about the thing that "m" multiplies for the slot width.
Currently 12.5.

I can see the potential, but (of course) we are again talking about
future-proofing in a rather speculative way.
Where do we stand with data plane specs and implementations of this hardware?

A

> Sent: 06 February 2014 08:37
> To: [email-masked]; 'Gabriele Maria Galimberti (ggalimbe)'; 'Daniel
King';
Switching
> Routers
> 
> Hi Adrian,
> 
> I'm not talking about defining new CS values. I'm proposing adding a separate
> SWG (slot width granularity) field to allow for granularities finer than 12.5
GHz in
> the future. Maybe this is unnecessarily future-proof and we can deal with it
> if/when it becomes necessary. Just wanted to bring it up for discussion.
> 
> Cheers,
> Jonas
> 
> > > the only defined value would correspond to 12.5 GHz. This would
> accommodate
> > a
> > > > >I think the discussion ran aground when we tried to understand what
ITU-
> T

---

From: "Gabriele Maria Galimberti (ggalimbe)" <[email-masked]>
Date: Fri, 7 Feb 2014 14:38:17 +0000

AFSIK there are a couple of Optical Module Vendors that can provide finer
granularity (up to 1GHz).
The module are not yet in mass production but working in Lab.

Best Regards, 

Gabriele

Gabriele Galimberti
Technical Leader
Cisco Photonics Srl

Via Philips, 12
20900 - Monza (MI)
Italy

[email-masked]
Phone :+39 039 2091462
Mobile :+39 335 7481947
Fax :+39 039 2092049

On 2/6/14 11:57 AM, "Adrian Farrel" <[email-masked]> wrote:

>> > I think that the proposed CS value gives us 6.25 (recall, we already
>>had
>> > 12.5).
>> >
>> > If 3.125 or some "odd" value like 17.937 becomes a requirement in the
>>future
>> > we
>> > label" and then utilise the two currently reserved bytes. That is how
>>we
>might
>> > do it, but I would be less than enthusiastic about making this
>>provision now
>> > on
>> > > To: Gabriele Maria Galimberti (ggalimbe); [email-masked];
>>'Daniel
>> > King';
>> > > 'CCAMP'
>> > > I don't know if this has been proposed and discussed already but
>>why not
>> > also
>> > > > >I believe that we could easily increase the size of the m field,
>>but as
>I
>> > > > >> From: CCAMP [mailto:[email-masked]] On Behalf Of
>>Gabriele
>> > > Maria
>> > > > >> Galimberti (ggalimbe)
>> > > > >> Subject: Re: [CCAMP] Generalized Labels for the Flexi-Grid in
>>LSC
>Label
>> > > > >Switching
>> > > > >> Routers
>> > > > >>
>> > > > >> Hi Daniel
>> > > > >>
>> > > > >>    |       m     |                     Reserved
>>    |
>> > > > >> |                m              |            Reserved
>> |
>> > > > >> >The authors are planning a revision of this I-D before
>>London, but
>the
>> > > > >> >only
>> > > > >> >changes will be the addition of an Implementation Status
>>section as
>> > per
>> > > > >> >RFC6982.
>> > > > >> >

---

From: "Zhangxian (Xian)" <[email-masked]>
Date: Sat, 8 Feb 2014 07:15:23 +0000

Hi, Jonas, 

  In the label object, we already have a field name CS value. According to ITU G.694.1, SWG is 2 times CS value ( currently CS=6.25GHz). So if I understand correctly, these two values are related. So unless we expect a change/update supported by the device in the near future, not sure whether such a field is needed.

Cheers,
Xian

-----Original Message-----
From: CCAMP [mailto:[email-masked]] On Behalf Of Jonas M?rtensson
Sent: 2014年2月6日 16:37
To: [email-masked]; 'Gabriele Maria Galimberti (ggalimbe)'; 'Daniel King'; 'CCAMP'
Subject: Re: [CCAMP] Generalized Labels for the Flexi-Grid in LSC Label Switching Routers

Hi Adrian,

Cheers,
Jonas