Subject: [CCAMP] FW: New Version Notification for draft-farrel-interconnected-te-info-exchange-03.txt

From: "Adrian Farrel" <[email-masked]>
Date: Fri, 14 Feb 2014 23:15:01 -0000

All,

We continue to update this I-D to fill in the gaps.

In this case there are a couple more "applicability statements" showing how the architecture fits deployment models and the use cases in the problem statement part of the draft.

We remain interested in your review and comments.

Thanks,
Adrian

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: 14 February 2014 22:58
> To: Daniele Ceccarelli; George Swallow; George Swallow; Adrian Farrel; Nabil
> Bitar; John Drake; Daniele Ceccarelli; Adrian Farrel; John Drake; Dr. Nabil N. Bitar
> Subject: New Version Notification for draft-farrel-interconnected-te-info-
> exchange-03.txt
> 
> 
> A new version of I-D, draft-farrel-interconnected-te-info-exchange-03.txt
> has been successfully submitted by Adrian Farrel and posted to the
> IETF repository.
> 
> Name:		draft-farrel-interconnected-te-info-exchange
> Revision:	03
> Title:		Problem Statement and Architecture for Information Exchange
> Between Interconnected Traffic Engineered Networks
> Document date:	2014-02-14
> Group:		Individual Submission
> Pages:		49
> URL:            http://www.ietf.org/internet-drafts/draft-farrel-interconnected-te-
> info-exchange-03.txt
> Status:         https://datatracker.ietf.org/doc/draft-farrel-interconnected-te-info-
> exchange/
> Htmlized:       http://tools.ietf.org/html/draft-farrel-interconnected-te-info-
> exchange-03
> Diff:           http://www.ietf.org/rfcdiff?url2=draft-farrel-interconnected-te-info-
> exchange-03
> 
> Abstract:
>    In Traffic Engineered (TE) systems, it is sometimes desirable to
>    establish an end-to-end TE path with a set of constraints (such as
>    bandwidth) across one or more network from a source to a destination.
>    TE information is the data relating to nodes and TE links that is
>    used in the process of selecting a TE path.  The availability of TE
>    information is usually limited to within a network (such as an IGP
>    area) often referred to as a domain.
> 
>    In order to determine the potential to establish a TE path through a
>    series of connected networks, it is necessary to have available a
>    certain amount of TE information about each network.  This need not
>    be the full set of TE information available within each network, but
>    does need to express the potential of providing TE connectivity. This
>    subset of TE information is called TE reachability information.
> 
>    This document sets out the problem statement and architecture for the
>    exchange of TE information between interconnected TE networks in
>    support of end-to-end TE path establishment.  For reasons that are
>    explained in the document, this work is limited to simple TE
>    constraints and information that determine TE reachability.
> 
> 
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat

---

From: Khuzema Pithewan <[email-masked]>
Date: Thu, 20 Feb 2014 01:11:32 +0000

Hi Adrian,

This draft lists all the possible (PCE, VNTM, L1VPN) mechanisms dealing with e-2-e path computation in multi-layer/multi-domain network configuration. It is a good thorough document that has everything that could be related to e-2-e te-path computation for multi-layer network.

We have 2 questions :

1. Since the document is marked as "Standard Track", does it mean that if it becomes RFC, the compliancy to this document will require supporting all the mechanisms?

2. Since this document is a summary of multiple mechanisms, should this be an "Informational draft", or are we missing something here that requires standardization?

Thanks
Khuzema, Rajan, Snigdho

-----Original Message-----
From: CCAMP [mailto:[email-masked]] On Behalf Of Adrian Farrel
Sent: Friday, February 14, 2014 3:15 PM
To: 'CCAMP'
Subject: [CCAMP] FW: New Version Notification for draft-farrel-interconnected-te-info-exchange-03.txt

All,

Thanks,
Adrian

> To: Daniele Ceccarelli; George Swallow; George Swallow; Adrian Farrel; 
> Nabil Bitar; John Drake; Daniele Ceccarelli; Adrian Farrel; John 
> Drake; Dr. Nabil N. Bitar
> A new version of I-D, 
> draft-farrel-interconnected-te-info-exchange-03.txt
> Please note that it may take a couple of minutes from the time of 
> submission until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat

_______________________________________________
CCAMP mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ccamp

---

From: John E Drake <[email-masked]>
Date: Thu, 20 Feb 2014 14:03:44 +0000

Khuzema,

Comments inline.

Yours Irrespectively,

John

> From: CCAMP [mailto:[email-masked]] On Behalf Of Khuzema
> Pithewan
> Sent: Wednesday, February 19, 2014 5:12 PM
> To: [email-masked]; 'CCAMP'
> Subject: Re: [CCAMP] FW: New Version Notification for draft-farrel-
> interconnected-te-info-exchange-03.txt
> 
> Hi Adrian,
> 
> This draft lists all the possible (PCE, VNTM, L1VPN) mechanisms dealing with
> e-2-e path computation in multi-layer/multi-domain network configuration. It is
> a good thorough document that has everything that could be related to e-2-e
> te-path computation for multi-layer network.
> 
> We have 2 questions :
> 
> 1. Since the document is marked as "Standard Track", does it mean that if it
> becomes RFC, the compliancy to this document will require supporting all the
> mechanisms?

[JD]   When we were planning this draft we thought we would be adding sections describing the necessary protocol extensions.  However, we have since decided that the protocol extensions will go into a separate draft so making this draft Informational is fine.

> 
> 2. Since this document is a summary of multiple mechanisms, should this be an
> "Informational draft", or are we missing something here that requires
> standardization?

[JD]  See above. 

> In this case there are a couple more "applicability statements" showing how
> the architecture fits deployment models and the use cases in the problem
> statement part of the draft.
>

---

From: Khuzema Pithewan <[email-masked]>
Date: Thu, 20 Feb 2014 16:33:21 +0000

Great.

Thanks!
Khuzema

-----Original Message-----
From: John E Drake [mailto:[email-masked]] 
Sent: Thursday, February 20, 2014 6:04 AM
To: Khuzema Pithewan; [email-masked]; 'CCAMP'
Subject: RE: [CCAMP] FW: New Version Notification for draft-farrel-interconnected-te-info-exchange-03.txt

Khuzema,

Comments inline.

Yours Irrespectively,

John

> This draft lists all the possible (PCE, VNTM, L1VPN) mechanisms 
> dealing with e-2-e path computation in multi-layer/multi-domain 
> network configuration. It is a good thorough document that has 
> everything that could be related to e-2-e te-path computation for multi-layer network.
> 
> We have 2 questions :
> 
> 1. Since the document is marked as "Standard Track", does it mean that 
> if it becomes RFC, the compliancy to this document will require 
> supporting all the mechanisms?

> 
> 2. Since this document is a summary of multiple mechanisms, should 
> this be an "Informational draft", or are we missing something here 
> that requires standardization?

[JD]  See above. 

> In this case there are a couple more "applicability statements" 
> showing how the architecture fits deployment models and the use cases 
> in the problem statement part of the draft.
> 
> > To: Daniele Ceccarelli; George Swallow; George Swallow; Adrian 
> > Farrel; Nabil Bitar; John Drake; Daniele Ceccarelli; Adrian Farrel; 
> > John Drake; Dr. Nabil N. Bitar

---

From: John E Drake <[email-masked]>
Date: Thu, 20 Feb 2014 18:52:09 +0000

Khuzema,

You're welcome.

Yours Irrespectively,

John

> From: Khuzema Pithewan [mailto:[email-masked]]
> Sent: Thursday, February 20, 2014 8:33 AM
> To: John E Drake; [email-masked]; 'CCAMP'
> [JD]   When we were planning this draft we thought we would be adding
> sections describing the necessary protocol extensions.  However, we have
> since decided that the protocol extensions will go into a separate draft so
> making this draft Informational is fine.
> 
> >
> > > URL:            http://www.ietf.org/internet-drafts/draft-farrel-
> interconnected-
> > te-
> > > info-exchange-03.txt
> > > Status:         https://datatracker.ietf.org/doc/draft-farrel-interconnected-
> te-
> > info-
> > > exchange/