Subject: Re: [CCAMP] Fwd: Request for early IANA Allocation of values for new flag and RRO sub-object in draft-ietf-ccamp-rsvp-te-srlg-collect-05

From: Lou Berger <[email-masked]>
Date: Tue, 09 Sep 2014 16:15:03 -0400

Oscar,
    The draft looks good (Although it would have been best to mention
why there is a suggested value.)

Thanks,
Lou

On 8/26/2014 3:31 PM, OSCAR GONZALEZ DE DIOS wrote:
> Dear Lou, Deborah, Adrian,
>
>    We have submitted a new version of
> draft-ietf-ccamp-rsvp-te-srlg-collect with the IANA Section modified
> according to your comments.
>
>    Can you check if the text in the IANA Section is clear enough now to
> move forward with the early allocation?
>
>         Best Regards,
>
>                 Óscar
>
> El 25/08/14 20:31, "Adrian Farrel" <[email-masked]> escribió:
>
>> Sorry that I was silent on this (it found its way into my CCAMP folder).
>>
>> Yes, I support this request, but please know that IANA process the
>> request not according to the content of your email but based on the text
>> in the IANA Considerations section of the most recent revision of the
>> draft. So that needs to exactly what you want it to say.
>>
>> Cheers,
>> Adrian
>>
>>> -----Original Message-----
>>> From: CCAMP [mailto:[email-masked]] On Behalf Of Lou Berger
>>> Sent: 22 July 2014 23:18
>>> To: [email-masked]
>>> Cc: CCAMP
>>> Subject: [CCAMP] Fwd: Request for early IANA Allocation of values for
>>> new flag
>>> and RRO sub-object in draft-ietf-ccamp-rsvp-te-srlg-collect-05
>>>
>>>
>>> Adrian,
>>> The WG chairs support the following early allocation request:
>>>
>>> 1) In the "Attributes TLV Space" section of the "Resource Reservation
>>> Protocol-Traffic Engineering (RSVP-TE) Parameters" registry located in
>>> https://www.iana.org/assignments/rsvp-te-
>>> <https://www.iana.org/assignments/rsvp-te-parameters/rsvp-te-
>>> parameters.xhtml>
>>> parameters/rsvp-te-parameters.xhtml
>>> <https://www.iana.org/assignments/rsvp-te-parameters/rsvp-te-
>>> parameters.xhtml>:
>>>
>>> Type (value to be assigned)
>>> Name SRLG Collection Flag
>>> Allowed on LSP_ATTRIBUTES yes
>>> Allowed on LSP_REQUIRED_ATTRIBUTES yes
>>>
>>> 2) In the Sub-object type ‒ 21 ROUTE_RECORD portion of the Resource
>>> Reservation Protocol (RSVP) Parameters registry located at
>>> http://www.iana.org/assignments/rsvp-parameters/rsvp-parameters.xhtml:
>>> Value: (value to be assigned) 34 is suggested to align with ERO
>>> Description: SRLG sub-object
>>>
>>> 3) In the "Error Codes and Globally-Defined Error Value Sub-Codes,
>>> Sub-Codes ‒ 2 Policy Control Failure" section of the "RSVP PARAMETERS"
>>> registry located at http://www.iana.org/assignments/rsvp-parameters.
>>> Value: (value to be assigned)
>>> Description: SRLG sub-object
>>>
>>> Do you approve this request -- so that we can submit the request (per
>>> stpe 5 of RFC7120)?
>>>
>>> Thank you,
>>> Lou (and Deborah)
>>>
>>>
>>> -------- Original Message --------
>>> Subject:     Request for early IANA Allocation of values for new flag and
>>> RRO sub-object in draft-ietf-ccamp-rsvp-te-srlg-collect-05
>>> Date:        Tue, 22 Jul 2014 15:19:35 +0000
>>> From:        OSCAR GONZALEZ DE DIOS <[email-masked]>
>>> To:  Lou Berger <[email-masked]>, DEBORAH A BRUNGARD
>>> <[email-masked]>
>>> CC:  CCAMP <[email-masked]>
>>>
>>>
>>>
>>> Dear CCAMP WG Chairs,
>>>
>>> Following the procedure for Early IANA Allocation of Standards Track
>>> Code Points defined in Section 3.1 of RFC 7120, on behalf of the authors
>>> of the WG draft "RSVP-TE Extensions for Collecting SRLG Information",
>>> draft-ietf-ccamp-rsvp-te-srlg-collect-05, it is requested to CCAMP WG
>>> chairs the early allocation of the following values:
>>>
>>> --> Value for a new flag, named "SRLG Collection Flag" in the RSVP
>>> Attribute Bit Flags space. IANA has created a registry and manages the
>>> space of attributes bit flags of Attribute Flags TLV, as described in
>>> section 11.3 of [RFC5420], in the "Attributes TLV Space" section of the
>>> "Resource Reservation Protocol-Traffic Engineering (RSVP-TE) Parameters"
>>> registry located in
>>> https://www.iana.org/assignments/rsvp-te-parameters/rsvp-te-
>>> parameters.xhtml.
>>> The document "RSVP-TE Extensions for Collecting SRLG
>>> Information",draft-ietf-ccamp-rsvp-te-srlg-collect-05, introduces and
>>> defines a new Attribute Bit Flag, named "SRLG Collection Flag". It is
>>> requested that IANA makes an early assignment of the value of the "SRLG
>>> Collection Flag" from the Attribute Bit Flags.
>>>
>>> --> Type for a new RRO sub-object, named "SRLG sub-object " within the
>>> ROUTE_RECORD Object space. IANA has made assignments in the "Class
>>> Names, Class Numbers, and Class Types" section of the "RSVP PARAMETERS"
>>> registry located at http://www.iana.org/assignments/rsvp-parameters. It
>>> is requested that IANA makes an early assignment of the type of the new
>>> proposed RRO sub object in the document
>>> draft-ietf-ccamp-rsvp-te-srlg-collect-05 named "SRLG sub-object" from
>>> the ROUTE_RECORD portions of the mentioned registry.
>>>
>>> —> Value for a new Policy Control Failure Error sub code. IANA has made
>>> assignments in the "Error Codes and Globally-Defined Error Value
>>> Sub-Codes" section of the "RSVP
>>> PARAMETERS" registry located at
>>> http://www.iana.org/assignments/rsvp-parameters. We request that IANA
>>> makes an early assignment of a new error sub-code from the Policy
>>> Control Failure Sub-Codes registry.
>>>
>>> The main reason for the request of the early allocation is to facilitate
>>> interoperability of early implementations, as other WG documents have
>>> also new values in the same registry and clashes have been identified
>>> with the suggested values in the draft.
>>>
>>> Best Regards,
>>>
>>> Oscar
>>>
>>>
>>>
>>> ------------------------------------------------------------------------
>>>
>>> Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario,
>>> puede contener información privilegiada o confidencial y es para uso
>>> exclusivo de la persona o entidad de destino. Si no es usted. el
>>> destinatario indicado, queda notificado de que la lectura, utilización,
>>> divulgación y/o copia sin autorización puede estar prohibida en virtud
>>> de la legislación vigente. Si ha recibido este mensaje por error, le
>>> rogamos que nos lo comunique inmediatamente por esta misma vía y proceda
>>> a su destrucción.
>>>
>>> The information contained in this transmission is privileged and
>>> confidential information intended only for the use of the individual or
>>> entity named above. If the reader of this message is not the intended
>>> recipient, you are hereby notified that any dissemination, distribution
>>> or copying of this communication is strictly prohibited. If you have
>>> received this transmission in error, do not read it. Please immediately
>>> reply to the sender that you have received this communication in error
>>> and then delete it.
>>>
>>> Esta mensagem e seus anexos se dirigem exclusivamente ao seu
>>> destinatário, pode conter informação privilegiada ou confidencial e é
>>> para uso exclusivo da pessoa ou entidade de destino. Se não é vossa
>>> senhoria o destinatário indicado, fica notificado de que a leitura,
>>> utilização, divulgação e/ou cópia sem autorização pode estar proibida em
>>> virtude da legislação vigente. Se recebeu esta mensagem por erro,
>>> rogamos-lhe que nos o comunique imediatamente por esta mesma via e
>>> proceda a sua destruição
>>>
>>>
>>> _______________________________________________
>>> CCAMP mailing list
>>> [email-masked]
>>> https://www.ietf.org/mailman/listinfo/ccamp
>> _______________________________________________
>> CCAMP mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/ccamp
>
> ________________________________
>
> Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.
>
> The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.
>
> Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição

---

From: OSCAR GONZALEZ DE DIOS <[email-masked]>
Date: Tue, 9 Sep 2014 22:17:20 +0000

Hi Lou,

   I just saw you mentioned the reason of the suggested value in your mail
to IANA, thanks!

   Regarding the content of the draft itself, we would like to send a
version with an example of an use case provided by Dieter and fixing
editorial issues in a review made by Dhurv. Would it be OK to send it soon
or should we wait until early allocation is done? We believe that with
those changes the document should be ready for the Last Call.

   Best Regards,

        Óscar

El 09/09/14 22:15, "Lou Berger" <[email-masked]> escribió:

>>>>It
>> Este mensaje y sus adjuntos se dirigen exclusivamente a su
>>destinatario, puede contener información privilegiada o confidencial y
>>es para uso exclusivo de la persona o entidad de destino. Si no es
>>usted. el destinatario indicado, queda notificado de que la lectura,
>>utilización, divulgación y/o copia sin autorización puede estar
>>prohibida en virtud de la legislación vigente. Si ha recibido este
>>mensaje por error, le rogamos que nos lo comunique inmediatamente por
>>esta misma vía y proceda a su destrucción.
>>

---

From: Lou Berger <[email-masked]>
Date: Tue, 09 Sep 2014 18:23:18 -0400

On 09/09/2014 06:17 PM, OSCAR GONZALEZ DE DIOS wrote:
>  Would it be OK to send it soon

Sure!

Thanks,
Lou