Subject: Re: [CCAMP] [Technical Errata Reported] RFC7260 (4106)

From: "Adrian Farrel" <[email-masked]>
Date: Fri, 5 Dec 2014 15:49:02 -0000

Hi Greg,
 
I'm returning to this after an indecent interval.
 
I checked with IANA and they are OK that we can make this sort of change with an
Errata Report and they are happy.
 
So now we have to agree what it should say.
 
There is an error in your suggested change, I think because in the first table
you show 65533 as IETF review, and in the second as reserved for
experimentation.
 
I am keen to make only the minimal changes to fix the obvious bugs. Therefore I
think there is no need to reserve 65535 and it can remain as an experimental
value.
 
That leaves us with...
 
    IANA has created the "OAM Sub-TLVs" sub-registry of the "RSVP-TE OAM
    Configuration Registry" as follows:
    Range       | Note                         | Registration Procedures
    ------------+------------------------------|------------------------
    0-31        | Generic Sub-TLVs             | IETF Review
   32-65533    | Technology-specific Sub-TLVs | IETF Review
    65534-65535 | Experimental Sub-TLVs        | Reserved for
                                               |   Experimental Use
    IANA has populated the registry as follows:
       Sub-TLV Type | Description                   | Reference
       -------------+-------------------------------+----------
           0        | Reserved                      | [RFC7260]
           1        | OAM Function Flags Sub-TLV    | [RFC7260]
           2-65533  | Unassigned                    |
       65534-65535  | Reserved for Experimental Use | [RFC7260]
 
Is everyone OK with that change?
 
Thanks,
Adrian

---

From: Attila Takacs <[email-masked]>
Date: Fri, 5 Dec 2014 19:49:13 +0000

Hi Adrian,
Yes, I think we should do the simple fix as you have suggested.
Thanks,
Attila
From: Adrian Farrel <[email-masked]<mailto:[email-masked]>>
Reply-To: Adrian Farrel <[email-masked]<mailto:[email-masked]>>
Date: Friday, December 5, 2014 at 7:49 AM
To: Gregory Mirsky <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Ericsson <[email-masked]<mailto:[email-masked]>>, Don Fedyk <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Berger Lou <[email-masked]<mailto:[email-masked]>>, Deborah Brungard <[email-masked]<mailto:[email-masked]>>
Subject: RE: [Technical Errata Reported] RFC7260 (4106)

Hi Greg,

I checked with IANA and they are OK that we can make this sort of change with an Errata Report and they are happy.

There is an error in your suggested change, I think because in the first table you show 65533 as IETF review, and in the second as reserved for experimentation.

I am keen to make only the minimal changes to fix the obvious bugs. Therefore I think there is no need to reserve 65535 and it can remain as an experimental value.

That leaves us with...

                                               |   Experimental Use

           0        | Reserved                      | [RFC7260]

           2-65533  | Unassigned                    |

Thanks,

Adrian

---

From: Gregory Mirsky <[email-masked]>
Date: Sun, 7 Dec 2014 01:22:21 +0000

Hi Adrian,
thank you for your suggestions. My motivation to make all-1s reserved was to have symmetry with already reserved all-0s value. If authors of the RFC believe it is unnecessary then I'm more than happy with the proposed resolution.

                Regards,
                                Greg

From: Adrian Farrel [mailto:[email-masked]]
Sent: Friday, December 05, 2014 11:49 PM
To: Gregory Mirsky
Cc: [email-masked]; [email-masked]; Attila Takacs; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: RE: [Technical Errata Reported] RFC7260 (4106)

Hi Greg,

That leaves us with...

                                               |   Experimental Use

           0        | Reserved                      | [RFC7260]

           2-65533  | Unassigned                    |

Thanks,

Adrian

---

From: "Adrian Farrel" <[email-masked]>
Date: Sun, 7 Dec 2014 13:20:03 -0000

Thanks Greg,
 
I think we could reserve all-1s. But that would need an RFC not an Errata
Report.
The point of the report is to fix the text is accidentally different from what
the authors intended.
 
Cheers,
Adrian
 
From: Gregory Mirsky [mailto:[email-masked]] 
Sent: 07 December 2014 01:22
To: [email-masked]
Cc: [email-masked]; [email-masked]; Attila Takacs; [email-masked];
[email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: RE: [Technical Errata Reported] RFC7260 (4106)
 
Hi Adrian,
thank you for your suggestions. My motivation to make all-1s reserved was to
have symmetry with already reserved all-0s value. If authors of the RFC believe
it is unnecessary then I'm more than happy with the proposed resolution.
 
                Regards,
                                Greg
 
From: Adrian Farrel [mailto:[email-masked]] 
Sent: Friday, December 05, 2014 11:49 PM
To: Gregory Mirsky
Cc: [email-masked]; [email-masked]; Attila Takacs; [email-masked];
[email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: RE: [Technical Errata Reported] RFC7260 (4106)
 
Hi Greg,

 

 
That leaves us with...

 

 
Thanks,
Adrian

---

From: Gregory Mirsky <[email-masked]>
Date: Sun, 7 Dec 2014 13:49:10 +0000

Hi Adrian,
I agree with the resolution you've proposed.
Please let me know if I need to make changes to the Errata or it can be resolved based on your proposal.

                Regards,
                                Greg

From: Adrian Farrel [mailto:[email-masked]]
Sent: Sunday, December 07, 2014 9:20 PM
To: Gregory Mirsky
Cc: [email-masked]; [email-masked]; Attila Takacs; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: RE: [Technical Errata Reported] RFC7260 (4106)

Thanks Greg,

I think we could reserve all-1s. But that would need an RFC not an Errata Report.
The point of the report is to fix the text is accidentally different from what the authors intended.

Cheers,
Adrian

From: Gregory Mirsky [mailto:[email-masked]]
Sent: 07 December 2014 01:22
To: [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; Attila Takacs; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: RE: [Technical Errata Reported] RFC7260 (4106)

Hi Adrian,

                Regards,
                                Greg

From: Adrian Farrel [mailto:[email-masked]]
Sent: Friday, December 05, 2014 11:49 PM
To: Gregory Mirsky
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; Attila Takacs; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: RE: [Technical Errata Reported] RFC7260 (4106)

Hi Greg,

That leaves us with...

                                               |   Experimental Use

           0        | Reserved                      | [RFC7260]

           2-65533  | Unassigned                    |

Thanks,

Adrian

---

From: "Adrian Farrel" <[email-masked]>
Date: Sun, 7 Dec 2014 14:11:31 -0000

Nope, that's OK. I'll handle it.
 
Cheers,
Adrian
 
Sent: 07 December 2014 13:49
 
Hi Adrian,
I agree with the resolution you've proposed.
Please let me know if I need to make changes to the Errata or it can be resolved
based on your proposal.
 
                Regards,
                                Greg

Thanks Greg,

Cheers,
Adrian

Hi Adrian,
 
                Regards,
                                Greg

Hi Greg,

 

 
That leaves us with...

 

 
Thanks,
Adrian

---

From: "Hejia (Jia)" <[email-masked]>
Date: Mon, 8 Dec 2014 07:30:21 +0000

Adrian,

I'm OK with your proposal.

B.R.
Jia

From: Adrian Farrel [mailto:[email-masked]]
Sent: Friday, December 05, 2014 11:49 PM
To: [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]; Hejia (Jia); [email-masked]; [email-masked]; [email-masked]
Subject: RE: [Technical Errata Reported] RFC7260 (4106)

Hi Greg,

That leaves us with...

                                               |   Experimental Use

           0        | Reserved                      | [RFC7260]

           2-65533  | Unassigned                    |

Thanks,

Adrian