Subject: [CCAMP] IANA action consequent to RFC7260 (4106)

From: "Adrian Farrel" <[email-masked]>
Date: Sun, 7 Dec 2014 14:30:56 -0000

Hi IANA,

Could you please make the updates to
https://www.iana.org/assignments/rsvp-te-oam/rsvp-te-oam.xhtml#oam-sub-tlvs as
described in Errata Report 4106.

Many thanks,
Adrian

> -----Original Message-----
> From: RFC Errata System [mailto:[email-masked]]
> Sent: 07 December 2014 14:22
> To: [email-masked]; [email-masked];
> [email-masked]; [email-masked]
> Cc: [email-masked]; [email-masked]; [email-masked]; rfc-editor@rfc-
> editor.org
> Subject: [Errata Verified] RFC7260 (4106)
> 
> The following errata report has been verified for RFC7260,
> "GMPLS RSVP-TE Extensions for Operations, Administration, and Maintenance
> (OAM) Configuration".
> 
> --------------------------------------
> You may review the report below and at:
> http://www.rfc-editor.org/errata_search.php?rfc=7260&eid=4106
> 
> --------------------------------------
> Status: Verified
> Type: Technical
> 
> Reported by: Gregory Mirsky <[email-masked]>
> Date Reported: 2014-09-08
> Verified by: Adrian Farrel (IESG)
> 
> Section: 5.5.2
> 
> Original Text
> -------------
>    IANA has created the "OAM Sub-TLVs" sub-registry of the "RSVP-TE OAM
>    Configuration Registry" as follows:
> 
>    Range       | Note                         | Registration Procedures
>    ------------+------------------------------|------------------------
>    0-31        | Generic Sub-TLVs             | IETF Review
>    32-65534    | Technology-specific Sub-TLVs | IETF Review
>    65535-65536 | Experimental Sub-TLVs        | Reserved for
>                |                              |   Experimental Use
> 
>    IANA has populated the registry as follows:
> 
>       Sub-TLV Type | Description                   | Reference
>       -------------+-------------------------------+----------
>           0        | Reserved                      | [RFC7260]
>           1        | OAM Function Flags Sub-TLV    | [RFC7260]
>           2-65534  | Unassigned                    |
>       65535-65536  | Reserved for Experimental Use | [RFC7260]
> 
> 
> 
> Corrected Text
> --------------
>     IANA has created the "OAM Sub-TLVs" sub-registry of the "RSVP-TE OAM
>     Configuration Registry" as follows:
> 
>     Range       | Note                         | Registration Procedures
>     ------------+------------------------------|------------------------
>     0-31        | Generic Sub-TLVs             | IETF Review
>     32-65533    | Technology-specific Sub-TLVs | IETF Review
>     65534-65535 | Experimental Sub-TLVs        | Reserved for
>                 |                              |   Experimental Use
> 
>     IANA has populated the registry as follows:
> 
>        Sub-TLV Type | Description                   | Reference
>        -------------+-------------------------------+----------
>            0        | Reserved                      | [RFC7260]
>            1        | OAM Function Flags Sub-TLV    | [RFC7260]
>            2-65533  | Unassigned                    |
>        65534-65535  | Reserved for Experimental Use | [RFC7260]
> 
> 
> Notes
> -----
> Because the Type field is two octets long the value 65536 is unrealizable.
> Nevertheless, it was the intention of the working group to assign to values as
> experimental.
> 
> --------------------------------------
> RFC7260 (draft-ietf-ccamp-oam-configuration-fwk-13)
> --------------------------------------
> Title               : GMPLS RSVP-TE Extensions for Operations, Administration,
and
> Maintenance (OAM) Configuration
> Publication Date    : June 2014
> Author(s)           : A. Takacs, D. Fedyk, J. He
> Category            : PROPOSED STANDARD
> Source              : Common Control and Measurement Plane
> Area                : Routing
> Stream              : IETF
> Verifying Party     : IESG

---

From: "Adrian Farrel" <[email-masked]>
Date: Tue, 9 Dec 2014 19:20:38 -0000

FYI, IANA has completed actions on this Errata Report.

Adrian

> From: Amanda Baber via RT [mailto:[email-masked]]
> Sent: 09 December 2014 19:00
> To: [email-masked]; [email-masked]; ccamp-
> [email-masked]; [email-masked]; [email-masked];
> [email-masked]
> Subject: [IANA #797657] IANA action consequent to RFC7260 (4106)
> 
> Hi,
> 
> The registry now reads as follows:
> 
> OAM Sub-TLVs
> Reference: [RFC7260][RFC Errata 4106]
> 
> Range 	Registration Procedures 	Note
> 0-31	                IETF Review	Generic Sub-TLVs
> 32-65533 	IETF Review	Technology-specific Sub-TLVs
> 65534-65535	Reserved for Experimental Use	Experimental Sub-TLVs
> 
> Type 	Description 	Reference
> 0	Reserved	[RFC7260]
> 1	OAM Function Flags Sub-TLV	[RFC7260]
> 2-31	 Unassigned
> 32	Ethernet OAM Configuration Sub-TLV	[RFC7369]
> 33-65533 	Unassigned
> 65534-65535	Reserved for Experimental Use	[RFC7260][RFC Errata 4106]
> 
> Please see
> http://www.iana.org/assignments/rsvp-te-oam
> 
> thanks,
> 
> Amanda Baber
> IANA Request Specialist
> ICANN
> 
> On Sun Dec 07 14:33:35 2014, [email-masked] wrote:
> > Hi IANA,
> >