Subject: Re: [CCAMP] Vendor-Specific Application Code in draft-ietf-ccamp-rwa-wson-encode

From: Daniele Ceccarelli <[email-masked]>
Date: Mon, 2 Feb 2015 10:13:37 +0000

Working group,

It seems there is a strong willingness to support Vendor Specific Application Codes (a.k.a Option 2).  

This would require putting the draft on hold till the formal approval of G.874.1 (should be July 2015), but we would like not to stop the draft for so long since a lot of other contents are ready to be progressed. 

Our proposal is to move on with option 3 (i.e. Remove the option to include a Vendor-Specific Application Code field.) and add the support for vendor specific application codes later in a BIS or a small, simple and straightforward draft as soon as G.874.1 is approved. 

Young, authors, please update the draft accordingly and maybe add a note saying that  "future work may add support for vendor-specific AI once the ITU-T has completed its work in that area"

Working group, who would find it impossible to live with this as a compromise approach? If you cannot live with this approach, please explain why.

BR
Daniele & Fatai

> -----Original Message-----
> From: CCAMP [mailto:[email-masked]] On Behalf Of Leeyoung
> Sent: giovedì 29 gennaio 2015 20:11
> To: [email-masked]; 'Varma, Eve L (Eve)'; [email-masked]; 'Lam,
> Hing-Kam (Kam)'; [email-masked]; [email-masked]
> Cc: [email-masked]; [email-masked]; ccamp-
> [email-masked]; [email-masked]
> Subject: Re: [CCAMP] Vendor-Specific Application Code in draft-ietf-ccamp-
> rwa-wson-encode
> 
> Hi Adrian,
> 
> I think you misinterpreted what was said.
> 
> >> Now, what is the purpose of standard FECs and modulations in the AI?
> >> Given several choices each vendor may support in its device, the path
> >> computation would find a matched types for FEC and modulation for a
> given optical path.
> >> This is what is intended when optical signal processing constraints
> >> were proposed as part of path computation constraints in optical
> networks.
> 
> > The case you are making here is for no standard control plane!
> > What is the point of standardising if there is never any interworking?
> > But actually, we know about interworking at the physical layer, and (more
> important) we know about a single, > end-to-end control plane that spans
> multiple vendor devices. It all exists.
> 
> The standard AI allows to match optical processing constraints (including
> FECs and Modulations implied in an AI). This information is advertised that a
> PCE would be able to compute an optical path matching AIs for all the
> devices to dertermine a feasible path. I am talking about this standard
> control plane work. This is what was intended in the draft.
> 
> Regards,
> Young
> 
> -----Original Message-----
> From: Adrian Farrel [mailto:[email-masked]]
> Sent: Thursday, January 29, 2015 7:24 AM
> To: Leeyoung; 'Varma, Eve L (Eve)'; [email-masked]; 'Lam, Hing-Kam
> (Kam)'; [email-masked]; [email-masked]
> Cc: [email-masked]; [email-masked]; ccamp-
> [email-masked]; [email-masked]
> Subject: RE: [CCAMP] Vendor-Specific Application Code in draft-ietf-ccamp-
> rwa-wson-encode
> 
> Hi again,
> 
> > There is always a priori knowledge in optical network domain as to who
> > are you interfacing with. So you know which vendor you are interfacing.
> > If you do not know, then you are in trouble.
> 
> Hmmm. It is exactly type of trouble we are trying to detect and protect
> against.
> 
> I refute your statement of a priori knowledge. I think there is a priori
> intention, but not knowledge. Unless you have very good eyesight or
> someone at the other end of the fiber when you give it a tug, you don't
> know. And even then. Fibering errors happen from time to time. Consider, in
> particular a patch panel.
> 
> > Now, what is the purpose of standard FECs and modulations in the AI?
> > Given several choices each vendor may support in its device, the path
> > computation would find a matched types for FEC and modulation for a
> given optical path.
> > This is what is intended when optical signal processing constraints
> > were proposed as part of path computation constraints in optical
> networks.
> 
> 
> The case you are making here is for no standard control plane!
> What is the point of standardising if there is never any interworking?
> But actually, we know about interworking at the physical layer, and (more
> important) we know about a single, end-to-end control plane that spans
> multiple vendor devices. It all exists.
> 
> Of course, we can fall back into the old-style vendor islands, and many like to
> do so. But it is not a compulsory deployment model.
> 
> > There is very little chance for vendor specific FECs and Modulations
> > will match even if they are identified with the OUI code.
> 
> You have it the wrong way round!
> The OUI is largely to protect against expectations of interworking when none
> can exist.
> It might (much less frequently) be used to describe the way that vendorA and
> vendorB pick FECs and modulations in order to achieve interworking.
> 
> Adrian
> 
> _______________________________________________
> CCAMP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ccamp

---

From: Leeyoung <[email-masked]>
Date: Mon, 2 Feb 2015 15:38:13 +0000

Hi Daniele and Fatai,

Thanks for the resolution. I am still waiting for Adrian's other comments (as part of the AD review) and comments from ITU-T Q6/15 on the Application Codes. Once they are resolved, a revision will be made available.

Regards,
Young

-----Original Message-----
From: Daniele Ceccarelli [mailto:[email-masked]] 
Sent: Monday, February 02, 2015 4:14 AM
To: Leeyoung; [email-masked]; 'Varma, Eve L (Eve)'; [email-masked]; 'Lam, Hing-Kam (Kam)'; [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: RE: [CCAMP] Vendor-Specific Application Code in draft-ietf-ccamp-rwa-wson-encode

Working group,

BR
Daniele & Fatai

---

From: "Adrian Farrel" <[email-masked]>
Date: Mon, 2 Feb 2015 18:06:21 -0000

Thanks all.

In my opinion we have converged enough on all of the review points for Young to
post a new version and for us to move it forwards.

Adrian

> From: Leeyoung [mailto:[email-masked]]
> Sent: 02 February 2015 15:38
> To: Daniele Ceccarelli; [email-masked]; 'Varma, Eve L (Eve)';
> [email-masked]; 'Lam, Hing-Kam (Kam)'; [email-masked];
> [email-masked]
> Cc: [email-masked]; [email-masked]; [email-masked];
> [email-masked]
> Thanks for the resolution. I am still waiting for Adrian's other comments (as
part
> of the AD review) and comments from ITU-T Q6/15 on the Application Codes.
> Once they are resolved, a revision will be made available.
> 
> Regards,
> Young
> 
> To: Leeyoung; [email-masked]; 'Varma, Eve L (Eve)'; [email-masked]; 'Lam,
> Cc: [email-masked]; [email-masked]; [email-masked];
> [email-masked]
> This would require putting the draft on hold till the formal approval of
G.874.1
> (should be July 2015), but we would like not to stop the draft for so long
since a
> lot of other contents are ready to be progressed.
> 
> Our proposal is to move on with option 3 (i.e. Remove the option to include a
> Vendor-Specific Application Code field.) and add the support for vendor
specific
> application codes later in a BIS or a small, simple and straightforward draft
as soon
> as G.874.1 is approved.
> 
> Young, authors, please update the draft accordingly and maybe add a note
saying
> that  "future work may add support for vendor-specific AI once the ITU-T has
> completed its work in that area"
> 
> Working group, who would find it impossible to live with this as a compromise
> approach? If you cannot live with this approach, please explain why.
> 
> BR
> Daniele & Fatai
> 
> 
> 
>