Subject: Re: [CCAMP] [RTG-DIR] RtgDir review: draft-ietf-ccamp-general-constraint-encode-16.txt

From: "Adrian Farrel" <[email-masked]>
Date: Mon, 2 Feb 2015 18:37:07 -0000

I think that the bottom line of this thread was a new revision clarifying sub-matrix and bidirectional link sets.

Then (hopefully) we're done.

Adrian

> -----Original Message-----
> From: Leeyoung [mailto:[email-masked]]
> Sent: 23 January 2015 17:25
> To: Lou Berger; Tomonori Takeda; [email-masked]
> Cc: [email-masked]'; 'draft-ietf-ccamp-general-constraint-
> [email-masked]'; [email-masked]'
> Subject: RE: [RTG-DIR] RtgDir review: draft-ietf-ccamp-general-constraint-
> encode-16.txt
> 
> Lou,
> 
> I can add some clarifying text in the next revision.
> 
> Thanks,
> Young
> 
> -----Original Message-----
> From: Lou Berger [mailto:[email-masked]]
> Sent: Friday, January 23, 2015 11:22 AM
> To: Leeyoung; Tomonori Takeda; [email-masked]
> Cc: [email-masked]'; 'draft-ietf-ccamp-general-constraint-
> [email-masked]'; [email-masked]'
> Subject: Re: [RTG-DIR] RtgDir review: draft-ietf-ccamp-general-constraint-
> encode-16.txt
> 
> Young,
> 
> On 1/23/2015 11:51 AM, Leeyoung wrote:
> > Hi Lou,
> >
> > Are you referring 'any specific language changes' to Adrian's 'Resource'
> language?
> Actually, no.
> > If so, yes, I expect Adrian's input on where to place any changes in the draft.
> Other than that I believe the version 17 (which was published) reflects
> Tomonori's rtg-dir review. Let me know if you believe any other aspect (other
> than 'resource' language) should be updated in the upcoming version 18.
> 
> I may have misunderstood the thread below, but I read it as there are
> two areas in -17 that should be  clarified.
> 
> Thanks,
> Lou
> 
> > Thanks,
> > Young
> >
> > -----Original Message-----
> > From: Lou Berger [mailto:[email-masked]]
> > Sent: Friday, January 23, 2015 10:42 AM
> > To: Tomonori Takeda; Leeyoung; [email-masked]
> > Cc: [email-masked]'; 'draft-ietf-ccamp-general-constraint-
> [email-masked]'; [email-masked]'
> > Subject: Re: [RTG-DIR] RtgDir review: draft-ietf-ccamp-general-constraint-
> encode-16.txt
> >
> > Young,
> > 	Can you review any changes planned as a result of the rtg-dir review?
> > Please also include any specific language changes, that you may have
> > already identified.
> >
> > Thanks,
> > Lou (as doc Shepherd)
> >
> > On 01/23/2015 03:01 AM, Tomonori Takeda wrote:
> >> Hi Young,
> >>
> >> OK, thanks,
> >>
> >> Tomonori
> >>
> >> -----Original Message-----
> >> From: Leeyoung [mailto:[email-masked]]
> >> Sent: Thursday, January 22, 2015 2:44 AM
> >> To: Tomonori Takeda（武田知典）; Leeyoung; [email-masked]
> >> Cc: [email-masked]'; 'draft-ietf-ccamp-general-constraint-
> [email-masked]'; [email-masked]'
> >> Subject: RE: [RTG-DIR] RtgDir review: draft-ietf-ccamp-general-constraint-
> encode-16.txt
> >>
> >> Hi Tomonori,
> >>
> >> Thanks for your comment. Please see in-line for my response. Please let me
> know if the response would satisfy you.
> >>
> >> Best regards,
> >> Young
> >>
> >> -----Original Message-----
> >> From: Tomonori Takeda [mailto:[email-masked]]
> >> Sent: Wednesday, January 21, 2015 12:48 AM
> >> To: Leeyoung; [email-masked]
> >> Cc: [email-masked]'; 'draft-ietf-ccamp-general-constraint-
> [email-masked]'; [email-masked]'; Tomonori Takeda
> >> Subject: RE: [RTG-DIR] RtgDir review: draft-ietf-ccamp-general-constraint-
> encode-16.txt
> >>
> >> Hi Young,
> >>
> >> Thanks.
> >>
> >> Two follow-up questions/comments.
> >> (I am fine with other points, which you already addressed in the updated
> draft.)
> >>
> >>> 2) In section 2.1, it says "two matrices will not have the same {src port, src
> label, dst port, dst label}". To be precise, I guess this should be > "two matrices
> will not have the same {src port, src label}, and two matrices will not have the
> same {dst port, dst label}"?
> >>>
> >>> YOUNG>> I think your suggestion may be too restrictive. For instance, if we
> have one source (port 1) and one destination (port 2) with two labels > each.
> Then we would have: {(1,1,2,1), (1,1,2,2), (1,2,2,1), (1,2,2,2)} I think with the
> current statement, we can send this info in any combination > of multiple
> matrices, which I think perfectly fine. With your suggestion, I would not be able
> send (1,1,2,1) and (1,1,2,2) together. Why would this > not be made possible? My
> take is as long as each submatrix represents a set of disjoint quadruples, that
> should be allowed.
> >> My reading of "two matrices will not have the same {src port, src label, dst
> port, dst label}" is as follows.
> >>
> >> <Example A>
> >>
> >>   input port=1  --> Submatrix#1 --> output port=2
> >>   input label=1                     output label=1
> >>
> >>   input port=1  --> Submatrix#2 --> output port=2
> >>   input label=1                     output label=2
> >>
> >>   This is allowed.
> >>
> >> <Example B>
> >>
> >>   input port=1  --> Submatrix#1 --> output port=2
> >>   input label=1                     output label=1
> >>
> >>   input port=1  --> Submatrix#2 --> output port=2
> >>   input label=1                     output label=1
> >>
> >>   This is not allowed.
> >>
> >> <Example C>
> >>
> >>   input port=1  --> Submatrix#1 --> output port=2
> >>   input label=1                     output label=1
> >>
> >>   input port=1  --> Submatrix#2 --> output port=2
> >>   input label=2                     output label=2
> >>
> >>   This is allowed.
> >>
> >> Is above understanding correct?
> >> If so, I am not sure how example A works, since I am not sure what is the
> indentifier to direct from input to each submatrix.
> >>
> >> Maybe I am mis-understanding what sub-matrix is. I thought sub-matrix is a
> sort of virtual node, splitting the single matrix (or switch) into smaller pieces.
> >>
> >> YOUNG>> OK, I think the definition of submatrix was not clear. It is simply
> dividing up a matrix into several pieces in case the size of the matrix becomes too
> big or a way to advertize the changed port/label set in one place (sub-matrix)
> then other unchanged port/label set in other place (different sub-matrix). The
> identifier for each sub-matrix is the MATRIX ID. There is not separate identifier to
> direct from input. The input is a part of the sub-matrix. Say if we have N*M
> matrix that describes all input and output port/label. We might divide up into
> N*(M-L) and N*L or any other combinations as far as they are all disjoint from
> each other.
> >>
> >>> 4) In section 2.1, for Link Set A dir=bidirectional, Link Set B dir=bidirectional, if
> any signal on an input link X is output on a link Y, then any > signal on an input link
> Y is output on a link X (after cross-connect)? Or any constraint on such signal flow
> (after cross-connect) is out of scope?
> >>>
> >>> <YOUNG>> I am not sure what "after cross-connect" is meant.
> >> <Example>
> >>
> >>   Link set A: link#1, link#2, link#3
> >>   Link set B: link#4, link#5, link#6
> >>
> >>   Both of Link set A and Link set B are specified as "dir".
> >>
> >>   In this case,
> >>   - Is it possible to problem the cross-connect as input=link#1, output=link#4
> >>     & input=link#5, output=link#1 simultaneolusly?
> >>   - Or is it automatically assumed if input=link#1, output=link#4,
> >>     then input=link#4, output=link#1?
> >>   - Or this sort of constraint is not specified in Link Set Field?
> >>
> >> The text seems like saying the first option, but I do not think this is a common
> equipment implementaion.
> >>
> >> YOUGN>> OK. I think I understand you more clearly. For this case
> (bidirectional link sets), the first case is definitely not the intention. The second
> case is assumed.
> >>
> >> Thanks,
> >> Tomonori
> >>
> >> -----Original Message-----
> >> From: Leeyoung [mailto:[email-masked]]
> >> Sent: Tuesday, January 20, 2015 7:54 AM
> >> To: Tomonori Takeda（武田知典）; [email-masked]
> >> Cc: [email-masked]'; 'draft-ietf-ccamp-general-constraint-
> [email-masked]'; [email-masked]'
> >> Subject: RE: [RTG-DIR] RtgDir review: draft-ietf-ccamp-general-constraint-
> encode-16.txt
> >>
> >> Hi Tomonori,
> >>
> >> Thanks for providing good comments. Here's my response. Please see in-line.
> >>
> >> Regards,
> >> Young
> >>
> >> -----Original Message-----
> >> From: rtg-dir [mailto:[email-masked]] On Behalf Of Tomonori Takeda
> >> Sent: Saturday, January 17, 2015 7:59 AM
> >> To: [email-masked]
> >> Cc: [email-masked]'; 'draft-ietf-ccamp-general-constraint-
> [email-masked]'; [email-masked]'
> >> Subject: [RTG-DIR] RtgDir review: draft-ietf-ccamp-general-constraint-
> encode-16.txt
> >>
> >> Hello,
> >>
> >> I have been selected as the Routing Directorate reviewer for this draft. The
> Routing Directorate seeks to review all routing or routing-related drafts as they
> pass through IETF last call and IESG review, and sometimes on special request.
> The purpose of the review is to provide assistance to the Routing ADs. For more
> information about the Routing Directorate, please see 
> http://trac.tools.ietf.org/area/rtg/trac/wiki/RtgDir
> >>
> >> Although these comments are primarily for the use of the Routing ADs, it
> would be helpful if you could consider them along with any other IETF Last Call
> comments that you receive, and strive to resolve them through discussion or by
> updating the draft.
> >>
> >> Document: draft-ietf-ccamp-general-constraint-encode-16.txt
> >> Reviewer: Tomonori Takeda
> >> Review Date: 17 January, 2015
> >> IETF LC End Date: 17 January, 2015
> >> Intended Status: Standards Track
> >>
> >> Summary:
> >>
> >> This document is basically ready for publication, but has nits that should be
> considered prior to publication.
> >>
> >> Comments:
> >>
> >> This document specifies protocol-agnostic encodings for general information
> elements described in draft-ietf-ccamp-rwa-info.
> >> I think the document is in good shape but there are a few points that should
> be clarified for better understanding.
> >>
> >> Major Issues:
> >>
> >> None
> >>
> >> Minor Issues:
> >>
> >> None
> >>
> >> Nits:
> >>
> >> 1) In section 1.2, label continuity constraint (e.g., wavelength continuity in
> WSON) is mentioned. However, I am not sure whether information elements for
> which this document specifies encodings can describe such constraint. My
> reading is that information element such as Port Label Restriction is rather for
> describing wavelength tuning capabilities/restrictions.
> >>
> >> YOUNG>> Label continuity constraints can be inferred from the two places in
> the draft: (i) Port Label Restriction, which gives the set of labels (wavelengths)
> that may not be available on certain links including tuning range/restriction; (ii)
> Available/Shared Backup Label Fields (section 2.4 & section 2.5). There is no
> encoding for label continuity constraint per se. The aforementioned constraints
> are encoded to give a node or a PCE to be able to compute a path (i.e., path with
> wavelength continuity) subject to these constraints.
> >>
> >> 2) In section 2.1, it says "two matrices will not have the same {src port, src
> label, dst port, dst label}". To be precise, I guess this should be "two matrices will
> not have the same {src port, src label}, and two matrices will not have the same
> {dst port, dst label}"?
> >>
> >> YOUNG>> I think your suggestion may be too restrictive. For instance, if we
> have one source (port 1) and one destination (port 2) with two labels each. Then
> we would have: {(1,1,2,1), (1,1,2,2), (1,2,2,1), (1,2,2,2)} I think with the current
> statement, we can send this info in any combination of multiple matrices, which I
> think perfectly fine. With your suggestion, I would not be able send (1,1,2,1) and
> (1,1,2,2) together. Why would this not be made possible? My take is as long as
> each submatrix represents a set of disjoint quadruples, that should be allowed.
> >>
> >> 3) In section 2.1, it says "The value of 0xFF is reserved for use with port
> wavelength constraints". I think "port wavelength constraints" should be "port
> label restriction".
> >>
> >> YOUNG>> Yes, thanks.
> >>
> >> 4) In section 2.1, for Link Set A dir=bidirectional, Link Set B dir=bidirectional, if
> any signal on an input link X is output on a link Y, then any signal on an input link Y
> is output on a link X (after cross-connect)? Or any constraint on such signal flow
> (after cross-connect) is out of scope?
> >>
> >> YOUNG>> I am not sure what "after cross-connect" is meant.
> >>
> >> 5) In section 2.2.1, it says "In this case the accompanying label set indicates the
> labels permitted on the port." I think "port" should be "port/matrix".
> >>
> >> YOUNG>> Yes, thanks.
> >>
> >> 6) In section 2.2.2, it would be better to describe the type (e.g., integer) for
> MaxNumChannels.
> >> This also applies for MaxLabelRange (in section 2.2.3) and Num Labels (in
> section 2.6).
> >>
> >> YOUNG>> OK.
> >>
> >> 7) In section 2.6, it says "Label Set Field is used within the <AvailableLabels> or
> the <SharedBackupLabels>". But I think Label Set Field is also used within
> SIMPLE_LABEL, LABEL_RANGE and SIMPLE_LABEL & CHANNEL_COUNT.
> >>
> >> YOUNG>> Yes, it is used in multiple places.
> >>
> >> How about:
> >> OLD: Label Set Field is used within the <AvailableLabels> or the
> >>    <SharedBackupLabels>, which is defined in Section 2.4. and 2.5.,
> >>    respectively.
> >> NEW: Label Set Field is used within the <AvailableLabels> or the
> >>    <SharedBackupLabels>, which is defined in Section 2.4. and 2.5.,
> >>    respectively. It is also used within the <SIMPLE_LABEL>,
> >>    <LABEL_RANGE>, <SIMPLE_LABEL> or <CHANNEL_COUNT>, which is
> defined
> >>    in Sections 2.1.1 - 2.1.4, respectively.
> >>
> >>
> >> Thanks,
> >> Tomonori
> >>

---

From: Leeyoung <[email-masked]>
Date: Mon, 2 Feb 2015 21:09:25 +0000

Hi Adrian and Lou,

Updated (v.18) with a set of clarifying text on sub-matrix and bidirectional link sets. 

http://datatracker.ietf.org/doc/draft-ietf-ccamp-general-constraint-encode/

Thanks,
Young

-----Original Message-----
From: Adrian Farrel [mailto:[email-masked]] 
Sent: Monday, February 02, 2015 12:37 PM
To: Leeyoung; 'Lou Berger'; 'Tomonori Takeda'; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: RE: [RTG-DIR] RtgDir review: draft-ietf-ccamp-general-constraint-encode-16.txt

Adrian

---

From: Lou Berger <[email-masked]>
Date: Mon, 02 Feb 2015 16:28:40 -0500

Hi Young,

I see you just published an update.  I have one question below.

On 1/23/2015 3:01 AM, Tomonori Takeda wrote:
> Cc: [email-masked]'; [email-masked]'; [email-masked]'
> Thanks for your comment. Please see in-line for my response. Please let me know if the response would satisfy you. 
>
> Best regards,
> Young
>
> Cc: [email-masked]'; [email-masked]'; [email-masked]'; Tomonori Takeda
> (I am fine with other points, which you already addressed in the updated draft.)
>
>> 2) In section 2.1, it says "two matrices will not have the same {src port, src label, dst port, dst label}". To be precise, I guess this should be > "two matrices will not have the same {src port, src label}, and two matrices will not have the same {dst port, dst label}"?
>>
>> YOUNG>> I think your suggestion may be too restrictive. For instance, if we have one source (port 1) and one destination (port 2) with two labels > each. Then we would have: {(1,1,2,1), (1,1,2,2), (1,2,2,1), (1,2,2,2)} I think with the current statement, we can send this info in any combination > of multiple matrices, which I think perfectly fine. With your suggestion, I would not be able send (1,1,2,1) and (1,1,2,2) together. Why would this > not be made possible? My take is as long as each submatrix represents a set of disjoint quadruples, that should be allowed.
> My reading of "two matrices will not have the same {src port, src label, dst port, dst label}" is as follows.
>
> <Example A>
>
> If so, I am not sure how example A works, since I am not sure what is the indentifier to direct from input to each submatrix.
>
> Maybe I am mis-understanding what sub-matrix is. I thought sub-matrix is a sort of virtual node, splitting the single matrix (or switch) into smaller pieces.

Can you explain how the revised text clarifies this point?

Thanks,
Lou

> ....

---

From: Leeyoung <[email-masked]>
Date: Mon, 2 Feb 2015 22:15:06 +0000

Hi Lou,

The original question Tomonori raised was if sub-matrices are like virtual nodes attached to connectivity matrix. The answer was no, and sub-matrix is simply a partition of connectivity matrix into smaller pieces. To that end, I added the following text in Section 2.1

   Each sub-matrix is assigned a unique Matrix ID to represent a 
   mutually exclusive set of {src port, src label, dst port, dst label} 
   from other sub-matrices. 

Let me know what you think.

Thanks,
Young

-----Original Message-----
From: Lou Berger [mailto:[email-masked]] 
Sent: Monday, February 02, 2015 3:29 PM
To: Leeyoung
Cc: Tomonori Takeda; [email-masked]; [email-masked]'; [email-masked]'; [email-masked]'
Subject: Re: [RTG-DIR] RtgDir review: draft-ietf-ccamp-general-constraint-encode-16.txt

Hi Young,

Thanks,
Lou

---

From: Lou Berger <[email-masked]>
Date: Tue, 03 Feb 2015 08:59:26 -0500

Young,

I guess I didn't see the new text as substantively different or more
informative than preceding text:

   ... There may be more than one matrix associated with
   a node as the node can partition the switch matrix into several sub-
   matrices for various reasons such as incremental updates, etc. When
   the matrix is partitioned into sub-matrices, it is envisioned that
   they are mutually exclusive to one another in representing which
   ports/labels are associated with each sub-matrix. This implies that
   two matrices will not have the same {src port, src label, dst port,
   dst label}.

I'd suggest directly addressing the ambiguity by revising the first
sentence and "for various reasons such as incremental updates, etc. " in
particular.  Perhaps "primarily to limit the size of any individual
information element used to represent the matrix."  or however else
you'd like to capture the intent.

Lou

---

From: Leeyoung <[email-masked]>
Date: Tue, 3 Feb 2015 17:08:17 +0000

Lou,

OK, How about:

OLD 

NEW: 

... There may be more than one matrix associated with
   a node as the node can partition the switch matrix into several sub-
   matrices for various reasons primarily to limit the size of any 
   individual information element used to represent the matrix or allow 
   incremental updates, etc. When the matrix is partitioned into 
   sub-matrices, it is envisioned that they are mutually exclusive to 
   one another in representing which ports/labels are associated with 
   each sub-matrix. This implies that two matrices will not have the 
   same {src port, src label, dst port, dst label}.

Would this be Ok with you? Then I will publish a revision upon your approval.

Thanks,
Young

-----Original Message-----
From: Lou Berger [mailto:[email-masked]] 
Sent: Tuesday, February 03, 2015 7:59 AM
To: Leeyoung
Cc: [email-masked]'; [email-masked]'; [email-masked]'; Tomonori Takeda; [email-masked]
Subject: Re: [RTG-DIR] RtgDir review: draft-ietf-ccamp-general-constraint-encode-16.txt

Young,

Lou

---

From: Lou Berger <[email-masked]>
Date: Tue, 03 Feb 2015 12:21:30 -0500

Young,
    I think we're close, but lets tighten up the language a bit.

How about:

   There may be more than one Field associated with
   a node as a node can partition the switch matrix into several sub-
   matrices. This partitioning is primarily to limit the size of any 
   individual information element used to represent the matrix and to 
   enable incremental updates. When the matrix is partitioned into 
   sub-matrices, each sub-matrix will be mutually exclusive to 
   one another in representing which ports/labels are associated with 
   each sub-matrix. This implies that two matrices will not have the 
   same {src port, src label, dst port, dst label}.

   Each sub-matrix is identified via a different Matrix ID which MUST 
   represent a unique combination of {src port, src label, dst port, 
   dst label}.

Lou

> Would this be Ok with you? Then I will publish a revision upon your approval.
Also we need to hear from Tomonori on if his issues is addressed.

Thanks,
Lou

---

From: Leeyoung <[email-masked]>
Date: Tue, 3 Feb 2015 17:27:53 +0000

Lou,

That sounds good to me. I will upload with this change.

Thanks,
Young

-----Original Message-----
From: Lou Berger [mailto:[email-masked]] 
Sent: Tuesday, February 03, 2015 11:22 AM
To: Leeyoung
Cc: [email-masked]'; [email-masked]'; [email-masked]'; Tomonori Takeda; [email-masked]
Subject: Re: [RTG-DIR] RtgDir review: draft-ietf-ccamp-general-constraint-encode-16.txt

Young,

How about:

Lou

Thanks,
Lou