Subject: [CCAMP] Discussion on "Optical Interface Parameters" drafts

From: Fatai Zhang <[email-masked]>
Date: Tue, 27 Oct 2015 09:40:33 +0000

Hi authors and CCAMPers,

There are a couple of drafts on "Optical Interface Parameters", such as draft-kdkgall-ccamp-dwdm-if-mng-ctrl-fwk-01, draft-galikunze-ccamp-dwdm-if-snmp-mib-00,
draft-dharini-netmod-dwdm-if-yang-00, draft-dharinigert-ccamp-dwdm-if-lmp<http://tools.ietf.org/id/draft-dharinigert-ccamp-dwdm-if-lmp-00.txt>.

I would like to trigger some discussion on these drafts before they will be presented in Yokohama meeting, because there is no any discussion on this topic since the last IETF meeting.

After I reviewed these drafts, it seems to me the major change is that the title of these drafts has been changed from "G.698.2..." to "Optical Interface Parameters", but the content in these drafts is still almost the same as before(even though LMP use case was moved from LMP draft to the FWK draft). Probably, I missed something important.

In Prague meeting, I think the consensus from the floor is to make the "content" (rather than only "title") much more generic, i.e., beyond of g.698.2.

Therefore, could you clarify what changes have been made to make things generic to reflect the discussion in Prague meeting?

Best Regards

Fatai

---

From: "Zafar Ali (zali)" <[email-masked]>
Date: Tue, 27 Oct 2015 17:34:50 +0000

Folks-

I am unable to travel for this IETF - sorry will miss it.

Thanks

Regards ... Zafar

From: Fatai Zhang <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, October 27, 2015 at 5:40 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Gert Grammel <[email-masked]<mailto:[email-masked]>>, "Gabriele Maria Galimberti (ggalimbe)" <[email-masked]<mailto:[email-masked]>>, zali <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Dieter Beller <[email-masked]<mailto:[email-masked]>>
Subject: Discussion on "Optical Interface Parameters" drafts

Hi authors and CCAMPers,

Best Regards

Fatai

---

From: "Gabriele Maria Galimberti (ggalimbe)" <[email-masked]>
Date: Wed, 28 Oct 2015 17:01:37 +0000

Hi Fatai, ]

Thanks for the feedbacks,  definitely we have to meet before ccamp, Monday morning is the only option.

What about at 9:00am at the registration desk ?

Best Regards,

Gabriele
[http://www.cisco.com/swa/i/logo.gif]

Gabriele Galimberti
Principal Engineer
Cisco Photonics Srl

via S.Maria Molgora, 48 C
20871 - Vimercate (MB)
Italy
www.cisco.com/global/IT/<http://www.cisco.com/global/IT/>

[email-masked]<mailto:[email-masked]>
Phone :+39 039 2091462
Mobile :+39 335 7481947
Fax :+39 039 2092049

From: Fatai Zhang <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, October 27, 2015 10:40 AM
To: "CCAMP ([email-masked]<mailto:[email-masked]>)" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Gert Grammel <[email-masked]<mailto:[email-masked]>>, Gabriele Galimberti <[email-masked]<mailto:[email-masked]>>, "Zafar Ali (zali)" <[email-masked]<mailto:[email-masked]>>, Ruediger Kunze <[email-masked]<mailto:[email-masked]>>, Dieter Beller <[email-masked]<mailto:[email-masked]>>
Subject: Discussion on "Optical Interface Parameters" drafts

Hi authors and CCAMPers,

Best Regards

Fatai

---

From: Gert Grammel <[email-masked]>
Date: Wed, 28 Oct 2015 17:29:33 +0000

Hi Fatai,

The framework draft is supposed to cover the use cases irrespective of G.698.2 considerations. Therefore we also pulled the use cases from LMP into the Framework. This was one of the options discussed during IETF93.
The other drafts went beyond G698.2 as they include also interfaces that are not defined in G.698,2.  Much of the content was already there but the title not being aligned with the content created confusion which we want to resolve now. The scope is to define a YANG/SNMP/LMP for WDM interfaces in general, where G.698.2 compliant ones are a subset.

Best

Gert

From: Fatai Zhang [mailto:[email-masked]]
Sent: 27 October 2015 10:41
To: CCAMP ([email-masked]); Dharini Hiremagalur; Gert Grammel; [email-masked]; 'Zafar Ali (zali)'; [email-masked]; Dieter Beller
Subject: Discussion on "Optical Interface Parameters" drafts

Hi authors and CCAMPers,

Best Regards

Fatai