Subject: [CCAMP] WG adoption poll on draft-fioccola-ccamp-l1csm-yang-01

From: "Zhangfatai (Fatai Zhang)" <[email-masked]>
Date: Tue, 10 Apr 2018 02:01:11 +0000

Hi all,
We now have the IPR declaration replies from all the authors/contributors (Please see https://datatracker.ietf.org/doc/draft-fioccola-ccamp-l1csm-yang/history/) and no IPR was disclosed against this document.
This starts a two weeks poll on making [draft-fioccola-ccamp-l1csm-yang-01] a CCAMP working group document.
Please send email to the list indicating "yes/support" or "no/do not support" and a motivation for your reply, mandatory for the "not support" and nice to have for the "support".
The polling ends on April 24th , 2018.

Thanks
Fatai & Daniele

---

From: Leeyoung <[email-masked]>
Date: Tue, 10 Apr 2018 02:19:26 +0000

Yes/ support.

Young (co-author)
From:Zhangfatai (Fatai Zhang)
To:CCAMP ([email-masked]),
Cc:[email-masked],[email-masked],
Date:2018-04-09 21:01:44
Subject:[CCAMP] WG adoption poll on draft-fioccola-ccamp-l1csm-yang-01

Hi all,

Thanks
Fatai & Daniele

---

From: Dhruv Dhody <[email-masked]>
Date: Tue, 10 Apr 2018 03:38:39 +0000

Yes/Support

Dhruv (as a co-author)

From: CCAMP [mailto:[email-masked]] On Behalf Of Zhangfatai (Fatai Zhang)
Sent: 10 April 2018 07:31
To: CCAMP ([email-masked]) <[email-masked]>
Cc: [email-masked]; [email-masked]
Subject: [CCAMP] WG adoption poll on draft-fioccola-ccamp-l1csm-yang-01

Hi all,

Thanks
Fatai & Daniele

---

From: "t.petch" <[email-masked]>
Date: Tue, 10 Apr 2018 12:28:12 +0100

Mmmm

I can't help thinking that this I-D may indicate a failure of the WG to
be a WG:-(

I see a very long list of enumerations/identities for Gigabit Ethernet,
Fiber channel, STM, OC, etc

Surely a layer one Connectivity Service Model is not going to be the
only place where these are needed (Gigabit Ethernet already exists is
some form) so what I think that a WG should be doing is to produce a
'types' module for generic use, IETF and even non-IETF, the way in which
the Netmod WG has done for Interfaces, and other WGs - CCAMP - did many
years earlier for MIB Modules.

And, albeit of less import, there are a significant number of places
where this I-D does not conform with YANG Guidelines.

Tom Petch

----- Original Message -----
From: "Zhangfatai (Fatai Zhang)" <[email-masked]>
To: <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>
Sent: Tuesday, April 10, 2018 3:01 AM
Subject: [CCAMP] WG adoption poll on draft-fioccola-ccamp-l1csm-yang-01

Hi all,
We now have the IPR declaration replies from all the
authors/contributors (Please see
https://datatracker.ietf.org/doc/draft-fioccola-ccamp-l1csm-yang/history
/) and no IPR was disclosed against this document.
This starts a two weeks poll on making
[draft-fioccola-ccamp-l1csm-yang-01] a CCAMP working group document.
Please send email to the list indicating "yes/support" or "no/do not
support" and a motivation for your reply, mandatory for the "not
support" and nice to have for the "support".
The polling ends on April 24th , 2018.

Thanks
Fatai & Daniele

------------------------------------------------------------------------
--------

> _______________________________________________
> CCAMP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ccamp
>

---

From: Leeyoung <[email-masked]>
Date: Tue, 10 Apr 2018 12:27:42 +0000

Hi Tom,

Thank you for your comment.
I agree with you. We can improve the model using types statement instead of the enumeration of the list.

I think WG adoption is just a starting point not a completion of the draft and it's model. Please suggest other concerns so that the draft and the model can be improved.

Thanks.
Young (on behalf of co-authors)

From:t.petch
To:Zhangfatai (Fatai Zhang),[email-masked],
Cc:[email-masked],[email-masked],
Date:2018-04-10 06:30:24
Subject:Re: [CCAMP] WG adoption poll on draft-fioccola-ccamp-l1csm-yang-01

Mmmm

Tom Petch

----- Original Message -----
From: "Zhangfatai (Fatai Zhang)" <[email-masked]>
To: <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>
Sent: Tuesday, April 10, 2018 3:01 AM
Subject: [CCAMP] WG adoption poll on draft-fioccola-ccamp-l1csm-yang-01

Hi all,

Thanks
Fatai & Daniele

---

From: Fioccola Giuseppe <[email-masked]>
Date: Tue, 10 Apr 2018 15:07:05 +0000

Support as coauthor.

Giuseppe

Da: Zhangfatai (Fatai Zhang) [mailto:[email-masked]]
Inviato: martedì 10 aprile 2018 04:01
A: CCAMP ([email-masked])
Cc: [email-masked]; [email-masked]
Oggetto: WG adoption poll on draft-fioccola-ccamp-l1csm-yang-01

Hi all,

Thanks
Fatai & Daniele

Questo messaggio e i suoi allegati sono indirizzati esclusivamente alle persone indicate. La diffusione, copia o qualsiasi altra azione derivante dalla conoscenza di queste informazioni sono rigorosamente vietate. Qualora abbiate ricevuto questo documento per errore siete cortesemente pregati di darne immediata comunicazione al mittente e di provvedere alla sua distruzione, Grazie. 

This e-mail and any attachments is confidential and may contain privileged information intended for the addressee(s) only. Dissemination, copying, printing or use by anybody else is unauthorised. If you are not the intended recipient, please delete this message and any attachments and advise the sender by return e-mail, Thanks. 

Rispetta l'ambiente. Non stampare questa mail se non è necessario.

---

From: "t.petch" <[email-masked]>
Date: Tue, 10 Apr 2018 16:49:14 +0100

Lee

I am suggesting that this should not be one I-D at all but should be
split into two I-D, with the body of one I-D containing from
          identity protocol-type {
to
          /* coding func needs to expand for Fiber Channel, SONET, SDH
*/
or perhaps as far as
            "ER4-PMD-clause-88 Optical Interface function for 100GBASE-R
PCS-82";
(these last I am less familiar with compared to GigE, STM, OC etc))

with the other I-D being more or less
        grouping uni-attributes {
to
        }//service top container

that is, the list of protocol types, at least, are likely to be needed
by other CCAMP RFC and perhaps by other WG RFC - MPLS, say - and so
belong in a separate RFC.

It does the IETF no good to have Gigabit Ethernet defined in many
different places without good cause, and I struggle to think of such a
cause.

I do not think that having two modules, one types, one data, in the
single RFC would form a good basis for ongoing work (unlike, say,
microwave radio where having two YANG modules in one RFC seems ok since
the scope for reuse of the 'enumerations' seems more limited).

Tom Petch

----- Original Message -----
From: "Leeyoung" <[email-masked]>
To: "t.petch" <[email-masked]>; "Zhangfatai (Fatai Zhang)"
<[email-masked]>; <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>
Sent: Tuesday, April 10, 2018 1:27 PM
Subject: RE: [CCAMP] WG adoption poll on
draft-fioccola-ccamp-l1csm-yang-01

Hi Tom,

Thank you for your comment.
I agree with you. We can improve the model using types statement instead
of the enumeration of the list.

I think WG adoption is just a starting point not a completion of the
draft and it's model. Please suggest other concerns so that the draft
and the model can be improved.

Thanks.

From:t.petch
To:Zhangfatai (Fatai Zhang),[email-masked],
Cc:[email-masked],[email-masked],
Date:2018-04-10 06:30:24
Subject:Re: [CCAMP] WG adoption poll on
draft-fioccola-ccamp-l1csm-yang-01

Mmmm

Tom Petch

----- Original Message -----
From: "Zhangfatai (Fatai Zhang)" <[email-masked]>
To: <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>
Sent: Tuesday, April 10, 2018 3:01 AM
Subject: [CCAMP] WG adoption poll on draft-fioccola-ccamp-l1csm-yang-01

Hi all,

Thanks
Fatai & Daniele

---

From: Leeyoung <[email-masked]>
Date: Tue, 10 Apr 2018 19:01:00 +0000

Hi Tom,

Thanks again for your suggestion. We will follow-up with that. 

In regards to why GE is defined here is because of the MEF L1 Conn. Service attribute work has that. So we are not re-inventing but follow MEF definition. 
You  may raise this issue to MEF L1 folks per Daniele's email to CCAMP from last week. 

Hope this helps. 

Thanks.
Young

-----Original Message-----
From: t.petch [mailto:[email-masked]] 
Sent: Tuesday, April 10, 2018 10:49 AM
To: Leeyoung <[email-masked]>; Zhangfatai (Fatai Zhang) <[email-masked]>; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: Re: [CCAMP] WG adoption poll on draft-fioccola-ccamp-l1csm-yang-01

Lee

I am suggesting that this should not be one I-D at all but should be split into two I-D, with the body of one I-D containing from
          identity protocol-type {
to
          /* coding func needs to expand for Fiber Channel, SONET, SDH */ or perhaps as far as
            "ER4-PMD-clause-88 Optical Interface function for 100GBASE-R PCS-82"; (these last I am less familiar with compared to GigE, STM, OC etc))

that is, the list of protocol types, at least, are likely to be needed by other CCAMP RFC and perhaps by other WG RFC - MPLS, say - and so belong in a separate RFC.

It does the IETF no good to have Gigabit Ethernet defined in many different places without good cause, and I struggle to think of such a cause.

I do not think that having two modules, one types, one data, in the single RFC would form a good basis for ongoing work (unlike, say, microwave radio where having two YANG modules in one RFC seems ok since the scope for reuse of the 'enumerations' seems more limited).

Tom Petch

----- Original Message -----
From: "Leeyoung" <[email-masked]>
To: "t.petch" <[email-masked]>; "Zhangfatai (Fatai Zhang)"

Hi Tom,

Thanks.

From:t.petch
To:Zhangfatai (Fatai Zhang),[email-masked], Cc:[email-masked],[email-masked],
Date:2018-04-10 06:30:24
Subject:Re: [CCAMP] WG adoption poll on
draft-fioccola-ccamp-l1csm-yang-01

Mmmm

I can't help thinking that this I-D may indicate a failure of the WG to be a WG:-(

I see a very long list of enumerations/identities for Gigabit Ethernet, Fiber channel, STM, OC, etc

Surely a layer one Connectivity Service Model is not going to be the only place where these are needed (Gigabit Ethernet already exists is some form) so what I think that a WG should be doing is to produce a 'types' module for generic use, IETF and even non-IETF, the way in which the Netmod WG has done for Interfaces, and other WGs - CCAMP - did many years earlier for MIB Modules.

And, albeit of less import, there are a significant number of places where this I-D does not conform with YANG Guidelines.

Tom Petch

----- Original Message -----
From: "Zhangfatai (Fatai Zhang)" <[email-masked]>
To: <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>
Sent: Tuesday, April 10, 2018 3:01 AM
Subject: [CCAMP] WG adoption poll on draft-fioccola-ccamp-l1csm-yang-01

Hi all,
We now have the IPR declaration replies from all the authors/contributors (Please see https://datatracker.ietf.org/doc/draft-fioccola-ccamp-l1csm-yang/history

Thanks
Fatai & Daniele

---

From: Italo Busi <[email-masked]>
Date: Wed, 11 Apr 2018 08:00:31 +0000

Yes/support

Italo

From: Zhangfatai (Fatai Zhang) [mailto:[email-masked]]
Sent: Tuesday, April 10, 2018 4:01 AM
To: CCAMP ([email-masked]) <[email-masked]>
Cc: [email-masked]; [email-masked]
Subject: [CCAMP] WG adoption poll on draft-fioccola-ccamp-l1csm-yang-01

Hi all,

Thanks
Fatai & Daniele

---

From: Daniele Ceccarelli <[email-masked]>
Date: Wed, 11 Apr 2018 15:48:25 +0000

Hi Tom,

all valuable comments. As co-author of the draft I'm inclined to accept all of them. As co-chair I believe they can be addressed after the adoption of the draft. Moreover since you are suggesting a split of the text as it is, I don't se any issue in adopting the draft and then splitting it into two WG documents. 
As Young correctly remembered the adoption of the draft is the time in which the WG starts to work on it as there is interest. If we adopted drafts ready for publication we would be an acceptance board and not a working group 😊

By the way the decision on this is on Fatai since I'm co-authoring the draft and I lose all of my rights as co-chair on the draft.

BR
Daniele  

> Sent: martedì 10 aprile 2018 17:49
> I am suggesting that this should not be one I-D at all but should be split into
> two I-D, with the body of one I-D containing from
>           identity protocol-type {
> to
>             "ER4-PMD-clause-88 Optical Interface function for 100GBASE-R PCS-
> 82"; (these last I am less familiar with compared to GigE, STM, OC etc))
> 
> that is, the list of protocol types, at least, are likely to be needed by other
> CCAMP RFC and perhaps by other WG RFC - MPLS, say - and so belong in a
> separate RFC.
> 
> It does the IETF no good to have Gigabit Ethernet defined in many different
> places without good cause, and I struggle to think of such a cause.
> 
> I do not think that having two modules, one types, one data, in the single RFC
> would form a good basis for ongoing work (unlike, say, microwave radio
> where having two YANG modules in one RFC seems ok since the scope for
> reuse of the 'enumerations' seems more limited).
> 
> Tom Petch
> 
> I think WG adoption is just a starting point not a completion of the draft and
> it's model. Please suggest other concerns so that the draft and the model can
> be improved.
> 
> Thanks.
> Surely a layer one Connectivity Service Model is not going to be the only
> place where these are needed (Gigabit Ethernet already exists is some form)
> so what I think that a WG should be doing is to produce a 'types' module for
> generic use, IETF and even non-IETF, the way in which the Netmod WG has
> done for Interfaces, and other WGs - CCAMP - did many years earlier for MIB
> Modules.
> 
> And, albeit of less import, there are a significant number of places where this
> I-D does not conform with YANG Guidelines.
> 
> Tom Petch
> 
> We now have the IPR declaration replies from all the authors/contributors
> (Please see https://datatracker.ietf.org/doc/draft-fioccola-ccamp-l1csm-
> yang/history
> Please send email to the list indicating "yes/support" or "no/do not support"
> and a motivation for your reply, mandatory for the "not support" and nice to
> have for the "support".

---

From: 윤빈영 <[email-masked]>
Date: Thu, 12 Apr 2018 07:29:32 +0000

Yes/Support.

Bin,

Sent: Monday, April 09, 2018 9:01 PM

Hi all,

Thanks
Fatai & Daniele

---

From: "Zhenghaomian (Zhenghaomian, Optical &Microwave Technology Research Dept)" <[email-masked]>
Date: Mon, 16 Apr 2018 01:53:18 +0000

Yes/Support.

Best wishes,
Haomian

发件人: CCAMP [mailto:[email-masked]] 代表 Zhangfatai (Fatai Zhang)
发送时间: 2018年4月10日 10:01
收件人: CCAMP ([email-masked]) <[email-masked]>
抄送: [email-masked]; [email-masked]
主题: [CCAMP] WG adoption poll on draft-fioccola-ccamp-l1csm-yang-01

Hi all,

Thanks
Fatai & Daniele

---

From: shiyan49 <[email-masked]>
Date: Mon, 16 Apr 2018 10:13:36 +0800

Hi, all

Yes, support.

Thanks.

——————————————————————
师严 SHI Yan
网络技术研究部(Department of Network Technology )  
中国联通网络技术研究院 (China Unicom Network Technology Research Institute) 
通信地址：北京市首体南路9号主语国际#3号楼, 100048
Addr: No.9 South Shouti Road, BLDG 3, Beijing, China, 100048 
Phone：010-68799999-7253/18601106693
Email: [email-masked]
 
From: Zhangfatai (Fatai Zhang)
Date: 2018-04-10 10:01
To: CCAMP ([email-masked])
CC: [email-masked]; [email-masked]
Subject: [CCAMP] WG adoption poll on draft-fioccola-ccamp-l1csm-yang-01
Hi all,
We now have the IPR declaration replies from all the authors/contributors (Please see https://datatracker.ietf.org/doc/draft-fioccola-ccamp-l1csm-yang/history/) and no IPR was disclosed against this document.
This starts a two weeks poll on making [draft-fioccola-ccamp-l1csm-yang-01] a CCAMP working group document.
Please send email to the list indicating "yes/support" or "no/do not support" and a motivation for your reply, mandatory for the "not support" and nice to have for the "support".
The polling ends on April 24th , 2018.
 
Thanks
Fatai & Daniele

---

From: "Belotti, Sergio (Nokia - IT/Vimercate)" <[email-masked]>
Date: Mon, 16 Apr 2018 06:50:23 +0000

Hello chairs, CCAMPers,

yes/support

Thanks
Sergio

Hi all,

Thanks
Fatai & Daniele

---

From: 이광국(Network Intelligence Proj) <[email-masked]>
Date: Mon, 16 Apr 2018 23:01:03 +0000

Yes/Support

Best regards,
Kwang-koog Lee (KT)

From: Zhenghaomian (Zhenghaomian, Optical &Microwave Technology Research Dept) [mailto:[email-masked]]
Sent: Monday, April 16, 2018 10:53 AM
To: Zhangfatai (Fatai Zhang) <[email-masked]>; CCAMP ([email-masked]) <[email-masked]>
Cc: [email-masked]; [email-masked]
Subject: 答复: WG adoption poll on draft-fioccola-ccamp-l1csm-yang-01

Yes/Support.

Best wishes,
Haomian

发件人: CCAMP [mailto:[email-masked]] 代表 Zhangfatai (Fatai Zhang)
发送时间: 2018年4月10日 10:01
收件人: CCAMP ([email-masked]<mailto:[email-masked]>) <[email-masked]<mailto:[email-masked]>>
抄送: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
主题: [CCAMP] WG adoption poll on draft-fioccola-ccamp-l1csm-yang-01

Hi all,

Thanks
Fatai & Daniele

이 메일은 지정된 수취인만을 위해 작성되었으며, 중요한 정보나 저작권을 포함하고 있을 수 있습니다. 어떠한 권한 없이, 본 문서에 포함된 정보의 전부 또는 일부를 무단으로 제3자에게 공개, 배포, 복사 또는 사용하는 것을 엄격히 금지합니다. 만약, 본 메일이 잘못 전송된 경우, 발신인 또는 당사에 알려주시고, 본 메일을 즉시 삭제하여 주시기 바랍니다.
This E-mail may contain confidential information and/or copyright material. This email is intended for the use of the addressee only. If you receive this email by mistake, please either delete it without reproducing, distributing or retaining copies thereof or notify the sender immediately.

---

From: Dieter Beller <[email-masked]>
Date: Thu, 19 Apr 2018 19:06:55 +0200

Hi all,

yes/support

Thanks,

Dieter

On 10.04.2018 04:01, Zhangfatai (Fatai
Zhang) wrote:

Hi all,

We now have the IPR
declaration replies from all the authors/contributors
(Please see

https://datatracker.ietf.org/doc/draft-fioccola-ccamp-l1csm-yang/history/)
and no IPR was disclosed against this document.

This starts a two
weeks poll on making [draft-fioccola-ccamp-l1csm-yang-01] a
CCAMP working group document.

Please send email to
the list indicating "yes/support" or "no/do not support" and
a motivation for your reply, mandatory for the "not support"
and nice to have for the "support".

The polling ends on
April 24th , 2018.

Thanks

Fatai & Daniele

---

From: "Zhangfatai (Fatai Zhang)" <[email-masked]>
Date: Mon, 23 Apr 2018 07:51:19 +0000

Hi Tom and all,

Thank you all for your valuable comments.

From a chair point of view, I would like to agree with Young and Daniele that WG adoption means that this draft is a good foundation for this topic (not a completion of the draft), and there are plenty of opportunities to refine this draft (e.g., splitting the text) by WG process.

We could make a decision on the poll by weighing the support from the WG.

Thanks

Fatai

-----邮件原件-----
发件人: Daniele Ceccarelli [mailto:[email-masked]]
发送时间: 2018年4月11日 23:48
收件人: t.petch <[email-masked]>; Leeyoung <[email-masked]>; Zhangfatai (Fatai Zhang) <[email-masked]>; [email-masked]
抄送: [email-masked]; [email-masked]
主题: RE: [CCAMP] WG adoption poll on draft-fioccola-ccamp-l1csm-yang-01

Hi Tom,

BR

Daniele

> To: Leeyoung <[email-masked]<mailto:[email-masked]>>; Zhangfatai (Fatai Zhang)

> <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>

> Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>

> Subject: Re: [CCAMP] WG adoption poll on

> draft-fioccola-ccamp-l1csm-yang-

> 01

> */ or perhaps as far as

>             "ER4-PMD-clause-88 Optical Interface function for

> 100GBASE-R PCS- 82"; (these last I am less familiar with compared to

> GigE, STM, OC etc))

> different places without good cause, and I struggle to think of such a cause.

> microwave radio where having two YANG modules in one RFC seems ok

> since the scope for reuse of the 'enumerations' seems more limited).

> From: "Leeyoung" <[email-masked]<mailto:[email-masked]>>

> To: "t.petch" <[email-masked]<mailto:[email-masked]>>; "Zhangfatai (Fatai Zhang)"

> <[email-masked]<mailto:[email-masked]>>; <[email-masked]<mailto:[email-masked]>>

> Cc: <[email-masked]<mailto:[email-masked]>>;

> <[email-masked]<mailto:[email-masked]>>

> I agree with you. We can improve the model using types statement

> instead of the enumeration of the list.

> Cc:[email-masked],draft- [email-masked]<mailto:[email-masked]>,

> I can't help thinking that this I-D may indicate a failure of the WG

> to be a WG:- (

> I see a very long list of enumerations/identities for Gigabit

> Ethernet, Fiber channel, STM, OC, etc

> 'types' module for generic use, IETF and even non-IETF, the way in

> which the Netmod WG has done for Interfaces, and other WGs - CCAMP -

> did many years earlier for MIB Modules.

> From: "Zhangfatai (Fatai Zhang)" <[email-masked]<mailto:[email-masked]>>

> To: <[email-masked]<mailto:[email-masked]>>

> Cc: <[email-masked]<mailto:[email-masked]>>;

> <[email-masked]<mailto:[email-masked]>>

> Subject: [CCAMP] WG adoption poll on

> https://datatracker.ietf.org/doc/draft-fioccola-ccamp-l1csm-

> and a motivation for your reply, mandatory for the "not support" and

> nice to have for the "support".

> ----------------------------------------------------------------------

> --

> > [email-masked]<mailto:[email-masked]>

---

From: "Zhangfatai (Fatai Zhang)" <[email-masked]>
Date: Tue, 24 Apr 2018 06:37:44 +0000

Hi all,
The WG adoption poll is closed and I see lots of support.
Authors,
Please republish [draft-fioccola-ccamp-l1csm-yang-01] as [draft-ietf-ccamp-l1csm-yang-00] with only the date and file name changed.
Please discuss the comments raised during the adoption poll on the list and have them addressed in the -01 version of the WG draft if needed.

Thanks

Fatai & Daniele

Hi all,

Thanks
Fatai & Daniele