Subject: [CCAMP] Opsdir last call review of draft-ietf-ccamp-microwave-framework-05

From: Tianran Zhou <[email-masked]>
Date: Fri, 20 Apr 2018 21:57:40 -0700

Reviewer: Tianran Zhou
Review result: Has Issues

I have reviewed this document as part of the Operational directorate's ongoing
effort to review all IETF documents being processed by the IESG.  These
comments were written with the intent of improving the operational aspects of
the IETF drafts. Comments that are not addressed in last call may be included
in AD reviews during the IESG review.  Document editors and WG chairs should
treat these comments just like any other last call comments.

Document reviewed: draft-ietf-ccamp-microwave-framework-05
Intended Status: Informational

Summary:
In general, this document is clear to me. I did not see any special operational
or network management related issue. But there are several minor issues, for
the authors consideration.

Minor issues:
1. The last sentence in the abstract confused me.
"Some parts of the resulting model may be generic which could also be used by
other technologies." Both "some parts" and "other technologies" are not clear,
which makes this words meaningless. At least, you may say what kind of
technologies may reuse this model.

2. Both "packet interfaces" and "packet functionality" are not clear to me.
Those terminologies appear many times in the draft. I am not familiar with
transport network, not sure if those terminologies are commonly used. I think
it's better to say "packet transport (link) interface" or so, compared to
"radio link interface".

3. There are two solutions, "Network management solutions" and "SDN solution",
under the Section 3. But: Firstly, it's hard to distinguish the network
management and SDN, IMHO. Secondly, you actually did not describe the network
management solution. I think the SDN solution is the way you used in the
framework. Your following use cases and modelling requirements are all based on
the the so called SDN solution. So, I would suggest you do not distinguish
network management solution and SDN solution. But only to say "this is the
target solution to manage and control radio link interface" in your proposed
framework.

4. You may need to update the contributors section. As far as I know, some
people's contact and affiliation changed.

---

From: Jonas Ahlberg <[email-masked]>
Date: Wed, 25 Apr 2018 19:20:52 +0000

Hi Tianran,

Thank you for reviewing the microwave framework document.

We will address your comments in the next revision of the document.

Regards
JonasA

-----Original Message-----
From: Tianran Zhou [mailto:[email-masked]] 
Sent: den 21 april 2018 06:58
To: [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Opsdir last call review of draft-ietf-ccamp-microwave-framework-05

Reviewer: Tianran Zhou

I have reviewed this document as part of the Operational directorate's ongoing effort to review all IETF documents being processed by the IESG.  These comments were written with the intent of improving the operational aspects of the IETF drafts. Comments that are not addressed in last call may be included in AD reviews during the IESG review.  Document editors and WG chairs should treat these comments just like any other last call comments.

Summary:
In general, this document is clear to me. I did not see any special operational or network management related issue. But there are several minor issues, for the authors consideration.

Minor issues:
1. The last sentence in the abstract confused me.
"Some parts of the resulting model may be generic which could also be used by other technologies." Both "some parts" and "other technologies" are not clear, which makes this words meaningless. At least, you may say what kind of technologies may reuse this model.

2. Both "packet interfaces" and "packet functionality" are not clear to me.
Those terminologies appear many times in the draft. I am not familiar with transport network, not sure if those terminologies are commonly used. I think it's better to say "packet transport (link) interface" or so, compared to "radio link interface".

3. There are two solutions, "Network management solutions" and "SDN solution", under the Section 3. But: Firstly, it's hard to distinguish the network management and SDN, IMHO. Secondly, you actually did not describe the network management solution. I think the SDN solution is the way you used in the framework. Your following use cases and modelling requirements are all based on the the so called SDN solution. So, I would suggest you do not distinguish network management solution and SDN solution. But only to say "this is the target solution to manage and control radio link interface" in your proposed framework.

4. You may need to update the contributors section. As far as I know, some people's contact and affiliation changed.