Subject: [CCAMP] I-D Action: draft-ietf-ccamp-l1csm-yang-02.txt

From: [email-masked]
Date: Wed, 20 Jun 2018 08:39:27 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Common Control and Measurement Plane WG of the IETF.

        Title           : A Yang Data Model for L1 Connectivity Service Model (L1CSM)
        Authors         : G. Fioccola
                          K. Lee
                          Y. Lee
                          D. Dhody
                          D. Ceccarelli
	Filename        : draft-ietf-ccamp-l1csm-yang-02.txt
	Pages           : 24
	Date            : 2018-06-20

Abstract:
   This document provides a YANG data model for Layer 1 Connectivity
   Service Model (L1CSM).

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-ccamp-l1csm-yang/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-ccamp-l1csm-yang-02
https://datatracker.ietf.org/doc/html/draft-ietf-ccamp-l1csm-yang-02

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-ccamp-l1csm-yang-02

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Leeyoung <[email-masked]>
Date: Wed, 20 Jun 2018 15:49:51 +0000

Hi,

The revision incorporated comments received from the last CCAMP meeting and the MEF Q2 meeting in April.  

I believe the draft is stable. Please feel free to provide your feedback. 
Thanks & best regards,

Young (on behalf of other co-authors)

-----Original Message-----
From: CCAMP [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Wednesday, June 20, 2018 10:39 AM
To: [email-masked]
Cc: [email-masked]
Subject: [CCAMP] I-D Action: draft-ietf-ccamp-l1csm-yang-02.txt

Abstract:

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

_______________________________________________
CCAMP mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ccamp

---

From: "t.petch" <[email-masked]>
Date: Thu, 21 Jun 2018 12:29:57 +0100

----- Original Message -----
From: "Leeyoung" <[email-masked]>
To: <[email-masked]>
Cc: "Martin, David (Nokia - CA/Ottawa)" <[email-masked]>
Sent: Wednesday, June 20, 2018 4:49 PM

> I believe the draft is stable.

I hope not:-)

I find it hard to read; the indentation is, for me excessive, causing
lines to spill off the page.  You are indenting each lower level in the
YANG model by 10 spaces whereas I would prefer you followed in the
footsteps of
draft-ietf-ccamp-mw-yang
which uses two.

The tree diagram notation is now an RFC and I would expect you to
reference that and not include your own notation, again as in
draft-ietf-ccamp-mw-yang

5 Security Considerations needs to call out the sensitive nodes by name
or say that there are none, again as in
draft-ietf-ccamp-mw-yang-.

The YANG modules need Copyright as in
draft-ietf-ccamp-mw-yang

The Introduction needs to say whether or not the YANG module is NMDA
compatible, as in
draft-ietf-ccamp-mw-yang

The import in the YANG modules should have reference statements, as in
draft-ietf-ccamp-mw-yang

You need references in the I-D for YANG and Netconf, as in
draft-ietf-ccamp-mw-yang

I would expect to see examples, as in
draft-ietf-ccamp-mw-yang

I think that some abbreviations should be expanded in the definitions
 SLS
UNI
PE
CE
p,c,o

I wonder if the future would be simpler if the protocol types were
grouped, eg into Ethernet, FiberChannel, STM etc.  It depends how they
will be used, but I would expect there to be conditional statements
based on these groups.Your view of what makes a sensible group will be
better than mine but I think that the current flat structure is unlikely
to be easy to use.  A comparable change was introduced after the YANG
doctor review of
draft-ietf-ccamp-mw-yang

Tom Petch

                                Please feel free to provide your
feedback.
> Please note that it may take a couple of minutes from the time of
submission until the htmlized version and diff are available at
tools.ietf.org.

---

From: Leeyoung <[email-masked]>
Date: Thu, 21 Jun 2018 13:39:21 +0000

Hi Tom,

Thank you for providing good and constructive comments. I would take most of your concerns/comments; basically we have a good model to look after - microwave yang model :) 

In regards to your last comment on the protocol types grouping, I would defer to yang doctor review. The list is enumerated as flat by the MEF reference document: "Subscriber Layer 1 Connectivity Service Attributes", Working Draft (WD) v0.09 December 13, 2017. 

Best regards,
Young

-----Original Message-----
From: t.petch [mailto:[email-masked]] 
Sent: Thursday, June 21, 2018 6:30 AM
To: Leeyoung <[email-masked]>; [email-masked]
Cc: Martin, David (Nokia - CA/Ottawa) <[email-masked]>
Subject: Re: [CCAMP] FW: I-D Action: draft-ietf-ccamp-l1csm-yang-02.txt

----- Original Message -----
From: "Leeyoung" <[email-masked]>
To: <[email-masked]>
Cc: "Martin, David (Nokia - CA/Ottawa)" <[email-masked]>
Sent: Wednesday, June 20, 2018 4:49 PM

I hope not:-)

I find it hard to read; the indentation is, for me excessive, causing lines to spill off the page.  You are indenting each lower level in the YANG model by 10 spaces whereas I would prefer you followed in the footsteps of draft-ietf-ccamp-mw-yang which uses two.

The tree diagram notation is now an RFC and I would expect you to reference that and not include your own notation, again as in draft-ietf-ccamp-mw-yang

5 Security Considerations needs to call out the sensitive nodes by name or say that there are none, again as in draft-ietf-ccamp-mw-yang-.

The Introduction needs to say whether or not the YANG module is NMDA compatible, as in draft-ietf-ccamp-mw-yang

The import in the YANG modules should have reference statements, as in draft-ietf-ccamp-mw-yang

You need references in the I-D for YANG and Netconf, as in draft-ietf-ccamp-mw-yang

I think that some abbreviations should be expanded in the definitions  SLS UNI PE CE p,c,o

I wonder if the future would be simpler if the protocol types were grouped, eg into Ethernet, FiberChannel, STM etc.  It depends how they will be used, but I would expect there to be conditional statements based on these groups.Your view of what makes a sensible group will be better than mine but I think that the current flat structure is unlikely to be easy to use.  A comparable change was introduced after the YANG doctor review of draft-ietf-ccamp-mw-yang

Tom Petch

                                Please feel free to provide your feedback.
> Please note that it may take a couple of minutes from the time of
submission until the htmlized version and diff are available at tools.ietf.org.