Subject: [CCAMP] draft-ietf-ccamp-alarm-module-01, Missing Alarm Attributes

From: Marta Seda <[email-masked]>
Date: Thu, 28 Jun 2018 00:01:49 +0000

Hi Stefan,
Thank you for the updated draft v-(01) CCAMP Alarm Module.  This draft is missing alarm attributes.  I have attached an excel spreadsheet to illustrate the question.  The attachment contains two tables:

  *   Alarm-fields for alarm inventory
  *   Alarm-fields for alarm instances

Both tables compare the list of supported CCAMP alarm attributes for different "specialized" alarm types (e.g., sensor alarms, E.720-like grade of service alarms (alarms risen under certain traffic conditions), security alarms and MEF 35.1 Stateful Events Alarms).

For each attribute, traceability to which standards discusses these attributes is included in the attachment.

If one examines the differences, the following alarm attributes are not included in the CCAMP alarm module:

  *   Service-effect (GR-833 defines alarm attribute - only included this in case vendors need to support this alarm attribute for legacy reasons)
  *   Threshold information (x.733, 3GPP TS 32.111-2 , M.3100)
  *   Monitored attributes (x.733, 3GPP TS 32.111-2 , M.3100)
  *   Proposed repair actions (x.733, 3GPP TS 32.111-2 , M.3100)
  *   Tca-type (MEF35.1 specific attribute)
  *   Security alarm detector (x.736, 3GPP TS 32.111-2)
  *   Security alarm cause (x.736, 3GPP TS 32.111-2)
  *   Service user (x.736, 3GPP TS 32.111-2)
  *   Service provider (x.736, 3GPP TS 32.111-2)
  *   Additional information (3GPP TS 32.111-2, X.736, X.733)

For the X.733 traceable alarm attributes, these attributes are considered "optional" in nature.  On the other hand, X.736 considers the security attributes (starting with "security-x") as mandatory.

Discussion:
a) Is there any particular reason for the omission of these attributes?
b) Are there any plans to support any of these attributes in the CCAMP Alarm module in the future?  Or do you view these attributes as outside of the IETF CCAMP scope (and therefore if someone needs these particular attributes they can augment the IETF CCAMP YANG?  I am attempting to understand the boundaries of what CCAMP intends to cover.

Best Regards,

Marta Seda

---

From: Marta Seda <[email-masked]>
Date: Thu, 28 Jun 2018 17:48:35 +0000

When I checked this morning on any responses, I noticed that the IETF tool shows a link to the attachment I added (titled "alarm-attributes-per-alarm-type.xlsx").  When I attempted to open the attachment, I get a weird document popping up called "binwXkaMBWy57.bin" (it is not an excel spreadsheet).  Not sure what is going on (if the issue is the IETF tool OR a local problem on my laptop).  I don't know if others are experiencing this problem.

Let's try instead a .pdf file output to see if that works (maybe the tool will store and allow retrieving of the pdf file).  Hope this attachment variant works.

Regards,

Marta

From: Marta Seda
Sent: Wednesday, June 27, 2018 5:02 PM
To: [email-masked]
Subject: [CCAMP] draft-ietf-ccamp-alarm-module-01, Missing Alarm Attributes

Hi Stefan,

Discussion:

Best Regards,

Marta Seda

---

From: Daniele Ceccarelli <[email-masked]>
Date: Fri, 29 Jun 2018 14:54:54 +0000

Hi Marta,

first of all thanks for sharing your comments. The excel file attached to your mail worked well for me.
I'll let Stefan and the working group reply on what is planned to be supported, but what I can tell is that despite there are alarms in your list that seem not to be strictly related to CCAMP charter and domain competence (well, you're bringing that competence to CCAMP with your contribution, review and proposal right now) I would prefer to deliver a document that covers al the aspects of alarms.
I'm not thinking of a fully comprehensive document that doesn't need any augmentation at all but also not a document that needs to be augmented from day 1 to build something deliverable.

There are probably topics that might fit into an augmentation as self contained one a clearly belonging to other domain competence (e.g. security ?), but this is again something we need to discuss.

Thanks
Daniele

From: CCAMP <[email-masked]> On Behalf Of Marta Seda
Sent: giovedì 28 giugno 2018 19:49
To: [email-masked]
Subject: Re: [CCAMP] draft-ietf-ccamp-alarm-module-01, Missing Alarm Attributes

When I checked this morning on any responses, I noticed that the IETF tool shows a link to the attachment I added (titled "alarm-attributes-per-alarm-type.xlsx").  When I attempted to open the attachment, I get a weird document popping up called "binwXkaMBWy57.bin" (it is not an excel spreadsheet)..  Not sure what is going on (if the issue is the IETF tool OR a local problem on my laptop).  I don't know if others are experiencing this problem.

Regards,

Marta

From: Marta Seda
Sent: Wednesday, June 27, 2018 5:02 PM
To: [email-masked]<mailto:[email-masked]>
Subject: [CCAMP] draft-ietf-ccamp-alarm-module-01, Missing Alarm Attributes

Hi Stefan,

Discussion:

Best Regards,

Marta Seda