Subject: [CCAMP] I-D Action: draft-ietf-ccamp-dwdm-if-mng-ctrl-fwk-10.txt

From: [email-masked]
Date: Wed, 06 Jun 2018 09:17:48 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Common Control and Measurement Plane WG of the IETF.

        Title           : A framework for Management and Control of DWDM optical interface parameters
        Authors         : Ruediger Kunze
                          Gert Grammel
                          Dieter Beller
                          Gabriele Galimberti
                          Julien Meuric
	Filename        : draft-ietf-ccamp-dwdm-if-mng-ctrl-fwk-10.txt
	Pages           : 31
	Date            : 2018-06-06

Abstract:
   The control and management of DWDM interfaces are a precondition for
   enhanced multilayer networking.  They are needed to ensure an
   efficient data transport, to meet the requirements requested by
   today's IP-services and to provide a further automation of network
   provisioning and operations.  This document describes use cases,
   requirements and solutions for the control and management of optical
   interface parameters according to different types of single channel
   DWDM interfaces.  The focus is on automating the network provisioning
   process irrespective on how it is triggered i.e. by Element Manager
   System (EMS), Network Management System (NMS) or Generalized Multi
   Protocol Label Switching (GMPLS).  This document covers management
   and control considerations in different scenarios of single channel
   DWDM interfaces.  The purpose is to identify the necessary
   information and processes to be used by control or management systems
   to properly and efficiently drive the network.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-ccamp-dwdm-if-mng-ctrl-fwk/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-ccamp-dwdm-if-mng-ctrl-fwk-10
https://datatracker.ietf.org/doc/html/draft-ietf-ccamp-dwdm-if-mng-ctrl-fwk-10

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-ccamp-dwdm-if-mng-ctrl-fwk-10

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Gabriele Maria Galimberti (ggalimbe)" <[email-masked]>
Date: Wed, 6 Jun 2018 16:34:51 +0000

Dear All, 

This new draft is addressing the [RTG-DIR] RtgDir review: draft-ietf-ccamp-dwdm-if-mng-ctrl-fwk-09 
Review made by Dhruv.

Dhruv please let us know any feedbacks and further suggestions.

Thanks a lot, 

Best Regards, 

The Authors

Gabriele Galimberti
Principal Engineer
Cisco Photonics Srl

via S.Maria Molgora, 48 C
20871 - Vimercate (MB)
Italy
www.cisco.com/global/IT/ <http://www.cisco.com/global/IT/>

[email-masked]
Phone :+39 039 2091462
Mobile :+39 335 7481947
Fax :+39 039 2092049

On 06/06/2018, 18:17, "CCAMP on behalf of [email-masked]" <[email-masked] on behalf of [email-masked]> wrote:

    
    Abstract:

    

    _______________________________________________
    CCAMP mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/ccamp

---

From: Dhruv Dhody <[email-masked]>
Date: Thu, 7 Jun 2018 03:32:22 +0000

Hi Gabriele, 

Thanks for handling my comments. Just a few suggestions - 

- I am not sure if use of wordings from an IESG statement is wise in an I-D. How about we just simply say - 

   The YANG based NETCONF and RESTCONF protocol are better suited for
   creating and modifying configuration state and thus RECOMMENDED to be
   used over SNMP MIB.

- Regarding this text in 4.1.1 
 
   Is to be noted that the CL (client device) and the DWDM network are
   belonging to the same operator so the DWDM EMS and the Client devices
   are connected to the same DCN and the communication is not affected
   by security issue.

   True, but we can't say that it is not affected by security issues. Maybe reword to say that the existing security consideration continue to apply to CL? It is important that the recommended security settings used while using NetConf/RestConf/SNMP. 

- Move the Appendix to the end of the document (out of the main body). Add a note that this is the information at the time of publication of the document and thus subject to change. 

Thanks! 
Dhruv

> -----Original Message-----
> From: CCAMP [mailto:[email-masked]] On Behalf Of Gabriele Maria
> Galimberti (ggalimbe)
> Sent: 06 June 2018 22:05
> To: [email-masked]; [email-masked]
> Cc: [email-masked]
> Subject: Re: [CCAMP] I-D Action: draft-ietf-ccamp-dwdm-if-mng-ctrl-fwk-
> 10.txt
> 
> Dear All,
> 
> On 06/06/2018, 18:17, "CCAMP on behalf of [email-masked]"
> <[email-masked] on behalf of [email-masked]> wrote:
> 
>

---

From: "Gabriele Maria Galimberti (ggalimbe)" <[email-masked]>
Date: Mon, 11 Jun 2018 09:35:09 +0000

Hi Dhruv, 

Thanks a lot for your final comments, really appreciate !
I’ve submitted the -11 version of the doc. to address them (see attached mail).

Best Regards, 

Gabriele

Gabriele Galimberti
Principal Engineer
Cisco Photonics Srl

[email-masked]
Phone :+39 039 2091462
Mobile :+39 335 7481947
Fax :+39 039 2092049

On 07/06/2018, 05:32, "CCAMP on behalf of Dhruv Dhody" <[email-masked] on behalf of [email-masked]> wrote:

    Hi Gabriele, 

    

    

    Thanks! 
    Dhruv

Subject: New Version Notification for draft-ietf-ccamp-dwdm-if-mng-ctrl-fwk-11.txt
From: <[email-masked]>
To: Gert Grammel <[email-masked]>, <[email-masked]>, "Julien Meuric" <[email-masked]>, Gabriele Galimberti <[email-masked]>, Ruediger Kunze <[email-masked]>, Dieter Beller <[email-masked]>, Ruediger Kunze <[email-masked]>
Date: Mon, 11 Jun 2018 02:30:28 -0700

A new version of I-D, draft-ietf-ccamp-dwdm-if-mng-ctrl-fwk-11.txt
has been successfully submitted by Gabriele Galimberti and posted to the
IETF repository.

Name:		draft-ietf-ccamp-dwdm-if-mng-ctrl-fwk
Revision:	11
Title:		A framework for Management and Control of DWDM optical interface parameters
Document date:	2018-06-11
Group:		ccamp
Pages:		30
URL:            https://www.ietf.org/internet-drafts/draft-ietf-ccamp-dwdm-if-mng-ctrl-fwk-11.txt
Status:         https://datatracker.ietf.org/doc/draft-ietf-ccamp-dwdm-if-mng-ctrl-fwk/
Htmlized:       https://tools.ietf.org/html/draft-ietf-ccamp-dwdm-if-mng-ctrl-fwk-11
Htmlized:       https://datatracker.ietf.org/doc/html/draft-ietf-ccamp-dwdm-if-mng-ctrl-fwk
Diff:           https://www.ietf.org/rfcdiff?url2=draft-ietf-ccamp-dwdm-if-mng-ctrl-fwk-11

Abstract:

The IETF Secretariat