Subject: [CCAMP] IETF 102 - CCAMP agenda puslished

From: Daniele Ceccarelli <[email-masked]>
Date: Thu, 5 Jul 2018 07:37:40 +0000

Hi CCAMP,

the first draft of the agenda for IETF102 has been published and can be found at the following link: https://datatracker.ietf.org/meeting/102/materials/agenda-102-ccamp-00

Thanks,
Daniele, Fatai, Oscar

---

From: stefan vallin <[email-masked]>
Date: Tue, 10 Jul 2018 10:59:27 +0200

Hi All!
Based on Martas input I have now added all X733/X736 to the augmenting ietf-alarms-x733.yang module.
(The current version only has event-type and probable cause).

Before me and Martin publishes a new version we would like to have input from Marta and ITU on the mapping.
I have used the original ITU ASN.1 module as source, but in many cases I need to relax to strings.
See for example additional-information and its ASN.1 definition. I have made a middle-ground mapping.
Some alarm systems just use a single string, I have kept the three parameters.
This makes me wonder how useful this really is?

Attaching the x733 module as well for feedback.

Since all these are optional and non-config I have not if-featured them.

 augment /al:alarms/al:alarm-list/al:alarm:
    +--ro event-type?                event-type
    +--ro probable-cause?            uint32
    +--ro probable-cause-string?     string
    +--ro threshold-information
    |  +--ro triggered-threshold?   string
    |  +--ro observed-value?        value-type
    |  +--ro (threshold-level)?
    |  |  +--:(up)
    |  |  |  +--ro up-high?         value-type
    |  |  |  +--ro up-low?          value-type
    |  |  +--:(down)
    |  |     +--ro down-low?        value-type
    |  |     +--ro down-high?       value-type
    |  +--ro arm-time?              yang:date-and-time
    +--ro monitored-attributes* []
    |  +--ro id?      al:resource
    |  +--ro value?   string
    +--ro proposed-repair-actions*   string
    +--ro trend-indication?          trend
    +--ro backedup-status?           boolean
    +--ro backup-object?             al:resource
    +--ro additional-information* []
    |  +--ro identifier?    string
    |  +--ro significant?   boolean
    |  +--ro information?   string
    +--ro security-alarm-detector?   al:resource
    +--ro service-user?              al:resource
    +--ro service-provider?          al:resource

Br Stefan