Subject: Re: [CCAMP] I-D Action: draft-ietf-ccamp-alarm-module-06.txt

From: NICK HANCOCK <[email-masked]>
Date: Mon, 3 Dec 2018 11:16:17 +0000

Hi Stefan,

I am very happy with the progress of the YANG Alarm Module and fully support it.

There is, however, some uncertainty regarding how alarm severities are to be listed within the alarm inventory as a result of the configuration of alarm profiles that modify the alarm severity of a given alarm type for a specific set of resources only.

Since the alarm inventory is not keyed by resource, how can the modified alarm severity for the given subset of resources be unambiguously displayed in the alarm inventory?

Best regards
Nick

From: CCAMP [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Thursday, November 22, 2018 8:48 AM
To: [email-masked]
Cc: [email-masked]
Subject: [CCAMP] I-D Action: draft-ietf-ccamp-alarm-module-06.txt

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Common Control and Measurement Plane WG of the IETF.

Title : YANG Alarm Module
Authors : Stefan Vallin
Martin Bjorklund
Filename : draft-ietf-ccamp-alarm-module-06.txt
Pages : 79
Date : 2018-11-21

Abstract:
This document defines a YANG module for alarm management. It
includes functions for alarm list management, alarm shelving and
notifications to inform management systems. There are also
operations to manage the operator state of an alarm and
administrative alarm procedures. The module carefully maps to
relevant alarm standards.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-ccamp-alarm-module/<https://datatracker.ietf.org/doc/draft-ietf-ccamp-alarm-module/>

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-ccamp-alarm-module-06<https://tools.ietf.org/html/draft-ietf-ccamp-alarm-module-06>
https://datatracker.ietf.org/doc/html/draft-ietf-ccamp-alarm-module-06<https://datatracker.ietf.org/doc/html/draft-ietf-ccamp-alarm-module-06>

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-ccamp-alarm-module-06<https://www.ietf.org/rfcdiff?url2=draft-ietf-ccamp-alarm-module-06>

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/<ftp://ftp.ietf.org/internet-drafts/>

_______________________________________________
CCAMP mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ccamp<https://www.ietf.org/mailman/listinfo/ccamp>

---

From: stefan vallin <[email-masked]>
Date: Wed, 5 Dec 2018 09:52:16 +0100

Hi Nick!
Thanks for your continuous support in this effort. 

To your question/comment:
First of all the main purpose of the alarm inventory is to publish which candidate alarm types a specific system has.
This in order for operations and automation engines be prepared with corrective actions. Principle of least surprise.
Motivation:
- Not all alarm identities are implemented by all systems, and some alarm identities are abstract
- Publish any alarm qualifiers

The purpose is not to get a fine-grained mapping including which resources might have a specific severity. Just a coarse grained optional information per alarm type regarding possible resources and severity levels overall for the alarm type.

Again, the main purpose is to answer the question “which alarm types?”

Therefore in your example of alarm severity assignment profile, you would just add resources and severity levels to the leaf-lists for that alarm-type.
You will not be able to find a specific resource-severity mapping in the alarm inventory, this is not the purpose.

br Stefan and Martin

> On 3 Dec 2018, at 12:16, NICK HANCOCK <[email-masked]> wrote:
> 
> Hi Stefan,
>  
>  <>From: CCAMP [mailto:[email-masked] <mailto:[email-masked]>] On Behalf Of [email-masked] <mailto:[email-masked]>
> To: [email-masked] <mailto:[email-masked]>
> Cc: [email-masked] <mailto:[email-masked]>
> https://datatracker.ietf.org/doc/draft-ietf-ccamp-alarm-module/ <https://datatracker.ietf.org/doc/draft-ietf-ccamp-alarm-module/>
> 
> https://tools.ietf.org/html/draft-ietf-ccamp-alarm-module-06 <https://tools.ietf.org/html/draft-ietf-ccamp-alarm-module-06>
> https://datatracker.ietf.org/doc/html/draft-ietf-ccamp-alarm-module-06 <https://datatracker.ietf.org/doc/html/draft-ietf-ccamp-alarm-module-06>
> 
> https://www.ietf.org/rfcdiff?url2=draft-ietf-ccamp-alarm-module-06 <https://www.ietf.org/rfcdiff?url2=draft-ietf-ccamp-alarm-module-06>
> 
> 
> until the htmlized version and diff are available at tools.ietf.org <http://tools.ietf.org/>.
> 
> ftp://ftp.ietf.org/internet-drafts/ <ftp://ftp.ietf.org/internet-drafts/>
> 
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/ccamp <https://www.ietf.org/mailman/listinfo/ccamp>