Subject: [CCAMP] Review of alarm-module-06

From: "Beauville, Yves (Nokia - BE/Antwerp)" <[email-masked]>
Date: Mon, 3 Dec 2018 07:51:31 +0000

Hi Stefan,

I am very happy with the outcome of the reviews of the alarm module. I fully support it.

I have one comment though, hopefully easy to address.

I have noticed an inconsistency with X.733. In section 8.1.2.3, Perceived severity, of the CCITT specification, the following is documented:

>> Those severity levels which represent service affecting conditions ordered from most severe to least severe are Critical, Major, Minor and Warning

In the alarm-module-06, the type 'severity' is defined as below (omitting the descriptions):

     typedef severity {
       type enumeration {
         enum indeterminate {
           value 2;
         }
         enum minor {
           value 3;
         }
         enum warning {
           value 4;
         }
         enum major {
           value 5;
         }
         enum critical {
           value 6;
       }

The enum value provided for 'minor' and 'warning' is not consistent with the severity ordering defined in X.733.

The severity order is relevant in the IETF model when using severity filters with 'above' or 'below' criteria.

Should we swap the order (and enum values) of 'minor' and 'warning' in the above type definition?

Thanks
Yves

---

From: stefan vallin <[email-masked]>
Date: Mon, 3 Dec 2018 10:43:55 +0100

Hi Yves!
Oops, thanks for catching this!
We will fix
br Stefan

> On 3 Dec 2018, at 08:51, Beauville, Yves (Nokia - BE/Antwerp) <[email-masked]> wrote:
> 
> Hi Stefan,
>