Subject: [CCAMP] hi! two I-Ds about FlexE posted. Suggestions and comments are welcome. Thanks!

From: <[email-masked]>
Date: Fri, 22 Mar 2019 10:21:09 +0800 (CST)

hi,

We've posted two I-Ds about FlexE, shown in following links.

draft-wang-ccamp-flexe-control-analysis 

draft-xiaobn-ccamp-flexe-yang-mod 

Suggestions and comments are welcome.

Thanks!

BRs,

牛小兵     Xiaobing NIU

E: [email-masked]

www.zte.com.cn

---

From: tom petch <[email-masked]>
Date: Fri, 22 Mar 2019 12:50:46 +0000

---- Original Message -----
From: <[email-masked]>
Sent: Friday, March 22, 2019 2:21 AM

> Suggestions and comments are welcome.

I notice that you also published, in the run up to the last IETF,
 draft-xiaobn-flexe-yang-mod-00
which looks rather similar, down to the same points that need fixing in
a YANG module, such as:

NMDA support or lack thereof needs mentioning up front

Requirements language needs to refer to RFC8174

The tree diagram should have an Informative Reference to RFC8340 rather
than RYO

Several lines are too long for an RFC making them awkward to read

YANG modules version is 1 while the Introduction references 1.1

YANG modules import statements lack description clauses

YANG modules lack copyright statements

YANG modules lack references e.g. to the FlexE documents

Security considerations is out of date - you need to reference RESTCONF
and TLS 1.3

IANA Considerations needs to specfy prefix

Terminology covers the FlexE terminology but not the YANG terminology
which readers may, or may not, be familiar with.

HTH

Tom Petch

> CCAMP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ccamp
>

---

From: <[email-masked]>
Date: Mon, 25 Mar 2019 10:01:30 +0800 (CST)

Hi Tom,

Thanks a lot for your suggestions! I'll revise the file accordingly.

BRs,

牛小兵     Xiaobing NIU

www.zte.com.cn

原始邮件

发件人：tompetch <[email-masked]>
收件人：牛小兵10019881;[email-masked] <[email-masked]>;
抄送人：[email-masked] <[email-masked]>;
日 期 ：2019年03月22日 20:50
主 题 ：Re: [CCAMP] hi!  two I-Ds about FlexE posted.   Suggestions and comments are welcome. Thanks!

---- Original Message -----
From: <[email-masked]>
Sent: Friday, March 22, 2019 2:21 AM

HTH

Tom Petch