Subject: [CCAMP] Comment on draft-ietf-ccamp-l1csm-yang

From: "Scharf, Michael" <[email-masked]>
Date: Mon, 25 Mar 2019 10:06:37 +0000

Hi all,

In addition to my comment on the mic regarding references for performance metrics definition, I just read the following sentence:

"The Service SDN Controller is the control/management entity owned by higher-layer service department (e.g., L2/3 VPN) whereas the Network SDN Controller is the control/management entity responsible for Layer 1 connectivity service." 

I would suggest to replace "L2/3 VPN" by "L2/L3".

At least for IP VPNs, there are different ways how the IP VPN can be managed. Most importantly, an IP "SDN controller" that would interface the L1 SDN controller may not necessarily deal with IP VPNs. For instance, the IP "SDN controller" that actually is aware of the transport network could be an IP PCE. However, IP VPNs such as L3VPN or VPLS may not be managed by that PCE, but instead they may be configured by yet another software component - these software components could even come from different vendors. I believe it is not uncommon to implement the IP PCE and the IP service provisioning in different software components. IMHO it is also possible that the operational team in the network operator that manages the IP routing infrastructure (e.g. BGP routing) is different to the department that deploys customer-facing IP VPNs on top of that IP network. These IP details actually don't matter for this specific document. But IMHO the document should not make assumptions about the way the IP network is engineered and operated.

My 2 academic cents

Michael

---

From: Leeyoung <[email-masked]>
Date: Mon, 25 Mar 2019 14:18:12 +0000

Hi Michael,

Thanks for your comment. Please see inline for my comment.

Best regards,

Young

-----Original Message-----

From: Scharf, Michael [mailto:[email-masked]]

Sent: Monday, March 25, 2019 5:07 AM

To: [email-masked]

Cc: [email-masked]

Subject: Comment on draft-ietf-ccamp-l1csm-yang

Hi all,

YL>> Will add references for metric definition.

YL>> Would "L2/L3 services" work for you?

My 2 academic cents

Michael

---

From: "Scharf, Michael" <[email-masked]>
Date: Mon, 25 Mar 2019 15:41:51 +0000

Regarding "L2/L3 services": To me that is a synonym of "L2/L3 VPN" and thus it has the same issues.

As far as I am familiar with implementations of IP "SDN controllers", I believe that the software component that would deal with L1 connectivity may not be identical to the software component that manages L2/L3 services. I already mentioned that the former could be a IP PCE while the latter could be a service provisioning tool. I believe that vendors may use different software components for these two functions (disclaimer: this comment is not about products of my former employer).

The wording "L2/L3 services" thus implies a certain software architecture for the IP "SDN controller" and that assumption may not reflect (some) running code.

As I wrote, an easy fix would be just to use the term "L2/L3" as this avoids these subtle issues that are actually orthogonal to this document.

Michael

From: Leeyoung <[email-masked]>
Sent: Monday, March 25, 2019 3:18 PM
To: Scharf, Michael <[email-masked]>; [email-masked]
Cc: [email-masked]
Subject: RE: Comment on draft-ietf-ccamp-l1csm-yang

Hi Michael,

Best regards,

Young

-----Original Message-----

To: [email-masked]<mailto:[email-masked]>

Cc: [email-masked]<mailto:[email-masked]>

Hi all,

My 2 academic cents

Michael