Subject: [CCAMP] WG adoption poll on draft-dharini-ccamp-dwdm-if-param-yang-06

From: Daniele Ceccarelli <[email-masked]>
Date: Mon, 11 Mar 2019 16:41:52 +0000

Working group,

We finally managed to collect all the IPR disclosures and we're ready to
start the WG adoption poll for the dwdm-if drafts (YANG and LMP).

This starts a two weeks poll on making
draft-dharini-ccamp-dwdm-if-param-yang-06 a CCAMP working group document.

Please send email to the list indicating "yes/support" or "no/do not
support" and a motivation for  your reply, mandatory for the "not support"
and nice to have for the "support".

The polling will end on Monday March 25th .

Thanks,

Daniele & Fatai

---

From: "Giovanni Martinelli (giomarti)" <[email-masked]>
Date: Fri, 15 Mar 2019 10:17:01 +0000

yes/support

Cheers
G

On 11 Mar 2019, at 17:41, Daniele Ceccarelli <[email-masked]<mailto:[email-masked]>> wrote:

Working group,

We finally managed to collect all the IPR disclosures and we’re ready to start the WG adoption poll for the dwdm-if drafts (YANG and LMP).

This starts a two weeks poll on making  draft-dharini-ccamp-dwdm-if-param-yang-06 a CCAMP working group document.
Please send email to the list indicating "yes/support" or "no/do not support" and a motivation for  your reply, mandatory for the "not support" and nice to have for the "support".

The polling will end on Monday March 25th ..

Thanks,
Daniele & Fatai

_______________________________________________
CCAMP mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ccamp

---

From: "Beller, Dieter (Nokia - DE/Stuttgart)" <[email-masked]>
Date: Fri, 15 Mar 2019 17:11:23 +0000

Daniele & Fatai, WG,

before replying to the WG adoption poll, I would like to raise a concern:

draft-dharini-ccamp-dwdm-if-param-yang-06 is IMHO opinion overlapping with draft-lee-ccamp-optical-impairment-topology-yang-01 that also defines a YANG model including
optical transponder properties (see https://tools.ietf.org/html/draft-lee-ccamp-optical-impairment-topology-yang-01#section-2.5 and the related YANG model attributes).

As there is a lot of interest in draft-lee-ccamp-optical-impairment-topology-yang-01 on the vendor as well as operator side ( we had weekly calls in the last weeks), the authors
are of the opinion that this draft shall also become a WG draft asap. This is something that should be discussed during the CCAMP session at IETF 104  in Prague.

The concerns are:

  *   How do we ensure consistency between the two drafts? The topology draft has a wider scope but deals with the same information contained in the if-param draft.
  *   The topology draft also defines 2 additional options to address optical transponder properties - the if-param draft only supports 1 out of 3 options!
  *   If draft-dharini-ccamp-dwdm-if-param-yang is defining a device model, an SDN controller must be capable to retrieve the information defined in the topology YANG
from the device in order to construct the topology. Hence model consistency is really a must.

Guidance from the chairs is appreciated.

Thanks,
Sergio and Dieter

On 11.03.2019 17:41, Daniele Ceccarelli wrote:

Working group,

Thanks,

Daniele & Fatai

---

From: Gert Grammel <[email-masked]>
Date: Fri, 15 Mar 2019 20:04:35 +0000

Hi Dieter,

To prepare the discussion, let me address the detailed concerns you identified (inverted sequence).

  *   Q: If draft-dharini-ccamp-dwdm-if-param-yang is defining a device model, an SDN controller must be capable to retrieve the information defined in the topology YANG
from the device in order to construct the topology. Hence model consistency is really a must.
     *   A: draft-dharini-ccamp-dwdm-if-param-yang augments the IETF interface model which makes it a topological entity that is supposed to be used and augmented by other work just like any other interface like Ethernet.

The ietf-ext-xponder-wdm-if is an augment to the ietf-interface.
augment /if:interfaces/if:interface:

  *   Q: The topology draft also defines 2 additional options to address optical transponder properties - the if-param draft only supports 1 out of 3 options!
     *   A: https://datatracker.ietf.org/doc/draft-dharini-ccamp-dwdm-if-yang/ actually introduced the notion of a ‘mode templates’ into the transponder model in version-02 and we left it as simple string type. This allows using names such as application identifiers or application codes defined by other standards bodies that can be referenced by other models too. IOW the draft as it stands today would support all 3 options the topology-yang is referring to. It allows for standard application identifiers and vendor-modes or organization specific modes.
grouping opt-if-och-mode-params  {
             description "OCh mode parameters.";
             leaf mode-id {
                   type string {
                         length "1..255";
                   }
                   description
                         "Id for the OCh mode template";
             }

  *   Q: How do we ensure consistency between the two drafts? The topology draft has a wider scope but deals with the same information contained in the if-param draft.
     *   A: while dwdm-if-yang is supposed to be a simple interface model exposed by a network node – or perhaps an interface module. It simply augments the IETF interface model. The topology model is a new model exposed by an SDN controller representing the network for the purpose of impairment validation.
     *   A: AFAIK the IETF doesn’t have an insurance policy for consistency. The usual way is to discuss this among the authors of the drafts in question. Gabriele and myself are authors on both drafts and we share the goal to have a consistent YANG model for optical networks. If you have a concrete proposal, IETF is certainly a good place to discuss and align.
Best
Gert

From: CCAMP <[email-masked]> on behalf of Dieter Beller <[email-masked]>
Date: Friday, March 15, 2019 at 18:11
To: Daniele Ceccarelli <[email-masked]>, CCAMP <[email-masked]>, Fatai Zhang <[email-masked]>
Subject: Re: [CCAMP] WG adoption poll on draft-dharini-ccamp-dwdm-if-param-yang-06

Daniele & Fatai, WG,

draft-dharini-ccamp-dwdm-if-param-yang-06 is IMHO opinion overlapping with draft-lee-ccamp-optical-impairment-topology-yang-01 that also defines a YANG model including
optical transponder properties (see https://tools.ietf.org/html/draft-lee-ccamp-optical-impairment-topology-yang-01#section-2.5<https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Dlee-2Dccamp-2Doptical-2Dimpairment-2Dtopology-2Dyang-2D01-23section-2D2.5&d=DwMF-g&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=Sf-T94Aod4TTEURQzTXYYw-Q-H8PyeOsweqqcNyVIcU&m=n9OhevnXk7wbb15izmK2c3fLh7El_yfYO806z3Ol3cs&s=io2o38_gWPabCrhnWlKk2lWV0YOcoUQfAkQLDSUV6uQ&e=> and the related YANG model attributes).

The concerns are:

Thanks,
Sergio and Dieter

Working group,

Thanks,

Daniele & Fatai

CCAMP mailing list

https://www.ietf.org/mailman/listinfo/ccamp<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_ccamp&d=DwMF-g&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=Sf-T94Aod4TTEURQzTXYYw-Q-H8PyeOsweqqcNyVIcU&m=n9OhevnXk7wbb15izmK2c3fLh7El_yfYO806z3Ol3cs&s=Ugu_sWbKBSbBY4oCaREvyTC-ELBlTlsA0EetIUsHqxQ&e=>

---

From: <[email-masked]>
Date: Tue, 19 Mar 2019 17:29:51 +0100

Hi all,

I support the adoption of the I-D. Like
draft-lee-ccamp-optical-impairment-topology-yang, it clearly fills a
hole. If both these drafts get adopted, I think bringing consistency on
good ideas from both will be straightforward.

Thanks,

Julien

On 11/03/2019 17:41, Daniele Ceccarelli wrote:
>
> Working group,
>
>  
>
> We finally managed to collect all the IPR disclosures and we’re ready
> to start the WG adoption poll for the dwdm-if drafts (YANG and LMP).
>
>  
>
> *draft-dharini-ccamp-dwdm-if-param-yang-06 *a CCAMP working group
> document.
>
> support" and a motivation for  your reply, mandatory for the "not
> support" and nice to have for the "support".
>
>  
>
> The polling will end on *Monday March 25^th * ..
>
>  
>
> Thanks,
>
> Daniele & Fatai
>
>  
>

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: "Beller, Dieter (Nokia - DE/Stuttgart)" <[email-masked]>
Date: Tue, 19 Mar 2019 17:02:04 +0000

Hi Julien, all,

I concur with you that it would be the best to also adopt draft-lee-ccamp-optical-impairment-topology-yang asap and make sure that both drafts are well aligned
and consistent.

Both drafts may share the same types/groupings (intention of ietf-layer0-types?). Probably layer0-types should be put in a separate draft like te-types (TEAS).
Other drafts on the CCAMP agenda should be based on layer0-types as well.

Let's discuss this during the CCAMP session next Mon at IETF 104 in Prague.

Thanks,
Dieter

On 19.03.2019 17:29, [email-masked]<mailto:[email-masked]> wrote:

Hi all,

Thanks,

Julien

Working group,

Thanks,

Daniele & Fatai

---

From: Daniele Ceccarelli <[email-masked]>
Date: Tue, 19 Mar 2019 17:05:26 +0000

Hi Dieter,

Thanks for raising this up. We'll discuss during the CCAMP session in
Prague.

The issues you're raising are very valid and need to be addressed, and I
agree with Julien on the fact that the solution is quite straightforward. 

*	How do we ensure consistency between the two drafts? The topology
draft has a wider scope but deals with the same information contained in the
if-param draft.

>This is simple. My suggestion would be to focus on the interface on one
draft and topology on the other.

*	The topology draft also defines 2 additional options to address
optical transponder properties - the if-param draft only supports 1 out of 3
options!

>I don't like many options. Let's see which ones to go for and then move
them to the interface draft.

*	If draft-dharini-ccamp-dwdm-if-param-yang is defining a device
model, an SDN controller must be capable to retrieve the information defined
in the topology YANG
from the device in order to construct the topology. Hence model consistency
is really a must.

>totally agree.

BR

Daniele  

From: Beller, Dieter (Nokia - DE/Stuttgart) <[email-masked]> 
Sent: den 15 mars 2019 18:11
To: Daniele Ceccarelli <[email-masked]>; CCAMP
([email-masked]) <[email-masked]>; Fatai Zhang <[email-masked]>
Cc: Belotti, Sergio (Nokia - IT/Vimercate) <[email-masked]>
Subject: Re: [CCAMP] WG adoption poll on
draft-dharini-ccamp-dwdm-if-param-yang-06

Daniele & Fatai, WG,

draft-dharini-ccamp-dwdm-if-param-yang-06 is IMHO opinion overlapping with
draft-lee-ccamp-optical-impairment-topology-yang-01 that also defines a YANG
model including
optical transponder properties (see
https://tools.ietf.org/html/draft-lee-ccamp-optical-impairment-topology-yang
-01#section-2.5 and the related YANG model attributes).

As there is a lot of interest in
draft-lee-ccamp-optical-impairment-topology-yang-01 on the vendor as well as
operator side ( we had weekly calls in the last weeks), the authors
are of the opinion that this draft shall also become a WG draft asap. This
is something that should be discussed during the CCAMP session at IETF 104
in Prague.

The concerns are:

*	How do we ensure consistency between the two drafts? The topology
draft has a wider scope but deals with the same information contained in the
if-param draft.
*	The topology draft also defines 2 additional options to address
optical transponder properties - the if-param draft only supports 1 out of 3
options!
*	If draft-dharini-ccamp-dwdm-if-param-yang is defining a device
model, an SDN controller must be capable to retrieve the information defined
in the topology YANG
from the device in order to construct the topology. Hence model consistency
is really a must.

Thanks,
Sergio and Dieter

Working group,

Thanks,

Daniele & Fatai

_______________________________________________
CCAMP mailing list
[email-masked] <mailto:[email-masked]> 
https://www.ietf.org/mailman/listinfo/ccamp

---

From: "Beller, Dieter (Nokia - DE/Stuttgart)" <[email-masked]>
Date: Tue, 19 Mar 2019 18:09:59 +0000

Hi Daniele, all,

I think that a discussion during the CCAMP session in Prague is probably the most efficient way going forward.

Just one remark regarding the 3 options without going into the technical details here: I had the feeling that there was consensus at the end of our discussion that
all 3 options have value and we leave it up to the operator to select which option is preferred from a network operations perspective. This may differ from operator
to operator. The 3 options and their pros and cons were discussed comprehensively. So, I am not sure whether it is wise to remove one or even two.

Thanks,
Dieter

On 19.03.2019 18:05, Daniele Ceccarelli wrote:
Hi Dieter,

Thanks for raising this up. We’ll discuss during the CCAMP session in Prague.
The issues you’re raising are very valid and need to be addressed, and I agree with Julien on the fact that the solution is quite straightforward.

>This is simple. My suggestion would be to focus on the interface on one draft and topology on the other.

>I don’t like many options. Let’s see which ones to go for and then move them to the interface draft.

BR

Daniele

From: Beller, Dieter (Nokia - DE/Stuttgart) <[email-masked]><mailto:[email-masked]>
Sent: den 15 mars 2019 18:11
To: Daniele Ceccarelli <[email-masked]><mailto:[email-masked]>; CCAMP ([email-masked]<mailto:[email-masked]>) <[email-masked]><mailto:[email-masked]>; Fatai Zhang <[email-masked]><mailto:[email-masked]>
Cc: Belotti, Sergio (Nokia - IT/Vimercate) <[email-masked]><mailto:[email-masked]>
Subject: Re: [CCAMP] WG adoption poll on draft-dharini-ccamp-dwdm-if-param-yang-06

Daniele & Fatai, WG,

The concerns are:

Thanks,
Sergio and Dieter

Working group,

Thanks,

Daniele & Fatai

CCAMP mailing list

--

Dieter Beller
Open Agent & Routing Project Manager
IP/Optical Networks, Optics, Nokia

m : +49 175 7266874 | j: 8831186<ciscotel://8831186>
[email-masked]<mailto:[email-masked]>

Nokia Solutions and Networks GmbH & Co. KG
Lorenzstr. 10, 70435 Stuttgart
Sitz der Gesellschaft: München / Registered office: Munich
Registergericht: München / Commercial registry: Munich, HRA 88537
WEEE-Reg.-Nr.: DE 52984304
Persönlich haftende Gesellschafterin / General Partner: Nokia Solutions and Networks Management GmbH
Geschäftsleitung / Board of Directors: Dr. Wolfgang Hackenberg, Ralf Niederberger
Vorsitzender des Aufsichtsrats / Chairman of supervisory board: Hans-Jürgen Bill
Sitz der Gesellschaft: München / Registered office: Munich
Registergericht: München / Commercial registry: Munich, HRB 163416

This e-mail and its attachments, if any, may contain confidential information.
If you have received this e-mail in error, please notify us and delete or destroy the e-mail and its attachments, if any, immediately.
If you have received this e-mail in error, you must not forward or make use of the e-mail and its attachments, if any.

---

From: "Beller, Dieter (Nokia - DE/Stuttgart)" <[email-masked]>
Date: Tue, 19 Mar 2019 18:11:16 +0000

Hi Daniele, all,

Thanks,
Dieter

BR

Daniele

Daniele & Fatai, WG,

The concerns are:

Thanks,
Sergio and Dieter

Working group,

Thanks,

Daniele & Fatai

CCAMP mailing list

---

From: Leeyoung <[email-masked]>
Date: Tue, 19 Mar 2019 19:36:21 +0000

Hi WG

I agree with Dieter's suggestion on:

-          draft-lee-ccamp-optical-impairment-topology-yang should be adopted on par with draft-dharini-ccamp-dwdm-if-param-yang-06

-          putting all common grouping to layer0-types makes sense -- -all wson/flexi-grid related models and draft-lee-ccamp-optical-impairment-topology-yang have already imported groupings from layer0-types. We might need to do the same for draft-dharini-ccamp-dwdm-if-param-yang-06.

In regard to having a separate draft that hosts only the layer0-types, this would makes sense if we have a stable layer0-types and move this draft first before all other drafts to avoid the hang-over case (which happened for te-topology draft).

Thanks.
Young

From: CCAMP [mailto:[email-masked]] On Behalf Of Beller, Dieter (Nokia - DE/Stuttgart)
Sent: Tuesday, March 19, 2019 12:02 PM
To: [email-masked]; [email-masked]
Subject: Re: [CCAMP] WG adoption poll on draft-dharini-ccamp-dwdm-if-param-yang-06

Hi Julien, all,

Thanks,
Dieter

Hi all,

Thanks,

Julien

Working group,

We finally managed to collect all the IPR disclosures and we're ready

document.

Thanks,

Daniele & Fatai

Thank you.

CCAMP mailing list

---

From: Fatai Zhang <[email-masked]>
Date: Sun, 24 Mar 2019 10:26:40 +0000

Hi Dieter,

No worries.

Daniele might be confused by many options for the same thing, but I think Gert clarified your question perfectly (“draft-dharini as it stands today would support all 3 options the topology-yang is referring to”).

Thanks

Fatai

发件人: Beller, Dieter (Nokia - DE/Stuttgart) [mailto:[email-masked]]
发送时间: 2019年3月20日 2:11
收件人: Daniele Ceccarelli; CCAMP ([email-masked]); Fatai Zhang
抄送: Belotti, Sergio (Nokia - IT/Vimercate)
主题: Re: [CCAMP] WG adoption poll on draft-dharini-ccamp-dwdm-if-param-yang-06

Hi Daniele, all,

Thanks,
Dieter

BR

Daniele

Daniele & Fatai, WG,

The concerns are:

Thanks,
Sergio and Dieter

Working group,

Thanks,

Daniele & Fatai

CCAMP mailing list

---

From: Daniele Ceccarelli <[email-masked]>
Date: Tue, 26 Mar 2019 08:40:42 +0000

WG,

The poll is closed and the draft adopted as WG document.

Authors, please resubmit the draft as
draft-ietf-ccamp-dwdm-if-param-yang-00 changing only title and date.

Please note that we are planning to complete/extend this work including
optical impairments topology (this is a candidate for such work
<https://tools.ietf.org/id/draft-lee-ccamp-optical-impairment-topology-yang-
01.txt>
https://tools.ietf.org/id/draft-lee-ccamp-optical-impairment-topology-yang-0
1.txt ) and the working group is expected to work on solving any overlap and
keeping the two activities fully aligned.

Thanks,

Daniele  & Fatai

From: CCAMP <[email-masked]> On Behalf Of Daniele Ceccarelli
Sent: den 11 mars 2019 17:42
To: CCAMP ([email-masked]) <[email-masked]>
Subject: [CCAMP] WG adoption poll on
draft-dharini-ccamp-dwdm-if-param-yang-06

Working group,

Thanks,

Daniele & Fatai