Subject: [CCAMP] I-D Action: draft-ietf-ccamp-rsvp-te-bandwidth-availability-15.txt

From: [email-masked]
Date: Mon, 29 Apr 2019 19:25:08 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Common Control and Measurement Plane WG of the IETF.

        Title           : Ethernet Traffic Parameters with Availability Information
        Authors         : Hao Long
                          Min Ye
                          Greg Mirsky
                          Alessandro D'Alessandro
                          Himanshu Shah
	Filename        : draft-ietf-ccamp-rsvp-te-bandwidth-availability-15.txt
	Pages           : 12
	Date            : 2019-04-29

Abstract:
   A packet switching network may contain links with variable
   bandwidth, e.g., copper, radio, etc. The bandwidth of such links is
   sensitive to external environment (e.g., climate). Availability is
   typically used for describing these links when doing network
   planning. This document introduces an optional Bandwidth
   Availability TLV in Resource ReSerVation Protocol - Traffic Engineer
   (RSVP-TE) signaling. This extension can be used to set up a
   Generalized Multi-Protocol Label Switching (GMPLS) Label Switched
   Path (LSP) in conjunction with the Ethernet SENDER_TSPEC object.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-ccamp-rsvp-te-bandwidth-availability/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-ccamp-rsvp-te-bandwidth-availability-15
https://datatracker.ietf.org/doc/html/draft-ietf-ccamp-rsvp-te-bandwidth-availability-15

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-ccamp-rsvp-te-bandwidth-availability-15

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Yemin (Amy)" <[email-masked]>
Date: Tue, 30 Apr 2019 02:48:22 +0000

Hi Ben, Adam and Magnus,

The draft is now updated to address all the Discuss & Comments received in IESG review. Please review. https://datatracker.ietf.org/doc/draft-ietf-ccamp-rsvp-te-bandwidth-availability/   
Sorry for the late update due to my travelling in the past weeks. 

BR,
Amy (on behalf of co-authors)

-----Original Message-----
From: CCAMP [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Tuesday, April 30, 2019 10:25 AM
To: [email-masked]
Cc: [email-masked]
Subject: [CCAMP] I-D Action: draft-ietf-ccamp-rsvp-te-bandwidth-availability-15.txt

Abstract:

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

_______________________________________________
CCAMP mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ccamp

---

From: Adam Roach <[email-masked]>
Date: Mon, 29 Apr 2019 22:26:31 -0500

Thanks for the update!

I apologize for not being clearer in my DISCUSS that "binary interchange 
format" is as important as "IEEE 754-2008." The issues are twofold: 
IEEE-754 defines both binary and decimal formats; you presumably want to 
specify the use of the binary format. The standard also defines 
arithmetic formats, meant for efficiency of computation, and interchange 
formats, meant for unambiguous transmission between processors. You'll 
want to specify the second one.

/a

---

From: Magnus Westerlund <[email-masked]>
Date: Tue, 30 Apr 2019 09:11:44 +0000

Thanks,

I have cleared. I will leave Adam to ensure the formal definition part.

Cheers

Magnus

-- 

Magnus Westerlund 

----------------------------------------------------------------------
Network Architecture & Protocols, Ericsson Research
----------------------------------------------------------------------
Ericsson AB                 | Phone  +46 10 7148287
Torshamnsgatan 23           | Mobile +46 73 0949079
SE-164 80 Stockholm, Sweden | mailto: [email-masked]
----------------------------------------------------------------------

---

From: "Yemin (Amy)" <[email-masked]>
Date: Tue, 30 Apr 2019 09:32:28 +0000

Hi Adam, 

In order to be aligned with RFC8330, it's better to use binary 32 here. 
How about "a 32-bit format floating-point number in binary interchange format [IEEE754]..."?

BR,
Amy
-----Original Message-----
From: Adam Roach [mailto:[email-masked]] 
Sent: Tuesday, April 30, 2019 11:27 AM
To: Yemin (Amy) <[email-masked]>; Benjamin Kaduk <[email-masked]>; [email-masked]
Cc: [email-masked]
Subject: Re: [CCAMP] I-D Action: draft-ietf-ccamp-rsvp-te-bandwidth-availability-15.txt

Thanks for the update!

I apologize for not being clearer in my DISCUSS that "binary interchange format" is as important as "IEEE 754-2008." The issues are twofold: 
IEEE-754 defines both binary and decimal formats; you presumably want to specify the use of the binary format. The standard also defines arithmetic formats, meant for efficiency of computation, and interchange formats, meant for unambiguous transmission between processors. You'll want to specify the second one.

/a

On 4/29/19 9:48 PM, Yemin (Amy) wrote:
> Hi Ben, Adam and Magnus,
>
> The draft is now updated to address all the Discuss & Comments 
> received in IESG review. Please review. 
> https://datatracker.ietf.org/doc/draft-ietf-ccamp-rsvp-te-bandwidth-av
> ailability/ Sorry for the late update due to my travelling in the past 
> weeks.
>
> BR,
> Subject: [CCAMP] I-D Action: 
> draft-ietf-ccamp-rsvp-te-bandwidth-availability-15.txt
>
>

---

From: Adam Roach <[email-masked]>
Date: Tue, 30 Apr 2019 14:47:12 -0500

Yes, that's perfect. Thanks.

/a

On 4/30/19 4:32 AM, Yemin (Amy) wrote:
>> ailability/