Subject: [CCAMP] Mirja Kühlewind's No Objection on draft-ietf-ccamp-rsvp-te-bandwidth-availability-14: (with COMMENT)

From: Mirja Kühlewind via Datatracker <[email-masked]>
Date: Wed, 03 Apr 2019 03:06:03 -0700

Mirja Kühlewind has entered the following ballot position for
draft-ietf-ccamp-rsvp-te-bandwidth-availability-14: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-ccamp-rsvp-te-bandwidth-availability/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Just one quick question I was wondering about in section 3.2.:
"When a node receives
   several <bandwidth, availability> pairs, but there're are extra
   bandwidth-TLVs without matching index Availability-TLV, the extra
   bandwidth-TLVs MAY be ignored and SHOULD NOT be propagated."
Why is that? Is it not valid to also send some requests without availability? I
thought that would make sense because it's basically saying, "just give me
whatever you have because I don't know the availability requirements anyway",
no?

---

From: "Yemin (Amy)" <[email-masked]>
Date: Mon, 8 Apr 2019 09:42:43 +0000

Hi Mirja, 

Thanks for the comment. 
In section 3.1, the description of Index defines that there's n*(1:1) association or n:1 association between bandwidth-TLV and availability-TLV. 
That's why an extra bandwidth-TLV in the pair list is considered as an error. 
If a message with bandwidth-TLV only, without any availability-TLV, it's possible to be done as you described. 

BR,
Amy

-----Original Message-----
From: CCAMP [mailto:[email-masked]] On Behalf Of Mirja Kühlewind via Datatracker
Sent: Wednesday, April 03, 2019 6:06 PM
To: The IESG <[email-masked]>
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: [CCAMP] Mirja Kühlewind's No Objection on draft-ietf-ccamp-rsvp-te-bandwidth-availability-14: (with COMMENT)

When responding, please keep the subject line intact and reply to all email addresses included in the To and CC lines. (Feel free to cut this introductory paragraph, however.)

Why is that? Is it not valid to also send some requests without availability? I thought that would make sense because it's basically saying, "just give me whatever you have because I don't know the availability requirements anyway", no?

_______________________________________________
CCAMP mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ccamp