Subject: Re: [CCAMP] Webex meeting changed: Optical impairments draft

From: Gert Grammel <[email-masked]>
Date: Thu, 29 Oct 2020 16:33:44 +0000

We discussed today a difference in the interpretation of the model related to https://github.com/ietf-ccamp-wg/draft-ietf-ccamp-optical-impairment-topology-yang/issues/29 and its interpretation. The different interpretation lead to different computation requirements.
The design team appreciates feedback which of both Cases is preferred and what consideration led to the preference

Case A:
======
https://github.com/ietf-ccamp-wg/draft-ietf-ccamp-optical-impairment-topology-yang/issues#issuecomment-677768528 from August 20 documented the structure of the model:
+--ro supported-modes* [mode-id]
>   +--ro mode-id
>   +--ro (mode)?
>   |  +--:(G.698.2)
>   |  |  +--ro standard-mode?                standard-mode
>   |  +--:(organizational-mode)
>   |  |  +--ro operational-mode?             operational-mode
>   |  |  +--ro organization-identifier?      vendor-identifier
➢ |  +--:(explicit-mode)
➢ |    +--ro supported-standard-mode*? leafref
>   |     +--ro modulation-types                   identityref
>   |     ......

This snippet would allow to use standard mode or operational mode as a simple matching criteria for compatibility i.e. two transponders with Operational-mode=X and suitable line parameters would interoperate.
In case of “explicit” mode, the set of parameters provided, can support one or more application code/organizational mode, that means this set of parameters if applied to configure the transceiver, is aligned with one or more application code/organizational mode.
(Note that there are no additional parameters associated to the organizational mode in this case)

Case B:
======

https://github.com/ietf-ccamp-wg/draft-ietf-ccamp-optical-impairment-topology-yang/blob/master/ietf-optical-impairment-topology.tree contains additional parameters to the Operational Mode that are also replicated in the explicit mode. Those parameters are related to the min/max ranges which are allowed.

  +--ro supported-mode* [mode-id]
                +--ro mode-id                      string
                +--ro (mode)
                   +--:(G.698.2)
                   |  +--ro standard-mode?         standard-mode
                   +--:(organizational-mode)
                   |  +--ro organizational-mode
                   |     +--ro operational-mode?
                   |     |       operational-mode
                   |     +--ro organization-identifier?
                   |     |       organization-identifier
                   |     +--ro min-central-frequency?
                   |     |       frequency-thz
                   |     +--ro max-central-frequency?
                   |     |       frequency-thz
                   |     +--ro minimum-channel-spacing?
                   |     |       frequency-ghz
                   |     +--ro tx-channel-power-min?      dbm-t
                   |     +--ro tx-channel-power-max?      dbm-t
                   |     +--ro rx-channel-power-min?      dbm-t
                   |     +--ro rx-channel-power-max?      dbm-t
                   |     +--ro rx-total-power-max?        dbm-t
                   +--:(explicit-mode)
                      +--ro explicit-mode
                         +--ro supported-modes
                         |  +--ro supported-application-codes*
                         |  |       -> ../../mode-id
                         |  +--ro supported-organizational-modes*
                         |          -> ../../mode-id
                         +--ro line-coding-bitrate?
                         |       identityref
                     <snip>
                         +--ro min-central-frequency?
                         |       frequency-thz
                         +--ro max-central-frequency?
                         |       frequency-thz
                         +--ro minimum-channel-spacing?
                         |       frequency-ghz
                         +--ro tx-channel-power-min?
                         |       dbm-t
                         +--ro tx-channel-power-max?
                         |       dbm-t
                         +--ro rx-channel-power-min?
                         |       dbm-t
                         +--ro rx-channel-power-max?
                         |       dbm-t
                         +--ro rx-total-power-max?
                                 dbm-t

In this case, interoperability can only be provided if the organizational code on each side match AND all other explicit parameters defined in the organizational-code have a matching range.
(Note that min/max parameters are associated to the organizational mode AND to the explicit mode in this case)

Juniper Business Use Only

---

From: Italo Busi <[email-masked]>
Date: Fri, 30 Oct 2020 16:14:25 +0000

Hi Gert,

Let me try to look at this issue from a different perspective.

I think the objective of our work is to define a YANG model for the optical specification methodologies which are used in the field to represent the capabilities of the transponders.

I do not think that it is in the scope of our work to discuss the optical specification methodologies other than understanding how they could be used for path computation (ensuring interoperability between the sender and receiver) and modelled using YANG.
	
As far as I have understood from past discussion, we have agreed to support three optical specification methodologies which are used by existing optical interfaces implementations and we have named them as application code (ITU-T G.698.2), organizational mode and explicit mode.

After some rounds of discussions and questions for clarification, the latest proposed text to describe the behavior of the organization mode has been prepared on github:

https://github.com/ietf-ccamp-wg/draft-ietf-ccamp-optical-impairment-topology-yang/issues/29#issuecomment-719503150

I think this updated description has improved the clarity of how the operational mode are implemented and, in particular that:

"Two transceivers are inter-operable, if they have at least one (organization-identifier, operational-mode) pair in common and if the supported carrier frequency and power attributes have a matching range."

As a consequence, I think that the YANG model defined in "Case A" below does not work (since it does not provide enough information to check that " the supported carrier frequency and power attributes have a matching range ") while the one defined in "Case B" works properly.

This text describing the operational mode behavior has been provided by people who have implemented it.

Therefore, I think we can update the draft with the changes discussed in the last few weeks incorporating the definitions capturing our current understanding of how these optical specification methodologies (application code, organizational mode and explicit mode) behave and the YANG model aligned with our current understanding (i.e., based on "Case B" below).

Since we are not yet in WG LC stage, we still have plenty of time to update both the description and the YANG model based on the feedbacks we receive from data plane experts.

My 2 cents

Italo (as co-author of the draft)

-----Original Message-----
From: Gert Grammel [mailto:[email-masked]] 
Sent: giovedì 29 ottobre 2020 17:34
To: [email-masked]; [email-masked]
Subject: Re: [CCAMP] Webex meeting changed: Optical impairments draft

Case A:
======
➢ |  +--:(explicit-mode)

Case B:
======

---

From: Dieter Beller <[email-masked]>
Date: Sat, 31 Oct 2020 10:28:28 +0100

Thanks, Italo, for your contribution to the technical discussion!

I would like to emphasize that the text on GitHub ( see 
https://github.com/ietf-ccamp-wg/draft-ietf-ccamp-optical-impairment-topology-yang/issues/29#issuecomment-719503150) 
tries
to provide the technical justification for the modeling approach taken 
for the organizational mode option - here is the text, which was 
referenced in Italo's mail:

*Organizational Mode:*
Organizations like operator groups, industry fora, or equipment vendors 
can define organizational modes, which will allow these organizations to 
make use of advanced transceiver capabilities going beyond existing 
standardized application codes. Such an organizational mode is 
identified by the organization-identifier attribute defining the scope 
and an operational-mode that is meaningful within the scope of the 
organization. Hence, the two attributes must always be considered 
together. Two transceivers are inter-operable, if they have at least one 
(organization-identifier, operational-mode) pair in common and if the 
supported carrier frequency and power attributes have a matching range. 
This is a necessary condition for path computation in the context of 
organizational modes. An operational mode is a transceiver preset (a 
configuration with well-defined parameter values) subsuming several 
transceiver properties including:
• FEC type
• Modulation scheme
• Encoding (mapping of bit patterns to symbols in the constellation diagram)
• Baud rate (symbol rate)
• Carrier bandwidth (typically measured in GHz)

The major reason for these transceiver presets is the fact that the 
attribute values typically cannot be configured independently and are 
therefore advertised as supported operational mode capabilities.
It is the responsibility of the organization to assign operational modes 
and to ensure that operational modes are unique and not ambiguous within 
the scope of the organization.
In addition to the transceiver properties subsumed by the operational 
mode, optical power and carrier frequency related properties are modeled 
separately, i.e., outside of the operational mode. This modeling 
approach allows transponders using different transceiver variants (e.g. 
optical modules) with slightly different power and/or frequency range 
properties to interoperate without defining separate operational modes. 
Different optical modules (pluggables) from different suppliers 
typically have slightly different input and output power ranges or may 
have slightly different carrier frequency tuning ranges.
The received channel power and the received total power are two 
parameters that can be measured by the receiver and can be provided by 
the transceiver in order to allow a controller to determine the expected 
performance of the end-to-end service taking into account the optical 
impairments along the path.

Moreover, implementations exist that are based on the same modeling 
approach and hence it is *already field proven!*

Thanks,
Dieter

On 30.10.2020 17:14, Italo Busi wrote:
> _______________________________________________
> CCAMP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ccamp