Subject: [CCAMP] Robert Wilton's No Objection on draft-ietf-ccamp-layer0-types-08: (with COMMENT)

From: Robert Wilton via Datatracker <[email-masked]>
Date: Tue, 01 Dec 2020 08:32:39 -0800

Robert Wilton has entered the following ballot position for
draft-ietf-ccamp-layer0-types-08: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-ccamp-layer0-types/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Hi,

Thank you for your effort on this document.  I appreciate that I have reviewed
this module previously.  I have a few minor (mostly editorial) comments on the
latest revision of the YANG module:

A few minor comments on the latest version of the YANG module:

Some of the descriptions have been wrapped at less than 69 characters. 
Corrected examples are below.

1)
  grouping wson-label-start-end {
    description
      "The WSON label-start or label-end used to specify WSON label
       range.";

2)
          case single {
            leaf dwdm-n {
              type l0-types:dwdm-n;
              description
                "The given value 'N' is used to determine the nominal
                 central frequency.";
            }
          }

3)
    leaf priority {
      type uint8;
      description
        "Priority in Interface Switching Capability Descriptor
         (ISCD).";

4)
  grouping flexi-grid-label-start-end {
    description
      "The Flexi-grid label-start or label-end used to specify
       Flexi-grid label range.";

5)
      case super {
        list subcarrier-flexi-n {
          key flexi-n;
          uses flexi-grid-frequency-slot;
          description
            "List of subcarrier channels for flexi-grid super
             channel.";
        }
      }

6)
      leaf slot-width-granularity {
        type identityref {
          base flexi-slot-width-granularity;
        }
        default flexi-swg-12p5ghz;
        description
          "Minimum space between slot widths. Default is 12.500 GHz";

The following leaf had an extra blank line before the description:
PROPOSED:

    leaf flexi-n {
      type l0-types:flexi-n;
      description
        "The given value 'N' is used to determine the nominal central
         frequency.";
    }

Please change the description to "Flexi-grid-specific label range related
information", i.e.,

CURRENT:
  grouping flexi-grid-label-range-info {
    description
      "Info of Flexi-grid-specific label range";

PROPOSED:
  grouping flexi-grid-label-range-info {
    description
      "Flexi-grid-specific label range related information";
    uses l0-label-range-info;

Nit, some of the descriptions have an extra trailing space after the full stop,
plesae search/replace '. "'

For min-slot-width-factor, I would suggest removing the last sentence, and only
specifying the constraint on the max-slot-width-factor, and also define a must
statement as well.

CURRENT:
      leaf min-slot-width-factor {
        type uint16 {
          range "1..max";
        }
        default 1;
        description
          "Slot width range: two multipliers of the slot width ,
           granularity, each indicating the minimal and maximal slot
           width supported by a port, respectively.

           Minimum slot width is calculated by:
             Minimum slot width (GHz) =
               min-slot-width-factor * slot-width-granularity.
           Minimum slot width should be smaller than or equal to
           Maximum slot width. ";

PROPOSED:
      leaf min-slot-width-factor {
        type uint16 {
          range "1..max";
        }
        default 1;
        description
          "Slot width range: two multipliers of the slot width ,
           granularity, each indicating the minimal and maximal slot
           width supported by a port, respectively.

           Minimum slot width is calculated by:
             Minimum slot width (GHz) =
               min-slot-width-factor * slot-width-granularity.";
        reference
          "RFC8363: GMPLS OSPF-TE Extensions in Support of Flexi-Grid
           Dense Wavelength Division Multiplexing (DWDM) Networks";
      }

I suggest tweaking the description and adding a must constraint to the
max-slot-width-factor.  My assumption here is that a client could set the
min-slot-width-factor to 2, and doesn't need to also specify
max-slot-width-factor unless they want it to be greater than 2.  Coversely,
they can specify both if they wish.

CURRENT:
      leaf max-slot-width-factor {
        type uint16 {
          range "1..max";
        }
        description
          "Slot width range: two multipliers of the slot width ,
           granularity, each indicating the minimal and maximal slot
           width supported by a port, respectively.

           Maximum slot width is calculated by:
             Maximum slot width (GHz) =
               max-slot-width-factor * slot-width-granularity
           Maximum slot width should be bigger than or equal to
           Minimum slot width. ";
        reference
          "RFC8363: GMPLS OSPF-TE Extensions in Support of Flexi-Grid
           Dense Wavelength Division Multiplexing (DWDM) Networks";
      }

PROPOSED:

      leaf max-slot-width-factor {
        type uint16 {
          range "1..max";
        }
        must '. >= min-slot-width-factor' {
          error-message
            "Maximum slot width must be greater than or equal to
             minimum slot width.";
        }
        description
          "Slot width range: two multipliers of the slot width ,
           granularity, each indicating the minimal and maximal slot
           width supported by a port, respectively.

           Maximum slot width is calculated by:
             Maximum slot width (GHz) =
               max-slot-width-factor * slot-width-granularity

           If specified, maximum slot width must be greater than or
           equal to minimum slot width.";
        reference
          "RFC8363: GMPLS OSPF-TE Extensions in Support of Flexi-Grid
           Dense Wavelength Division Multiplexing (DWDM) Networks";
      }

Regards,
Rob

---

From: Zhenghaomian <[email-masked]>
Date: Wed, 16 Dec 2020 07:25:25 +0000

Hi, Rob, 

Thank you for the review and comments, again. As the comments are all about the YANG model changes, please refer to https://github.com/ietf-ccamp-wg/draft-ietf-ccamp-layer0-types/pull/15 for our revision in the module, and let us know if you have other considerations.

Best wishes,
Haomian (on behalf of all authors & contributors)

-----邮件原件-----
发件人: Robert Wilton via Datatracker [mailto:[email-masked]] 
发送时间: 2020年12月2日 0:33
收件人: The IESG <[email-masked]>
抄送: [email-masked]; [email-masked]; [email-masked]; Daniele Ceccarelli <[email-masked]>; [email-masked]
主题: Robert Wilton's No Objection on draft-ietf-ccamp-layer0-types-08: (with COMMENT)

When responding, please keep the subject line intact and reply to all email addresses included in the To and CC lines. (Feel free to cut this introductory paragraph, however.)

Hi,

Thank you for your effort on this document.  I appreciate that I have reviewed this module previously.  I have a few minor (mostly editorial) comments on the latest revision of the YANG module:

1)

2)
          case single {
            leaf dwdm-n {
              type l0-types:dwdm-n;
              description

3)
    leaf priority {
      type uint8;
      description

4)

5)
      case super {

6)

    leaf flexi-n {
      type l0-types:flexi-n;
      description

Please change the description to "Flexi-grid-specific label range related information", i.e.,

CURRENT:

PROPOSED:

Nit, some of the descriptions have an extra trailing space after the full stop, plesae search/replace '. "'

For min-slot-width-factor, I would suggest removing the last sentence, and only specifying the constraint on the max-slot-width-factor, and also define a must statement as well.

CURRENT:

PROPOSED:

I suggest tweaking the description and adding a must constraint to the max-slot-width-factor.  My assumption here is that a client could set the min-slot-width-factor to 2, and doesn't need to also specify max-slot-width-factor unless they want it to be greater than 2.  Coversely, they can specify both if they wish.

CURRENT:

PROPOSED:

Regards,
Rob