Subject: [CCAMP] I-D Action: draft-ietf-ccamp-layer0-types-09.txt

From: [email-masked]
Date: Tue, 29 Dec 2020 19:30:26 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Common Control and Measurement Plane WG of the IETF.

        Title           : A YANG Data Model for Layer 0 Types
        Authors         : Haomian Zheng
                          Young Lee
                          Aihua Guo
                          Victor Lopez
                          Daniel King
	Filename        : draft-ietf-ccamp-layer0-types-09.txt
	Pages           : 22
	Date            : 2020-12-29

Abstract:
   This document defines a collection of common data types and groupings
   in the YANG data modeling language.  These derived common types and
   groupings are intended to be imported by modules that model Layer 0
   optical Traffic Engineering (TE) configuration and state capabilities
   such as Wavelength Switched Optical Networks (WSONs) and Flexi-grid
   Dense Wavelength Division Multiplexing (DWDM) Networks.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-ccamp-layer0-types/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-ccamp-layer0-types-09
https://datatracker.ietf.org/doc/html/draft-ietf-ccamp-layer0-types-09

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-ccamp-layer0-types-09

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: tom petch <[email-masked]>
Date: Thu, 31 Dec 2020 12:34:03 +0000

Some stray thoughts of an Admin nature on this I-D

I-D has five authors  YANG module has six AD may complain

YANG import need reference clauses - they used to have them but were removed

YANG contact information is the wrong format and lacks web and list references

l1types must be a Normative reference

MEF 63 is much referenced in the YANG module but inconsistently sometimes just as that sometimes with the title - consistency is good, I prefer the latter

YANG identity for performance reference MEF 63 - I would have expected an ITU-T reference such as G.826 which other I-D use or one of the M. series

YANG groupings are ...-attribute or .....-attributes consistency is good, I prefer the latter

YANG time-interval - is there a sensible default or worthwhile guidance in the description beyond the e.g.?

YANG endpoint-1 and endpoint-2 - must they be different id in which case YANG can enforce that

YANG id is a string of unconstrained length and character set; this is what most authors do but I wish that YANG had a suitable type for identifiers as SMI has

YANG case ITU could do with a reference ideally to ITU-T rather than to l1types

/an unique/a unique/ (English is perverse!)

YANG description clauses the text should start with a Capital letter 

examples are usually at the end and in an Appendix, which is then by default Informative

HTH

Tom Petch