Subject: [CCAMP] Charter update

From: Daniele Ceccarelli <[email-masked]>
Date: Tue, 30 Mar 2021 12:02:52 +0000

Hi working group,

as briefly anticipated during the CCAMP session at IETF110 please find below the proposal for the update to the charter.
Please send you comments/suggestions before April 15th.

Thanks
Daniele , Fatai, Oscar
------

The CCAMP working group is responsible for standardizing a common control plane and a separate common measurement plane for non-packet technologies found in the Internet and in the networks of telecom service providers (ISPs and SPs). Examples of the devices in such networks include photonic cross-connects, OEO switches, ROADMs, TDM switches, microwave links, and Ethernet switches.
In this context, measurement refers to the acquisition and distribution of attributes relevant to the setting up of tunnels and paths.
The working group develops extensions to core Traffic Engineering protocols that are under the care of other working groups as well as YANG models for the control and management of non-packet networks (this includes both device models and network models). The CCAMP working group will coordinate with the TEAS working group to ensure that extensions that can be generalized for use with more than one technology are made appropriately, and with the working groups that have responsibility for the specific protocols.

CCAMP WG work scope includes:

  *   Definition of protocol-independent metrics and parameters (measurement attributes) for describing links and paths that are required for routing and signaling in technology-specific networks. These will be developed in conjunction with requests and requirements from other WGs to ensure overall usefulness.
  *   Maintenance and extension of the Link Management Protocol (LMP)
  *   Functional specification of extensions for GMPLS-related routing  (OSPF, ISIS) and signaling (RSVP-TE) protocols required for path establishment and maintenance in non-packet, technology-specific  networks. Protocol formats and procedures that embody these   extensions will be done jointly with the WGs supervising those  protocols and the TEAS working group has the responsibility to   determine whether such protocol extensions should be generalized  for Traffic Engineering in any network. This may include protocol work to support data planes that have  already been approved by another Standards Development Organization. Note that the specification or modification of data  planes is out of scope of this working group.
  *   Definition of management objects (e.g., as part of MIB modules or YANG models) and control of OAM techniques relevant to the  protocols and extensions specified within the WG. The OAM work will be synchronized with the LIME WG
  *   Describe non-packet-specific aspects of traffic engineering including for multi-areas/multi-AS/multi-layer scenarios and  define protocol extensions in cooperation with the TEAS and  PCE working groups.
  *   Define how the properties of network resources gathered by a measurement protocol (or by other means such as configuration) can be distributed in existing routing protocols, such as OSPF,  IS-IS, and BGP-LS. CCAMP will work with the WGs that supervise  these.
The CCAMP WG currently works on the following tasks:

  *   Protocol extensions and YANG models in support of optical networks (e.g. WSON, flexi grid) with and without awareness of the optical impairments.
- Protocol extensions in support of flexible grid lambda networks.

  *   Protocol extensions and YANG models in support of TDM networks (e.g. OTN).
  *   YANG models in support of microwave networks.
  *   YANG models fin support of L1 services
  *   Client TE topologies
  *   Maintenance of existing protocol extensions for non-packet technology-specific networks (Ethernet, TDM, OTN) already specified by CCAMP.
  *   Maintenance of LMP.

---

From: "Adrian Farrel" <[email-masked]>
Date: Tue, 30 Mar 2021 23:22:09 +0100

Hi,

Thanks for the work on this. It's looking good.

Small point

*	"OAM work will be synchronized with the LIME WG"
LIME was closed down just over 3 years ago

Cheers,

Adrian

From: CCAMP <[email-masked]> On Behalf Of Daniele Ceccarelli
Sent: 30 March 2021 13:03
To: CCAMP <[email-masked]>
Subject: [CCAMP] Charter update

Hi working group,

as briefly anticipated during the CCAMP session at IETF110 please find below
the proposal for the update to the charter. 

Thanks

Daniele , Fatai, Oscar

------

The CCAMP working group is responsible for standardizing a common control
plane and a separate common measurement plane for non-packet technologies
found in the Internet and in the networks of telecom service providers (ISPs
and SPs). Examples of the devices in such networks include photonic
cross-connects, OEO switches, ROADMs, TDM switches, microwave links, and
Ethernet switches.

In this context, measurement refers to the acquisition and distribution of
attributes relevant to the setting up of tunnels and paths.

The working group develops extensions to core Traffic Engineering protocols
that are under the care of other working groups as well as YANG models for
the control and management of non-packet networks (this includes both device
models and network models). The CCAMP working group will coordinate with the
TEAS working group to ensure that extensions that can be generalized for use
with more than one technology are made appropriately, and with the working
groups that have responsibility for the specific protocols.

*	Definition of protocol-independent metrics and parameters
(measurement attributes) for describing links and paths that are required
for routing and signaling in technology-specific networks. These will be
developed in conjunction with requests and requirements from other WGs to
ensure overall usefulness.
*	Maintenance and extension of the Link Management Protocol (LMP)
*	Functional specification of extensions for GMPLS-related routing
(OSPF, ISIS) and signaling (RSVP-TE) protocols required for path
establishment and maintenance in non-packet, technology-specific  networks.
Protocol formats and procedures that embody these   extensions will be done
jointly with the WGs supervising those  protocols and the TEAS working group
has the responsibility to   determine whether such protocol extensions
should be generalized  for Traffic Engineering in any network. This may
include protocol work to support data planes that have  already been
approved by another Standards Development Organization. Note that the
specification or modification of data  planes is out of scope of this
working group.
*	Definition of management objects (e.g., as part of MIB modules or
YANG models) and control of OAM techniques relevant to the  protocols and
extensions specified within the WG. The OAM work will be synchronized with
the LIME WG
*	Describe non-packet-specific aspects of traffic engineering
including for multi-areas/multi-AS/multi-layer scenarios and  define
protocol extensions in cooperation with the TEAS and  PCE working groups.
*	Define how the properties of network resources gathered by a
measurement protocol (or by other means such as configuration) can be
distributed in existing routing protocols, such as OSPF,  IS-IS, and BGP-LS.
CCAMP will work with the WGs that supervise  these.

*	Protocol extensions and YANG models in support of optical networks
(e.g. WSON, flexi grid) with and without awareness of the optical
impairments.

*	Protocol extensions and YANG models in support of TDM networks (e.g.
OTN).
*	YANG models in support of microwave networks.
*	YANG models fin support of L1 services
*	Client TE topologies 
*	Maintenance of existing protocol extensions for non-packet
technology-specific networks (Ethernet, TDM, OTN) already specified by
CCAMP.
*	Maintenance of LMP.

---

From: Daniele Ceccarelli <[email-masked]>
Date: Wed, 31 Mar 2021 06:59:47 +0000

Hi Adrian,

Thanks for spotting it.
The " Strikethrough" got lost when pasting the content into the mail.

Actually that applies to two statements:

  *   The OAM work will be synchronized with the LIME WG (WG closed)
  *   Protocol extensions in support of flexible grid lambda networks. (which is now included in the first bullet of the list).

Thanks,
Daniele

From: Adrian Farrel <[email-masked]>
Sent: den 31 mars 2021 00:22
To: Daniele Ceccarelli <[email-masked]>; 'CCAMP' <[email-masked]>
Subject: RE: [CCAMP] Charter update

Hi,

Small point

Cheers,
Adrian

From: CCAMP <[email-masked]<mailto:[email-masked]>> On Behalf Of Daniele Ceccarelli
Sent: 30 March 2021 13:03
To: CCAMP <[email-masked]<mailto:[email-masked]>>
Subject: [CCAMP] Charter update

Hi working group,

Thanks
Daniele , Fatai, Oscar
------

---

From: "Belotti, Sergio (Nokia - IT/Vimercate)" <[email-masked]>
Date: Wed, 31 Mar 2021 08:30:01 +0000

Hi Daniele, Adrian,

About OAM, LIME is clearly gone,  shall we put a reference to other SDO traditionally involved in OAM standardization like ITU-T or industrial forum like ONF ? Just a question.

About this part:
"The CCAMP WG currently works on the following tasks:

  *   Protocol extensions and YANG models in support of optical networks (e.g. WSON, flexi grid) with and without awareness of the optical impairments.
- Protocol extensions in support of flexible grid lambda networks"

It seems to me the same concept in the two bullets right?

Third: we started with OTN suggesting extension in network slicing technology specific.
Maybe something related to "slicing" should be added.

Thanks
Sergio

From: CCAMP <[email-masked]> On Behalf Of Daniele Ceccarelli
Sent: Wednesday, March 31, 2021 9:00 AM
To: [email-masked]; 'CCAMP' <[email-masked]>
Subject: Re: [CCAMP] Charter update

Hi Adrian,

Thanks for spotting it.

Thanks,
Daniele

From: Adrian Farrel <[email-masked]<mailto:[email-masked]>>
Sent: den 31 mars 2021 00:22
To: Daniele Ceccarelli <[email-masked]<mailto:[email-masked]>>; 'CCAMP' <[email-masked]<mailto:[email-masked]>>
Subject: RE: [CCAMP] Charter update

Hi,

Small point

Cheers,
Adrian

Hi working group,

Thanks
Daniele , Fatai, Oscar
------

---

From: Oscar González de Dios <[email-masked]>
Date: Wed, 31 Mar 2021 08:45:32 +0000

Hi Sergio, Daniele, Adrian,

                Regarding the slicing, if an explicit wording is required, would it make sense to have a similar sentence as with traffic engineering?

Description of non-packet-specific (e.g. Ethernet, TDM, OTN, WDM, ...)  aspects (requirements, use cases, ...) of network slicing and protocol and Yang models extensions in cooperation with the TEAS and  PCE working groups.

Best Regards,

                Oscar

De: CCAMP <[email-masked]> En nombre de Belotti, Sergio (Nokia - IT/Vimercate)
Enviado el: miércoles, 31 de marzo de 2021 10:30
Para: Daniele Ceccarelli <daniele.ceccarelli=[email-masked]>; [email-masked]; 'CCAMP' <[email-masked]>
Asunto: Re: [CCAMP] Charter update

Hi Daniele, Adrian,

About this part:

Thanks
Sergio

From: CCAMP <[email-masked]<mailto:[email-masked]>> On Behalf Of Daniele Ceccarelli
Sent: Wednesday, March 31, 2021 9:00 AM
To: [email-masked]<mailto:[email-masked]>; 'CCAMP' <[email-masked]<mailto:[email-masked]>>
Subject: Re: [CCAMP] Charter update

Hi Adrian,

Thanks for spotting it.

-          The OAM work will be synchronized with the LIME WG (WG closed)
-          Protocol extensions in support of flexible grid lambda networks. (which is now included in the first bullet of the list).

Thanks,
Daniele

Hi,

Small point
-          "OAM work will be synchronized with the LIME WG"
LIME was closed down just over 3 years ago

Cheers,
Adrian

Hi working group,

Thanks
Daniele , Fatai, Oscar
------

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição

---

From: "Belotti, Sergio (Nokia - IT/Vimercate)" <[email-masked]>
Date: Wed, 31 Mar 2021 08:50:24 +0000

Hi Oscar,
I personally like your suggestion.

Thanks
Sergio

From: Oscar González de Dios <[email-masked]>
Sent: Wednesday, March 31, 2021 10:46 AM
To: Belotti, Sergio (Nokia - IT/Vimercate) <[email-masked]>; Daniele Ceccarelli <daniele.ceccarelli=[email-masked]>; [email-masked]; 'CCAMP' <[email-masked]>
Subject: RE: [CCAMP] Charter update

Best Regards,

                Oscar

De: CCAMP <[email-masked]<mailto:[email-masked]>> En nombre de Belotti, Sergio (Nokia - IT/Vimercate)
Enviado el: miércoles, 31 de marzo de 2021 10:30
Para: Daniele Ceccarelli <daniele.ceccarelli=[email-masked]<mailto:daniele.ceccarelli=[email-masked]>>; [email-masked]<mailto:[email-masked]>; 'CCAMP' <[email-masked]<mailto:[email-masked]>>
Asunto: Re: [CCAMP] Charter update

Hi Daniele, Adrian,

About this part:

Thanks
Sergio

Hi Adrian,

Thanks for spotting it.

Thanks,
Daniele

Hi,

Small point

Cheers,
Adrian

Hi working group,

Thanks
Daniele , Fatai, Oscar
------

---

From: Greg Mirsky <[email-masked]>
Date: Wed, 31 Mar 2021 12:40:32 -0700

Hi Sergio, et al.,
I agree that there would be benefits of coordinating CCAMP work related to
OAM with other SDOs. At the same time, IETF has several WGs, e.g., IPPM,
OPSAWG, BFD, and RTGWG, where various aspects of OAM and on-path telemetry
have been discussed and a good number of RFCs already published and more
will be. It seems reasonable to look if some of the existing solutions are
applicable to problems discussed in the CCAMP WG.

Regards,
Greg

On Wed, Mar 31, 2021 at 1:30 AM Belotti, Sergio (Nokia - IT/Vimercate) <
[email-masked]> wrote:

> Hi Daniele, Adrian,
>
>
>
> About OAM, LIME is clearly gone,  shall we put a reference to other SDO
> traditionally involved in OAM standardization like ITU-T or industrial
> forum like ONF ? Just a question.
>
>
>
> About this part:
>
> “The CCAMP WG currently works on the following tasks:
>
>    - Protocol extensions and YANG models in support of optical networks
> - Protocol extensions in support of flexible grid lambda networks”
>
>
>
> Maybe something related to “slicing” should be added.
>
>
>
> Thanks
>
> Sergio
>
>
>
>
>
>
>
> *From:* CCAMP <[email-masked]> *On Behalf Of * Daniele Ceccarelli
> *Sent:* Wednesday, March 31, 2021 9:00 AM
> *To:* [email-masked]; 'CCAMP' <[email-masked]>
> *Subject:* Re: [CCAMP] Charter update
>
>
>
> Hi Adrian,
>
>
>
> Thanks for spotting it.
>
> The ” Strikethrough” got lost when pasting the content into the mail.
>
>
>
>    (which is now included in the first bullet of the list).
>
>
>
> Thanks,
> Daniele
>
>
>
>
>
> *From:* Adrian Farrel <[email-masked]>
> *Sent:* den 31 mars 2021 00:22
> *To:* Daniele Ceccarelli <[email-masked]>; 'CCAMP' <
> [email-masked]>
> *Subject:* RE: [CCAMP] Charter update
>
>
>
> Hi,
>
>
>
> Thanks for the work on this. It’s looking good.
>
>
>
> Small point
>
>    - “OAM work will be synchronized with the LIME WG”
> *From:* CCAMP <[email-masked]> *On Behalf Of *Daniele Ceccarelli
> *Sent:* 30 March 2021 13:03
> *To:* CCAMP <[email-masked]>
> *Subject:* [CCAMP] Charter update
>
>
>
> Hi working group,
>
>
>
> as briefly anticipated during the CCAMP session at IETF110 please find
> below the proposal for the update to the charter.
>
> found in the Internet and in the networks of telecom service providers
> (ISPs and SPs). Examples of the devices in such networks include photonic
> The working group develops extensions to core Traffic Engineering
> protocols that are under the care of other working groups as well as YANG
> models for the control and management of non-packet networks (this includes
> both device models and network models). The CCAMP working group will
> coordinate with the TEAS working group to ensure that extensions that can
> be generalized for use with more than one technology are made
> appropriately, and with the working groups that have responsibility for the
> specific protocols.
>
>
>
>    - Definition of protocol-independent metrics and parameters
>    - Maintenance and extension of the Link Management Protocol (LMP)
>    - Functional specification of extensions for GMPLS-related routing
>    jointly with the WGs supervising those  protocols and the TEAS working
>    group has the responsibility to   determine whether such protocol
>    extensions should be generalized  for Traffic Engineering in any network.
>    This may include protocol work to support data planes that have  already
>    been approved by another Standards Development Organization. Note that the
>    - Definition of management objects (e.g., as part of MIB modules or
>    - Describe non-packet-specific aspects of traffic engineering
>    - Define how the properties of network resources gathered by a
>    distributed in existing routing protocols, such as OSPF,  IS-IS, and
>    BGP-LS. CCAMP will work with the WGs that supervise  these.
>
>    - Protocol extensions and YANG models in support of optical networks
>    - Protocol extensions and YANG models in support of TDM networks (e.g.
>    OTN).
>    - YANG models in support of microwave networks.
>    - YANG models fin support of L1 services
>    - Client TE topologies
>    - Maintenance of existing protocol extensions for non-packet
>    - Maintenance of LMP.
> _______________________________________________
> CCAMP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ccamp
>