Subject: [CCAMP] 答复: Yangdoctors last call review of draft-ietf-ccamp-l1csm-yang-15

From: Zhenghaomian <[email-masked]>
Date: Thu, 9 Dec 2021 14:50:09 +0000

Hi Joe, 

Thank you very much for the review and useful comments. We are accepting all the proposals and please check the diffs from https://github.com/haomianzheng/IETF-ACTN-YANG-Model/pull/91/files.  

We plan to update the draft with latest yang/tree in a week, thanks. 

Best wishes,
Haomian

-----邮件原件-----
发件人: Joe Clarke via Datatracker [mailto:[email-masked]] 
发送时间: 2021年11月29日 21:41
收件人: [email-masked]
抄送: [email-masked]; [email-masked]; [email-masked]
主题: Yangdoctors last call review of draft-ietf-ccamp-l1csm-yang-15

Reviewer: Joe Clarke
Review result: Ready with Nits

I have been asked to review this draft and the L1CSM YANG module it includes on behalf of YANG Doctors.  Overall, I think the draft/module is ready, but I did find a few small issues.  First, please run "pyang -f yang" on this to normalize its formatting.  There were a few spacing and other formatting issues that will be cleaned up by doing this.  Other items are below:

In the header of the YANG module, you import ietf-layer1-types with a mark of RFCYYYY.  In your comment below calling out RFCXXXX (i.e., this RFC) it would be good to point the RFC Editor to YYYY as well.

===

In your identity definition section, you have a number of identity descriptions which are self-referential.  Admittedly, this is one of my pet peeves, but if you could add more clarifying description text to identities such as one-way-delay, one-way-errored-second, etc. it would help implementors and operators better consume the YANG module without always needing to refer to external references.

===

Can time-interval be uint32 instead of int?  I do not thing a negative time interval is possible/useful here.

===

The description of the grouping subscriber-l1vc-sls-service-attributes doesn't look accurate.  This is not a value per se, but a collection of attributes.

===

In the /services/service list you explicitly have "mandatory true" for the key service-id.  This is not needed since the key is mandatory.

---

From: "Joe Clarke (jclarke)" <[email-masked]>
Date: Fri, 10 Dec 2021 14:20:21 +0000

Thanks for the changes, Haomian.  On the YYYY note, you might want to explicitly call out that the RFC number there will be for ietf-layer1-types.

With the subscriber-l1vc-sls-service-attributes grouping description, I'm still not sure it accurately reflects what it shows.  I don't see how it provides a collection of values.  Rather to me, it looks like a set of SLS attributes that provide a way to gauge service performance.

Joe

On 12/9/21 09:50, Zhenghaomian wrote:

Hi Joe,

Best wishes,
Haomian

-----邮件原件-----
发件人: Joe Clarke via Datatracker [mailto:[email-masked]]
发送时间: 2021年11月29日 21:41
收件人: [email-masked]<mailto:[email-masked]>
抄送: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
主题: Yangdoctors last call review of draft-ietf-ccamp-l1csm-yang-15

Reviewer: Joe Clarke

===

===

===

===

---

From: Zhenghaomian <[email-masked]>
Date: Mon, 13 Dec 2021 06:41:36 +0000

Hi, Joe,

Thank you for the feedback. I took another look at MEF 63, how about the following description for subscriber-l1vc-sls-service-attributes grouping?

---Description starts---
A set of service attributes on L1VC Service Level Specification (SLS) that is agreed between the service provider and the subscriber.
---Description ends---

Best wishes,
Haomian

发件人: Joe Clarke (jclarke) [mailto:[email-masked]]
发送时间: 2021年12月10日 22:20
收件人: Zhenghaomian <[email-masked]>; [email-masked]
抄送: [email-masked]; [email-masked]; [email-masked]
主题: Re: 答复: Yangdoctors last call review of draft-ietf-ccamp-l1csm-yang-15

Joe

Hi Joe,

Best wishes,

Haomian

-----邮件原件-----

发送时间: 2021年11月29日 21:41

Reviewer: Joe Clarke

===

===

===

===

---

From: "Joe Clarke (jclarke)" <[email-masked]>
Date: Mon, 13 Dec 2021 14:05:44 +0000

Much better.  Thanks.

Joe

On 12/13/21 01:41, Zhenghaomian wrote:
Hi, Joe,

---Description ends---

Best wishes,
Haomian

发件人: Joe Clarke (jclarke) [mailto:[email-masked]]
发送时间: 2021年12月10日 22:20
收件人: Zhenghaomian <[email-masked]><mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
抄送: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
主题: Re: 答复: Yangdoctors last call review of draft-ietf-ccamp-l1csm-yang-15

Joe

Hi Joe,

Best wishes,

Haomian

-----邮件原件-----

发送时间: 2021年11月29日 21:41

Reviewer: Joe Clarke

===

===

===

===