Subject: [CCAMP] WG last call on draft-ietf-ccamp-flexigrid-yang-11

From: Daniele Ceccarelli <[email-masked]>
Date: Fri, 17 Dec 2021 14:50:06 +0000

CCAMP,

the IPR declaration collection has been successfully completed and we can move to the next step. Given the upcoming holiday period we'll allow for a longer last call.

This starts a 4 weeks working group last call on draft-ietf-ccamp-flexigrid-yang-11
The last call ends on Friday January 14th. Please send you comments to the CCAMP mailing list.

All the IPR declarations from authors and contributors have been collected and can be found in the history of the document (https://datatracker.ietf.org/doc/draft-ietf-ccamp-flexigrid-yang/history/)
If interested, please volunteer to be the shepherd of the draft (authors excluded).

Thanks

Daniele & Fatai

---

From: tom petch <[email-masked]>
Date: Mon, 20 Dec 2021 10:20:41 +0000

From: CCAMP <[email-masked]> on behalf of Daniele Ceccarelli <daniele.ceccarelli=[email-masked]>
Sent: 17 December 2021 14:50

CCAMP,

<tp>

wrong YANG  prefix (s.9)

After all the discussions on CCAMP and TEAS WG lists about what would make for a good prefix, this does not bode well - sigh

Tom Petch

Thanks

Daniele & Fatai

---

From: tom petch <[email-masked]>
Date: Mon, 20 Dec 2021 11:03:42 +0000

From: CCAMP <[email-masked]> on behalf of tom petch <[email-masked]>
Sent: 20 December 2021 10:20
From: CCAMP <[email-masked]> on behalf of Daniele Ceccarelli <daniele.ceccarelli=[email-masked]>
Sent: 17 December 2021 14:50

CCAMP,

<tp>

wrong YANG  prefix (s.9)

<tp2>

And while I am on the admin ...

The dates ib the module are wrong but differently wrong in different places - if it were all the same wrong I would live with it.

Security Considerations make no mention of any nodes in this I-D - I doubt if the AD will countenance that.

RFC Editor Note Please replace XXXX with the numbers assigned to RFC9093
Really?  Look in the YANG module revision reference and you may think again

TLP is out of date

Copyright out of date  - perhaps 2022!

URL lack security (https:) in several places

URL to an obsolete web page (tool)

[G.694.1] .... G-872
Really?

As I have commented before, it is a pig to review because TE got its YANG structure wrong in the first place so whether or not I will look at the semantics of the model , I do not know - perhaps if Boxing Day gets very boring:-)

Tom Petch

Thanks

Daniele & Fatai

_______________________________________________
CCAMP mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ccamp

---

From: <[email-masked]>
Date: Mon, 20 Dec 2021 11:08:22 -0000

Hi Tom, 

As an editor of the document, I appreciate your time and the review. So I'll
pick up the NITS in the text.  

Re: YANG Code and Prefix - I'll let the vendors address the issue(s).

BR, Dan.  

-----Original Message-----
From: CCAMP <[email-masked]> On Behalf Of tom petch
Sent: 20 December 2021 11:04
To: Daniele Ceccarelli <daniele.ceccarelli=[email-masked]>;
CCAMP <[email-masked]>
Subject: Re: [CCAMP] WG last call on draft-ietf-ccamp-flexigrid-yang-11

From: CCAMP <[email-masked]> on behalf of tom petch
<[email-masked]>
Sent: 20 December 2021 10:20
From: CCAMP <[email-masked]> on behalf of Daniele Ceccarelli
<daniele.ceccarelli=[email-masked]>
Sent: 17 December 2021 14:50

CCAMP,

This starts a 4 weeks working group last call on
draft-ietf-ccamp-flexigrid-yang-11
The last call ends on Friday January 14th. Please send you comments to the
CCAMP mailing list.

<tp>

wrong YANG  prefix (s.9)

After all the discussions on CCAMP and TEAS WG lists about what would make
for a good prefix, this does not bode well - sigh

<tp2>

The dates ib the module are wrong but differently wrong in different places
- if it were all the same wrong I would live with it.

Security Considerations make no mention of any nodes in this I-D - I doubt
if the AD will countenance that.

TLP is out of date

[G.694.1] .... G-872
Really?

As I have commented before, it is a pig to review because TE got its YANG
structure wrong in the first place so whether or not I will look at the
semantics of the model , I do not know - perhaps if Boxing Day gets very
boring:-)

Tom Petch

Thanks

Daniele & Fatai

---

From: tom petch <[email-masked]>
Date: Thu, 30 Dec 2021 11:02:14 +0000

From: CCAMP <[email-masked]> on behalf of tom petch <[email-masked]>
Sent: 20 December 2021 11:03

CCAMP,

<tp3>

Wound up by an intensely irritating Christmas with the prospect of a New Year that is not an improvement, ....

I have probably asked this before and forgotten the answer.  Most augments have a 'when' clause but the template related ones do not; why?

Also on 'when' the tests are all the same except that they are not because they use a relative path statement so they are all different.  If the 'when' used an absolute form then they would all be identical and it would be obvious whether they were right or wrong.  Thoughts?

Tom Petch

<tp>

wrong YANG  prefix (s.9)

<tp2>

TLP is out of date

[G.694.1] .... G-872
Really?

Tom Petch

Thanks

Daniele & Fatai

---

From: tom petch <[email-masked]>
Date: Fri, 31 Dec 2021 10:22:23 +0000

Sent: 30 December 2021 11:02

CCAMP,

<tp3>

<tp3>

I asked on the netmod list and my first idea was wrong because there is a list in the Xpath which would then be true if any network had the flexigrid type so the augments would be for every node not just the flexigrid ones.

However, there is an 'ancestor' function which  would seem to overcome this.

Tom Petch

<tp>

wrong YANG  prefix (s.9)

<tp2>

TLP is out of date

[G.694.1] .... G-872
Really?

Tom Petch

Thanks

Daniele & Fatai