Subject: Re: [CCAMP] WG adoption poll on draft-zheng-ccamp-yang-otn-slicing-03

From: "Wubo (lana)" <[email-masked]>
Date: Fri, 14 Jan 2022 10:35:28 +0000

Hi Authors, all,

As the draft references the NSC NBI (draft-ietf-teas-ietf-network-slice-nbi-yang) and says that IETF NSC may use the OTN-SC NBI to realize the NSC NBI, I have some questions on this draft:

1)       I believe the NSC NBI technology-specific extensions should be defined as an augment to the technology-agnostic NSC NBI. For example, we received some comments, that Network slice endpoint needs to extend some technology-specific parameters agreed between CE and PE. I also noticed that the YANG structure of the OTN-SC NBI model has some similar parts with NSC NBI model.  So I understand that future NSC NBI models may need some technology-specific extensions, but wonder why the authors did not consider the augmentation of the NSC NBI YANG?

2)       The draft says that OTN-SC NBI needs a technology-specific model, but I do not see "ietf-transport-network-slice" contains any technology-specific or OTN-specific parameters. Is there any particular reason?

Thanks,
Bo

From: Fatai Zhang <zhangfatai=[email-masked]<mailto:[email-masked]>>
Date: Wed, Jan 12, 2022 at 7:54 AM
Subject: [CCAMP] WG adoption poll on draft-zheng-ccamp-yang-otn-slicing-03
To: CCAMP <[email-masked]<mailto:[email-masked]>>

Hi all,

All the IPR declarations regarding draft-zheng-ccamp-yang-otn-slicing-03 have been collected, this starts the polling for WG adoption.

The poll will last 2 weeks and will end on Wednesday January 26th.

Please send email to the list indicating "yes/support" or "no/do not support" and a motivation for your reply, mandatory for the "not support" and nice to have for the "support".

Thanks,

Fatai & Daniele

_______________________________________________
CCAMP mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ccamp

---

From: Aihua Guo <[email-masked]>
Date: Mon, 17 Jan 2022 18:23:39 -0500

Hi Wubo,

Thanks for the comments.

The OTN-SC NBI is designed to build on a technology-agnostic base model to
support both connectivity-based slicing and resource-based slicing using
topologies. The “ietf-transport-network-slice” model was our initial
proposal to serve this purpose.

We have analyzed and imported definitions from existing models, including
the VN YANG model, draft-liu-teas-transport-network-slice-yang and
draft-ietf-teas-ietf-network-slice-nbi-yang. At the time of analysis
draft-ietf-teas-ietf-network-slice-nbi-yang seems to contain IP technologic
specific parameters which are not applicable to transport, plus the missing
support for resource-based slicing as needed by OTN slicing. Considering
that draft-ietf-teas-ietf-network-slice-nbi-yang is still under changes and
is not stable yet, we thus took the approach to define the base model for
transport network slice. However, we are open to augment
draft-ietf-teas-ietf-network-slice-nbi-yang once it is stable and addresses
the issue above.

Thanks,
Aihua

On Fri, Jan 14, 2022 at 5:35 AM Wubo (lana) <lana.wubo=
[email-masked]> wrote:

> Hi Authors, all,
>
>
>
> As the draft references the NSC NBI
> (draft-ietf-teas-ietf-network-slice-nbi-yang) and says that IETF NSC may
> use the OTN-SC NBI to realize the NSC NBI, I have some questions on this
> draft:
>
> 1)       I believe the NSC NBI technology-specific extensions should be
> defined as an augment to the technology-agnostic NSC NBI. For example, we
> received some comments, that Network slice endpoint needs to extend some
> technology-specific parameters agreed between CE and PE. I also noticed
> that the YANG structure of the OTN-SC NBI model has some similar parts with
> NSC NBI model.  So I understand that future NSC NBI models may need some
> technology-specific extensions, but wonder why the authors did not consider
> the augmentation of the NSC NBI YANG?
>
> 2)       The draft says that OTN-SC NBI needs a technology-specific
> model, but I do not see "ietf-transport-network-slice" contains any
> technology-specific or OTN-specific parameters. Is there any particular
> reason?
>
>
>
> Thanks,
>
> Bo
>
>
>
> From: *Fatai Zhang* <zhangfatai=[email-masked]>
> To: CCAMP <[email-masked]>
>
>
>
> Hi all,
>
>
>
> All the IPR declarations regarding draft-zheng-ccamp-yang-otn-slicing-03
> have been collected, this starts the polling for WG adoption.
>
>
>
> Please send email to the list indicating "yes/support" or "no/do not
> support" and a motivation for your reply, mandatory for the "not support"
> and nice to have for the "support".
>
>
>
>
>
> Thanks,
>
>
>
> Fatai & Daniele
>
>
>
>
>
>
>
> [email-masked]
> [email-masked]