Subject: Re: [CCAMP] CCAMP Digest, Vol 166, Issue 9

From: <[email-masked]>
Date: Wed, 9 Mar 2022 11:06:14 +0800 (CST)

hi, 

The flexe-cm YANG model in the draft-wang-ccamp-flexe-yang-cm-02.txt summarizes the discussion previous in the maillist and fulfills the basic configuration requirements for FlexE groups and clients, and I think, it's useful and a great step forward.

In addition to some updates already indicated in the draft according to our discussion offline a few days ago, here are some further suggested editorial modifications.

1) In the YANG tree, the Key of flexe-group is [group-index], while 'group-index' is not in the YANG tree. The Key should be 'index' judging from the YANG module.

2) In the YANG tree, some of leaf nodes in FlexE-group, such as index, group-num,  are not optional. It's better to show mandatory in the ietf-flexe-cm YANG module.

3) In the YANG module, the max range of leaf group-num is 1048574 and that overflows the maxium of uint32. It's better to change the data type to uint64.

B.R.   

牛小兵     Xiaobing NIU

原始邮件

发件人：[email-masked]
收件人：[email-masked];
日 期 ：2022年03月07日 18:14
主 题 ：CCAMP Digest, Vol 166, Issue 9

Send CCAMP mailing list submissions to
    [email-masked]
 
To subscribe or unsubscribe via the World Wide Web, visit
    https://www.ietf.org/mailman/listinfo/ccamp
or, via email, send a message with subject or body 'help' to
    [email-masked]
 
You can reach the person managing the list at
    [email-masked]
 
When replying, please edit your Subject line so it is more specific
than "Re: Contents of CCAMP digest..." 

Today's Topics:
 
   1.  [ietf-ccamp-wg/ietf-ccamp-layer0-types-ext] 1eadfe: Updated
      draft (italobusi)
   2.
      [ietf-ccamp-wg/draft-ietf-ccamp-optical-impairment-topology-yang]
      ed27d8: Updated YANG (italobusi)
   3. Re:  [Editorial Errata Reported] RFC8632 (6866) (stefan vallin)
   4.
      [ietf-ccamp-wg/draft-ietf-ccamp-optical-impairment-topology-yang]
      6c2dad: Update test_yang.py (italobusi)
   5.
      [ietf-ccamp-wg/draft-ietf-ccamp-optical-impairment-topology-yang]
      aad2c6: Updated YANG model for IETF 113 (#104) (italobusi)
   6.
      [ietf-ccamp-wg/draft-ietf-ccamp-optical-impairment-topology-yang]
      (italobusi)
   7.  I-D Action: draft-wang-ccamp-flexe-yang-cm-02.txt
      ([email-masked])

_______________________________________________
CCAMP mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ccamp

---

From: <[email-masked]>
Date: Wed, 9 Mar 2022 12:09:36 +0800 (CST)

hi, 

B.R.   
Xiaobing NIU

------------------原始邮件------------------

Today's Topics:

---

From: "Yangfan(Fan,IP Standards)" <[email-masked]>
Date: Fri, 11 Mar 2022 10:29:34 +0000

Hi Xiaobing,

Thank you for your acknowledgement and comments. My response please see inline.

Best regards,
Fan 

-----Original Message-----
From: CCAMP [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Wednesday, March 9, 2022 12:10 PM
To: [email-masked]
Subject: Re: [CCAMP] CCAMP Digest, Vol 166, Issue 9

hi,
The flexe-cm YANG model in the draft-wang-ccamp-flexe-yang-cm-02.txt summarizes the discussion previous in the maillist and fulfills the basic configuration requirements for FlexE groups and clients, and I think, it's useful and a great step forward.
In addition to some updates already indicated in the draft according to our discussion offline a few days ago, here are some further suggested editorial modifications.
1) In the YANG tree, the Key of flexe-group is [group-index], while 'group-index' is not in the YANG tree. The Key should be 'index' judging from the YANG module.
---- accepted, would update in next revision.

2) In the YANG tree, some of leaf nodes in FlexE-group, such as index, group-num,  are not optional. It's better to show mandatory in the ietf-flexe-cm YANG module.
--- already updated in 02 revision.

3) In the YANG module, the max range of leaf group-num is 1048574 and that overflows the maxium of uint32. It's better to change the data type to uint64.
--- I think uint32 does satisfy the max range of 1048574. 

B.R.   
Xiaobing NIU

------------------原始邮件------------------
发件人：[email-masked]
收件人：[email-masked];
日 期 ：2022年03月07日 18:14
主 题 ：CCAMP Digest, Vol 166, Issue 9
Send CCAMP mailing list submissions to
[email-masked]
To subscribe or unsubscribe via the World Wide Web, visit https://www.ietf.org/mailman/listinfo/ccamp
or, via email, send a message with subject or body 'help' to [email-masked] You can reach the person managing the list at [email-masked] When replying, please edit your Subject line so it is more specific than "Re: Contents of CCAMP digest..."

Today's Topics:
1.  [ietf-ccamp-wg/ietf-ccamp-layer0-types-ext] 1eadfe: Updated draft (italobusi) 2.
[ietf-ccamp-wg/draft-ietf-ccamp-optical-impairment-topology-yang]
ed27d8: Updated YANG (italobusi)
3. Re:  [Editorial Errata Reported] RFC8632 (6866) (stefan vallin) 4.
[ietf-ccamp-wg/draft-ietf-ccamp-optical-impairment-topology-yang]
6c2dad: Update test_yang.py (italobusi)
5.
[ietf-ccamp-wg/draft-ietf-ccamp-optical-impairment-topology-yang]
aad2c6: Updated YANG model for IETF 113 (#104) (italobusi) 6.
[ietf-ccamp-wg/draft-ietf-ccamp-optical-impairment-topology-yang]
(italobusi)
7.  I-D Action: draft-wang-ccamp-flexe-yang-cm-02.txt
([email-masked])