Subject: [CDNi] TR: I-D Action:draft-bertrand-cdni-use-cases-00.txt

From: <[email-masked]>
Date: Thu, 13 Jan 2011 15:02:17 +0100

Hi,
 
A New Internet-Draft is available from the on-line Internet-Drafts directories.
 
      Title           : Use Cases for Content Distribution Network Interconnection
      Link            : http://www.ietf.org/internet-drafts/draft-bertrand-cdni-use-cases-00.txt 

This draft describes 5 use cases: 
 
 - CDN Interconnection inside one CDSP
 - CDN Interconnection between CDSPs
 - CDN Interconnection for CDN Overload Handling
 - CDN Interconnection for CDN Resiliency
 - Inter-Silos CDN Interconnection inside one CDSP
 
It complements the draft posted by Grant. Hence, we will work together to merge the two documents. In the meantime, comments and suggestions are invited so they can be factored in the merge work.
 
Regards
Emile
 
-----Message d'origine-----
De : [email-masked] [mailto:[email-masked]] De la part de [email-masked]
Envoyé : jeudi 13 janvier 2011 12:30
À : [email-masked]
Objet : I-D Action:draft-bertrand-cdni-use-cases-00.txt
 
A New Internet-Draft is available from the on-line Internet-Drafts directories.
 
      Title           : Use Cases for Content Distribution Network Interconnection
      Author(s)       : G. Bertrand, E. Stephan
      Filename        : draft-bertrand-cdni-use-cases-00.txt
      Pages           : 11
      Date            : 2011-01-13
 
This document depicts use cases for content delivery network (CDN)
interconnection based on Orange experiments.  The use cases are
divided in the two following categories.  Category 1 use cases
present situations that require a footprint extension for existing
CDNs.  Category 2 use cases include additional situations where CDN
interconnection would be desirable in a longer term.
 
A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-bertrand-cdni-use-cases-00.txt
 
Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/
 
Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: Francois Le Faucheur <[email-masked]>
Date: Fri, 14 Jan 2011 10:32:54 +0100

Hi Emile, Gilles, and others,

Thanks for working on documenting the use cases and for reflecting my earlier off-line input.

My overall comments are:
	* this provides useful additional material for documenting the CDNi use cases. 
	* it includes most of the key use cases that I see coming up regularly in NSPs.
	* one additional use case missing is the "national CDN federation" but some text has already been proposed on the list for that by Thomas Parmelan (http://www.ietf.org/mail-archive/web/cdni/current/msg00040.html)
	* it seems useful to attempt to distinguish between short-term & long-term use cases as you are proposing.
	* the conclusions of your experiments that you share in 3.2 are very interesting. They align well with the requirement for the "CDNI Request-Routing API" and "CDNI Metadata API" discussed in the problem statement.

Below are more detailed comments/suggestions:

* "This document depicts use cases for content delivery network (CDN) interconnection based on Orange experiments"
Did you mean "experience" instead of "experiments"?
(while section 3 discusses conclusions from "experiments", I take it that the use cases are not derived from the experiments)
Or perhaps this should even read "based on the author's experience" since we all speak as individuals here.

* "Category 1 use cases
   present situations that require a footprint extension for existing
   CDNs.  Category 2 use cases include additional situations where CDN
   interconnection would be desirable in a longer term.
"
The two categories seem to be defined against different criteria: Cat1 is defined against some functional objectives, Cat2 is defined in terms or urgency.
I assume Cat1 is essentially short term and Cat2 is longer term, right? 
I think it is indeed useful for the Use Case I-D to break use cases into short-term and long-term. I am just suggesting this be made even clearer and be retained in the "merge" exercise. (e.g. "2.1. Footprint Extension Use Cases" --> "2.1 Short term CDNi Use Cases")

* Access CDN.
This term is defined but I don't think it is actually used in the document. I am not clear it is needed.

*2.1.1  "Note that currently, the distribution of some content is restricted.
   For instance, distribution rights for audiovisual content are often
   negotiated per country."
That is certainly true, but it may be worth spelling out the consequences such as:
	* while the CDN federation need to be able to allow deliveries of some content across the combined footprint of the interconnected CDNs, it must also be able to restrict delivery of some content to a single CDN or subsets of CDN footprints.

*2.1.2 "the serie" --> "the series"

* 2.2.1 "during the prime time" --> "during their respective prime time"

I hope this helps.

Francois

On 13 Jan 2011, at 15:02, <[email-masked]> <[email-masked]> wrote:

> <draft-bertrand-cdni-use-cases-00.URL>