Subject: [CDNi] Proposed text for 3GPP and MPEG portions

From: "Ali C. Begen (abegen)" <[email-masked]>
Date: Mon, 7 Feb 2011 08:46:57 -0800

Hi everyone,

The current problem statement draft talks about other related standardization activities. 6.1.2 mentions 3GPP. Following up my conversation with Francois, he asked me to provide a bit more details on the developments in 3GPP as well as MPEG.

With Francois' input, I think the following text would be good to incorporate in the draft. It proposes some changes in 6.1.2 and adds a new section (preferably right after 6.1.2) for MPEG. Also note that 3GPP's method is called 3GP-DASH and MPEG's version is called MPEG DASH. The text should be updated throughout the draft appropriately. Below is also the revised list of references.

-acbegen

6.1.2.  3GPP

3GPP is the first organization that released a specification related to adaptive streaming over HTTP. 3GPP Release 9 was published in March 2010, and the SA4 Working Group is currently in the process of bug-fixing this specification taking into account experience from the first implementations. In addition, 3GPP is preparing an extended version for Release 10, which is scheduled to be published later in 2011. This release will include a number of clarifications, offer improvements and add new features.

[3GP-DASH] is defined as a general framework independent of the data encapsulation format. It has support for fast initial startup and seeking, adaptive bitrate switching, re-use of HTTP origin and cache servers, re-use of existing media playout engines, on-demand, live and time-shifted delivery. It specifies syntax and semantics of Media Presentation Description (MPD), format of segments and delivery protocol for segments. It does not specify content provisioning, client behavior or transport of MPD.

The content retrieved by a client using 3GP-DASH adaptive streaming could be obtained from a CDN but this is not discussed or specified in the 3GPP specifications as it is transparent to 3GP-DASH operations. Similarly, it is expected that 
3GP-DASH can be used transparently from the CDNs as a delivery protocol (between the delivering CDN surrogate and the User Agent) in a CDN Interconnect environment. 3GP-DASH could also be a candidate for content acquisition between CDNs in a CDN Interconnect environment.

6.1.3 MPEG

On the MPEG side, the Dynamic Adaptive Streaming over HTTP (DASH) Ad Hoc Group has adopted the 3GPP Release 9 as a baseline specification and started running several evaluation experiments to evaluate the submitted proposals. The DASH Ad Hoc Group is working on standardizing the manifest file, delivery format, conversion from/to existing file formats and the use of MPEG2 Transport Streams as a media format. The MPEG DASH specification could also be a candidate for delivery to the user agent and for content acquisition between CDNs in a CDN Interconnect environment. The Draft International Standard (DIS) version [MPEG-DASH] should be publicly available at http://mpeg.chiariglione.org/working_documents.htm#MPEG-B in early February.

In the 95th MPEG meeting in January 2011, the DASH Ad Hoc Group has decided to start a new evaluation experiment called "CDN-EE". The goals are to understand the requirements for MPEG DASH to better support CDN-based delivery, and to provide a guidelines document for CDN operators to better support MPEG DASH streaming services. The ongoing work is still very preliminary and does not currently target looking into CDN Interconnect issues.

[3GP-DASH]
"Transparent end-to-end Packet-switched Streaming Service (PSS); Progressive Download and Dynamic Adaptive Streaming over HTTP (3GP-DASH)" http://www.3gpp.org/ftp/Specs/html-info/26247.htm 

[MPEG-DASH] “Information technology — MPEG systems technologies — Part 6: Dynamic adaptive streaming over HTTP (DASH),” (DIS version), February 2011 http://mpeg.chiariglione.org/working_documents.htm#MPEG-B

---

From: Benjamin Niven-Jenkins <[email-masked]>
Date: Mon, 7 Feb 2011 21:51:47 +0000

Ali,

Thanks for proposing some improved text. If no-one objects we'll incorporate your proposal in the next version of the problem statement.

Ben

On 7 Feb 2011, at 16:46, Ali C. Begen (abegen) wrote:

> _______________________________________________
> CDNi mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cdni

---

From: Wangyekui <[email-masked]>
Date: Wed, 09 Feb 2011 12:31:02 +0000

Good text from Ali!

I have made some small changes, just trying to better reflect the 3GPP and MPEG situations. For the 3GPP text (6.1.2), I have only touched the first paragraph. For the MPEG text (6.1.3), main changes are also in paragraph 1, in paragraph 2 I only made a very minor change of "Ad Hoc Group" to "ad-hoc group", to be consistent with my changes in paragraph 1.

Please review (particularly Ali to confirm whether the changes are OK with you).

BR, YK

Ye-Kui Wang
Media Netowrking Lab
Core Network Product Line
Huawei Technologies
400 Crossing Blvd, 2nd Floor
Bridgewater, NJ 08807, USA

6.1.2. 3GPP

3GPP is the first organization that released a specification related to adaptive streaming over HTTP. 3GPP Release 9 specification on adaptive HTTP streaming was published in March 2010, and there have been some bug fixes on this specification since the publication. In addition, 3GPP is preparing an extended version for Release 10, which is scheduled to be published later in 2011. This release will include a number of clarifications, improvements and new features.

The content retrieved by a client using 3GP-DASH adaptive streaming could be obtained from a CDN but this is not discussed or specified in the 3GPP specifications as it is transparent to 3GP-DASH operations. Similarly, it is expected that 3GP-DASH can be used transparently from the CDNs as a delivery protocol (between the delivering CDN surrogate and the User Agent) in a CDN Interconnect environment. 3GP-DASH could also be a candidate for content acquisition between CDNs in a CDN Interconnect environment.

6.1.3 MPEG

On the MPEG side, the Dynamic Adaptive Streaming over HTTP (DASH) ad-hoc group adopted the 3GPP Release 9 as a starting point and has made some improvements and extensions. Similarly as 3GPP SA4, the MPEG DASH ad-hoc group has been working on standardizing the manifest file and the delivery format. Additionally, the MPEG DASH ad-hoc group has also been working on the use of MPEG-2 Transport Streams as a media format, conversion from/to existing file formats, common encryption, and so on. The MPEG DASH specification could also be a candidate for delivery to the user agent and for content acquisition between CDNs in a CDN Interconnect environment. The Draft International Standard (DIS) version [MPEG-DASH] should be publicly available at http://mpeg.chiariglione.org/working_documents.htm#MPEG-B in early February.

In the 95th MPEG meeting in January 2011, the DASH ad-hoc group has decided to start a new evaluation experiment called "CDN-EE". The goals are to understand the requirements for MPEG DASH to better support CDN-based delivery, and to provide a guidelines document for CDN operators to better support MPEG DASH streaming services. The ongoing work is still very preliminary and does not currently target looking into CDN Interconnect issues.

[3GP-DASH]

[MPEG-DASH] "Information technology - MPEG systems technologies - Part 6: Dynamic adaptive streaming over HTTP (DASH)," (DIS version), February 2011 http://mpeg.chiariglione.org/working_documents.htm#MPEG-B

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Benjamin Niven-Jenkins
Sent: Monday, February 07, 2011 4:52 PM
To: Ali C. Begen (abegen)
Cc: [email-masked]; [email-masked]
Subject: Re: [CDNi] Proposed text for 3GPP and MPEG portions

Ali,

Ben

On 7 Feb 2011, at 16:46, Ali C. Begen (abegen) wrote:

> [MPEG-DASH] "Information technology - MPEG systems technologies - Part 6: Dynamic adaptive streaming over HTTP (DASH)," (DIS version), February 2011 http://mpeg.chiariglione.org/working_documents.htm#MPEG-B

---

From: Wangyekui <[email-masked]>
Date: Wed, 09 Feb 2011 12:38:37 +0000

BTW, all instances of "Cable Labs" in the problem statement document should be changed to "CableLabs", I think.

BR, YK

-----Original Message-----
From: Wangyekui 
Sent: Wednesday, February 09, 2011 7:31 AM
To: 'Benjamin Niven-Jenkins'; Ali C. Begen (abegen)
Cc: [email-masked]; [email-masked]
Subject: RE: [CDNi] Proposed text for 3GPP and MPEG portions

Good text from Ali!

BR, YK

Ye-Kui Wang
Media Netowrking Lab

6.1.2. 3GPP

6.1.3 MPEG

[3GP-DASH]

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Benjamin Niven-Jenkins
Sent: Monday, February 07, 2011 4:52 PM
To: Ali C. Begen (abegen)
Cc: [email-masked]; [email-masked]
Subject: Re: [CDNi] Proposed text for 3GPP and MPEG portions

Ali,

Ben

---

From: "Ali C. Begen (abegen)" <[email-masked]>
Date: Wed, 9 Feb 2011 06:14:46 -0800

Looks good to me.

-acbegen

> From: Wangyekui [mailto:[email-masked]]
> To: Benjamin Niven-Jenkins; Ali C. Begen (abegen)
> I have made some small changes, just trying to better reflect the 3GPP and MPEG situations. For the 3GPP text (6.1.2), I have
> only touched the first paragraph. For the MPEG text (6.1.3), main changes are also in paragraph 1, in paragraph 2 I only
> made a very minor change of "Ad Hoc Group" to "ad-hoc group", to be consistent with my changes in paragraph 1.
> 
> 3GPP is the first organization that released a specification related to adaptive streaming over HTTP. 3GPP Release 9
> specification on adaptive HTTP streaming was published in March 2010, and there have been some bug fixes on this
> specification since the publication. In addition, 3GPP is preparing an extended version for Release 10, which is scheduled to
> be published later in 2011. This release will include a number of clarifications, improvements and new features.
> 
> [3GP-DASH] is defined as a general framework independent of the data encapsulation format. It has support for fast initial
> startup and seeking, adaptive bitrate switching, re-use of HTTP origin and cache servers, re-use of existing media playout
> engines, on-demand, live and time-shifted delivery. It specifies syntax and semantics of Media Presentation Description
> (MPD), format of segments and delivery protocol for segments. It does not specify content provisioning, client behavior or
> transport of MPD.
> 
> The content retrieved by a client using 3GP-DASH adaptive streaming could be obtained from a CDN but this is not discussed
> or specified in the 3GPP specifications as it is transparent to 3GP-DASH operations. Similarly, it is expected that 3GP-DASH
> can be used transparently from the CDNs as a delivery protocol (between the delivering CDN surrogate and the User Agent)
> in a CDN Interconnect environment. 3GP-DASH could also be a candidate for content acquisition between CDNs in a CDN
> Interconnect environment.
> 
> 6.1.3 MPEG
> 
> On the MPEG side, the Dynamic Adaptive Streaming over HTTP (DASH) ad-hoc group adopted the 3GPP Release 9 as a
> starting point and has made some improvements and extensions. Similarly as 3GPP SA4, the MPEG DASH ad-hoc group has
> been working on standardizing the manifest file and the delivery format. Additionally, the MPEG DASH ad-hoc group has also
> been working on the use of MPEG-2 Transport Streams as a media format, conversion from/to existing file formats, common
> encryption, and so on. The MPEG DASH specification could also be a candidate for delivery to the user agent and for content
> acquisition between CDNs in a CDN Interconnect environment. The Draft International Standard (DIS) version [MPEG-DASH]
> should be publicly available at http://mpeg.chiariglione.org/working_documents.htm#MPEG-B in early February.
> 
> In the 95th MPEG meeting in January 2011, the DASH ad-hoc group has decided to start a new evaluation experiment called
> "CDN-EE". The goals are to understand the requirements for MPEG DASH to better support CDN-based delivery, and to
> provide a guidelines document for CDN operators to better support MPEG DASH streaming services. The ongoing work is still
> very preliminary and does not currently target looking into CDN Interconnect issues.
> 
> [3GP-DASH]
> "Transparent end-to-end Packet-switched Streaming Service (PSS); Progressive Download and Dynamic Adaptive Streaming
> over HTTP (3GP-DASH)" http://www.3gpp.org/ftp/Specs/html-info/26247.htm
> 
> [MPEG-DASH] "Information technology - MPEG systems technologies - Part 6: Dynamic adaptive streaming over HTTP
> (DASH)," (DIS version), February 2011 http://mpeg.chiariglione.org/working_documents.htm#MPEG-B
> 
> 
> > The current problem statement draft talks about other related standardization activities. 6.1.2 mentions 3GPP. Following up
> my conversation with Francois, he asked me to provide a bit more details on the developments in 3GPP as well as MPEG.
> >
> > With Francois' input, I think the following text would be good to incorporate in the draft. It proposes some changes in 6.1.2
> and adds a new section (preferably right after 6.1.2) for MPEG. Also note that 3GPP's method is called 3GP-DASH and
> MPEG's version is called MPEG DASH. The text should be updated throughout the draft appropriately. Below is also the
> revised list of references.
> >
> > -acbegen
> >
> >
> >
> > 6.1.2.  3GPP
> >
> > 3GPP is the first organization that released a specification related to adaptive streaming over HTTP. 3GPP Release 9 was
> published in March 2010, and the SA4 Working Group is currently in the process of bug-fixing this specification taking into
> account experience from the first implementations. In addition, 3GPP is preparing an extended version for Release 10, which
> is scheduled to be published later in 2011. This release will include a number of clarifications, offer improvements and add
> new features.
> >
> > [3GP-DASH] is defined as a general framework independent of the data encapsulation format. It has support for fast initial
> startup and seeking, adaptive bitrate switching, re-use of HTTP origin and cache servers, re-use of existing media playout
> engines, on-demand, live and time-shifted delivery. It specifies syntax and semantics of Media Presentation Description
> (MPD), format of segments and delivery protocol for segments. It does not specify content provisioning, client behavior or
> transport of MPD.
> >
> > The content retrieved by a client using 3GP-DASH adaptive streaming could be obtained from a CDN but this is not
> discussed or specified in the 3GPP specifications as it is transparent to 3GP-DASH operations. Similarly, it is expected that
> > 3GP-DASH can be used transparently from the CDNs as a delivery protocol (between the delivering CDN surrogate and the
> User Agent) in a CDN Interconnect environment. 3GP-DASH could also be a candidate for content acquisition between CDNs
> in a CDN Interconnect environment.
> >
> > 6.1.3 MPEG
> >
> > On the MPEG side, the Dynamic Adaptive Streaming over HTTP (DASH) Ad Hoc Group has adopted the 3GPP Release 9 as a
> baseline specification and started running several evaluation experiments to evaluate the submitted proposals. The DASH Ad
> Hoc Group is working on standardizing the manifest file, delivery format, conversion from/to existing file formats and the use
> of MPEG2 Transport Streams as a media format. The MPEG DASH specification could also be a candidate for delivery to the
> user agent and for content acquisition between CDNs in a CDN Interconnect environment. The Draft International Standard
> (DIS) version [MPEG-DASH] should be publicly available at http://mpeg.chiariglione.org/working_documents.htm#MPEG-B in
> early February.
> >
> > In the 95th MPEG meeting in January 2011, the DASH Ad Hoc Group has decided to start a new evaluation experiment
> called "CDN-EE". The goals are to understand the requirements for MPEG DASH to better support CDN-based delivery, and to
> provide a guidelines document for CDN operators to better support MPEG DASH streaming services. The ongoing work is still
> very preliminary and does not currently target looking into CDN Interconnect issues.
> >
> > [3GP-DASH]
> > "Transparent end-to-end Packet-switched Streaming Service (PSS); Progressive Download and Dynamic Adaptive Streaming
> over HTTP (3GP-DASH)" http://www.3gpp.org/ftp/Specs/html-info/26247.htm
> >
> > [MPEG-DASH] "Information technology - MPEG systems technologies - Part 6: Dynamic adaptive streaming over HTTP
> (DASH)," (DIS version), February 2011 http://mpeg.chiariglione.org/working_documents.htm#MPEG-B