Subject: [CDNi] Comments on definition of recursive&iterative request routing

From: He Xiaoyan <[email-masked]>
Date: Wed, 08 Jun 2011 10:23:46 +0800

Hi all,

Some comments on definition of recursive and iterative request routing in
I-D .draft-lefaucheur-cdni-requirements.

1) "When an Upstream CDN elects to redirect a request towards a Downstream
CDN,the Upstream CDN can query the Downstream CDN Request Routing system via
the CDNI Request Routing protocol to find out how the Downstream CDN wants
the request to be redirected ." This definition only covers requests
initiated by users where upstream CDN will query the downstream CDN for
routing decision. There is another case where recursive request routing is
also utilized but not covered by this definition in CDNI, i.e. In case of
cache miss and hence dynamic content acquisition invoked, for the content
locate request issued by a delivery node of downstream CDN, the downstream
CDN can query the upstream CDN on routing/redirection decision. In my view,
these are two very similar scenarios with no essential difference on routing
procedure.

2) Similarly, for iterative request routing, the definition only covers the
case that requests redirected from upstream CDN to downstream CDN, the
direction that requests redirected from downstream CDN to upstream CDN for
content locate requests in case of dynamic content acquisition is not
covered.

Is the intent to exclude routings for content locate requests or something
else? 

Thanks.

Best Regards

Xiaoyan(Susan) He

---

From: Francois Le Faucheur <[email-masked]>
Date: Wed, 8 Jun 2011 18:18:35 +0200

Hello He,

You are right that these definitions have been written with handling of enduser requests in mind (as opposed to handling of inter-CDN acquisition requests).

The logic is that the inter-CDN acquisition request (issued by a downstream CDN cache and pointing to the upstream CDN request routing system) can be considered simply as another request of its own (only, in that case, the "end user" happens to be a downstream CDN cache). Since the inter-CDN acquisition request is expected to come out of a cache (eg via a HTTP get), I am not sure we'd want to invoke the CDNI Request Routing protocol at that stage (that is intended to operate across Request Routing systems). ie I'd picture that the cache in the downstream CDN (CDN2) will issue its inter-CDN acquisition request and that request will be handled directly by the upstream CDN Request Routing system (CDN1) - via HTTP or DNS, like a regular CDN scenario. Of course, if the upstream CDN (CDN1) decided to redirect that particular (inter-CDN acquisition) request to a 3rd CDN (CDN3), then the iterative/recursive redirection would apply across these CDNs; but in this case, I think the current definitions actually work, because with respect to the inter-CDN acquisition request, CDN1 is the upstream CDN and CDN3 is the downstream CDN). (remember that the definitions of upstream CDN and downstream CDN are all relative to a given user request).

Thanks for looking into the Requirements document.

Francois

On 8 Jun 2011, at 04:23, He Xiaoyan wrote:

> Hi all,
> Some comments on definition of recursive and iterative request routing in I-D .draft-lefaucheur-cdni-requirements.
> 1) “When an Upstream CDN elects to redirect a request towards a Downstream CDN,the Upstream CDN can query the Downstream CDN Request Routing system via the CDNI Request Routing protocol to find out how the Downstream CDN wants the request to be redirected …” This definition only covers requests initiated by users where upstream CDN will query the downstream CDN for routing decision. There is another case where recursive request routing is also utilized but not covered by this definition in CDNI, i.e. In case of cache miss and hence dynamic content acquisition invoked, for the content locate request issued by a delivery node of downstream CDN, the downstream CDN can query the upstream CDN on routing/redirection decision. In my view, these are two very similar scenarios with no essential difference on routing procedure.
>  
> 2) Similarly, for iterative request routing, the definition only covers the case that requests redirected from upstream CDN to downstream CDN, the direction that requests redirected from downstream CDN to upstream CDN for content locate requests in case of dynamic content acquisition is not covered.
> Is the intent to exclude routings for content locate requests or something else?
> Thanks.
>  
> Best Regards
> Xiaoyan(Susan) He
>  
> _______________________________________________
> CDNi mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cdni

Francois Le Faucheur
Distinguished Engineer
Corporate Development
[email-masked]
Phone: +33 49 723 2619
Mobile: +33 6 19 98 50 90

Cisco Systems France
Greenside
400 Ave de Roumanille
06410 Sophia Antipolis
France
Cisco.com

 Think before you print.

This email may contain confidential and privileged material for the sole use of the intended recipient. Any review, use, distribution or disclosure by others is strictly prohibited. If you are not the intended recipient (or authorized to receive for the recipient), please contact the sender by reply email and delete all copies of this message.

Cisco Systems France, Société à responsabiité limitée, Rue Camille Desmoulins – Imm Atlantis Zac Forum Seine Ilot 7 92130 Issy les Moulineaux, Au capital de 91.470 €, 349 166 561 RCS Nanterre, Directeur de la publication: Jean-Luc Michel Givone.

For corporate legal information go to:
http://www.cisco.com/web/about/doing_business/legal/cri/index.html