Subject: [CDNi] Normative language in draft-lefaucheur-cdni-requirements-02

From: Martin Stiemerling <[email-masked]>
Date: Thu, 21 Jul 2011 13:47:05 +0000

Hi,

I have just stumbled over the new normative language in draft-lefaucheur-cdni-requirements-02. It does not take the one of RFC 2119 and also uses a different typing in the draft.

Is there a specific intent to not use RFC 2119 language?

  Martin

[email-masked]

NEC Laboratories Europe - Network Research Division NEC Europe Limited | Registered Office: NEC House, 1 Victoria Road, London W3 6BL | Registered in England 2832014

---

From: Francois Le Faucheur <[email-masked]>
Date: Thu, 21 Jul 2011 16:57:38 +0200

Hello Martin,

> Is there a specific intent to not use RFC 2119 language?

Yes. 
In a nutshell, the idea is that our Must/May/Should terminology for the cdni-requirements I-D does not exactly coincide with the terminology of RFC2119. RFC2119 terminology is designed for Standards Track document, and we will obviously use that terminology in all the interface specifications, but for our Informational Track requirements document, it feels more appropriate to define a more relevant terminology.

See also:
http://www.ietf.org/mail-archive/web/cdni/current/msg00287.html
http://www.ietf.org/mail-archive/web/cdni/current/msg00290.html
http://www.ietf.org/mail-archive/web/cdni/current/msg00292.html

Cheers

Francois

> _______________________________________________
> CDNi mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cdni

---

From: Martin Stiemerling <[email-masked]>
Date: Fri, 22 Jul 2011 09:15:25 +0000

Hello Francois,

I see the difference and the intention to go for another set of definitions. 

It would be good to document what you have said below in the draft before defining the terms. This would avoid more of these questions like mine :)

Thanks,

  Martin

> -----Original Message-----
> From: Francois Le Faucheur [mailto:[email-masked]]
> Sent: Thursday, July 21, 2011 4:58 PM
> To: Martin Stiemerling
> Cc: Francois Le Faucheur; [email-masked]
> Subject: Re: [CDNi] Normative language in draft-lefaucheur-cdni-requirements-
> 02
> 
> Hello Martin,
> 
> > I have just stumbled over the new normative language in draft-lefaucheur-
> cdni-requirements-02. It does not take the one of RFC 2119 and also uses a
> different typing in the draft.
> >
> In a nutshell, the idea is that our Must/May/Should terminology for the cdni-
> requirements I-D does not exactly coincide with the terminology of RFC2119.
> RFC2119 terminology is designed for Standards Track document, and we will
> obviously use that terminology in all the interface specifications, but for our
> Informational Track requirements document, it feels more appropriate to
> define a more relevant terminology.
> 
> See also:
> > NEC Laboratories Europe - Network Research Division NEC Europe Limited |
> Registered Office: NEC House, 1 Victoria Road, London W3 6BL | Registered in
> England 2832014
> >

---

From: Francois Le Faucheur <[email-masked]>
Date: Fri, 22 Jul 2011 11:30:52 +0200

Yiu, Kent,

This sounds like a good suggestion to me. If you also agree, can you add that to the To Do list?

Thanks

Francois

---

From: "Lee, Yiu" <[email-masked]>
Date: Fri, 22 Jul 2011 13:53:39 +0000

Ok. We will add this to the to-do list.

On 7/22/11 5:30 AM, "Francois Le Faucheur" <[email-masked]> wrote:

>> It would be good to document what you have said below in the draft
>>before defining the terms. This would avoid more of these questions like
>>mine :)
>> 
>> Thanks,
>> 
>>  Martin
>>