Subject: [CDNi] Asymetric Distribution use case in draft-bertrand-cdni-use-cases-02

From: "Brandenburg, R. (Ray) van" <[email-masked]>
Date: Tue, 26 Jul 2011 21:37:17 +0000

Hi all,

I noticed that the new version of the use cases document now includes an Asymetric Distribution use case in section 4.1 which describes a scenario in which different 'versions' of the same content are delivered by different CDNs. 

Although not explicitely stated in the text, the last paragraph in this section seems to strongly suggest that this use case should also work in combination with the Nomadic scenario in which a device starts in one CDN and switches to another (mid-stream). If this is indeed what the authors suggest, I think it would be a good idea to more clearly state this, since such a use case adds a significant number of requirements compared to the 'regular' asymmetric distribution use case. 

In the case of HLS for example, it would require different segments belonging to the same content item to be able to be distributed across CDNs.  In turn this would require involved CDNs to no longer be able to handle a bundle of segments belonging to the same content as if it were a single file for distribution and management purposes. 

Best regards,

Ray van Brandenburg 

This e-mail and its contents are subject to the DISCLAIMER at http://www.tno.nl/emaildisclaimer

---

From: Kevin J Ma <[email-masked]>
Date: Tue, 26 Jul 2011 18:31:12 -0400

Hi Ray,

  I believe your inference is correct.  The use case considers the possibility
  of multiple bundles (e.g., a tv bundle and a mobile bundle).  It could be
  that there also is a super-bundle, but the use case was there for the scenario
  that you described.  Though, to Francois's point, they could be considered
  as independent pieces of content, rather than versions of the same content?

thanx.

--  Kevin J. Ma
  
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Brandenburg, R. (Ray) van
> Sent: Tuesday, July 26, 2011 5:37 PM
> To: [email-masked]'
> Cc: [email-masked]'
> Subject: [CDNi] Asymetric Distribution use case in draft-bertrand-cdni-
> use-cases-02
> 
> Hi all,
> 
> I noticed that the new version of the use cases document now includes an
> Asymetric Distribution use case in section 4.1 which describes a scenario
> in which different 'versions' of the same content are delivered by
> different CDNs.
> 
> Although not explicitely stated in the text, the last paragraph in this
> section seems to strongly suggest that this use case should also work in
> combination with the Nomadic scenario in which a device starts in one CDN
> and switches to another (mid-stream). If this is indeed what the authors
> suggest, I think it would be a good idea to more clearly state this, since
> such a use case adds a significant number of requirements compared to the
> 'regular' asymmetric distribution use case.
> 
> In the case of HLS for example, it would require different segments
> belonging to the same content item to be able to be distributed across
> CDNs.  In turn this would require involved CDNs to no longer be able to
> handle a bundle of segments belonging to the same content as if it were a
> single file for distribution and management purposes.
> 
> Best regards,
> 
> Ray van Brandenburg
> 
> 
> _______________________________________________
> CDNi mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cdni

---

From: "Brandenburg, R. (Ray) van" <[email-masked]>
Date: Tue, 26 Jul 2011 22:40:11 +0000

Hi Kevin,

> Though, to Francois's point, they could be considered as independent pieces of content, rather than versions of the same content?

Sure, that would be one way to look at it. But either way, in order to be able to provide a seamless transfer as stated in the current document, the relationships between the pieces of content should either be known to both CDNs, or be reflected in the associated manifest files. One could argue that when different pieces of content are linked together through for example a manifest file, that you can no longer talk about independent pieces of content. Of course this depends on whether you the manifest file as the content or the associated segments.

Cheers,

Ray

-----Original Message-----
From: Kevin J Ma [mailto:[email-masked]] 
Sent: woensdag 27 juli 2011 0:31
To: Brandenburg, R. (Ray) van; [email-masked]'
Cc: [email-masked]'
Subject: RE: Asymetric Distribution use case in draft-bertrand-cdni-use-cases-02

Hi Ray,

thanx.

--  Kevin J. Ma
  
> From: [email-masked] [mailto:[email-masked]] On Behalf 
> Of Brandenburg, R. (Ray) van
> I noticed that the new version of the use cases document now includes 
> an Asymetric Distribution use case in section 4.1 which describes a 
> scenario in which different 'versions' of the same content are 
> delivered by different CDNs.
> 
> Although not explicitely stated in the text, the last paragraph in 
> this section seems to strongly suggest that this use case should also 
> work in combination with the Nomadic scenario in which a device starts 
> in one CDN and switches to another (mid-stream). If this is indeed 
> what the authors suggest, I think it would be a good idea to more 
> clearly state this, since such a use case adds a significant number of 
> requirements compared to the 'regular' asymmetric distribution use case.
> 
> CDNs.  In turn this would require involved CDNs to no longer be able 
> to handle a bundle of segments belonging to the same content as if it 
> were a single file for distribution and management purposes.
> 
> Best regards,
> 
> Ray van Brandenburg
> 
>

---

From: Scott Wainner <[email-masked]>
Date: Thu, 28 Jul 2011 12:34:05 -0400

Ray,

     I think we have to decouple the properties of the content from the 
policy.  In addition, I'll expand the definition of content to include a 
set of assets.  For a given asset, it has certain properties (aspect 
ratio, bit rate, etc.).  I don't think we want to embed policy in the 
asset (e.g. manifest) as the policy may change depending on the environment.

     In the use case defined for asymmetric distribution, a 'low bit 
rate asset' may be viable over either the wireless network or the 
wireline network while a 'high bit rate asset' may only be viable on the 
wireline network.  I don't think we want to define two versions for the 
low-bit rate asset: one for wireless and one for wireline.  This means 
we would need to provide policy that is associated with, but not 
incorporated into the asset.  I'm inclined to believe there are two 
capabilities advertised (wireless / wireline), a policy associated with 
the content (metadata), and the policy is associated with specific 
assets in the content bundle.  The matching of the capabilities to the 
policy will dictate which CDN and which asset could be delivered.

Scott

On 7/26/11 6:40 PM, Brandenburg, R. (Ray) van wrote:
>
> Hi Kevin,
>
> > Though, to Francois's point, they could be considered as independent 
> pieces of content, rather than versions of the same content?
>
> Sure, that would be one way to look at it. But either way, in order to 
> be able to provide a seamless transfer as stated in the current 
> document, the relationships between the pieces of content should 
> either be known to both CDNs, or be reflected in the associated 
> manifest files. One could argue that when different pieces of content 
> are linked together through for example a manifest file, that you can 
> no longer talk about independent pieces of content. Of course this 
> depends on whether you the manifest file as the content or the 
> associated segments.
>
> Cheers,
>
> Ray
>
> To: Brandenburg, R. (Ray) van; 
> [email-masked]'
> Cc: [email-masked]'