Subject: Re: [CDNi] new Internet Draft

From: Kevin J Ma <[email-masked]>
Date: Thu, 7 Jul 2011 03:30:17 -0400

Hi Larry,

  I had a couple of comments/questions on the draft:

  In sections 5.x.1, i just wanted to clarify if the exchange of IP
  prefixes is just an example of a method for determining geo-footprint,
  or is there a more fundamental requirement for IP prefix information?

  In section 6.4, with respect to bypassing metadata distribution,
  checking availability windows on an initial request may not work
  well for certain types of content, e.g., HLS with relative uris and
  and endlist tag, where the manifest may point at multiple hours of
  content?  As for proxying metadata requests, could that introduce
  scalability issues for the uCDN?

thanx!

--  Kevin J. Ma

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Peterson, Larry
> Sent: Tuesday, April 19, 2011 2:33 PM
> To: [email-masked]
> Subject: [CDNi] new Internet Draft
> 
> Dear all,
> 
> We have posted a new I-D, available at
> 
>      http://tools.ietf.org/html/draft-peterson-cdni-strawman-00
> 
> It presents a strawman for CDN interconnection,
> and is meant to spur discussion.
> 
> Looking forward to your feedback.
> 
> Larry
> 
> _______________________________________________
> CDNi mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cdni

---

From: "Peterson, Larry" <[email-masked]>
Date: Wed, 13 Jul 2011 12:54:57 -0400

Thanks for the comments. I apologize for letting this get stuck in my inbox...

>  or is there a more fundamental requirement for IP prefix information?

Right. It's an example.

>  scalability issues for the uCDN?

I'm sure interesting discussion with ensue on this issue, but my main
point is that the functional distinction between the metadata and control
interfaces is not clear. Instead, the distinction seems to be more about
an engineering choice -- it's easier to tell me once, up-front, how to 
behave rather than control my behavior at run-time.

---

From: Eric Burger <[email-masked]>
Date: Thu, 28 Jul 2011 09:42:28 -0400

Just FYI, that is a really, really bad example.