Subject: [CDNi] BGP and prefix hijacking (CDN footprint capability )

From: Martin Stiemerling <[email-masked]>
Date: Wed, 16 Nov 2011 03:00:21 +0000

Hi all,

Just to follow-up the current discussion about using BGP for CDN footprint capability handling we had in the CDNi session some minutes ago. 

BGP is vulnerable to letting ISPs announcing IP prefixes which they are actually not own by them:
http://en.wikipedia.org/wiki/IP_hijacking

This will cause that the traffic for particular prefixes to not reach the intended destination, actually creating a black hole for this traffic.

This links documents also a very prominent case of prefix hijacking. 

This would be also applicable if using BPG (and variants of it) for the CDN footprint capability handling.

  Martin

[email-masked]

NEC Laboratories Europe - Network Research Division NEC Europe Limited | Registered Office: NEC House, 1 Victoria Road, London W3 6BL | Registered in England 2832014

---

From: Francois Le Faucheur <[email-masked]>
Date: Wed, 16 Nov 2011 12:36:28 +0800

Hi Martin,

I think:
	* what can be concluded from this information is that the CDNI WG really needs to consider the security aspects associated with "Footprint & Capabilities Advertisement".
	* what certainly can not be concluded from this information is that one approach on the table (e.g. BGP) is less suitable than another  (e.g. ALTO, Web-services based) for "Footprint & Capabilities Advertisement".

Are we in line?

Thanks

Francois

On 16 Nov 2011, at 11:00, Martin Stiemerling wrote:

> _______________________________________________
> CDNi mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cdni

---

From: Martin Stiemerling <[email-masked]>
Date: Thu, 17 Nov 2011 01:25:36 +0000

Hi Francois,

Yes, we are on the same side.

I see Jon's proposal a good way forward, i.e., to initially work on the semantics required for this.

  Martin

[email-masked]<mailto:[email-masked]>

From: Francois Le Faucheur [mailto:[email-masked]]
Sent: Wednesday, November 16, 2011 5:36 AM
To: Martin Stiemerling
Cc: Francois Le Faucheur; [email-masked]
Subject: Re: [CDNi] BGP and prefix hijacking (CDN footprint capability )

Hi Martin,

I think:

Are we in line?

Thanks

Francois

Hi all,

 Martin

[email-masked]<mailto:[email-masked]>

_______________________________________________
CDNi mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/cdni

---

From: Eric Burger <[email-masked]>
Date: Thu, 17 Nov 2011 05:14:36 -0500

+1. It is neither a BGP nor ALTO thing, it is a generic thing.

On Nov 16, 2011, at 8:25 PM, Martin Stiemerling wrote:

> I see Jon’s proposal a good way forward, i.e., to initially work on the semantics required for this.
>  
>   Martin
>