Subject: [CDNi] draft-ma-cdni-metadata-01.txt: mD objects extensibility

From: <[email-masked]>
Date: Wed, 2 Nov 2011 15:19:58 +0100

Hi Kevin,

Following are my thoughts on v01.

IMO, It is obvious that the framework of CDNi will include objects extensibility and consequently support opaque metadata. The draft should focus on the identification of the information elements required to support the awareness and the restriction of the 7 interfaces listed in the introduction rather than promoting the need of opaque metadata.

So I propose that we add something like following in draft-davie-cdni-framework:

"5 Data modeling Framework
5.1  Objects extensibility

   CDNs interoperate to distribute content services that may require the exchange of
   specific metadata.  Consequently each object is extensible and
   includes a field 'extension' for this purpose. This applies to all CDNi interfaces.
"

Regards
Emile

> -----Message d'origine-----
> De : [email-masked] [mailto:[email-masked]] De la part de
> Kevin J Ma
> Envoyé : mardi 1 novembre 2011 00:37
> À : [email-masked]
> Objet : [CDNi] FW: New Version Notification fordraft-ma-cdni-metadata-
> 01.txt
> 
> An updated version of draft-ma-cdni-metadata has been uploaded.
> It fixes some typos, incorporates some of the comments received
> from the list, and adds some core metadata definitions.
> 
> comments welcome.
> 
> thanx.
> 
> --  Kevin J. Ma
> 
> 
> A new version of I-D, draft-ma-cdni-metadata-01.txt has been
> successfully submitted by Kevin Ma and posted to the IETF repository.
> 
> Filename:	 draft-ma-cdni-metadata
> Revision:	 01
> Title:		 Content Distribution Network Interconnection (CDNI)
> Metadata Interface
> Creation date:	 2011-10-31
> WG ID:		 Individual Submission
> Number of pages: 33
> 
> 
> _______________________________________________
> CDNi mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cdni

---

From: Kevin J Ma <[email-masked]>
Date: Wed, 2 Nov 2011 18:30:51 -0400

Hi Emile,

  By extensible, I mean that uCDNs should be able to define their own
  private metadata (if they want) to describe delivery functions that
  they support and if a dCDN understands it then that's great, but if
  not then the uCDN should be able to specify whether or not the dCDN
  must decline to serve the content.

  In general, I favor a protocol which has opaque data encapsulation,
  using a layered approach, but, there are certainly other ways to do
  it, and the WG may choose to go a different route.  I don't know if
  an 'extension' field is the best approach, but I hope that the CDNI
  MI specification will ultimately support vendor defined metadata.

thanx.

--  Kevin J. Ma

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Wednesday, November 02, 2011 10:20 AM
> To: Kevin J Ma; [email-masked]
> Cc: [email-masked]; [email-masked]; [email-masked]
> Subject: [CDNi] draft-ma-cdni-metadata-01.txt: mD objects extensibility
> 
> Hi Kevin,
> 
> IMO, It is obvious that the framework of CDNi will include objects
> extensibility and consequently support opaque metadata. The draft should
> focus on the identification of the information elements required to
> support the awareness and the restriction of the 7 interfaces listed in
> the introduction rather than promoting the need of opaque metadata.
>

---

From: <[email-masked]>
Date: Thu, 3 Nov 2011 09:11:21 +0100

Hi Kevin,

See below.

> De : Kevin J Ma [mailto:[email-masked]]
> Envoyé : mercredi 2 novembre 2011 23:31
> À : STEPHAN Emile RD-CORE-LAN; [email-masked]
> Cc : [email-masked]; [email-masked]; [email-masked]
> Objet : RE: [CDNi] draft-ma-cdni-metadata-01.txt: mD objects
> extensibility
> 
> Hi Emile,
> 

IMO, we don't need to lost time and energy on this point.
To go further we need to add the support of proprietary defined metadata in the req and framework documents.

Regards
Emile

> > So I propose that we add something like following in draft-davie-
> cdni-
> > framework:
> >
> >    CDNs interoperate to distribute content services that may require
> the
> > exchange of
> >    includes a field 'extension' for this purpose. This applies to all
> CDNi
> > interfaces.
> > "
> >
> > Regards
> > Emile
> >