Subject: Re: [CDNi] Discussing "Adaptive Streaming" more in cdni-framework

From: "Peterson, Larry" <[email-masked]>
Date: Wed, 16 Nov 2011 07:54:50 -0500

I agree. We need to explicitly discuss adaptive streaming in the framework doc.

Sent from my Verizon Wireless Phone

----- Reply message -----
From: "Francois Le Faucheur" <[email-masked]>
To: "Bruce Davie" <[email-masked]>, "Peterson, Larry" <[email-masked]>
Cc: "Le Faucheur Francois" <[email-masked]>, "Aaron Falk" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Discussing "Adaptive Streaming" more in cdni-framework
Date: Wed, Nov 16, 2011 12:11 am

Bruce, Larry,

I just wanted to pass on a suggestion made during the WG session.

>From talking to people this week, it became clear to me that:
        * just about everyone expects a CDNI mesh to support content delivery via HTTP Adaptive Streaming
        * people have different expectations about how CDNI supports this.

So my suggestion is that the framework very explicitly addresses this question (perhaps even as a standalone section, so people can easily find the discussion on that specific question). In line with the general current approach of the framework, the expectation would not be that the framework mandates a given approach, but explores the design spaces, and helps analysis and converging on if/what CDNI interfaces need to support something specific for adaptive.
A few aspects that come to mind are:
        * Request Routing: should/can request routing be performed more efficiently than once per segment?
        * Acquisition: should/can acquisition be performed on a per-segment basis or differently?
        * Logging: the framework already brings up the point about logging for adaptive in section 4.3
        * Metadata: is any specific metadata required.

Can you consider expanding the discussion on adaptive streaming in the next rev?

Thanks

Francois

---

From: Christian Timmerer (ITEC) <[email-masked]>
Date: Wed, 16 Nov 2011 15:17:35 +0100

>         * Acquisition: should/can acquisition be performed on a per-segment basis or differently?
Depending on whether segments or subsegments are used. In the former case, the content is physically divided into segments, each individually addressable by HTTP URL whereas in the latter case, the content is logically divided into segments, each individually addressable by HTTP byte range requests.

>         * Logging: the framework already brings up the point about logging for adaptive in section 4.3  
For example, MPEG-DASH defines already some metrics that are related to what is defined in section 4.3 but, of course, go beyond and are specific to DASH. However, some are probably applicable in a more general HTTP adaptive streaming context.

>         * Metadata: is any specific metadata required.
The manifest file, for example.

Best regards,
 -Christian

> _______________________________________________
> CDNi mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cdni

---

From: ZhouZhipeng <[email-masked]>
Date: Fri, 18 Nov 2011 03:06:53 +0000

All,
As for "* Acquisition: should/can acquisition be performed on a per-segment basis or differently?", the essence is whether there is much benefit by delivering part(segment) of the content to uCDN rather than delivering whole content to uCDN . Generally, it should be the whole content been delivered to the uCDN while the  uCDN may provide adaptive streaming service to UE.
Thanks.
Zhipeng

From: Christian Timmerer [mailto:[email-masked]]
Sent: Wednesday, November 16, 2011 10:18 PM
To: Peterson, Larry; Francois Le Faucheur; Bruce Davie
Cc: [email-masked]
Subject: Re: [CDNi] Discussing "Adaptive Streaming" more in cdni-framework

Bruce, Larry,

Best regards,
 -Christian

Thanks

Francois

_______________________________________________
CDNi mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/cdni