Subject: Re: [CDNi] Definitions inside PS and Framework draft

From: Ben Niven-Jenkins <[email-masked]>
Date: Wed, 7 Dec 2011 00:38:43 +0000

Hi Gilles,

It would be good to hear other folks' opinions, I've included mine below.

On 28 Nov 2011, at 09:59, <[email-masked]> <[email-masked]> wrote:

> Colleagues,
>  
> As discussed during IETF#82, we are tidying up the terminology section of the use cases draft.
>  
> The use cases and the problem statement drafts propose slightly different definitions of some terms:
> Problem statement:
>    Authoritative CDN: A CDN which has a direct relationship with a CSP
>    for the distribution & delivery of that CSP's content.
>  
>    CDN Interconnection (CDNI): The set of interfaces over which two or
>    more CDNs communicate with each other in order to achieve the
>    delivery of content to User Agents by Surrogates in one CDN (the
>    downstream CDN) on behalf of another CDN (the upstream CDN).
> Use cases:
>    Authoritative CDN (aCDN):   A CDN provider contracted by the CSP for delivery of content by its
>    CDN or by its downstream CDNs.

For "Authoritative CDN":

I prefer to retain "A CDN" (vs "A CDN Provider") because we are likely to be mainly talking in technical terms about a specific CDN amongst a group of CDNs which may belong to a single CDN Provider, multiple CDN Providers or some combination.

I also prefer "direct relationship" (vs "contracted by") as it is more general and doesn't assume a particular business model (the CSP may not contract the CDN if they are both the same entity), we could change "direct relationship" to "direct association" if that makes it clearer?

I'm OK with adding "by the authoritative CDN or by its downstream CDNs" to the end of the definition.
 
>   CDN Interconnection:
>    Relationship between two CDNs that enables a CDN to provide content
>    delivery services on behalf of another CDN.  It relies on a set of
>    interfaces over which two CDNs communicate in order to achieve the
>    delivery of content to end-users by one CDN (the downstream CDN) on
>    behalf of another CDN (the upstream CDN).
> I find these two definitions from the use cases draft clearer. Do you agree?

For "CDN Interconnection":

I prefer "delivery of content to User Agents" (vs "delivery of content to end-users") because I think it is more accurate - the ultimate consumer of the content may not be an End User e.g. an automated software update may be requested & received by a User Agent without any End User involvement.

What was the reasoning in changing "two or more CDNs" to "two CDNs"? I don't hold a strong opinion on that change but I wonder whether "over which a pair of CDNs communicate" is better wording?

> Some relevant terms are defined only in the use cases draft. Could you please include them in the problem statement?
>    Access CDN:
>    A CDN that is directly connected to the end-user's access.  An Access
>    CDN may have specific information about the end-user and the network,
>    for instance, end-user's profile and access capabilities.

This term isn't used in the problem statement so I don't think it should be defined by the problem statement.
 
>     Delivering CDN:
>    The CDN that delivers the requested piece of content to the end-user.
>    In particular, the delivering CDN can be an access CDN.

The only place this term is used in the problem statement is in the appendix that will be removed on publication as an RFC so I don't think it should be defined by the problem statement.

Regards
Ben

>  
>  
> Some terms are not defined yet in the WG's drafts. Could you define them inside the framework draft?
> 
>    recursive request routing
>    iterative request routing
>  
> 
> Cordialement, with kind regards,
> 
>  
> 
> 
> Gilles Bertrand
> R&D, AudioVisual Delivery (AVD)
> Content Network Architect
> tél. +33 (0) 145 29 89 46 
> [email-masked]
> 
>  
> _______________________________________________
> CDNi mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cdni

---

From: <[email-masked]>
Date: Mon, 12 Dec 2011 10:31:14 +0100

Hi Ben,

Thanks for your reply. 

Authoritative CDN: OK with your proposals below.

CDN Interconnection (CDNI): I agree with your proposals. A remaining issues is that the definition in the use cases draft designates the relationship (not the interfaces) between the CDNs. That's the key point I would like to bring in this definition.

Cheers,

Gilles

-----Message d'origine-----
De : Ben Niven-Jenkins [mailto:[email-masked]] 
Envoyé : mercredi 7 décembre 2011 01:39
À : BERTRAND Gilles RD-CORE-ISS
Cc : [email-masked]; [email-masked]; [email-masked]; [email-masked]
Objet : Re: [CDNi] Definitions inside PS and Framework draft

Hi Gilles,

For "Authoritative CDN":

 

 

Regards
Ben

---

From: Ben Niven-Jenkins <[email-masked]>
Date: Wed, 14 Dec 2011 10:31:05 +0000

Gilles,

I have updated the definitions in my working copy of the problem statement as follows:

   Authoritative CDN: A CDN which has a direct relationship with a CSP
   for the distribution & delivery of that CSP's content by the
   authoritative CDN or by downstream CDNs of the authoritative CDN.

This is as agreed except when editing I decided on "by downstream CDNs of the authoritative CDN" was better than "by its downstream CDNs" because it makes it explicit rather than being slightly ambiguous as to whether the "its" refers to the authoritative CDN or the CSP.

   CDN Interconnection (CDNI): A relationship between a pair of CDNs
   that enables one CDN to provide content delivery services on behalf
   of another CDN.  A CDN Interconnect may be wholly or partially
   realised through a set of interfaces over which a pair of CDNs
   communicate with each other in order to achieve the delivery of
   content to User Agents by Surrogates in one CDN (the downstream CDN)
   on behalf of another CDN (the upstream CDN).

Here I incorporated the sentence of the relationship from the use cases draft but changed the beginning of the next sentence from "It relies on a set of interfaces" to "A CDN Interconnect may be wholly or partially realised through a set of interfaces" because I think it then covers the case where a deployment may not 100% rely on the CDNI interfaces (e.g. some out of band business agreement, some static configuration of footprint/capabilities, etc.)

Ben

---

From: <[email-masked]>
Date: Wed, 14 Dec 2011 12:09:00 +0100

Thanks Ben. These definitions look great.

Gilles

-----Message d'origine-----
De : Ben Niven-Jenkins [mailto:[email-masked]] 
Envoyé : mercredi 14 décembre 2011 11:31
À : BERTRAND Gilles RD-CORE-ISS
Cc : [email-masked]; [email-masked]
Objet : Re: [CDNi] Definitions inside PS and Framework draft

Gilles,

Ben

On 12 Dec 2011, at 09:31, <[email-masked]> <[email-masked]> wrote:

> De : Ben Niven-Jenkins [mailto:[email-masked]] Envoyé : 
> mercredi 7 décembre 2011 01:39 À : BERTRAND Gilles RD-CORE-ISS Cc : 
> [email-masked]; [email-masked]; [email-masked]; 
> [email-masked] Objet : Re: [CDNi] Definitions inside PS and Framework 
> draft
> 
> Hi Gilles,
>