Subject: [CDNi] The role of Multicast in CDNI

From: <[email-masked]>
Date: Wed, 28 Dec 2011 15:59:43 +0100

Hi all,

(I'm new to the CDNI WG, so please excuse me if I have missed something)

I've been reading some of the CDNI drafts that have been produced so far, and it occurred to me that up until now there has not been a mention of multicast in a CDNI context.

As you may know, for some operators multicast is an important aspect of their CDN. I use the term multicast here in general, but in practice this may refer to IP Multicast, Ethernet Multicast, Broadcast or MBMS. It is important to note that I'm talking about using multicast from the delivering CDN to the end-user and not about multicast between CDN's or internet-wide multicast. For operators, using multicast is an important method in limiting traffic peaks in their access networks.

Although multicast is therefore primarily a dCDN-to-User method, which I have understood to be out-of-scope for this WG, it does have some implications for the CDNI interfaces. For example, it might be important for operator-controlled CDNs to be able to advertise their multicast capabilities. Another aspect might be the distribution of multicast join information from the dCDN upwards. Finally, reporting on multicasted content might be different than reporting on unicasted content.

At this moment I'm not sure whether these problems are in-scope of this WG, or in which documents these problems need to be discussed. Maybe we could add a multicast use case to the Use Case draft? Or say something about it in the Problem Statement draft?
I'm looking forward to the WG's ideas on this topic,

Kind regards,

Ad Bresser

---

From: Ben Niven-Jenkins <[email-masked]>
Date: Thu, 29 Dec 2011 01:15:48 +0000

Ad,

On 28 Dec 2011, at 14:59, <[email-masked]> wrote:

> Hi all,
>  
> (I’m new to the CDNI WG, so please excuse me if I have missed something)
>  
> I’ve been reading some of the CDNI drafts that have been produced so far, and it occurred to me that up until now there has not been a mention of multicast in a CDNI context.
>  
> As you may know, for some operators multicast is an important aspect of their CDN. I use the term multicast here in general, but in practice this may refer to IP Multicast, Ethernet Multicast, Broadcast or MBMS. It is important to note that I’m talking about using multicast from the delivering CDN to the end-user and not about multicast between CDN’s or internet-wide multicast. For operators, using multicast is an important method in limiting traffic peaks in their access networks.

Multicast from a CDN to End Users is not something that as far as I am aware is any more than an R&D topic at this stage.

Multicast to deliver IPTV type services to TVs/STBs is a different story but those services aren't delivered off CDNs.

> At this moment I’m not sure whether these problems are in-scope of this WG, or in which documents these problems need to be discussed. Maybe we could add a multicast use case to the Use Case draft? Or say something about it in the Problem Statement draft?
> I’m looking forward to the WG’s ideas on this topic,

My view is that the CDNI WG should focus on figuring out how CDNs can interconnect the services they are delivering today and not try to figure out how to interconnect services that don't yet exist. When new services/technologies come along we can figure out how to extend CDNI to cover them at that point in time and not try and second guess what those service/technologies will look like before they exist.
   
Ben

>  
> Kind regards,
>  
> Ad Bresser
>  
>  
> _______________________________________________
> CDNi mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cdni

---

From: <[email-masked]>
Date: Fri, 30 Dec 2011 11:26:43 +0100

Ben,

> > As you may know, for some operators multicast is an important aspect of their
> CDN. I use the term multicast here in general, but in practice this may refer to IP
> Multicast, Ethernet Multicast, Broadcast or MBMS. It is important to note that
> I'm talking about using multicast from the delivering CDN to the end-user and
> not about multicast between CDN's or internet-wide multicast. For operators,
> using multicast is an important method in limiting traffic peaks in their access
> networks.
> 
> Multicast from a CDN to End Users is not something that as far as I am aware is
> any more than an R&D topic at this stage.
> 

(Trying to avoid IPTV and CDN discussions)
So it is clear that connecting video servers to a multicast network is not rocket science.

I'm now seeing ISP's starting to distribute TV channels over the Internet connection of their customers by using their CDN's. Depending on their network architecture, they could benefit from using multicast. This has obviously not that much to do with CDN interconnection, but makes it likely that multicast capabilities will be linked to a CDN in the foreseeable future.
It is very unlikely that multicast capabilities of access networks can be exposed over the Internet. A CDN enabling it for CDN operators and content owners, would increase the efficiency of the content distribution. This efficiency can not be realized by the CDN operators and content owners; cooperation / interconnection is needed for this.

Kind regards,

Ad

---

From: Ben Niven-Jenkins <[email-masked]>
Date: Fri, 30 Dec 2011 10:40:13 +0000

Ad,

> I'm now seeing ISP's starting to distribute TV channels over the Internet connection of their customers by using their CDN's. Depending on their network architecture, they could benefit from using…

I don't disagree. However there are still many outstanding questions on what such a deployment would involve, e.g. what capabilities the User Agent/client will have, where the multicast terminates in the subscriber domain, what is actually carried in the multicast "stream", does it leverage an existing content provider workflow or require a different workflow etc. that are all out of scope for CDNI so I won't go into more details here.

Until it is clear what the deployment model(s) look like any work by the CDNI WG is just guesswork which is what led to my previous statement:

"My view is that the CDNI WG should focus on figuring out how CDNs can interconnect the services they are delivering today and not try to figure out how to interconnect services that don't yet exist. When new services/technologies come along we can figure out how to extend CDNI to cover them at that point in time and not try and second guess what those service/technologies will look like before they exist."

Ben