Subject: Re: [CDNi] TR: I-D Action: draft-bertrand-cdni-logging-00.txt

From: "Kent Leung (kleung)" <[email-masked]>
Date: Sun, 25 Mar 2012 03:30:50 -0700

Hi Gilles and Stephan. A few comments on your draft.

1. Sect. 3: Should the Logging Architecture include on-demand access to logging information (see LOG-9 requirement)? So it's not only CoDR Selection from uCDN to dCDN, but also CoDR Request.

2. Sect. 6.2: Not clear how Cascaded CDNs are supported in the Information Elements in the logging records? The CDNI Logging interface is between uCDN and dCDN. Some clarification on how cascaded CDNs are handled would be helpful (see LOG-3 requirement).

3. Sect. 7: Should there be logging for Metadata acquisition and purging?  Also, logging for Triggers (Control Interface) for content/metadata acquisition and purging?

4. Not sure if support for batch/offline exchange of logging records was mentioned (LOG-5 requirement)?

5. Not sure if resource consumption reporting is covered (LOG-12 requirement)?

6. Sect. 8.1.1: Just a note that draft-lefaucheur-cdni-logging-delivery has more details for ABR.

Kent

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, February 13, 2012 6:04 AM
To: [email-masked]
Subject: [CDNi] TR: I-D Action: draft-bertrand-cdni-logging-00.txt

Hi everyone,

We have submitted a new draft on the Logging interface:
http://tools.ietf.org/html/draft-bertrand-cdni-logging-00 

"This memo specifies the Logging interface between a downstream CDN
(dCDN) and an upstream CDN (uCDN). It introduces a framework, an
architecture design and a set of new requirements. Then it drafts an
information model."

Best regards,

Gilles

-----Message d'origine-----
De : [email-masked] [mailto:[email-masked]] De la part de [email-masked]
Envoyé : lundi 13 février 2012 14:56
À : [email-masked]
Objet : I-D Action: draft-bertrand-cdni-logging-00.txt

A New Internet-Draft is available from the on-line Internet-Drafts directories.

	Title           : CDNI Logging Interface
	Author(s)       : Gilles Bertrand
                          Stephan Emile
	Filename        : draft-bertrand-cdni-logging-00.txt
	Pages           : 26
	Date            : 2012-02-13

   This memo specifies the Logging interface between a downstream CDN
   (dCDN) and an upstream CDN (uCDN).  It introduces a framework, an
   architecture design and a set of new requirements.  Then it drafts an
   information model.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-bertrand-cdni-logging-00.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

This Internet-Draft can be retrieved at:
ftp://ftp.ietf.org/internet-drafts/draft-bertrand-cdni-logging-00.txt

_______________________________________________
I-D-Announce mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/i-d-announce
Internet-Draft directories: http://www.ietf.org/shadow.html or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
_______________________________________________
CDNi mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/cdni

---

From: <[email-masked]>
Date: Wed, 28 Mar 2012 13:55:50 +0200

Hi Kent,

Thanks for the useful comments. My answers are below.

Best regards,

Gilles

-----Message d'origine-----
De : Kent Leung (kleung) [mailto:[email-masked]] 
Envoyé : dimanche 25 mars 2012 12:31
À : BERTRAND Gilles RD-CORE-ISS; [email-masked]
Objet : RE: [CDNi] TR: I-D Action: draft-bertrand-cdni-logging-00.txt

GB: Agreed

GB: I agree it's an important point. The approach in this draft is first to agree on the core information elements that a dCDN needs to provide to the uCDN. We will extend this list in next version of the draft and we will get more into the details of the information elements provided in the Content Delivery Records. 

GB: Logging has various uses, in particular debugging. CDNs may keep a log of Metadata related operations and of Triggers. This information might be interesting for the uCDN for debugging purposes. 

GB: We will describe these aspects in section 9.

GB: We can consider such data as a KPI (rather than a "usual" raw Content Delivery Record) reported by the dCDN to the uCDN. We will describe how dCDNs should report such specific KPIs to the uCDN in next versions of the draft. 

GB: right. draft-lefaucheur-cdni-logging-delivery details more the Logging for ABR content. 

Kent

-----Original Message-----

From: [email-masked] <mailto:[email-masked]>  [mailto:[email-masked] <mailto:[email-masked]> ] On Behalf Of [email-masked] <mailto:[email-masked]> 

To: [email-masked] <mailto:[email-masked]> 

Hi everyone,

http://tools.ietf.org/html/draft-bertrand-cdni-logging-00 <http://tools.ietf.org/html/draft-bertrand-cdni-logging-00>  

(dCDN) and an upstream CDN (uCDN). It introduces a framework, an architecture design and a set of new requirements. Then it drafts an information model."

Best regards,

Gilles

-----Message d'origine-----

De : [email-masked] <mailto:[email-masked]>  [mailto:[email-masked] <mailto:[email-masked]> ] De la part de [email-masked] <mailto:[email-masked]>  Envoyé : lundi 13 février 2012 14:56 À : [email-masked] <mailto:[email-masked]>  Objet : I-D Action: draft-bertrand-cdni-logging-00.txt

                          Stephan Emile

      Pages           : 26

      Date            : 2012-02-13

   information model.

http://www.ietf.org/internet-drafts/draft-bertrand-cdni-logging-00.txt <http://www.ietf.org/internet-drafts/draft-bertrand-cdni-logging-00.txt> 

ftp://ftp.ietf.org/internet-drafts/ <ftp://ftp.ietf.org/internet-drafts/> 

ftp://ftp.ietf.org/internet-drafts/draft-bertrand-cdni-logging-00.txt <ftp://ftp.ietf.org/internet-drafts/draft-bertrand-cdni-logging-00.txt> 

[email-masked] <mailto:[email-masked]> 

https://www.ietf.org/mailman/listinfo/i-d-announce <https://www.ietf.org/mailman/listinfo/i-d-announce> 

Internet-Draft directories: http://www.ietf.org/shadow.html <http://www.ietf.org/shadow.html>  or ftp://ftp.ietf.org/ietf/1shadow-sites.txt <ftp://ftp.ietf.org/ietf/1shadow-sites.txt> 

CDNi mailing list

[email-masked] <mailto:[email-masked]> 

https://www.ietf.org/mailman/listinfo/cdni <https://www.ietf.org/mailman/listinfo/cdni>