Subject: Re: [CDNi] FW: New Version Notification for draft-he-cdni-routing-request-redirection-00.txt

From: Ben Niven-Jenkins <[email-masked]>
Date: Sun, 4 Mar 2012 18:17:01 +0000

On 16 Feb 2012, at 11:02, HeXiaoyan wrote:

> Hi all,
> We have submitted a draft on the routing request redirection（Recursive mode） of RRI, http://datatracker.ietf.org/doc/draft-he-cdni-routing-request-redirection/

I notice this is the third internet-draft that has now being published on this topic each with a different filename (the others being draft-xiaoyan-cdni-request-routing-protocol and draft-xiaoyan-cdni-requestrouting) and that many of the authors are common across all three drafts.

What is the relationship between the three drafts because from a glance they all look pretty similar?

Normal convention would be to just update the draft number between revisions not to publish under a new filename as that makes keeping track of which is the most up to date version significantly easier (as well helping track the history of things like IPR declarations as drafts move through the publication process).

Thanks
Ben

> 
> Your comments are welcome.
> 
> Best Regards
> Xiaoyan(Susan) He
> 
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] 
> Sent: Thursday, February 16, 2012 5:04 PM
> To: [email-masked]
> Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]
> Subject: New Version Notification for draft-he-cdni-routing-request-redirection-00.txt
> 
> A new version of I-D, draft-he-cdni-routing-request-redirection-00.txt has been successfully submitted by Xiaoyan He and posted to the IETF repository.
> 
> Filename:	 draft-he-cdni-routing-request-redirection
> Revision:	 00
> Title:		 Routing Request Redirection for CDN Interconnection
> Creation date:	 2012-02-16
> WG ID:		 Individual Submission
> Number of pages: 13
> 
> Abstract:
>  The Request Routing Interface comprises the asynchronous advertisement
> of   footprint and capabilities by a dCDN that allows a uCDN to decide whether
> to   redirect particular user requests to that dCDN; and the synchronous operation
> of   actually redirecting a user request. This document describes protocol for the
> part   of user requests redirection.
> 
> 
> 
> 
> The IETF Secretariat
> 
> _______________________________________________
> CDNi mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cdni

---

From: HeXiaoyan <[email-masked]>
Date: Mon, 05 Mar 2012 11:23:50 +0800

Ben,
You are right. Main content (redirection part) of the three drafts are quite similar.
Minor difference is the first version is an informational draft for discussion which only includes redirection part,
second version's intended status is standard track including redirection and capability advertisement part.
Third one is according the meeting's conclusion to divide redirection and capability advertisement to two separate draft which therefore only includes redirection part.
Thanks for telling the convention, I'll pay attention to that.

Best Regards
Xiaoyan(Susan) He
> From: Ben Niven-Jenkins [mailto:[email-masked]]
> Sent: Monday, March 05, 2012 2:17 AM
> To: HeXiaoyan
> Cc: [email-masked]
> Subject: Re: [CDNi] FW: New Version Notification for
> draft-he-cdni-routing-request-redirection-00.txt
> 
> > We have submitted a draft on the routing request redirection（Recursive
> mode） of RRI,
> http://datatracker.ietf.org/doc/draft-he-cdni-routing-request-redirection/
> 
> I notice this is the third internet-draft that has now being published on this
> topic each with a different filename (the others being
> draft-xiaoyan-cdni-request-routing-protocol and
> draft-xiaoyan-cdni-requestrouting) and that many of the authors are common
> across all three drafts.
> 
> Normal convention would be to just update the draft number between revisions
> not to publish under a new filename as that makes keeping track of which is the
> most up to date version significantly easier (as well helping track the history of
> things like IPR declarations as drafts move through the publication process).
> 
> Thanks
> Ben
> 
> >
> > Cc: [email-masked]; [email-masked];
> [email-masked]; [email-masked]
> > Subject: New Version Notification for
> draft-he-cdni-routing-request-redirection-00.txt
> >
> > A new version of I-D, draft-he-cdni-routing-request-redirection-00.txt has
> been successfully submitted by Xiaoyan He and posted to the IETF repository.
> >