Subject: [CDNi] TR: I-D Action: draft-bertrand-cdni-footprint-discovery-00.txt

From: <[email-masked]>
Date: Tue, 6 Mar 2012 10:50:43 +0100

Hi everyone,

I have submitted a new draft on CDN Footprint Discovery in CDNI. Its main purpose is to present use cases for CDN Footprint Discovery in CDNI. It provides a survey of   existing work on the subject and a set of additional requirements for controlling the exchange of Footprint information.

http://www.ietf.org/internet-drafts/draft-bertrand-cdni-footprint-discovery-00.txt 

Any feedback is welcome.

Cheers,

Gilles 

-----Message d'origine-----
De : [email-masked] [mailto:[email-masked]] De la part de [email-masked] Envoyé : lundi 5 mars 2012 18:54 À : [email-masked] Objet : I-D Action: draft-bertrand-cdni-footprint-discovery-00.txt

A New Internet-Draft is available from the on-line Internet-Drafts directories.

	Title           : CDN Footprint Discovery
	Author(s)       : Gilles Bertrand
	Filename        : draft-bertrand-cdni-footprint-discovery-00.txt
	Pages           : 13
	Date            : 2012-03-05

   Interconnected CDNs need to exchange information on the set of end-
   users to which they can deliver content.  This information is
   commonly referred to as "CDN Footprint".  This memo presents use
   cases for CDN Footprint Discovery in CDNI.  It provides a survey of
   existing work on the subject and a set of additional requirements for
   controlling the exchange of Footprint information.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-bertrand-cdni-footprint-discovery-00.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

This Internet-Draft can be retrieved at:
ftp://ftp.ietf.org/internet-drafts/draft-bertrand-cdni-footprint-discovery-00.txt

_______________________________________________
I-D-Announce mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/i-d-announce
Internet-Draft directories: http://www.ietf.org/shadow.html or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: Jan Seedorf <[email-masked]>
Date: Thu, 8 Mar 2012 16:16:32 +0000

Gilles,

Just a short question: Is "CDN Footprint Discovery" the opposite direction of "CDN Footprint advertisement", or how are the terms related?

 - Jan

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> [email-masked]
> Sent: Tuesday, March 06, 2012 10:51 AM
> To: [email-masked]
> Subject: [CDNi] TR: I-D Action: draft-bertrand-cdni-footprint-discovery-00.txt
> 
> Hi everyone,
> 
> I have submitted a new draft on CDN Footprint Discovery in CDNI. Its main
> purpose is to present use cases for CDN Footprint Discovery in CDNI. It
> provides a survey of   existing work on the subject and a set of additional
> requirements for controlling the exchange of Footprint information.
> 
> De : [email-masked] [mailto:i-d-announce-
> [email-masked]] De la part de [email-masked] Envoyé : lundi 5
> mars 2012 18:54 À : [email-masked] Objet : I-D Action: draft-bertrand-
> cdni-footprint-discovery-00.txt
> 
> 
> Internet-Draft directories: http://www.ietf.org/shadow.html or
> ftp://ftp.ietf.org/ietf/1shadow-sites.txt
> CDNi mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cdni

---

From: <[email-masked]>
Date: Fri, 9 Mar 2012 10:10:16 +0100

Hi Jan,

The term "Footprint advertisement" implies that the dCDN sends advertisements about its footprint through a protocol. 

draft-bertrand-cdni-footprint-discovery shows that such advertisements through a protocol are not always required depending on what information the CDNs need to share (e.g., high level vs. detailed footprint information). That's why we use a more general term in the draft: "Footprint Discovery".

Best regards,

Gilles

-----Message d'origine-----
De : Jan Seedorf [mailto:[email-masked]] 
Envoyé : jeudi 8 mars 2012 17:17
À : BERTRAND Gilles RD-CORE-ISS; [email-masked]
Objet : RE: [CDNi] TR: I-D Action:draft-bertrand-cdni-footprint-discovery-00.txt

Gilles,

 - Jan

> From: [email-masked] [mailto:[email-masked]] On Behalf 
> Of [email-masked]
> Subject: [CDNi] TR: I-D Action: 
> draft-bertrand-cdni-footprint-discovery-00.txt
> 
> Hi everyone,
> 
> I have submitted a new draft on CDN Footprint Discovery in CDNI. Its 
> main purpose is to present use cases for CDN Footprint Discovery in CDNI. It
> [email-masked]] De la part de [email-masked] Envoyé : 
> lundi 5 mars 2012 18:54 À : [email-masked] Objet : I-D Action: 
> draft-bertrand- cdni-footprint-discovery-00.txt
> 
> 
> ftp://ftp.ietf.org/internet-drafts/draft-bertrand-cdni-footprint-disco
> very-
> 00.txt
>

---

From: Jan Seedorf <[email-masked]>
Date: Fri, 9 Mar 2012 09:30:25 +0000

Hi Gilles,

Thanks for the explanation, although I do not see why the term is more general.

What I find confusing about the term "Footprint Discovery" is that - at a first glance - it is not clear if it means a) discovery from the perspective of the uCDN, i.e. a uCDN asking itself: "what footprint does a given dCDN have?", or b) discovery from the perspective of a dCDN *ITSELF*, i.e. a dCDN asking itself: "what footprint do I currently have?", in order to be able to advertise that discovered footprint then to a uCDN.

 - Jan

> From: [email-masked] [mailto:[email-masked]]
> Sent: Friday, March 09, 2012 10:10 AM
> To: Jan Seedorf
> Cc: [email-masked]
> Subject: RE: [CDNi] TR: I-D Action:draft-bertrand-cdni-footprint-discovery-
> 00.txt
> 
> Hi Jan,
> 
> The term "Footprint advertisement" implies that the dCDN sends
> advertisements about its footprint through a protocol.
> 
> draft-bertrand-cdni-footprint-discovery shows that such advertisements
> through a protocol are not always required depending on what information
> the CDNs need to share (e.g., high level vs. detailed footprint information).
> That's why we use a more general term in the draft: "Footprint Discovery".
> 
> Best regards,
> 
> Gilles
> 
> Just a short question: Is "CDN Footprint Discovery" the opposite direction of
> "CDN Footprint advertisement", or how are the terms related?
> 
>  - Jan
>

---

From: <[email-masked]>
Date: Fri, 9 Mar 2012 15:07:15 +0100

Hi Jan,

> What I find confusing about the term "Footprint Discovery" is that - at a first glance - it is not clear if it means a) discovery from the perspective of the uCDN, i.e. a uCDN asking itself: "what footprint does a given dCDN have?", 
> or b) discovery from the perspective of a dCDN *ITSELF*, i.e. a dCDN asking itself: "what footprint do I currently have?", in order to be able to advertise that discovered footprint then to a uCDN.

The dCDN knows its CDN Footprint ("b" what footprint do I currently have) because it discovers the CDN Footprint of its own dCDNs ("a" what footprint does a given dCDN have). In your statement "a" and "b" are different recursions of the Footprint Discovery problem.

Cheers,

Gilles 

> Subject: RE: [CDNi] TR: I-D 
> Action:draft-bertrand-cdni-footprint-discovery-
> 00.txt
> 
> Hi Jan,
> 
> through a protocol are not always required depending on what 
> information the CDNs need to share (e.g., high level vs. detailed footprint information).
> De : Jan Seedorf [mailto:[email-masked]] Envoyé : jeudi 8 mars 
> 2012 17:17 À : BERTRAND Gilles RD-CORE-ISS; [email-masked] Objet : RE: 
> [CDNi] TR: I-D Action:draft-bertrand-cdni-footprint-discovery-
> 00.txt
> 
> Gilles,
> 
> Just a short question: Is "CDN Footprint Discovery" the opposite 
> direction of "CDN Footprint advertisement", or how are the terms related?
> 
>  - Jan
>

---

From: Jan Seedorf <[email-masked]>
Date: Fri, 9 Mar 2012 14:19:15 +0000

> does a given dCDN have). In your statement "a" and "b" are different
> recursions of the Footprint Discovery problem.
Ok, and what out of these recursion is your draft about? :)

 - Jan

> Sent: Friday, March 09, 2012 3:07 PM
> To: Jan Seedorf
> Cc: [email-masked]
> > What I find confusing about the term "Footprint Discovery" is that - at a first
> glance - it is not clear if it means a) discovery from the perspective of the
> uCDN, i.e. a uCDN asking itself: "what footprint does a given dCDN have?",
> > or b) discovery from the perspective of a dCDN *ITSELF*, i.e. a dCDN asking
> itself: "what footprint do I currently have?", in order to be able to advertise
> that discovered footprint then to a uCDN.
> 
> The dCDN knows its CDN Footprint ("b" what footprint do I currently have)
> because it discovers the CDN Footprint of its own dCDNs ("a" what footprint
> does a given dCDN have). In your statement "a" and "b" are different
> recursions of the Footprint Discovery problem.
> 
> Cheers,
> 
> Gilles
> 
> 
> > > main purpose is to present use cases for CDN Footprint Discovery in
> CDNI.
> > It