Subject: Re: [CDNi] Working Group Last Call on draft-ietf-cdni-use-cases-03.txt

From: Ben Niven-Jenkins <[email-masked]>
Date: Sun, 4 Mar 2012 16:38:31 +0000

On 22 Feb 2012, at 16:31, Francois Le Faucheur wrote:

> Folks,
> 
> The Last Call period for draft-ietf-cdni-use-cases has now closed, but we haven't received any comments, so we'll extend it until 2 March.

Apologies that this is a little past the deadline.

I have read draft-ietf-cdni-use-cases-03 and apart from one thing I think it is ready to be sent to the IESG.

Sections 2, 3 and 4 seem to fulfil the purpose of the document, i.e. to outline the different *use cases for interconnecting CDNs*, however section 5 seems out of place in this document because it describes CSP requirements that are placed on CDNs today and does not introduce any CDN Interconnect specific *use cases*.

I propose that we remove section 5 from the use cases draft and then take the text of that section and distill it into the specific requirements it describes and we add the resulting requirements to the requirements draft.

Ben

>  
> As per the show of hand at the last IETF meeting, quite a few of you are familiar with this document. So can you please have a look at the latest version and pass on your comments, or a brief statement like "I think it's ready" or "I think it needs rework before going further", so we can get explicit confirmation that the document is ready (or not) from the WG perspective.
> 
> Thanks
> 
> Francois & Rich
> 
> 
> On 30 Jan 2012, at 14:37, Francois Le Faucheur wrote:
> 
>> All,
>> 
>> This is the start of a two-week working group last call on draft-ietf-cdni-use-cases-03.txt:
>> https://datatracker.ietf.org/doc/draft-ietf-cdni-use-cases/
>> 
>> This working group last call will end 13 Feb 2012. Please send your comments to the CDNI mailing list.
>> 
>> Francois & Rich
>> 
>> 
>> Begin forwarded message:
>> 
>>> From: <[email-masked]>
>>> Date: 30 January 2012 12:12:50 CET
>>> To: <[email-masked]>
>>> Subject: [CDNi] TR: I-D Action: draft-ietf-cdni-use-cases-03.txt
>>> 
>>> Hi,
>>> 
>>> We have submitted a revision addressing Kent's comments.
>>> 
>>> http://tools.ietf.org//rfcdiff?url1=http://tools.ietf.org/id/draft-ietf-cdni-use-cases-02.txt&url2=http://tools.ietf.org/id/draft-ietf-cdni-use-cases-03.txt 
>>> 
>>> Best regards,
>>> 
>>> Gilles
>>> 
>>> 
>>> 
>>> 
>>> -----Message d'origine-----
>>> De : [email-masked] [mailto:[email-masked]] De la part de [email-masked]
>>> Envoyé : lundi 30 janvier 2012 12:07
>>> À : [email-masked]
>>> Cc : [email-masked]
>>> Objet : [CDNi] I-D Action: draft-ietf-cdni-use-cases-03.txt
>>> 
>>> 
>>> A New Internet-Draft is available from the on-line Internet-Drafts directories. This draft is a work item of the Content Delivery Networks Interconnection Working Group of the IETF.
>>> 
>>> 	Title           : Use Cases for Content Delivery Network Interconnection
>>> 	Author(s)       : Gilles Bertrand
>>>                          Stephan Emile
>>>                          Grant Watson
>>>                          Trevor Burbridge
>>>                          Philip Eardley
>>>                          Kevin Ma
>>> 	Filename        : draft-ietf-cdni-use-cases-03.txt
>>> 	Pages           : 18
>>> 	Date            : 2012-01-30
>>> 
>>>   Content Delivery Networks (CDNs) are commonly used for improving the
>>>   End User experience of a content delivery service, at a reasonable
>>>   cost.  This document outlines real world use cases (not technical
>>>   solutions) for interconnecting CDNs.  It focuses on use cases that
>>>   correspond to identified industry needs and that are expected to be
>>>   realized once a CDN Interconnection (CDNI) solution is available.
>>>   This document can be used to provide guidance to the CDNI WG about
>>>   the interconnection arrangements to be supported and to validate the
>>>   requirements of the various CDNI interfaces.
>>> 
>>> 
>>> A URL for this Internet-Draft is:
>>> http://www.ietf.org/internet-drafts/draft-ietf-cdni-use-cases-03.txt
>>> 
>>> Internet-Drafts are also available by anonymous FTP at:
>>> ftp://ftp.ietf.org/internet-drafts/
>>> 
>>> This Internet-Draft can be retrieved at:
>>> ftp://ftp.ietf.org/internet-drafts/draft-ietf-cdni-use-cases-03.txt
>>> 
>>> _______________________________________________
>>> CDNi mailing list
>>> [email-masked]
>>> https://www.ietf.org/mailman/listinfo/cdni
>>> _______________________________________________
>>> CDNi mailing list
>>> [email-masked]
>>> https://www.ietf.org/mailman/listinfo/cdni
>> 
>> 
>> _______________________________________________
>> CDNi mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/cdni
> 
> 
> _______________________________________________
> CDNi mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cdni

---

From: <[email-masked]>
Date: Sun, 4 Mar 2012 21:47:42 +0000

your point is logical, although personally I think it's better if Section 5 is included - this is probably the first document someone would read about cdni, so a bit of hinting about where the tricky points might be is quite nice. 

I agree the requirements should go into the requirements draft. at a very quick glance it seems that someof them are not in there. Should they be added, or is it correct that they're missing?

- 5.1: resolution-constraint 
- 5.1 geolocation-constraint (geo-location from where content delivered)
- 5.2 security (CSP restricting uCDN which restricts dCDN about which security protocol to use)
- 5.2 security (CSP enforcing per-request authentication/authorisation) 
- 5.3 branding     

Anyway, if S5 stays in the use cases, should be consistent with the requirements doc

best wishes
phil

________________________________________
From: [email-masked] [[email-masked]] On Behalf Of Ben Niven-Jenkins [[email-masked]]
Sent: 04 March 2012 16:38
To: Francois Le Faucheur
Cc: [email-masked]
Subject: Re: [CDNi] Working Group Last Call on  draft-ietf-cdni-use-cases-03.txt

Ben