Subject: [CDNi] CDNI Logging - ucdn-centric-uri

From: "Francois Le Faucheur (flefauch)" <[email-masked]>
Date: Tue, 28 May 2013 09:12:50 +0000

Hi Rob and all,

I've done a little more thinking about your earlier suggestion to redefine the ELF "r" prefix into something that designates the uCDN , and then rename "ucdn-centric-uri" into "sr-uri".

I'm concluding we should not do that because:
	* this would probably actually be confusing. When reading "sr-uri" many people will probably think this is the uri used by the dCDN surrogate to acquire the content from its upstream cache. Case in point, Ben's recent message on cs-uri precisely made that exact assumption i.e. "sr-uri would be the URI that the surrogate presented to its upstream source on a cache miss." 
	* if we ever want to define an additional log field related to what happens between the surrogate and its upstream cache, the natural "r" prefix will be already taken.

So how about we just define new prefixes to refer to uCDN and dCDN when needed?
For example we could coin "u" for uCDN and "d" for dCDN and then we could rename "ucdn-centric-uri" into "du-uri"?
Would that work?

Francois

---

From: Rob Murray <[email-masked]>
Date: Wed, 29 May 2013 10:16:54 +0000

Good idea - that naming makes sense, should avoid a lot of confusion.

-----Original Message-----
From: "Francois Le Faucheur   (flefauch)" <[email-masked]>
Date: Tuesday, 28 May 2013 14:42
To: Rob Murray <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: CDNI Logging - ucdn-centric-uri

>Hi Rob and all,
>
>I've done a little more thinking about your earlier suggestion to
>redefine the ELF "r" prefix into something that designates the uCDN , and
>then rename "ucdn-centric-uri" into "sr-uri".
>
>	* this would probably actually be confusing. When reading "sr-uri" many
>people will probably think this is the uri used by the dCDN surrogate to
>acquire the content from its upstream cache. Case in point, Ben's recent
>message on cs-uri precisely made that exact assumption i.e. "sr-uri would
>be the URI that the surrogate presented to its upstream source on a cache
>miss." 
>	* if we ever want to define an additional log field related to what
>happens between the surrogate and its upstream cache, the natural "r"
>prefix will be already taken.
>

---

From: <[email-masked]>
Date: Wed, 29 May 2013 14:20:57 +0200

Yes, I think too this is a good idea beacuse the r and s meanings were not that clear, depending on the context. We can discuss this in more detail this afternoon.

Cheers,
-- iuniana  

-----Original Message-----
From: "Francois Le Faucheur   (flefauch)" <[email-masked]>
Date: Tuesday, 28 May 2013 14:42
To: Rob Murray <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: CDNI Logging - ucdn-centric-uri

>redefine the ELF "r" prefix into something that designates the uCDN , 
>and then rename "ucdn-centric-uri" into "sr-uri".
>
>	* this would probably actually be confusing. When reading "sr-uri" 
>many people will probably think this is the uri used by the dCDN 
>surrogate to acquire the content from its upstream cache. Case in 
>point, Ben's recent message on cs-uri precisely made that exact 
>assumption i.e. "sr-uri would be the URI that the surrogate presented 
>to its upstream source on a cache miss."
>For example we could coin "u" for uCDN and "d" for dCDN and then we 
>could rename "ucdn-centric-uri" into "du-uri"?
>Would that work?
>
>Francois

_______________________________________________
CDNi mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/cdni

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
France Telecom - Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, France Telecom - Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: "Francois Le Faucheur (flefauch)" <[email-masked]>
Date: Wed, 29 May 2013 14:31:50 +0000

So I think we have agreement to go ahead with "u" and "d" prefixes. Good.

Now, with respect to renaming the "ucdn-centric-uri", I think we may want to call this field "u-uri" (instead of my earlier proposal of "du-uri") because this uri is intended to be meaningful to the uCDN but it may or may not exactly coincide with the uri that is used for actual content acquisition by dCDN from uCDN (which would be the "du-uri").

Bottom line, I propose we rename "ucdn-centric-uri" into "u-uri".