Subject: [CDNi] Chair review of Requirements draft

From: Daryl Malas <[email-masked]>
Date: Fri, 24 May 2013 20:34:59 +0000

Kent and Yiu,

Here is my chair review of the requirements draft.  Overall, I think this draft is in great shape.  Let me know if you have any questions.

Regards,

Daryl

Abstract:
I think the cdni WG charter actually describes the problem better than the text used in the draft.  I recommend better aligning with the charter text - "As a result of the significant growth in content delivered over IP networks, existing CDN providers are scaling up their infrastructure and many Network Service Providers and Enterprise Service Providers are deploying their own CDNs. Subject to the policy of the CSP, it is generally desirable that a given item of content can be delivered to an end user regardless of that end user's location or attachment network.  This creates a need for interconnecting (previously) standalone CDNs so they can interoperate and collectively behave as a single delivery infrastructure."

Nit - "…such CDN interconnection." to "…such CDN interconnections."

Remove this sentence - "This draft is a work in progress and requirements may be added, modified, or removed by the working group."

The "Requirements Language" should be moved to the "Terminology" section.

Under the sub-bullets for "high, medium and low," I recommend we remove references to compromising the working group's schedule.  Instead, change these comments to indicate the goal in assigning the varying priorities is relative to providing a "deployable solution in a short timeframe (18-24 months) as needed by the industry."  This is the goal as part of the working group charter.

Introduction:
My experience is that "subjective" language should be avoided in IETF drafts.  The introduction in this draft is full of subjective phrases: "rapidly increasing and expected to continue", "reduced delivery cost", "improved quality of experience", "increased robustness", "cost benefit and user experience".  At a minimum, I suggest removing some of this subjectivity and focus on how CDNI will allow for content delivery across multiple CDNs.

In the last paragraph, instead of saying "In order to meet the timelines" -- see comment above regarding "short timeframe (18-24 months) as needed by the industry."

CDNI Control Interface Requirements:
The following sentence lends to discussing potential solutions.  "We observe that while the CDNI Control interface is currently discussed as a single "protocol", further analysis will determine whether the corresponding requirements are to be realized over a single interface and protocol, or over multiple interfaces and protocols."  I suggest we remove this from this requirement and make a statement at the beginning along the lines of, "The working group attempted to align requirements with the appropriate interface; however, solutions to these requirements may apply to a different interface or another interface in addition to the interface it is associated with."

CI-1 – Suggest changing this requirement from "…Downstream CDN (and, if cascaded CDNs are supported by the solution, that the potential cascaded Downstream CDNs) delete…" to "…Downstream CDN, including downstream cascaded CDNs, delete…"  Apply this to CI-3, CI-4 and any other similar references.  Since, we support cascaded CDNs, then we should simply specify the inclusion in the requirement.

CI-4 – I think we should require a "reason" to be included with a failure response.  Initially it could simply be a string, unless we are going to simply use HTTP response codes.

CI-8 - "CDNI interconnection" is redundant.  Also, I think "i.e." should be "e.g.".

CDNI Request Routing/Redirection Interface Requirements:
RI-6 appears to be what RI-5 refers to with regards to the "loop prevention mechanism".  If this is the case, I think we should add that language to RI-6 and change the order of these two.

CDNI Metadata Distribution Interface Requirements:
MI-16 has a list with only 1 bullet point.  I suggest changing it to, "For example, this could potentially including the need to validate URI signed information (e.g.  Expiry time, Client IP address)."
MI-21 nit, "Streamin" to "Streaming"; and, this needs to be removed and addressed "[Ed: need to improve wording?]"

CDNI Logging Interface Requirements:
[Same comment as in the CDNI Control Interface Requirements with regards to noting whether it may or may not be multiple protocols.]
LI-13 nit, "requests on via the CDNI" to "requests via the CDNI"

CDNI Security Requirements:
Opening paragraph nit, "Some of those" to "Some of these".

>end.

---

From: "Kent Leung (kleung)" <[email-masked]>
Date: Tue, 28 May 2013 18:25:59 +0000

Hi Daryl. Thanks for your thorough review. We should be able to incorporate your comments into the next version in a few days.

Kent

From: Daryl Malas [mailto:[email-masked]]
Sent: Friday, May 24, 2013 1:35 PM
To: Kent Leung (kleung); [email-masked]
Cc: [email-masked]
Subject: [CDNi] Chair review of Requirements draft

Kent and Yiu,

Regards,

Daryl

Abstract:

Nit - "...such CDN interconnection." to "...such CDN interconnections."

Introduction:

CI-1 - Suggest changing this requirement from "...Downstream CDN (and, if cascaded CDNs are supported by the solution, that the potential cascaded Downstream CDNs) delete..." to "...Downstream CDN, including downstream cascaded CDNs, delete..."  Apply this to CI-3, CI-4 and any other similar references.  Since, we support cascaded CDNs, then we should simply specify the inclusion in the requirement.

CI-4 - I think we should require a "reason" to be included with a failure response.  Initially it could simply be a string, unless we are going to simply use HTTP response codes.

---

From: Daryl Malas <[email-masked]>
Date: Tue, 28 May 2013 19:47:45 +0000

Kent,

Thanks for your (and Yiu) efforts.  Once we have the final revision, I will start the process of submitting it for AD review.  I will be the document shepherd on this draft, also.

Regards,

Daryl

From: "Kent Leung (kleung)" <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, May 28, 2013 12:25 PM
To: Daryl Malas <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: RE: [CDNi] Chair review of Requirements draft

Kent

From: Daryl Malas [mailto:[email-masked]]
Sent: Friday, May 24, 2013 1:35 PM
To: Kent Leung (kleung); [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Subject: [CDNi] Chair review of Requirements draft

Kent and Yiu,

Regards,

Daryl

Abstract:

Introduction:

---

From: "Kent Leung (kleung)" <[email-masked]>
Date: Tue, 28 May 2013 20:58:41 +0000

Hi Daryl. I'd like to get some clarifications on your points. See below.

Kent and Yiu,

Regards,

Daryl

Abstract:

KL> Just want to clarify. Is this text correct for the Abstract section?

"Content Delivery Networks (CDNs) are frequently used for large-scale content delivery. As a result of the significant growth in content delivered over IP networks, existing CDN providers are scaling up their infrastructure and many Network Service Providers and Enterprise Service Providers are deploying their own CDNs. Subject to the policy of the CSP, it is generally desirable that a given item of content can be delivered to an end user regardless of that end user's location or attachment network.  This creates a need for interconnecting (previously) standalone CDNs so they can interoperate and collectively behave as a single delivery infrastructure. The Content Distribution Network Interconnection (CDNI) working group has been chartered to develop an interoperable and scalable solution for such CDN interconnection.

The goal of the present document is to outline the requirements for the solution and interfaces to be specified by the CDNI working group."

KL> Is the following OK?

"   This document uses the terminology defined in section 1.1 of
   Framework for CDNI [I-D.davie-cdni-framework].  In addition, the key
   words "High Priority", "Medium Priority" and "Low Priority" in this
   document are to be interpreted in the following way:

   o  "High Priority" indicates requirements that are to be supported by
      the CDNI interfaces.  A requirement is stated as "High Priority"
      when it is established by the working group that it can be met to
      achieve the goal of a deployable solution in a short timeframe
      (18-24 months) as needed by the industry.  This is tagged as
      "[HIGH]".

   o  "Medium Priority" indicates requirements that are to be supported
      by the CDNI interfaces unless the WG realizes at a later stage
      that attempting to meet this requirement does not achieve the goal
      of a deployable solution in a short timeframe (18-24 months) as
      needed by the industry.  This is tagged as "[MED]".

   o  "Low Priority" indicates requirements that are to be supported by
      the CDNI interfaces provided that dedicating WG resources to this
      work does not prevent addressing "High Priority" and "Medium
      Priority" requirements and that attempting to meet this
      requirement is not an obstacle to achieving the goal of a
      deployable solution in a short timeframe (18-24 months) as needed
      by the industry.  This is tagged as "[LOW]"."

Introduction:

KL> IMHO, removing the text that describes the rationale for CDN seems to lose the background material that argues for the benefits of interconnecting CDNs. BTW, the rationale is consistent with the CDNI Problem Statement RFC.  I think the intended logic is this: Why is a CDN needed now? Why interconnect the CDNs is beneficial? Is the following text OK?

"The volume of video and multimedia content delivered over the Internet is rapidly increasing and expected to continue doing so in the future. In the face of this growth, Content Delivery Networks (CDNs) provide numerous benefits: reduced delivery cost for cacheable content, improved quality of experience for end users, and increased robustness of delivery. For these reasons CDNs are frequently used for large-scale content delivery. As a result of the significant growth in content delivered over IP networks, existing CDN providers are scaling up their infrastructure and many Network Service Providers and Enterprise Service Providers are deploying their own CDNs. Subject to the policy of the CSP, it is generally desirable that a given item of content can be delivered to an end user regardless of that end user's location or attachment network.  This creates a need for interconnecting (previously) standalone CDNs so they can interoperate and collectively behave as a single delivery infrastructure. The Content Distribution Network Interconnection (CDNI) working group has been chartered to develop an interoperable and scalable solution for such CDN interconnections."

KL> OK

KL> OK to CI list.

KL> RI-6 does not have to be related to loop  prevention. It may be the level of depth in cascaded CDNs. Limit on the number of redirections may be for various reasons.

KL> OK to MI list.

KL> OK.

Kent

---

From: "Lee, Yiu" <[email-masked]>
Date: Wed, 29 May 2013 04:20:21 +0000

Hi Kent and Darly,

I want to make a slight change of the abstract to make it even more
objective:

"Content Delivery Networks (CDNs) are frequently used for content delivery.
As a result of significant growth in content delivered over IP networks,
existing CDN providers are scaling up their infrastructure. Many Network
Service Providers and Enterprise Service Providers are also deploying their
own CDNs. To deliver contents from the Content Service Protect (CSP) to end
users, the contents may traverse across multiple CDNs. This creates a need
for interconnecting (previously) standalone CDNs so that they can
collectively act as a single delivery platform from the CSP to the end
users.

The goal of this memo is to outline the requirements for the CDNI working
group."

What do you guys think?

Thanks,
Yiu

From:  "Kent Leung   (kleung)" <[email-masked]>
Date:  Tuesday, May 28, 2013 4:58 PM
To:  Daryl Malas <[email-masked]>, "Yiu L. LEE"
<[email-masked]>
Cc:  "[email-masked]" <[email-masked]>
Subject:  RE: [CDNi] Chair review of Requirements draft

³Content Delivery Networks (CDNs) are frequently used for large-scale
content delivery. As a result of the significant growth in content delivered
over IP networks, existing CDN providers are scaling up their infrastructure
and many Network Service Providers and Enterprise Service Providers are
deploying their own CDNs. Subject to the policy of the CSP, it is generally
desirable that a given item of content can be delivered to an end user
regardless of that end user's location or attachment network.  This creates
a need for interconnecting (previously) standalone CDNs so they can
interoperate and collectively behave as a single delivery infrastructure.
The Content Distribution Network Interconnection (CDNI) working group has
been chartered to develop an interoperable and scalable solution for such
CDN interconnection.
 
The goal of the present document is to outline the requirements for the
solution and interfaces to be specified by the CDNI working group.²

---

From: "Kent Leung (kleung)" <[email-masked]>
Date: Fri, 31 May 2013 15:49:58 +0000

Hi Yiu. This looks good to me.

Kent

From: Lee, Yiu [mailto:[email-masked]]
Sent: Tuesday, May 28, 2013 9:20 PM
To: Kent Leung (kleung); Daryl Malas
Cc: [email-masked]
Subject: Re: [CDNi] Chair review of Requirements draft

Hi Kent and Darly,

I want to make a slight change of the abstract to make it even more objective:

"Content Delivery Networks (CDNs) are frequently used for content delivery. As a result of significant growth in content delivered over IP networks, existing CDN providers are scaling up their infrastructure. Many Network Service Providers and Enterprise Service Providers are also deploying their own CDNs. To deliver contents from the Content Service Protect (CSP) to end users, the contents may traverse across multiple CDNs. This creates a need for interconnecting (previously) standalone CDNs so that they can collectively act as a single delivery platform from the CSP to the end users.

The goal of this memo is to outline the requirements for the CDNI working group."

What do you guys think?

Thanks,
Yiu

To: Daryl Malas <[email-masked]<mailto:[email-masked]>>, "Yiu L. LEE" <[email-masked]<mailto:[email-masked]>>