Subject: [CDNi] non-repudiation questions

From: David Mandelberg <[email-masked]>
Date: Thu, 30 May 2013 13:28:18 -0400

Hi,

What are the goals of non-repudiation of logging data? I've listed two
possibilities below. Are those right? Is there anything else that people
want non-repudiation to do for them?

 * Audits: If a uCDN detects a problem that's supported by logging
information, the dCDN can't claim that they never supplied that logging
information or that the information was modified in transit.
 * Billing: Once a uCDN receives a log file, the dCDN can't claim that
there are additional records that are missing from that file. (But they can
still add those records to a future log file.)

Also, how would dCDNs be willing to protect their private keys? If dCDNs
don't want to use hardware security modules, I'd recommend a solution that
uses ephemeral keys.

-- 
David Eric Mandelberg / dseomn
http://david.mandelberg.org/

---

From: <[email-masked]>
Date: Thu, 30 May 2013 19:24:10 +0200

Hello,

I'm in line with the two goals of non-repudiation for the logging data.  

Cannot offer help for the private keys question.
-- iuniana

-----Message d'origine-----
De : [email-masked] [mailto:[email-masked]] De la part de David Mandelberg
Envoyé : jeudi 30 mai 2013 19:28
À : [email-masked]
Objet : [CDNi] non-repudiation questions

Hi,

What are the goals of non-repudiation of logging data? I've listed two possibilities below. Are those right? Is there anything else that people want non-repudiation to do for them?

 * Audits: If a uCDN detects a problem that's supported by logging information, the dCDN can't claim that they never supplied that logging information or that the information was modified in transit.
 * Billing: Once a uCDN receives a log file, the dCDN can't claim that there are additional records that are missing from that file. (But they can still add those records to a future log file.)

Also, how would dCDNs be willing to protect their private keys? If dCDNs don't want to use hardware security modules, I'd recommend a solution that uses ephemeral keys.

--
David Eric Mandelberg / dseomn
http://david.mandelberg.org/
_______________________________________________
CDNi mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/cdni

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
France Telecom - Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, France Telecom - Orange is not liable for messages that have been modified, changed or falsified.
Thank you.