Subject: [CDNi] CDNI Logging - whitespace

From: Ben Niven-Jenkins <[email-masked]>
Date: Tue, 28 May 2013 09:01:31 +0100

Colleagues,

Reading draft-ietf-cdni-logging-02 Section 3.1:

   o  Fields:

      *  format: <field-name>[ <field-name>], where the allowed list of
         <field-name> are specified for each Record-Type in Section 3.2

      *  semantic: this lists the names of all the fields for which a
         value is to appear in the CDNI Logging Records that are after
         this directive.  The names of the fields, as well as their
         possible occurrences, are specified for each type of CDNI
         Logging Records in Section 3.2. The field names listed in this
         directive MUST be separated by a whitespace (" ").

Does this mean separated by any whitespace or specifically by a single (or multiple?) space character?

(Section 3.2 specifies TAB MUST be used to separate the actual field values in the log)

Thanks
Ben

---

From: "Francois Le Faucheur (flefauch)" <[email-masked]>
Date: Tue, 28 May 2013 08:39:51 +0000

> Does this mean separated by any whitespace or specifically by a single (or multiple?) space character?

How about we say that transmitting end MUST include a single spec character and receiving end MUST be able to parse one or multiple space characters?

> _______________________________________________
> CDNi mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cdni

---

From: Ben Niven-Jenkins <[email-masked]>
Date: Tue, 28 May 2013 10:16:11 +0100

> How about we say that transmitting end MUST include a single spec character and receiving end MUST be able to parse one or multiple space characters?

That works for me but should we align the #Fields: directive with the actual log lines and use a TAB instead?

Ben

---

From: "Francois Le Faucheur (flefauch)" <[email-masked]>
Date: Tue, 28 May 2013 09:22:51 +0000

On 28 May 2013, at 11:16, Ben Niven-Jenkins <[email-masked]>
 wrote:

> That works for me but should we align the #Fields: directive with the actual log lines and use a TAB instead

Makes sense. I have changed it to TAB.