Subject: [CDNi] I-D Action: draft-ietf-cdni-redirection-11.txt

From: [email-masked]
Date: Mon, 20 Jul 2015 00:45:20 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Content Delivery Networks Interconnection Working Group of the IETF.

        Title           : Request Routing Redirection Interface for CDN Interconnection
        Authors         : Ben Niven-Jenkins
                          Ray van Brandenburg
	Filename        : draft-ietf-cdni-redirection-11.txt
	Pages           : 32
	Date            : 2015-07-20

Abstract:
   The Request Routing Interface comprises of (1) the asynchronous
   advertisement of footprint and capabilities by a downstream Content
   Delivery Network (CDN) that allows an upstream CDN to decide whether
   to redirect particular user requests to that downstream CDN; and (2)
   the synchronous operation of an upstream CDN requesting whether a
   downstream CDN is prepared to accept a user request and of a
   downstream CDN responding with how to actually redirect the user
   request.  This document describes an interface for the latter part,
   i.e. the CDNI Request Routing Redirection interface.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-cdni-redirection/

There's also a htmlized version available at:
https://tools.ietf.org/html/draft-ietf-cdni-redirection-11

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-cdni-redirection-11

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Francois Le Faucheur (flefauch)" <[email-masked]>
Date: Tue, 21 Jul 2015 14:00:30 +0000

Hi Ray,

As agreed Yesterday I reviewed the security section in draft-ietf-cdni-redirection to ensure alignment with the final text agreed in the context of cdni-logging.

Here are my comments for complete alignment with final text:

OLD:
“
The use of TLS for
   transport of the CDNI Redirection interface messages allows:

   o  The dCDN and uCDN to authenticate each other (to ensure they are
      transmitting/receiving CDNI Redirection minterface messages from
      an authenticated CDN).

   o  CDNI Redirection interface messages to be transmitted with
      confidentiality.

   o  The integrity of the CDNI Redirection interface messages to be
      protected during the exchange.
“
NEW:
“
The use of TLS for
   transport of the CDNI Redirection interface messages allows:

   o  The dCDN and uCDN to authenticate each other

and, once they have mutually authenticated each other, it allows:

   o  the dCDN and uCDN to authorize each other (to ensure they are
      transmitting/receiving CDNI Redirection messages to/from an authorized CDN)

   o  CDNI Redirection interface messages to be transmitted with
      confidentiality.

   o  The integrity of the CDNI Redirection interface messages to be
      protected during the exchange.
“

OLD:
“
the use of a mutually authenticated encrypted transport MUST be used
“
NEW:
“
mutually authenticated encrypted transport MUST be used
“

OLD:
“
TLS MUST be used
“
NEW:
To that end, TLS MUST be used
“

OLD:
“
The general TLS usage guidance in [RFC7525] SHOULD be followed.
“
NEW:
“
When TLS is used, the general TLS usage guidance in [RFC7525] MUST be followed.
“

Thanks

Francois

Begin forwarded message:

From: <[email-masked]<mailto:[email-masked]>>
Subject: [CDNi] I-D Action: draft-ietf-cdni-redirection-11.txt
Date: 20 July 2015 09:45:20 CEST
To: <[email-masked]<mailto:[email-masked]>>
Cc: <[email-masked]<mailto:[email-masked]>>

Abstract:

_______________________________________________
CDNi mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/cdni

---

From: "Brandenburg, R. (Ray) van" <[email-masked]>
Date: Wed, 22 Jul 2015 15:32:26 +0000

Hi Francois,

Thanks for the review. I just added your proposed revisions to my working copy of the draft. Once I have dealt with the DNS/HTTPS comment that Jon made during the meeting, I will publish a new version.

Ray

From: "[email-masked]<mailto:[email-masked]>"
Date: Tuesday 21 July 2015 16:00
To: Ray van Brandenburg
Cc: "[email-masked]<mailto:[email-masked]>"
Subject: Aligning security/TLS text in Fwd: [CDNi] I-D Action: draft-ietf-cdni-redirection-11.txt

Hi Ray,

OLD:
“
The use of TLS for

OLD:
“

OLD:
“
TLS MUST be used
“
NEW:

OLD:
“

Thanks

Francois

Begin forwarded message:

Abstract:

_______________________________________________
CDNi mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/cdni

This message may contain information that is not intended for you. If you are not the addressee or if this message was sent to you by mistake, you are requested to inform the sender and delete the message. TNO accepts no liability for the content of this e-mail, for the manner in which you use it and for damage of any kind resulting from the risks inherent to the electronic transmission of messages.