Subject: Re: [CDNi] New Version Notification for draft-slovetskiy-cdni-https-delegation-approaches-00.txt

From: Sergey Slovetsky <[email-masked]>
Date: Mon, 6 Jul 2015 21:43:42 +0000

Hi All,

As the first step to stimulate a discussion on the "HTTPS in interconnected CDNs" topic that has been raised by Iuniana in Dallas, I wrote a draft outlining the basic use case, problem scope, and examples of possible solutions.

Feedback is very welcome and will be highly appreciated.

Thanks in advance,

Rgds,
//Sergey

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Monday, July 06, 2015 5:27 PM
To: Sergey Slovetsky; Sergey Slovetsky
Subject: New Version Notification for draft-slovetskiy-cdni-https-delegation-approaches-00.txt

A new version of I-D, draft-slovetskiy-cdni-https-delegation-approaches-00.txt
has been successfully submitted by Sergey Slovetskiy and posted to the IETF repository.

Name:		draft-slovetskiy-cdni-https-delegation-approaches
Revision:	00
Title:		Approaches to HTTPS-based Request Routing and Delegation
Document date:	2015-07-06
Group:		Individual Submission
Pages:		2
URL:            https://www.ietf.org/internet-drafts/draft-slovetskiy-cdni-https-delegation-approaches-00.txt
Status:         https://datatracker.ietf.org/doc/draft-slovetskiy-cdni-https-delegation-approaches/
Htmlized:       https://tools.ietf.org/html/draft-slovetskiy-cdni-https-delegation-approaches-00

Abstract:
This document provides a basic non exhaustive background and discusses potential approaches to the issue of correct delegation of the encrypted
(TLS-based) traffic requests between CDNs in inter CDN networks and during interactions between client UAs, CSPs, and CDNs.

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: <[email-masked]>
Date: Tue, 7 Jul 2015 09:50:37 +0000

Hello fellow IETF-ers,

The irony of life makes it that I also posted a draft on the same topic of HTTPS in interconnected CDNs, just minutes before the deadline. Pheeeew! I think we most definitely need to talk about this in Prague and see how to proceed, given that there seems to be interest.

I'd like to thank again Jan Seedorf for some initial comments on HTTP redirection and Jon Peterson for actually contributing with substantial text to this draft.

Below you will find the reference.
--iuniana

-----Message d'origine-----
De : [email-masked] [mailto:[email-masked]] Envoyé : mardi 7 juillet 2015 01:49 À : FIEAU Frédéric IMT/OLN; OPRESCU Iuniana IMT/OLN Objet : New Version Notification for draft-fieau-https-delivery-delegation-00.txt

A new version of I-D, draft-fieau-https-delivery-delegation-00.txt
has been successfully submitted by Iuniana Oprescu and posted to the IETF repository.

Name:		draft-fieau-https-delivery-delegation
Revision:	00
Title:		HTTPS and delegation of encrypted traffic between interconnected CDNs
Document date:	2015-07-06
Group:		Individual Submission
Pages:		7
URL:            https://www.ietf.org/internet-drafts/draft-fieau-https-delivery-delegation-00.txt
Status:         https://datatracker.ietf.org/doc/draft-fieau-https-delivery-delegation/
Htmlized:       https://tools.ietf.org/html/draft-fieau-https-delivery-delegation-00

Abstract:
   This document illustrates some use cases and associated problems
   related to delivery of HTTPS secured traffic in the context of
   interconnected CDNs.  A common scenario is when a uCDN is delegating
   the delivery of encrypted traffic to a dCDN using HTTP or DNS
   redirection.  Some potential solutions are considered.

The IETF Secretariat

%%%%%%%%%%%%%%%%%%%%%%%%%%%%%

-----Message d'origine-----
De : CDNi [mailto:[email-masked]] De la part de Sergey Slovetsky
Envoyé : lundi 6 juillet 2015 23:44
À : [email-masked]
Objet : Re: [CDNi] New Version Notification for draft-slovetskiy-cdni-https-delegation-approaches-00.txt

Hi All,

Thanks in advance,

Rgds,
//Sergey

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Monday, July 06, 2015 5:27 PM
To: Sergey Slovetsky; Sergey Slovetsky
Subject: New Version Notification for draft-slovetskiy-cdni-https-delegation-approaches-00.txt

Abstract:

The IETF Secretariat

_______________________________________________
CDNi mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/cdni

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: <[email-masked]>
Date: Tue, 7 Jul 2015 10:11:39 +0000

Hello all,

I'm the co-author of the draft Iuniana has mentioned. Please review it, and don't hesitate to comment it, both on the mailing list and in Prague. 
Looking forward to receiving your comments. Thanks in advance.

We'll of course give a read to the draft posted by Sergey which seems to be similar. We'll have to work together to take the topic further.

Regards,
Frederic

-----Message d'origine-----
De : CDNi [mailto:[email-masked]] De la part de [email-masked]
Envoyé : mardi 7 juillet 2015 11:51
À : Sergey Slovetsky; [email-masked]
Objet : Re: [CDNi] New Version Notification for draft-slovetskiy-cdni-https-delegation-approaches-00.txt

Hello fellow IETF-ers,

-----Message d'origine-----

Abstract:

The IETF Secretariat

-----Message d'origine-----
De : CDNi [mailto:[email-masked]] De la part de Sergey Slovetsky Envoyé : lundi 6 juillet 2015 23:44 À : [email-masked] Objet : Re: [CDNi] New Version Notification for draft-slovetskiy-cdni-https-delegation-approaches-00.txt

Hi All,

Thanks in advance,

Rgds,
//Sergey

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Monday, July 06, 2015 5:27 PM
To: Sergey Slovetsky; Sergey Slovetsky
Subject: New Version Notification for draft-slovetskiy-cdni-https-delegation-approaches-00.txt

Abstract:

The IETF Secretariat