Subject: [CDNi] I-D Action: draft-ietf-cdni-redirection-10.txt

From: [email-masked]
Date: Thu, 02 Jul 2015 03:50:49 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Content Delivery Networks Interconnection Working Group of the IETF.

        Title           : Request Routing Redirection Interface for CDN Interconnection
        Authors         : Ben Niven-Jenkins
                          Ray van Brandenburg
	Filename        : draft-ietf-cdni-redirection-10.txt
	Pages           : 31
	Date            : 2015-07-02

Abstract:
   The Request Routing Interface comprises of (1) the asynchronous
   advertisement of footprint and capabilities by a downstream Content
   Delivery Network (CDN) that allows an upstream CDN to decide whether
   to redirect particular user requests to that downstream CDN; and (2)
   the synchronous operation of an upstream CDN requesting whether a
   downstream CDN is prepared to accept a user request and of a
   downstream CDN responding with how to actually redirect the user
   request.  This document describes an interface for the latter part,
   i.e. the CDNI Request Routing Redirection interface.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-cdni-redirection/

There's also a htmlized version available at:
https://tools.ietf.org/html/draft-ietf-cdni-redirection-10

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-cdni-redirection-10

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Brandenburg, R. (Ray) van" <[email-masked]>
Date: Thu, 2 Jul 2015 10:53:48 +0000

Hi all,

We've updated the redirection draft to align the security section with the Logging and Control Triggers drafts with regards to the use of TLS. 

As authors, we believe the current version is ready for submission to the IESG. 

Best regards,

Ray

> On 02 Jul 2015, at 12:50, "[email-masked]" <[email-masked]> wrote:
> 
> 
> _______________________________________________
> CDNi mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cdni
This message may contain information that is not intended for you. If you are not the addressee or if this message was sent to you by mistake, you are requested to inform the sender and delete the message. TNO accepts no liability for the content of this e-mail, for the manner in which you use it and for damage of any kind resulting from the risks inherent to the electronic transmission of messages.

---

From: "Francois Le Faucheur (flefauch)" <[email-masked]>
Date: Thu, 16 Jul 2015 17:09:54 +0000

Hi Ray,

In Dallas, we also agreed you would add a discussion about privacy.  Has this been done in this version according to the discussion in Dallas?

Excerpt form minutes for convenience:
“
- Francois reminded the WG to think about the privacy comments raised by the IESG during their review of cdni-logging and encouraged document authors to consider privacy considerations and write some text about it
- Ray: there is a statement about the fact that the full IP address is passed, but that is a necessary evil
- Francois: One could argue that it may be sufficient to pass a partially masked IP address
- Ray: that is true and should work. I will think about that. But in any case, the dCDN will eventually serve the request and will get it from the client with its full IP address, so was it worth hiding it in the cdmi-redirection interaction?
- Francois: that is a good argument and should be presented in the draft 
- Chair : we will proceed to IESG review after update to (i) align with latest TLS usage conclusions (see cdni-logging) , (ii) address comments from upcoming JSON expert review and (iii) add/check statements about privacy.
- Ray: since cdni interface are between CDNs and not endusers, and what people care about is user privacy, do we really need much in terms of privacy in the CDNI interfaces (other than logging which can potentially carry a lot of enduser information).
- Francois (Chair): the bottom line is that each interface needs to consider its relevant privacy concerns (or lack thereof) and should explain what measure sit takes or does not take.
…
“

Thanks

Francois

> On 2 Jul 2015, at 12:53, Brandenburg, R. (Ray) van <[email-masked]> wrote:
> 
> Hi all,
>

---

From: "Brandenburg, R. (Ray) van" <[email-masked]>
Date: Fri, 17 Jul 2015 06:56:04 +0000

Hi Francois,

Good point, I completely forgot about that. I’ll work with Ben on updating the draft so that we can publish it on Monday once the draft submission process opens again.

Ray